aboutsummaryrefslogtreecommitdiff
path: root/dev/python/pyrex/Pyrex.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev/python/pyrex/Pyrex.SlackBuild')
-rwxr-xr-xdev/python/pyrex/Pyrex.SlackBuild56
1 files changed, 29 insertions, 27 deletions
diff --git a/dev/python/pyrex/Pyrex.SlackBuild b/dev/python/pyrex/Pyrex.SlackBuild
index ade78172..f570f0d5 100755
--- a/dev/python/pyrex/Pyrex.SlackBuild
+++ b/dev/python/pyrex/Pyrex.SlackBuild
@@ -10,13 +10,13 @@
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General
# Public License for more details.
#
-# You should have received a copy of the GNU General Public License along with
-# this program; if not, write to the Free Software Foundation, Inc., 59 Temple
-# Place - Suite 330, Boston, MA 02111-1307, USA
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA
#
-# slackbuild for Pyrex, by Silvio Rhatto
-# requires:
-# tested: Pyrex-0.9.6.4
+# slackbuild for Pyrex, by Rudson R. Alves
+# requires: python
+# tested: Pyrex-0.9.8.4
#
# Look for slackbuildrc
@@ -31,9 +31,9 @@ CWD="$(pwd)"
SRC_NAME="Pyrex"
PKG_NAME="Pyrex"
ARCH=${ARCH:=i486}
-SRC_VERSION=${VERSION:=0.9.6.4}
+SRC_VERSION=${VERSION:=0.9.8.4}
PKG_VERSION="$(echo "$SRC_VERSION" | tr '[[:blank:]-]' '_')"
-BUILD=${BUILD:=1rha}
+BUILD=${BUILD:=1srv}
SRC_DIR=${SRC_DIR:=$CWD}/$PKG_NAME
TMP=${TMP:=/tmp}
PKG=${PKG:=$TMP/package-$PKG_NAME}
@@ -41,7 +41,7 @@ REPOS=${REPOS:=$TMP}
PREFIX=${PREFIX:=/usr}
PKG_WORK="$TMP/$SRC_NAME"
CONF_OPTIONS=${CONF_OPTIONS:=""}
-NUMJOBS=${NUMJOBS:=""}
+NUMJOBS=${NUMJOBS:="-j4"}
# Set system libraries' path and optmization flags based on $ARCH
LIBDIR="$PREFIX/lib"
@@ -57,6 +57,7 @@ elif [ "$ARCH" = "s390" ]; then
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIR="$PREFIX/lib64"
+ LDFLAGS="-L/lib64 -L/usr/lib64"
fi
# Set error codes (used by createpkg)
@@ -79,18 +80,19 @@ mkdir -p "$PKG_WORK" || exit $ERROR_MKDIR
SRC="$SRC_NAME-$VERSION.tar.gz"
URL="http://www.cosc.canterbury.ac.nz/greg.ewing/python/Pyrex/$SRC"
-if [ ! -s "$SRC_DIR/$SRC" ] || ! gunzip -t "$SRC_DIR/$SRC" 2> /dev/null; then
+#if [ ! -s "$SRC_DIR/$SRC" ] || ! gunzip -t "$SRC_DIR/$SRC" 2> /dev/null; then
+if [ ! -s "$SRC_DIR/$SRC" ]; then # gunzip test faill
wget "$URL" -O "$SRC_DIR/$SRC" || exit $ERROR_WGET
fi
# Untar
cd "$PKG_WORK"
tar --no-same-owner --no-same-permissions -xvf "$SRC_DIR/$SRC" || exit $ERROR_TAR
-PKG_SRC="$PWD/`ls -l | awk '/^d/ { print $8 }'`"
+PKG_SRC="$PWD/`ls -l | awk '/^d/ { print $NF }'`"
cd "$PKG_SRC"
-# Build and install package
-python setup.py build install --root=$PKG
+# Install
+python setup.py build install --root=$PKG || exit $ERROR_INSTALL
# Strip binaries
( cd "$PKG"
@@ -101,7 +103,7 @@ python setup.py build install --root=$PKG
)
# Install documentation
-DOCS="CHANGES.txt CHECKLIST.txt Doc/* README.txt ToDo.txt USAGE.txt"
+DOCS="CHANGES.txt CHECKLIST.txt INSTALL.txt MANIFEST.in README.txt ToDo.txt USAGE.txt"
mkdir -p "$PKG/usr/doc/$PKG_NAME-$PKG_VERSION" || exit $ERROR_MKDIR
for doc in $DOCS; do
if [ -f "$doc" ]; then
@@ -113,24 +115,24 @@ done
mkdir -p "$PKG/install" || exit $ERROR_MKDIR
cat << EODESC > "$PKG/install/slack-desc"
# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
+# The "handy ruler" below makes it easier to edit a package description. Line
# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
+# on the right side marks the last column you can put a character in. You must
# make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':'.
|-----handy-ruler--------------------------------------------------------|
-Pyrex: Pyrex (Language for Writing Python Extension Modules)
-Pyrex:
-Pyrex: Pyrex lets you write code that mixes Python and C data types any
-Pyrex: way you want, and compiles it into a C extension for Python.
-Pyrex:
-Pyrex:
-Pyrex:
-Pyrex:
-Pyrex:
-Pyrex:
-Pyrex:
+pyrex: Pyrex by Slack.Sarava
+pyrex:
+pyrex: Pyrex lets you write code that mixes Python and C data types any way
+pyrex: you want, and compiles it into a C extension for Python.
+pyrex:
+pyrex:
+pyrex:
+pyrex:
+pyrex:
+pyrex:
+pyrex:
EODESC
# Build the package