aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorrhatto <rhatto@370017ae-e619-0410-ac65-c121f96126d4>2008-12-11 12:54:14 +0000
committerrhatto <rhatto@370017ae-e619-0410-ac65-c121f96126d4>2008-12-11 12:54:14 +0000
commitf662d0888ea5461c42fbc6c66438af2b34c5dda4 (patch)
tree552fedc4baefb66ea0c64919a12a44bb0b32aa5c /www
parente5e42d11182bfe675537ee176184dfa47bf39fa1 (diff)
downloadslackbuilds-f662d0888ea5461c42fbc6c66438af2b34c5dda4.tar.gz
slackbuilds-f662d0888ea5461c42fbc6c66438af2b34c5dda4.tar.bz2
removing old build scripts
git-svn-id: svn+slack://slack.fluxo.info/var/svn/slackbuilds@2011 370017ae-e619-0410-ac65-c121f96126d4
Diffstat (limited to 'www')
-rwxr-xr-xwww/apps/trac/trac.build114
1 files changed, 0 insertions, 114 deletions
diff --git a/www/apps/trac/trac.build b/www/apps/trac/trac.build
deleted file mode 100755
index 8c4a5440..00000000
--- a/www/apps/trac/trac.build
+++ /dev/null
@@ -1,114 +0,0 @@
-#!/bin/bash
-#
-# trac.build is free software; you can redistribute it and/or modify it under the
-# terms of the GNU General Public License as published by the Free Software
-# Foundation; either version 2 of the License, or any later version.
-#
-# trac.build is distributed in the hope that it will be useful, but WITHOUT ANY
-# WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR
-# A PARTICULAR PURPOSE. See the GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License along with
-# this program; if not, write to the Free Software Foundation, Inc., 59 Temple
-# Place - Suite 330, Boston, MA 02111-1307, USA
-#
-# build script for trac
-# by rhatto at riseup.net
-# build it with slacktrack, example:
-#
-# slacktrack -jefkzp "trac-0.10.4-i486-1rha.tgz" "./trac.build"
-#
-
-CWD="`pwd`"
-
-if [ -f "/etc/slackbuildrc" ]; then
- source /etc/slackbuildrc
-fi
-
-if [ -f "~/.slackbuildrc" ]; then
- source ~/.slackbuildrc
-fi
-
-# default settings
-PACKAGE="trac"
-VERSION=${VERSION:=0.10.4}
-ARCH=${ARCH:=i486}
-BUILD=${BUILD:=1rha}
-SRC_DIR=${SRC:=$CWD}
-TMP=${TMP:=/tmp}
-
-RTOOL="wget"
-PACKAGE_EXT="gz"
-SRC="$PACKAGE-$VERSION.tar.$PACKAGE_EXT"
-URL="http://ftp.edgewall.com/pub/trac/$SRC"
-
-if [ "$ARCH" == "x86_64" ]; then
- LIBDIR=/usr/lib64
-else
- LIBDIR=/usr/lib
-fi
-
-# ------- error codes for createpkg --------------
-ERROR_WGET=31; ERROR_MAKE=32; ERROR_INSTALL=33
-ERROR_MD5=34; ERROR_CONF=35; ERROR_HELP=36
-ERROR_TAR=37; ERROR_MKPKG=38; ERROR_GPG=39
-ERROR_PATCH=40
-
-SRC_DIR="$SRC_DIR/$PACKAGE"
-
-if [ ! -d "$SRC_DIR" ]; then
- mkdir -p $SRC_DIR
-fi
-
-if [ "$RTOOL" == "wget" ] && [ ! -f "$SRC_DIR/$SRC" ]; then
- wget "$URL" -O "$SRC_DIR/$SRC" || exit $ERROR_WGET
-fi
-
-TMP="$TMP/$PACKAGE"
-
-if [ ! -d "$TMP" ]; then
- mkdir -p $TMP
-fi
-
-cd $TMP
-
-tar xvf $SRC_DIR/$SRC
-cd $PACKAGE-$VERSION
-
-python setup.py install || exit $ERROR_INSTALL
-
-CWD="`pwd`"
-
-mkdir /install
-
-cat << EOF > /install/slack-desc
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
-
- |-----handy-ruler-----------------------------------------------------|
-trac: trac
-trac:
-trac: Trac is an enhanced wiki and issue tracking system for software
-trac: development projects. Trac uses a minimalistic approach to
-trac: web-based software project management.
-trac:
-trac:
-trac:
-trac:
-trac:
-trac:
-EOF
-
-# docs
-mkdir -p /usr/doc/$PACKAGE-$VERSION
-
-DOCS="AUTHORS COPYING ChangeLog README README.tracd RELEASE THANKS UPGRADE"
-
-for file in $DOCS; do
- cp $CWD/$file* /usr/doc/$PACKAGE-$VERSION/
-done
-