aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorrhatto <rhatto@370017ae-e619-0410-ac65-c121f96126d4>2009-04-29 02:54:44 +0000
committerrhatto <rhatto@370017ae-e619-0410-ac65-c121f96126d4>2009-04-29 02:54:44 +0000
commit0cd577fbe7f2be7885099c9dd576b1a2a0c67916 (patch)
tree5ec59a4f522fd6fbd788fc762d1cb9823a5cc1eb /net
parent57087dea4f63bb113820d351697fdb7bd2c55f22 (diff)
downloadslackbuilds-0cd577fbe7f2be7885099c9dd576b1a2a0c67916.tar.gz
slackbuilds-0cd577fbe7f2be7885099c9dd576b1a2a0c67916.tar.bz2
EOLing old stuff
git-svn-id: svn+slack://slack.fluxo.info/var/svn/slackbuilds@2174 370017ae-e619-0410-ac65-c121f96126d4
Diffstat (limited to 'net')
-rwxr-xr-xnet/www/downtube/downtube.SlackBuild48
-rwxr-xr-xnet/www/downtube/downtube.build109
2 files changed, 0 insertions, 157 deletions
diff --git a/net/www/downtube/downtube.SlackBuild b/net/www/downtube/downtube.SlackBuild
deleted file mode 100755
index 1e7fe0d1..00000000
--- a/net/www/downtube/downtube.SlackBuild
+++ /dev/null
@@ -1,48 +0,0 @@
-#!/bin/bash
-#
-# downtube.SlackBuild is free software; you can redistribute it and/or modify it under the
-# terms of the GNU General Public License as published by the Free Software
-# Foundation; either version 2 of the License, or any later version.
-#
-# downtube.SlackBuild is distributed in the hope that it will be useful, but WITHOUT ANY
-# WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR
-# A PARTICULAR PURPOSE. See the GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License along with
-# this program; if not, write to the Free Software Foundation, Inc., 59 Temple
-# Place - Suite 330, Boston, MA 02111-1307, USA
-#
-# SlackBuild script to call downtube.build with correct settings
-#
-
-CWD="`pwd`"
-
-if [ -f ~/.slackbuildrc ]; then
- source ~/.slackbuildrc
-elif [ -f /etc/slackbuildrc ]; then
- source /etc/slackbuildrc
-fi
-
-# default settings
-PACKAGE="downtube"
-VERSION=${VERSION:=1.2}
-ARCH="noarch"
-BUILD=${BUILD:=1rha}
-SRC_DIR=${SRC:=$CWD}
-TMP=${TMP:=/tmp}
-REPOS=${REPOS:=$TMP}
-
-rm -rf $TMP/$PACKAGE
-mkdir -p $SRC_DIR/$PACKAGE $TMP/$PACKAGE
-
-export PACKAGE VERSION ARCH BUILD SRC_DIR TMP REPOS
-
-if which simpletrack &> /dev/null; then
- simpletrack $PACKAGE.build
-else
- slacktrack -b $REPOS -x $TMP,$SRC_DIR,/dev -jefkzp "$PACKAGE-$VERSION-$ARCH-$BUILD.tgz" "./$PACKAGE.build"
-fi
-
-if [ "$CLEANUP" == "yes" ]; then
- rm -rf $TMP/$PACKAGE
-fi
diff --git a/net/www/downtube/downtube.build b/net/www/downtube/downtube.build
deleted file mode 100755
index 97a4bd69..00000000
--- a/net/www/downtube/downtube.build
+++ /dev/null
@@ -1,109 +0,0 @@
-#!/bin/bash
-#
-# downtube.build is free software; you can redistribute it and/or modify it under the
-# terms of the GNU General Public License as published by the Free Software
-# Foundation; either version 2 of the License, or any later version.
-#
-# downtube.build is distributed in the hope that it will be useful, but WITHOUT ANY
-# WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR
-# A PARTICULAR PURPOSE. See the GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License along with
-# this program; if not, write to the Free Software Foundation, Inc., 59 Temple
-# Place - Suite 330, Boston, MA 02111-1307, USA
-#
-# build script for downtube
-# by rhatto at riseup.net
-# build it with slacktrack, example:
-#
-# slacktrack -jefkzp "downtube-1.2-noarch-1rha.tgz" "./downtube.build"
-#
-
-CWD="`pwd`"
-
-if [ -f "/etc/slackbuildrc" ]; then
- source /etc/slackbuildrc
-fi
-
-if [ -f "~/.slackbuildrc" ]; then
- source ~/.slackbuildrc
-fi
-
-# default settings
-PACKAGE="downtube"
-VERSION=${VERSION:=1.2}
-ARCH="noarch"
-BUILD=${BUILD:=1rha}
-SRC_DIR=${SRC:=$CWD}
-TMP=${TMP:=/tmp}
-
-RTOOL="wget"
-PACKAGE_EXT="gz"
-SRC="$PACKAGE-$VERSION.tar.$PACKAGE_EXT"
-URL="http://codigolivre.org.br/frs/download.php/5174/$SRC"
-
-SRC_DIR="$SRC_DIR/$PACKAGE"
-
-if [ ! -d "$SRC_DIR" ]; then
- mkdir -p $SRC_DIR
-fi
-
-if [ "$PACKAGE_EXT" == "bz2" ]; then
- tarflag="j"
-else
- tarflag="z"
-fi
-
-if [ "$RTOOL" == "wget" ] && [ ! -f "$SRC_DIR/$SRC" ]; then
- wget "$URL" -O "$SRC_DIR/$SRC"
-fi
-
-TMP="$TMP/$PACKAGE"
-
-if [ ! -d "$TMP" ]; then
- mkdir -p $TMP
-fi
-
-cd $TMP
-
-tar xvf$tarflag $SRC_DIR/$SRC
-cd $PACKAGE-$VERSION
-
-python setup.py install
-
-CWD="`pwd`"
-
-mkdir /install
-
-cat << EOF > /install/slack-desc
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
-
- |-----handy-ruler-----------------------------------------------------|
-downtube: downtube: youtube.com video downloader and converter.
-downtube:
-downtube:
-downtube:
-downtube:
-downtube:
-downtube:
-downtube:
-downtube:
-downtube:
-downtube:
-EOF
-
-# docs
-mkdir -p /usr/doc/$PACKAGE-$VERSION
-
-for file in AUTHORS COPYING ChangeLog FAQ INSTALL README TODO; do
- cp $CWD/$file* /usr/doc/$PACKAGE-$VERSION/
-done
-
-if [ "$CLEANUP" == "yes" ]; then
- rm -rf $TMP
-fi