aboutsummaryrefslogtreecommitdiff
path: root/net/www/downtube/downtube.build
diff options
context:
space:
mode:
Diffstat (limited to 'net/www/downtube/downtube.build')
-rwxr-xr-xnet/www/downtube/downtube.build109
1 files changed, 0 insertions, 109 deletions
diff --git a/net/www/downtube/downtube.build b/net/www/downtube/downtube.build
deleted file mode 100755
index 97a4bd69..00000000
--- a/net/www/downtube/downtube.build
+++ /dev/null
@@ -1,109 +0,0 @@
-#!/bin/bash
-#
-# downtube.build is free software; you can redistribute it and/or modify it under the
-# terms of the GNU General Public License as published by the Free Software
-# Foundation; either version 2 of the License, or any later version.
-#
-# downtube.build is distributed in the hope that it will be useful, but WITHOUT ANY
-# WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR
-# A PARTICULAR PURPOSE. See the GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License along with
-# this program; if not, write to the Free Software Foundation, Inc., 59 Temple
-# Place - Suite 330, Boston, MA 02111-1307, USA
-#
-# build script for downtube
-# by rhatto at riseup.net
-# build it with slacktrack, example:
-#
-# slacktrack -jefkzp "downtube-1.2-noarch-1rha.tgz" "./downtube.build"
-#
-
-CWD="`pwd`"
-
-if [ -f "/etc/slackbuildrc" ]; then
- source /etc/slackbuildrc
-fi
-
-if [ -f "~/.slackbuildrc" ]; then
- source ~/.slackbuildrc
-fi
-
-# default settings
-PACKAGE="downtube"
-VERSION=${VERSION:=1.2}
-ARCH="noarch"
-BUILD=${BUILD:=1rha}
-SRC_DIR=${SRC:=$CWD}
-TMP=${TMP:=/tmp}
-
-RTOOL="wget"
-PACKAGE_EXT="gz"
-SRC="$PACKAGE-$VERSION.tar.$PACKAGE_EXT"
-URL="http://codigolivre.org.br/frs/download.php/5174/$SRC"
-
-SRC_DIR="$SRC_DIR/$PACKAGE"
-
-if [ ! -d "$SRC_DIR" ]; then
- mkdir -p $SRC_DIR
-fi
-
-if [ "$PACKAGE_EXT" == "bz2" ]; then
- tarflag="j"
-else
- tarflag="z"
-fi
-
-if [ "$RTOOL" == "wget" ] && [ ! -f "$SRC_DIR/$SRC" ]; then
- wget "$URL" -O "$SRC_DIR/$SRC"
-fi
-
-TMP="$TMP/$PACKAGE"
-
-if [ ! -d "$TMP" ]; then
- mkdir -p $TMP
-fi
-
-cd $TMP
-
-tar xvf$tarflag $SRC_DIR/$SRC
-cd $PACKAGE-$VERSION
-
-python setup.py install
-
-CWD="`pwd`"
-
-mkdir /install
-
-cat << EOF > /install/slack-desc
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
-
- |-----handy-ruler-----------------------------------------------------|
-downtube: downtube: youtube.com video downloader and converter.
-downtube:
-downtube:
-downtube:
-downtube:
-downtube:
-downtube:
-downtube:
-downtube:
-downtube:
-downtube:
-EOF
-
-# docs
-mkdir -p /usr/doc/$PACKAGE-$VERSION
-
-for file in AUTHORS COPYING ChangeLog FAQ INSTALL README TODO; do
- cp $CWD/$file* /usr/doc/$PACKAGE-$VERSION/
-done
-
-if [ "$CLEANUP" == "yes" ]; then
- rm -rf $TMP
-fi