aboutsummaryrefslogtreecommitdiff
path: root/net/p2p/nicotine
diff options
context:
space:
mode:
authorrhatto <rhatto@370017ae-e619-0410-ac65-c121f96126d4>2009-03-03 00:10:21 +0000
committerrhatto <rhatto@370017ae-e619-0410-ac65-c121f96126d4>2009-03-03 00:10:21 +0000
commite005cb997e20f02356bd1658c1c3a0cbd8fe296e (patch)
treed8b400dcb3adc221b43b5273536ad25c36f1308a /net/p2p/nicotine
parent4a55491819dce43f793bd1ede909a950bfbfeca1 (diff)
downloadslackbuilds-e005cb997e20f02356bd1658c1c3a0cbd8fe296e.tar.gz
slackbuilds-e005cb997e20f02356bd1658c1c3a0cbd8fe296e.tar.bz2
nicotine+: updating to 1.2.10
git-svn-id: svn+slack://slack.fluxo.info/var/svn/slackbuilds@2113 370017ae-e619-0410-ac65-c121f96126d4
Diffstat (limited to 'net/p2p/nicotine')
-rwxr-xr-xnet/p2p/nicotine/nicotine+.SlackBuild48
-rwxr-xr-xnet/p2p/nicotine/nicotine+.build108
-rwxr-xr-xnet/p2p/nicotine/nicotine.SlackBuild144
-rwxr-xr-xnet/p2p/nicotine/nicotine.build106
-rw-r--r--net/p2p/nicotine/slack-required1
5 files changed, 0 insertions, 407 deletions
diff --git a/net/p2p/nicotine/nicotine+.SlackBuild b/net/p2p/nicotine/nicotine+.SlackBuild
deleted file mode 100755
index 16fe1f50..00000000
--- a/net/p2p/nicotine/nicotine+.SlackBuild
+++ /dev/null
@@ -1,48 +0,0 @@
-#!/bin/bash
-#
-# nicotine+.SlackBuild is free software; you can redistribute it and/or modify it under the
-# terms of the GNU General Public License as published by the Free Software
-# Foundation; either version 2 of the License, or any later version.
-#
-# nicotine+.SlackBuild is distributed in the hope that it will be useful, but WITHOUT ANY
-# WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR
-# A PARTICULAR PURPOSE. See the GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License along with
-# this program; if not, write to the Free Software Foundation, Inc., 59 Temple
-# Place - Suite 330, Boston, MA 02111-1307, USA
-#
-# SlackBuild script to call nicotine+.build with correct settings
-#
-
-CWD="`pwd`"
-
-if [ -f ~/.slackbuildrc ]; then
- source ~/.slackbuildrc
-elif [ -f /etc/slackbuildrc ]; then
- source /etc/slackbuildrc
-fi
-
-# default settings
-PACKAGE="nicotine+"
-VERSION=${VERSION:=1.2.4.1}
-ARCH="noarch"
-BUILD=${BUILD:=1rha}
-SRC_DIR=${SRC:=$CWD}
-TMP=${TMP:=/tmp}
-REPOS=${REPOS:=$TMP}
-
-rm -rf $TMP/$PACKAGE
-mkdir -p $SRC_DIR/$PACKAGE $TMP/$PACKAGE $REPOS
-
-export PACKAGE VERSION ARCH BUILD SRC_DIR TMP REPOS
-
-if which simpletrack &> /dev/null; then
- simpletrack $PACKAGE.build
-else
- slacktrack -b $REPOS -x $TMP,$SRC_DIR,/dev -jefkzp "$PACKAGE-$VERSION-$ARCH-$BUILD.tgz" "./$PACKAGE.build"
-fi
-
-if [ "$CLEANUP" == "yes" ]; then
- rm -rf $TMP/$PACKAGE
-fi
diff --git a/net/p2p/nicotine/nicotine+.build b/net/p2p/nicotine/nicotine+.build
deleted file mode 100755
index ba3c8f6b..00000000
--- a/net/p2p/nicotine/nicotine+.build
+++ /dev/null
@@ -1,108 +0,0 @@
-#!/bin/bash
-#
-# nicotine+.build is free software; you can redistribute it and/or modify it under the
-# terms of the GNU General Public License as published by the Free Software
-# Foundation; either version 2 of the License, or any later version.
-#
-# nicotine+.build is distributed in the hope that it will be useful, but WITHOUT ANY
-# WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR
-# A PARTICULAR PURPOSE. See the GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License along with
-# this program; if not, write to the Free Software Foundation, Inc., 59 Temple
-# Place - Suite 330, Boston, MA 02111-1307, USA
-#
-# build script for nicotine+
-# by rhatto at riseup.net
-# build it with slacktrack, example:
-#
-# slacktrack -jefkzp "nicotine+-1.2.4.1-noarch-1rha.tgz" "./nicotine+.build"
-#
-
-CWD="`pwd`"
-
-if [ -f "/etc/slackbuildrc" ]; then
- source /etc/slackbuildrc
-fi
-
-if [ -f "~/.slackbuildrc" ]; then
- source ~/.slackbuildrc
-fi
-
-# default settings
-PACKAGE="nicotine+"
-VERSION=${VERSION:=1.2.4.1}
-ARCH="noarch"
-BUILD=${BUILD:=1rha}
-SRC_DIR=${SRC:=$CWD}
-TMP=${TMP:=/tmp}
-
-RTOOL="wget"
-PACKAGE_EXT="bz2"
-SRC="$PACKAGE-$VERSION.tar.$PACKAGE_EXT"
-URL="http://easynews.dl.sourceforge.net/sourceforge/nicotine-plus/$SRC"
-
-SRC_DIR="$SRC_DIR/$PACKAGE"
-
-if [ ! -d "$SRC_DIR" ]; then
- mkdir -p $SRC_DIR
-fi
-
-if [ "$PACKAGE_EXT" == "bz2" ]; then
- tarflag="j"
-else
- tarflag="z"
-fi
-
-if [ "$RTOOL" == "wget" ] && [ ! -f "$SRC_DIR/$SRC" ]; then
- wget "$URL" -O "$SRC_DIR/$SRC"
-fi
-
-TMP="$TMP/$PACKAGE"
-
-if [ ! -d "$TMP" ]; then
- mkdir -p $TMP
-fi
-
-cd $TMP
-
-tar xvf$tarflag $SRC_DIR/$SRC
-cd $PACKAGE-$VERSION
-
-python setup.py install --prefix=/usr
-
-CWD="`pwd`"
-
-mkdir /install
-
-cat << EOF > /install/slack-desc
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
-
- |-----handy-ruler-----------------------------------------------------|
-nicotine+: nicotine+ (soulseek client clone)
-nicotine+:
-nicotine+: Nicotine is a SoulSeek client written in Python, based on the
-nicotine+: PySoulSeek project by Alexander Kanavin. It features, among other
-nicotine+: things, a completely rewritten graphical user interface which uses
-nicotine+: the PyGTK-2 toolkit and a less strict user request policy.
-nicotine+:
-nicotine+: This version is the forked one distributed at
-nicotine+: http://nicotine-plus.sourceforge.net
-nicotine+:
-nicotine+:
-EOF
-
-# docs
-mkdir -p /usr/doc/$PACKAGE-$VERSION
-
-for file in COPYING MANIFEST; do
- cp $CWD/$file* /usr/doc/$PACKAGE-$VERSION/
-done
-
-cp -R $CWD/docs/* /usr/doc/$PACKAGE-$VERSION/
-
diff --git a/net/p2p/nicotine/nicotine.SlackBuild b/net/p2p/nicotine/nicotine.SlackBuild
deleted file mode 100755
index 64cb000a..00000000
--- a/net/p2p/nicotine/nicotine.SlackBuild
+++ /dev/null
@@ -1,144 +0,0 @@
-#!/bin/bash
-#
-# nicotine.SlackBuild is free software; you can redistribute
-# it and/or modify it under the terms of the GNU General Public License as
-# published by the Free Software Foundation; either version 2 of the License,
-# or any later version.
-#
-# nicotine.SlackBuild is distributed in the hope that it will
-# be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General
-# Public License for more details.
-#
-# You should have received a copy of the GNU General Public License along
-# with this program; if not, write to the Free Software Foundation, Inc.,
-# 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA
-#
-# slackbuild for nicotine, by Silvio Rhatto
-# requires:
-# tested: nicotine-1.0.8
-#
-
-# Look for slackbuildrc
-if [ -f ~/.slackbuildrc ]; then
- source ~/.slackbuildrc
-elif [ -f /etc/slackbuildrc ]; then
- source /etc/slackbuildrc
-fi
-
-# Set variables
-CWD="$(pwd)"
-SRC_NAME="nicotine"
-PKG_NAME="nicotine"
-ARCH=${ARCH:=i486}
-SRC_VERSION=${VERSION:=1.0.8}
-PKG_VERSION="$(echo "$SRC_VERSION" | tr '[[:blank:]-]' '_')"
-BUILD=${BUILD:=1rha}
-SRC_DIR=${SRC_DIR:=$CWD}/$PKG_NAME
-TMP=${TMP:=/tmp}
-PKG=${PKG:=$TMP/package-$PKG_NAME}
-REPOS=${REPOS:=$TMP}
-PREFIX=${PREFIX:=/usr}
-PKG_WORK="$TMP/$SRC_NAME"
-CONF_OPTIONS=${CONF_OPTIONS:=""}
-NUMJOBS=${NUMJOBS:=""}
-
-# Set system libraries' path and optmization flags based on $ARCH
-LIBDIR="$PREFIX/lib"
-
-if [ "$ARCH" = "i386" ]; then
- SLKCFLAGS="-O2 -march=i386 -mcpu=i686"
-elif [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mcpu=i686"
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686"
-elif [ "$ARCH" = "s390" ]; then
- SLKCFLAGS="-O2"
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIR="$PREFIX/lib64"
- LDFLAGS="-L/lib64 -L/usr/lib64"
-fi
-
-# Set error codes (used by createpkg)
-ERROR_WGET=31; ERROR_MAKE=32; ERROR_INSTALL=33
-ERROR_MD5=34; ERROR_CONF=35; ERROR_HELP=36
-ERROR_TAR=37; ERROR_MKPKG=38; ERROR_GPG=39
-ERROR_PATCH=40; ERROR_VCS=41; ERROR_MKDIR=42
-
-# Clean up any leftovers of previous builds
-rm -rf "$PKG_WORK" 2> /dev/null
-rm -rf "$PKG" 2> /dev/null
-
-# Create directories if necessary
-mkdir -p "$SRC_DIR" || exit $ERROR_MKDIR
-mkdir -p "$PKG" || exit $ERROR_MKDIR
-mkdir -p "$REPOS" || exit $ERROR_MKDIR
-mkdir -p "$PKG_WORK" || exit $ERROR_MKDIR
-
-# Dowload source if necessary
-SRC="$SRC_NAME-$VERSION.tar.bz2"
-URL="http://nicotine.thegraveyard.org/$SRC"
-
-if [ ! -s "$SRC_DIR/$SRC" ] || ! bunzip2 -t "$SRC_DIR/$SRC" 2> /dev/null; then
- wget "$URL" -O "$SRC_DIR/$SRC" || exit $ERROR_WGET
-fi
-
-# Untar
-cd "$PKG_WORK"
-tar --no-same-owner --no-same-permissions -xvf "$SRC_DIR/$SRC" || exit $ERROR_TAR
-PKG_SRC="$PWD/`ls -l | awk '/^d/ { print $NF }'`"
-cd "$PKG_SRC"
-
-# Build and install package
-python setup.py build install --root=$PKG
-
-# Strip binaries
-( cd "$PKG"
- find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
- xargs strip --strip-unneeded 2> /dev/null
- find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
- xargs strip --strip-unneeded 2> /dev/null
-)
-
-# Install documentation
-DOCS="CHANGELOG COPYING KNOWN_BUGS MAINTAINERS MANIFEST PKG-INFO README README.import-winconfig TODO TRANSLATORS"
-mkdir -p "$PKG/usr/doc/$PKG_NAME-$PKG_VERSION" || exit $ERROR_MKDIR
-for doc in $DOCS; do
- if [ -f "$doc" ]; then
- cp -a $doc "$PKG/usr/doc/$PKG_NAME-$PKG_VERSION"
- fi
-done
-
-# Add package description (slack-desc)
-mkdir -p "$PKG/install" || exit $ERROR_MKDIR
-cat << EODESC > "$PKG/install/slack-desc"
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
-
- |-----handy-ruler-----------------------------------------------------|
-nicotine: nicotine (soulseek client clone)
-nicotine:
-nicotine: Nicotine is a SoulSeek client written in Python, based on the
-nicotine: PySoulSeek project by Alexander Kanavin. It features, among other
-nicotine: things, a completely rewritten graphical user interface which uses
-nicotine: the PyGTK-2 toolkit and a less strict user request policy.
-nicotine:
-nicotine:
-nicotine:
-nicotine:
-nicotine:
-EODESC
-
-# Build the package
-cd "$PKG"
-makepkg -l y -c n "$REPOS/$PKG_NAME-$PKG_VERSION-$ARCH-$BUILD.tgz" || exit $ERROR_MKPKG
-
-# Delete source and build directories if requested
-if [ "$CLEANUP" == "yes" ]; then
- rm -rf "$PKG_WORK" "$PKG"
-fi
diff --git a/net/p2p/nicotine/nicotine.build b/net/p2p/nicotine/nicotine.build
deleted file mode 100755
index 1a1f17c5..00000000
--- a/net/p2p/nicotine/nicotine.build
+++ /dev/null
@@ -1,106 +0,0 @@
-#!/bin/bash
-#
-# nicotine.build is free software; you can redistribute it and/or modify it under the
-# terms of the GNU General Public License as published by the Free Software
-# Foundation; either version 2 of the License, or any later version.
-#
-# nicotine.build is distributed in the hope that it will be useful, but WITHOUT ANY
-# WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR
-# A PARTICULAR PURPOSE. See the GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License along with
-# this program; if not, write to the Free Software Foundation, Inc., 59 Temple
-# Place - Suite 330, Boston, MA 02111-1307, USA
-#
-# build script for nicotine
-# by rhatto at riseup.net
-# build it with slacktrack, example:
-#
-# slacktrack -jefkzp "nicotine-1.2.4.1-noarch-1rha.tgz" "./nicotine.build"
-#
-
-CWD="`pwd`"
-
-if [ -f "/etc/slackbuildrc" ]; then
- source /etc/slackbuildrc
-fi
-
-if [ -f "~/.slackbuildrc" ]; then
- source ~/.slackbuildrc
-fi
-
-# default settings
-PACKAGE="nicotine"
-VERSION=${VERSION:=1.0.8}
-ARCH=${ARCH:=i486}
-BUILD=${BUILD:=1rha}
-SRC_DIR=${SRC:=$CWD}
-TMP=${TMP:=/tmp}
-
-RTOOL="wget"
-PACKAGE_EXT="bz2"
-SRC="$PACKAGE-$VERSION.tar.$PACKAGE_EXT"
-URL="http://nicotine.thegraveyard.org/$SRC"
-
-SRC_DIR="$SRC_DIR/$PACKAGE"
-
-if [ ! -d "$SRC_DIR" ]; then
- mkdir -p $SRC_DIR
-fi
-
-if [ "$PACKAGE_EXT" == "bz2" ]; then
- tarflag="j"
-else
- tarflag="z"
-fi
-
-if [ "$RTOOL" == "wget" ] && [ ! -f "$SRC_DIR/$SRC" ]; then
- wget "$URL" -O "$SRC_DIR/$SRC"
-fi
-
-TMP="$TMP/$PACKAGE"
-
-if [ ! -d "$TMP" ]; then
- mkdir -p $TMP
-fi
-
-cd $TMP
-
-tar xvf$tarflag $SRC_DIR/$SRC
-cd $PACKAGE-$VERSION
-
-python setup.py install --prefix=/usr
-
-CWD="`pwd`"
-
-mkdir /install
-
-cat << EOF > /install/slack-desc
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
-
- |-----handy-ruler-----------------------------------------------------|
-nicotine: nicotine (soulseek client clone)
-nicotine:
-nicotine: Nicotine is a SoulSeek client written in Python, based on the
-nicotine: PySoulSeek project by Alexander Kanavin. It features, among other
-nicotine: things, a completely rewritten graphical user interface which uses
-nicotine: the PyGTK-2 toolkit and a less strict user request policy.
-nicotine:
-nicotine:
-nicotine:
-nicotine:
-nicotine:
-EOF
-
-# docs
-mkdir -p /usr/doc/$PACKAGE-$VERSION
-
-for file in CHANGELOG COPYING INSTALL KNOWN_BUGS MAINTAINERS MANIFEST PKG-INFO README README.import-winconfig TODO TRANSLATORS; do
- cp $CWD/$file* /usr/doc/$PACKAGE-$VERSION/
-done
-
diff --git a/net/p2p/nicotine/slack-required b/net/p2p/nicotine/slack-required
deleted file mode 100644
index d01ef22f..00000000
--- a/net/p2p/nicotine/slack-required
+++ /dev/null
@@ -1 +0,0 @@
-pygtk