aboutsummaryrefslogtreecommitdiff
path: root/net/p2p/nicotine/nicotine.build
diff options
context:
space:
mode:
Diffstat (limited to 'net/p2p/nicotine/nicotine.build')
-rwxr-xr-xnet/p2p/nicotine/nicotine.build106
1 files changed, 0 insertions, 106 deletions
diff --git a/net/p2p/nicotine/nicotine.build b/net/p2p/nicotine/nicotine.build
deleted file mode 100755
index 1a1f17c5..00000000
--- a/net/p2p/nicotine/nicotine.build
+++ /dev/null
@@ -1,106 +0,0 @@
-#!/bin/bash
-#
-# nicotine.build is free software; you can redistribute it and/or modify it under the
-# terms of the GNU General Public License as published by the Free Software
-# Foundation; either version 2 of the License, or any later version.
-#
-# nicotine.build is distributed in the hope that it will be useful, but WITHOUT ANY
-# WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR
-# A PARTICULAR PURPOSE. See the GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License along with
-# this program; if not, write to the Free Software Foundation, Inc., 59 Temple
-# Place - Suite 330, Boston, MA 02111-1307, USA
-#
-# build script for nicotine
-# by rhatto at riseup.net
-# build it with slacktrack, example:
-#
-# slacktrack -jefkzp "nicotine-1.2.4.1-noarch-1rha.tgz" "./nicotine.build"
-#
-
-CWD="`pwd`"
-
-if [ -f "/etc/slackbuildrc" ]; then
- source /etc/slackbuildrc
-fi
-
-if [ -f "~/.slackbuildrc" ]; then
- source ~/.slackbuildrc
-fi
-
-# default settings
-PACKAGE="nicotine"
-VERSION=${VERSION:=1.0.8}
-ARCH=${ARCH:=i486}
-BUILD=${BUILD:=1rha}
-SRC_DIR=${SRC:=$CWD}
-TMP=${TMP:=/tmp}
-
-RTOOL="wget"
-PACKAGE_EXT="bz2"
-SRC="$PACKAGE-$VERSION.tar.$PACKAGE_EXT"
-URL="http://nicotine.thegraveyard.org/$SRC"
-
-SRC_DIR="$SRC_DIR/$PACKAGE"
-
-if [ ! -d "$SRC_DIR" ]; then
- mkdir -p $SRC_DIR
-fi
-
-if [ "$PACKAGE_EXT" == "bz2" ]; then
- tarflag="j"
-else
- tarflag="z"
-fi
-
-if [ "$RTOOL" == "wget" ] && [ ! -f "$SRC_DIR/$SRC" ]; then
- wget "$URL" -O "$SRC_DIR/$SRC"
-fi
-
-TMP="$TMP/$PACKAGE"
-
-if [ ! -d "$TMP" ]; then
- mkdir -p $TMP
-fi
-
-cd $TMP
-
-tar xvf$tarflag $SRC_DIR/$SRC
-cd $PACKAGE-$VERSION
-
-python setup.py install --prefix=/usr
-
-CWD="`pwd`"
-
-mkdir /install
-
-cat << EOF > /install/slack-desc
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
-
- |-----handy-ruler-----------------------------------------------------|
-nicotine: nicotine (soulseek client clone)
-nicotine:
-nicotine: Nicotine is a SoulSeek client written in Python, based on the
-nicotine: PySoulSeek project by Alexander Kanavin. It features, among other
-nicotine: things, a completely rewritten graphical user interface which uses
-nicotine: the PyGTK-2 toolkit and a less strict user request policy.
-nicotine:
-nicotine:
-nicotine:
-nicotine:
-nicotine:
-EOF
-
-# docs
-mkdir -p /usr/doc/$PACKAGE-$VERSION
-
-for file in CHANGELOG COPYING INSTALL KNOWN_BUGS MAINTAINERS MANIFEST PKG-INFO README README.import-winconfig TODO TRANSLATORS; do
- cp $CWD/$file* /usr/doc/$PACKAGE-$VERSION/
-done
-