aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorrhatto <rhatto@370017ae-e619-0410-ac65-c121f96126d4>2009-04-29 12:56:37 +0000
committerrhatto <rhatto@370017ae-e619-0410-ac65-c121f96126d4>2009-04-29 12:56:37 +0000
commit1e8b3a8695394d8201a282c97ee70297e3c13e3d (patch)
tree847578c924f2d480503d7a5f47d2de9b322e0b06
parent1d3107c4da15be40c7a4d08cfa744df8e736fdb2 (diff)
downloadslackbuilds-1e8b3a8695394d8201a282c97ee70297e3c13e3d.tar.gz
slackbuilds-1e8b3a8695394d8201a282c97ee70297e3c13e3d.tar.bz2
EOLing old patches
git-svn-id: svn+slack://slack.fluxo.info/var/svn/slackbuilds@2176 370017ae-e619-0410-ac65-c121f96126d4
-rwxr-xr-xpatches/fetchmail/fetchmail.SlackBuild108
-rw-r--r--patches/fetchmail/slack-desc19
-rw-r--r--patches/imagemagick/imagemagick.CVE-2005-4601.CVE-2006-0082.diff.gzbin1491 -> 0 bytes
-rwxr-xr-xpatches/imagemagick/imagemagick.SlackBuild172
-rw-r--r--patches/imagemagick/slack-desc19
-rw-r--r--patches/python/Python-2.3.3-dirs.patch.gzbin351 -> 0 bytes
-rw-r--r--patches/python/Python-2.4.4.diff351
-rwxr-xr-xpatches/python/python.SlackBuild163
-rw-r--r--patches/python/slack-desc19
9 files changed, 0 insertions, 851 deletions
diff --git a/patches/fetchmail/fetchmail.SlackBuild b/patches/fetchmail/fetchmail.SlackBuild
deleted file mode 100755
index 37d31d67..00000000
--- a/patches/fetchmail/fetchmail.SlackBuild
+++ /dev/null
@@ -1,108 +0,0 @@
-#!/bin/bash
-#
-# got it from ftp://ftp.slackware.com/pub/slackware/slackware-10.2/patches/source/fetchmail/fetchmail.SlackBuild
-# small changes by rhatto
-#
-
-# Set initial variables:
-
-CWD="`pwd`"
-
-if [ -f ~/.slackbuildrc ]; then
- source ~/.slackbuildrc
-elif [ -f /etc/slackbuildrc ]; then
- source /etc/slackbuildrc
-fi
-
-PACKAGE="fetchmail"
-VERSION=${VERSION:=6.3.4}
-ARCH=${ARCH:=i486}
-BUILD=${BUILD:=1rha}
-TMP=${TMP:=/tmp}
-SRC_DIR=${SRC:=$CWD}
-
-RTOOL="wget"
-PACKAGE_EXT="bz2"
-SRC="$PACKAGE-$VERSION.tar.$PACKAGE_EXT"
-URL="http://download.berlios.de/fetchmail/$SRC"
-
-if [ "$PACKAGE_EXT" == "bz2" ]; then
- tarflag="j"
-else
- tarflag="z"
-fi
-
-if [ "$RTOOL" == "wget" ] && [ ! -f "$SRC_DIR/$SRC" ]; then
- wget "$URL" -O "$SRC_DIR/$SRC"
-fi
-
-PKG=$TMP/package-fetchmail
-
-LIBDIR="/usr/lib"
-if [ "$ARCH" = "i386" ]; then
- SLKCFLAGS="-O2 -march=i386 -mcpu=i686"
-elif [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mcpu=i686"
-elif [ "$ARCH" = "s390" ]; then
- SLKCFLAGS="-O2"
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIR="/usr/lib64"
-fi
-
-rm -rf $PKG
-mkdir -p $PKG
-
-cd $TMP
-rm -rf fetchmail-$VERSION
-tar xvf$tarflag $SRC_DIR/$SRC
-cd fetchmail-$VERSION
-
-# this is the sloppiest source tarball ever
-chown -R root.root .
-find . -perm 664 -exec chmod 644 {} \;
-find . -perm 600 -exec chmod 644 {} \;
-find . -perm 444 -exec chmod 644 {} \;
-find . -perm 400 -exec chmod 644 {} \;
-find . -perm 440 -exec chmod 644 {} \;
-find . -perm 777 -exec chmod 755 {} \;
-find . -perm 775 -exec chmod 755 {} \;
-find . -perm 511 -exec chmod 755 {} \;
-find . -perm 711 -exec chmod 755 {} \;
-find . -perm 555 -exec chmod 755 {} \;
-
-CFLAGS="$SLKCFLAGS" \
-./configure \
- --prefix=/usr \
- --enable-nls \
- --with-ssl \
- --program-prefix="" \
- --program-suffix="" \
- $ARCH-slackware-linux
-make || exit 32
-make install DESTDIR=$PKG
-( cd $PKG
- find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
- find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
-)
-chown -R root.bin $PKG/usr/bin
-( cd $PKG/usr/man/man1
- rm fetchmailconf.1
- gzip -9 *
- ln -sf fetchmail.1.gz fetchmailconf.1.gz
-)
-mkdir -p $PKG/usr/doc/fetchmail-$VERSION
-cp -a \
- ABOUT-NLS COPYING FAQ FEATURES INSTALL NEWS NOTES README README.NTLM README.SSL TODO \
- *.html contrib *.lsm \
- $PKG/usr/doc/fetchmail-$VERSION
-
-rm -rf $PKG/usr/doc/fetchmail-$VERSION/RCS \
- $PKG/usr/doc/fetchmail-$VERSION/contrib/RCS \
- $PKG/usr/doc/fetchmail-$VERSION/fetchmail-man.html
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-makepkg -l y -c n $TMP/fetchmail-$VERSION-$ARCH-$BUILD.tgz
diff --git a/patches/fetchmail/slack-desc b/patches/fetchmail/slack-desc
deleted file mode 100644
index ac4c7c90..00000000
--- a/patches/fetchmail/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
-
- |-----handy-ruler------------------------------------------------------|
-fetchmail: fetchmail (mail retrieval and forwarding utility)
-fetchmail:
-fetchmail: fetchmail is a mail retrieval and forwarding utility. It fetches
-fetchmail: mail from a POP, IMAP, or ETRN-capable remote mailserver and forwards
-fetchmail: it to your local (client) machine's delivery system. You can then
-fetchmail: handle the retrieved mail using normal mail user agents such as elm,
-fetchmail: pine, or mutt. The fetchmail utility can be run in a daemon mode to
-fetchmail: repeatedly poll one or more systems at a specified interval.
-fetchmail:
-fetchmail:
-fetchmail:
diff --git a/patches/imagemagick/imagemagick.CVE-2005-4601.CVE-2006-0082.diff.gz b/patches/imagemagick/imagemagick.CVE-2005-4601.CVE-2006-0082.diff.gz
deleted file mode 100644
index 54a61cf5..00000000
--- a/patches/imagemagick/imagemagick.CVE-2005-4601.CVE-2006-0082.diff.gz
+++ /dev/null
Binary files differ
diff --git a/patches/imagemagick/imagemagick.SlackBuild b/patches/imagemagick/imagemagick.SlackBuild
deleted file mode 100755
index 294730df..00000000
--- a/patches/imagemagick/imagemagick.SlackBuild
+++ /dev/null
@@ -1,172 +0,0 @@
-#!/bin/bash
-#
-# got it from ftp://ftp.slackware.com/pub/slackware/slackware-10.2/patches/source/imagemagick/imagemagick.SlackBuild
-# small changes by rhatto.
-#
-
-if [ -s "slack-required" ]; then
- echo Recomended and required packages for building cairo are:
- cat slack-required | sed -e 's/^/\t/'
- if [ "$INTERACT" != "no" ]; then
- echo If you dont have those installed, press Ctrl-C. Otherwise, hit ENTER.
- read crap
-# else
-# echo Sleeping 3 seconds...
-# sleep 3
- fi
-fi
-
-CWD="`pwd`"
-
-if [ -f ~/.slackbuildrc ]; then
- source ~/.slackbuildrc
-elif [ -f /etc/slackbuildrc ]; then
- source /etc/slackbuildrc
-fi
-
-PACKAGE="imagemagick"
-TMP=${TMP:=/tmp}
-ARCH=${ARCH:=i486}
-BUILD=${BUILD:=1rha}
-SRC_DIR=${SRC:=$CWD}
-REPOS=${REPOS:=$TMP}
-
-if [ "$ARCH" == "x86_64" ]; then
- LIBDIR=/usr/lib64
-else
- LIBDIR=/usr/lib
-fi
-
-# ------- error codes for createpkg --------------
-ERROR_WGET=31; ERROR_MAKE=32; ERROR_INSTALL=33
-ERROR_MD5=34; ERROR_CONF=35; ERROR_HELP=36
-ERROR_TAR=37; ERROR_MKPKG=38; ERROR_GPG=39
-ERROR_PATCH=40
-
-TMP="$TMP/$PACKAGE"
-PKG=$TMP/package-imagemagick
-rm -rf $TMP
-mkdir -p $PKG
-
-# NOTE: This is to cope with ImageMagick version numbers such as 5.4.7-4,
-# which occur fairly often (but not always). If these numbers are all the same,
-# then this is not one of those versions.
-
-# This is a bit messy, so we'll explain it well. :-)
-
-# This is the base version number, which is needed to cd into the source tree
-BASEVER=6.3.3
-
-# This is the version number used in the source tarball filename
-FILEVER=6.3.3-0
-
-# This is the version number used in the package, where a version number cannot
-# contain a '-'
-PKGVER=6.3.3_0
-
-RTOOL="wget"
-PACKAGE_EXT="bz2"
-SRC="ImageMagick-$FILEVER.tar.$PACKAGE_EXT"
-URL="http://slack.sarava.org/slackware/slackware-11.0/patches/source/imagemagick/ImageMagick-6.3.3-0.tar.bz2"
-
-SRC_DIR="$SRC_DIR/$PACKAGE"
-mkdir -p $SRC_DIR
-
-if [ "$RTOOL" == "wget" ] && [ ! -f "$SRC_DIR/$SRC" ]; then
- wget "$URL" -O "$SRC_DIR/$SRC" || exit $ERROR_WGET
-fi
-
-if [ "$ARCH" = "i386" ]; then
- SLKCFLAGS="-O2 -march=i386 -mcpu=i686"
-elif [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mcpu=i686"
-elif [ "$ARCH" = "s390" ]; then
- SLKCFLAGS="-O2"
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2"
-fi
-
-# --with-x or not --with-x, that is the question. It seems many other
-# distributions don't compile with X support, but it's been traditional
-# here. I am moving the prefix to /usr (instead of /usr/X11R6) though,
-# because many X-linked things are put into /usr now (like GNOME), and
-# I've heard a few reports of compile failures when this isn't in /usr.
-# Everyone else does it -- time to follow the path of least resistance.
-
-cd $TMP
-
-tar xvf $SRC_DIR/$SRC || exit $ERROR_TAR
-cd ImageMagick-$BASEVER
-
-if [ "$BASEVER" == "6.2.3" ]; then
- zcat $CWD/imagemagick.CVE-2005-4601.CVE-2006-0082.diff.gz | patch -p1 --verbose || exit $ERROR_PATCH
-fi
-
-chown -R root.root .
-find . -perm 664 -exec chmod 644 {} \;
-find . -perm 600 -exec chmod 644 {} \;
-find . -perm 444 -exec chmod 644 {} \;
-find . -perm 400 -exec chmod 644 {} \;
-find . -perm 440 -exec chmod 644 {} \;
-find . -perm 777 -exec chmod 755 {} \;
-find . -perm 775 -exec chmod 755 {} \;
-find . -perm 511 -exec chmod 755 {} \;
-find . -perm 711 -exec chmod 755 {} \;
-find . -perm 555 -exec chmod 755 {} \;
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-./configure --prefix=/usr \
- --program-prefix= \
- --libdir=$LIBDIR \
- --enable-16bit-pixel \
- --with-x \
- --with-frozenpaths=no \
- --enable-static=no \
- --enable-shared \
- --with-perl \
- $ARCH-slackware-linux
-make || exit $ERROR_MAKE
-make install DESTDIR=$PKG || exit $ERROR_INSTALL
-
-# Lately ImageMagick has been smoking crack:
-rm -f $PKG/usr/lib/libltdl.*
-
-( cd $PKG
- # Nothing but a perl upgrade should replace this (and maybe not even that)
- find . -name perllocal.pod | xargs rm -f
-)
-
-# DESTDIR is still broken about this, but works well enough otherwise:
-chmod 644 $PKG/usr/share/man/man3/*
-mv $PKG/usr/share/man/man3 $PKG/usr/man
-rmdir $PKG/usr/share/man
-
-( cd $PKG/usr/lib/perl5
- # Ditch empty dirs:
- rmdir */* 2> /dev/null
- rmdir * 2> /dev/null
-)
-
-( cd $PKG
- find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
- find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
-)
-chown -R root.bin $PKG/usr/bin
-gzip -9 $PKG/usr/man/man?/*.?
-
-mkdir -p $PKG/usr
-mv $PKG/usr/share/doc $PKG/usr
-cp -a \
- AUTHORS LICENSE NEWS NOTICE Platforms.txt QuickStart.txt README.txt \
- $PKG/usr/doc/Imag*
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-makepkg -l y -c n $REPOS/imagemagick-$PKGVER-$ARCH-$BUILD.tgz || exit $ERROR_MKPKG
-
-if [ "$CLEANUP" == "yes" ]; then
- rm -rf $TMP
-fi
-
diff --git a/patches/imagemagick/slack-desc b/patches/imagemagick/slack-desc
deleted file mode 100644
index 80ac9a67..00000000
--- a/patches/imagemagick/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
-
- |-----handy-ruler------------------------------------------------------|
-imagemagick: imagemagick (a robust collection of image processing tools)
-imagemagick:
-imagemagick: ImageMagick is a collection of tools for manipulating and displaying
-imagemagick: digital images. It can merge images, transform image dimensions,
-imagemagick: do screen captures, create animation sequences, and convert between
-imagemagick: many different image formats.
-imagemagick:
-imagemagick: ImageMagick was written by John Cristy of ImageMagick Studio.
-imagemagick:
-imagemagick: Home page: http://www.imagemagick.org/
-imagemagick:
diff --git a/patches/python/Python-2.3.3-dirs.patch.gz b/patches/python/Python-2.3.3-dirs.patch.gz
deleted file mode 100644
index f788bc68..00000000
--- a/patches/python/Python-2.3.3-dirs.patch.gz
+++ /dev/null
Binary files differ
diff --git a/patches/python/Python-2.4.4.diff b/patches/python/Python-2.4.4.diff
deleted file mode 100644
index 09b3d804..00000000
--- a/patches/python/Python-2.4.4.diff
+++ /dev/null
@@ -1,351 +0,0 @@
-diff -Naur Python-2.4.4/Include/pythonrun.h Python-2.4.4.orig/Include/pythonrun.h
---- Python-2.4.4/Include/pythonrun.h 2006-11-02 20:40:07.000000000 -0200
-+++ Python-2.4.4.orig/Include/pythonrun.h 2004-10-07 00:58:07.000000000 -0300
-@@ -93,8 +93,6 @@
- /* In their own files */
- PyAPI_FUNC(const char *) Py_GetVersion(void);
- PyAPI_FUNC(const char *) Py_GetPlatform(void);
--PyAPI_FUNC(const char *) Py_GetArch(void);
--PyAPI_FUNC(const char *) Py_GetLib(void);
- PyAPI_FUNC(const char *) Py_GetCopyright(void);
- PyAPI_FUNC(const char *) Py_GetCompiler(void);
- PyAPI_FUNC(const char *) Py_GetBuildInfo(void);
-diff -Naur Python-2.4.4/Lib/distutils/command/install.py Python-2.4.4.orig/Lib/distutils/command/install.py
---- Python-2.4.4/Lib/distutils/command/install.py 2006-11-02 20:41:22.000000000 -0200
-+++ Python-2.4.4.orig/Lib/distutils/command/install.py 2005-01-20 17:15:39.000000000 -0200
-@@ -38,15 +38,15 @@
-
- INSTALL_SCHEMES = {
- 'unix_prefix': {
-- 'purelib': '$base/'+libname+'/python$py_version_short/site-packages',
-- 'platlib': '$platbase/'+libname+'/python$py_version_short/site-packages',
-+ 'purelib': '$base/lib/python$py_version_short/site-packages',
-+ 'platlib': '$platbase/lib/python$py_version_short/site-packages',
- 'headers': '$base/include/python$py_version_short/$dist_name',
- 'scripts': '$base/bin',
- 'data' : '$base',
- },
- 'unix_home': {
-- 'purelib': '$base/'+libname+'/python',
-- 'platlib': '$base/'+libname+'/python',
-+ 'purelib': '$base/lib/python',
-+ 'platlib': '$base/lib/python',
- 'headers': '$base/include/python/$dist_name',
- 'scripts': '$base/bin',
- 'data' : '$base',
-diff -Naur Python-2.4.4/Lib/distutils/sysconfig.py Python-2.4.4.orig/Lib/distutils/sysconfig.py
---- Python-2.4.4/Lib/distutils/sysconfig.py 2006-11-02 20:42:57.000000000 -0200
-+++ Python-2.4.4.orig/Lib/distutils/sysconfig.py 2006-10-08 14:41:25.000000000 -0300
-@@ -100,8 +100,7 @@
-
- if os.name == "posix":
- libpython = os.path.join(prefix,
-- sys.lib, "python" + get_python_version())
--
-+ "lib", "python" + get_python_version())
- if standard_lib:
- return libpython
- else:
-diff -Naur Python-2.4.4/Lib/distutils/tests/test_install.py Python-2.4.4.orig/Lib/distutils/tests/test_install.py
---- Python-2.4.4/Lib/distutils/tests/test_install.py 2006-11-02 20:44:16.000000000 -0200
-+++ Python-2.4.4.orig/Lib/distutils/tests/test_install.py 2004-06-25 20:02:59.000000000 -0300
-@@ -1,7 +1,6 @@
- """Tests for distutils.command.install."""
-
- import os
--import sys
- import unittest
-
- from distutils.command.install import install
-@@ -24,7 +23,7 @@
- dist.script_name = os.path.join(builddir, "setup.py")
- dist.command_obj["build"] = support.DummyCommand(
- build_base=builddir,
-- build_lib=os.path.join(builddir, sys.lib),
-+ build_lib=os.path.join(builddir, "lib"),
- )
-
- cmd = install(dist)
-@@ -39,7 +38,7 @@
- expected = os.path.normpath(expected)
- self.assertEqual(got, expected)
-
-- libdir = os.path.join(destination, sys.lib, "python")
-+ libdir = os.path.join(destination, "lib", "python")
- check_path(cmd.install_lib, libdir)
- check_path(cmd.install_platlib, libdir)
- check_path(cmd.install_purelib, libdir)
-diff -Naur Python-2.4.4/Lib/pydoc.py Python-2.4.4.orig/Lib/pydoc.py
---- Python-2.4.4/Lib/pydoc.py 2006-11-02 20:45:20.000000000 -0200
-+++ Python-2.4.4.orig/Lib/pydoc.py 2006-03-27 09:50:42.000000000 -0300
-@@ -326,7 +326,7 @@
-
- docloc = os.environ.get("PYTHONDOCS",
- "http://www.python.org/doc/current/lib")
-- basedir = os.path.join(sys.exec_prefix, sys.lib,
-+ basedir = os.path.join(sys.exec_prefix, "lib",
- "python"+sys.version[0:3])
- if (isinstance(object, type(os)) and
- (object.__name__ in ('errno', 'exceptions', 'gc', 'imp',
-diff -Naur Python-2.4.4/Lib/site.py Python-2.4.4.orig/Lib/site.py
---- Python-2.4.4/Lib/site.py 2006-11-02 20:46:06.000000000 -0200
-+++ Python-2.4.4.orig/Lib/site.py 2004-07-19 23:28:28.000000000 -0300
-@@ -179,12 +179,12 @@
- sitedirs = [os.path.join(prefix, "Lib", "site-packages")]
- elif os.sep == '/':
- sitedirs = [os.path.join(prefix,
-- sys.lib,
-+ "lib",
- "python" + sys.version[:3],
- "site-packages"),
-- os.path.join(prefix, sys.lib, "site-python")]
-+ os.path.join(prefix, "lib", "site-python")]
- else:
-- sitedirs = [prefix, os.path.join(prefix, sys.lib, "site-packages")]
-+ sitedirs = [prefix, os.path.join(prefix, "lib", "site-packages")]
- if sys.platform == 'darwin':
- # for framework builds *only* we add the standard Apple
- # locations. Currently only per-user, but /Library and
-diff -Naur Python-2.4.4/Lib/test/test_dl.py Python-2.4.4.orig/Lib/test/test_dl.py
---- Python-2.4.4/Lib/test/test_dl.py 2006-11-02 20:46:49.000000000 -0200
-+++ Python-2.4.4.orig/Lib/test/test_dl.py 2002-07-23 16:04:11.000000000 -0300
-@@ -4,12 +4,11 @@
- """
-
- import dl
--import sys
- from test.test_support import verbose,TestSkipped
-
- sharedlibs = [
-- ('/usr/' + sys.lib + '/libc.so', 'getpid'),
-- ('/' + sys.lib + '/libc.so.6', 'getpid'),
-+ ('/usr/lib/libc.so', 'getpid'),
-+ ('/lib/libc.so.6', 'getpid'),
- ('/usr/bin/cygwin1.dll', 'getpid'),
- ]
-
-diff -Naur Python-2.4.4/Lib/trace.py Python-2.4.4.orig/Lib/trace.py
---- Python-2.4.4/Lib/trace.py 2006-11-02 20:47:15.000000000 -0200
-+++ Python-2.4.4.orig/Lib/trace.py 2005-11-30 05:36:01.000000000 -0200
-@@ -732,10 +732,10 @@
- # should I also call expanduser? (after all, could use $HOME)
-
- s = s.replace("$prefix",
-- os.path.join(sys.prefix, sys.lib,
-+ os.path.join(sys.prefix, "lib",
- "python" + sys.version[:3]))
- s = s.replace("$exec_prefix",
-- os.path.join(sys.exec_prefix, sys.lib,
-+ os.path.join(sys.exec_prefix, "lib",
- "python" + sys.version[:3]))
- s = os.path.normpath(s)
- ignore_dirs.append(s)
-diff -Naur Python-2.4.4/Makefile.pre.in Python-2.4.4.orig/Makefile.pre.in
---- Python-2.4.4/Makefile.pre.in 2006-11-02 20:49:57.000000000 -0200
-+++ Python-2.4.4.orig/Makefile.pre.in 2006-10-08 14:41:25.000000000 -0300
-@@ -70,8 +70,6 @@
-
- # Machine-dependent subdirectories
- MACHDEP= @MACHDEP@
--LIB= @LIB@
--ARCH= @ARCH@
-
- # Install prefix for architecture-independent files
- prefix= @prefix@
-@@ -450,7 +448,6 @@
- -DEXEC_PREFIX='"$(exec_prefix)"' \
- -DVERSION='"$(VERSION)"' \
- -DVPATH='"$(VPATH)"' \
-- -DARCH='"$(ARCH)"' -DLIB='"$(LIB)"' \
- -o $@ $(srcdir)/Modules/getpath.c
-
- Modules/ccpython.o: $(srcdir)/Modules/ccpython.cc
-@@ -474,7 +471,7 @@
- Python/compile.o Python/symtable.o: $(GRAMMAR_H)
-
- Python/getplatform.o: $(srcdir)/Python/getplatform.c
-- $(CC) -c $(PY_CFLAGS) -DPLATFORM='"$(MACHDEP)"' -DARCH='"$(ARCH)"' -DLIB='"$(LIB)"' -o $@ $(srcdir)/Python/getplatform.c
-+ $(CC) -c $(PY_CFLAGS) -DPLATFORM='"$(MACHDEP)"' -o $@ $(srcdir)/Python/getplatform.c
-
- Python/importdl.o: $(srcdir)/Python/importdl.c
- $(CC) -c $(PY_CFLAGS) -I$(DLINCLDIR) -o $@ $(srcdir)/Python/importdl.c
-diff -Naur Python-2.4.4/Modules/getpath.c Python-2.4.4.orig/Modules/getpath.c
---- Python-2.4.4/Modules/getpath.c 2006-11-02 20:52:10.000000000 -0200
-+++ Python-2.4.4.orig/Modules/getpath.c 2006-02-20 14:37:39.000000000 -0300
-@@ -111,11 +111,9 @@
- #define EXEC_PREFIX PREFIX
- #endif
-
--#define LIB_PYTHON LIB "/python" VERSION
--
- #ifndef PYTHONPATH
--#define PYTHONPATH PREFIX "/" LIB_PYTHON ":" \
-- EXEC_PREFIX "/" LIB_PYTHON "/lib-dynload"
-+#define PYTHONPATH PREFIX "/lib/python" VERSION ":" \
-+ EXEC_PREFIX "/lib/python" VERSION "/lib-dynload"
- #endif
-
- #ifndef LANDMARK
-@@ -126,8 +124,7 @@
- static char exec_prefix[MAXPATHLEN+1];
- static char progpath[MAXPATHLEN+1];
- static char *module_search_path = NULL;
--static char lib_python[] = LIB_PYTHON;
--
-+static char lib_python[] = "lib/python" VERSION;
-
- static void
- reduce(char *dir)
-diff -Naur Python-2.4.4/Python/getplatform.c Python-2.4.4.orig/Python/getplatform.c
---- Python-2.4.4/Python/getplatform.c 2006-11-02 20:52:42.000000000 -0200
-+++ Python-2.4.4.orig/Python/getplatform.c 2000-09-01 20:29:29.000000000 -0300
-@@ -10,24 +10,3 @@
- {
- return PLATFORM;
- }
--
--#ifndef ARCH
--#define ARCH "unknown"
--#endif
--
--const char *
--Py_GetArch(void)
--{
-- return ARCH;
--}
--
--#ifndef LIB
--#define LIB "lib"
--#endif
--
--const char *
--Py_GetLib(void)
--{
-- return LIB;
--}
--
-diff -Naur Python-2.4.4/Python/sysmodule.c Python-2.4.4.orig/Python/sysmodule.c
---- Python-2.4.4/Python/sysmodule.c 2006-11-02 21:03:29.000000000 -0200
-+++ Python-2.4.4.orig/Python/sysmodule.c 2006-10-05 15:08:58.000000000 -0300
-@@ -1004,12 +1004,6 @@
- PyDict_SetItemString(sysdict, "hexversion",
- v = PyInt_FromLong(PY_VERSION_HEX));
- Py_XDECREF(v);
-- PyDict_SetItemString(sysdict, "arch",
-- v = PyString_FromString(Py_GetArch()));
-- Py_XDECREF(v);
-- PyDict_SetItemString(sysdict, "lib",
-- v = PyString_FromString(Py_GetLib()));
-- Py_XDECREF(v);
- /*
- * These release level checks are mutually exclusive and cover
- * the field, so don't get too fancy with the pre-processor!
-diff -Naur Python-2.4.4/configure.in Python-2.4.4.orig/configure.in
---- Python-2.4.4/configure.in 2006-11-02 21:04:51.000000000 -0200
-+++ Python-2.4.4.orig/configure.in 2006-10-17 14:03:36.000000000 -0200
-@@ -494,41 +494,6 @@
- ;;
- esac
-
--AC_SUBST(ARCH)
--AC_MSG_CHECKING(ARCH)
--ARCH=`uname -m`
--case $ARCH in
--i?86) ARCH=i386;;
--esac
--AC_MSG_RESULT($ARCH)
--
--AC_SUBST(LIB)
--AC_MSG_CHECKING(LIB)
--case $ac_sys_system in
--Linux*)
-- # Test if the compiler is 64bit
-- echo 'int i;' > conftest.$ac_ext
-- python_cv_cc_64bit_output=no
-- if AC_TRY_EVAL(ac_compile); then
-- case `/usr/bin/file conftest.$ac_objext` in
-- *"ELF 64"*)
-- python_cv_cc_64bit_output=yes
-- ;;
-- esac
-- fi
-- rm -rf conftest*
-- ;;
--esac
--
--case $ARCH:$python_cv_cc_64bit_output in
--ppc64:yes | powerpc64:yes | s390x:yes | sparc64:yes | x86_64:yes)
-- LIB="lib64"
-- ;;
--*:*)
-- LIB="lib"
-- ;;
--esac
--AC_MSG_RESULT($LIB)
-
- AC_SUBST(LIBRARY)
- AC_MSG_CHECKING(LIBRARY)
-diff -Naur Python-2.4.4/setup.py Python-2.4.4.orig/setup.py
---- Python-2.4.4/setup.py 2006-11-02 21:08:06.000000000 -0200
-+++ Python-2.4.4.orig/setup.py 2006-10-08 14:41:25.000000000 -0300
-@@ -240,7 +240,7 @@
-
- def detect_modules(self):
- # Ensure that /usr/local is always used
-- add_dir_to_list(self.compiler.library_dirs, '/usr/local/' + sys.lib)
-+ add_dir_to_list(self.compiler.library_dirs, '/usr/local/lib')
- add_dir_to_list(self.compiler.include_dirs, '/usr/local/include')
-
- # Add paths to popular package managers on OS X/darwin
-@@ -267,7 +267,8 @@
- # if a file is found in one of those directories, it can
- # be assumed that no additional -I,-L directives are needed.
- lib_dirs = self.compiler.library_dirs + [
-- '/' + sys.lib, '/usr/' + sys.lib,
-+ '/lib64', '/usr/lib64',
-+ '/lib', '/usr/lib',
- ]
- inc_dirs = self.compiler.include_dirs + ['/usr/include']
- exts = []
-@@ -449,7 +450,7 @@
- elif self.compiler.find_library_file(lib_dirs, 'curses'):
- readline_libs.append('curses')
- elif self.compiler.find_library_file(lib_dirs +
-- ['/usr/' + sys.lib + '/termcap'],
-+ ['/usr/lib/termcap'],
- 'termcap'):
- readline_libs.append('termcap')
-
-@@ -464,7 +465,7 @@
- readline_extra_link_args = ()
-
- exts.append( Extension('readline', ['readline.c'],
-- library_dirs=['/usr/' + sys.lib + '/termcap'],
-+ library_dirs=['/usr/lib/termcap'],
- extra_link_args=readline_extra_link_args,
- libraries=readline_libs) )
- if platform not in ['mac']:
-@@ -1065,18 +1066,18 @@
- # Check for various platform-specific directories
- if platform == 'sunos5':
- include_dirs.append('/usr/openwin/include')
-- added_lib_dirs.append('/usr/openwin/' + sys.lib)
-+ added_lib_dirs.append('/usr/openwin/lib')
- elif os.path.exists('/usr/X11R6/include'):
- include_dirs.append('/usr/X11R6/include')
-- added_lib_dirs.append('/usr/X11R6/' + sys.lib)
-+ added_lib_dirs.append('/usr/X11R6/lib64')
-+ added_lib_dirs.append('/usr/X11R6/lib')
- elif os.path.exists('/usr/X11R5/include'):
- include_dirs.append('/usr/X11R5/include')
-- added_lib_dirs.append('/usr/X11R5/' + sys.lib)
-+ added_lib_dirs.append('/usr/X11R5/lib')
- else:
- # Assume default location for X11
- include_dirs.append('/usr/X11/include')
-- added_lib_dirs.append('/usr/X11/' + sys.lib)
--
-+ added_lib_dirs.append('/usr/X11/lib')
-
- # If Cygwin, then verify that X is installed before proceeding
- if platform == 'cygwin':
diff --git a/patches/python/python.SlackBuild b/patches/python/python.SlackBuild
deleted file mode 100755
index 412396b2..00000000
--- a/patches/python/python.SlackBuild
+++ /dev/null
@@ -1,163 +0,0 @@
-#!/bin/bash
-#
-# slackbuild script for python
-# got it from ftp://ftp.slackware.com/pub/slackware/slackware-11.0/source/d/python/
-# small changes by rhatto at riseup.net
-#
-
-if [ -s "slack-required" ]; then
- echo Recomended and required packages for building python are:
- cat slack-required | sed -e 's/^/\t/'
- if [ "$INTERACT" != "no" ]; then
- echo If you dont have those installed, press Ctrl-C. Otherwise, hit ENTER.
- read crap
-# else
-# echo Sleeping 3 seconds...
-# sleep 3
- fi
-fi
-
-CWD="`pwd`"
-
-if [ -f ~/.slackbuildrc ]; then
- source ~/.slackbuildrc
-elif [ -f /etc/slackbuildrc ]; then
- source /etc/slackbuildrc
-fi
-
-PACKAGE="python"
-VERSION=${VERSION:=2.4.4}
-ARCH=${ARCH:=i486}
-BUILD=${BUILD:=1rha}
-SRC_DIR=${SRC:=$CWD}
-TMP=${TMP:=/tmp}
-REPOS=${REPOS:=$TMP}
-
-# ------- error codes for createpkg --------------
-ERROR_WGET=31; ERROR_MAKE=32; ERROR_INSTALL=33
-ERROR_MD5=34; ERROR_CONF=35; ERROR_HELP=36
-ERROR_TAR=37; ERROR_MKPKG=38; ERROR_GPG=39
-ERROR_PATCH=40
-
-RTOOL="wget"
-PACKAGE_EXT="bz2"
-SRC="Python-$VERSION.tar.$PACKAGE_EXT"
-URL="http://www.python.org/ftp/python/$VERSION/$SRC"
-HTML="html-2.4.4.tar.bz2"
-HTML_URL="http://www.python.org/ftp/python/doc/$VERSION/$HTML"
-
-SRC_DIR="$SRC_DIR/$PACKAGE"
-mkdir -p $SRC_DIR
-
-if [ "$RTOOL" == "wget" ]; then
- if [ ! -f "$SRC_DIR/$SRC" ]; then
- wget "$URL" -O "$SRC_DIR/$SRC" || exit $ERROR_WGET
- fi
- if [ ! -f "$SRC_DIR/$HTML" ]; then
- wget "$HTML_URL" -O "$SRC_DIR/$HTML" || exit $ERROR_WGET
- fi
-fi
-
-TMP=$TMP/$PACKAGE
-PKG=$TMP/package-$PACKAGE
-rm -rf $TMP
-mkdir -p $PKG
-
-# Location for Python site-packages:
-SITEPK=$PKG/usr/lib/python2.4/site-packages
-# same as above without $PKG
-TOOLSDIR=/usr/lib/python2.4/site-packages
-
-LIBDIR=/usr/lib
-
-# Normally I don't trust -O3, but it is the Python default so
-# I'll assume that in this case it has been well tested.
-if [ "$ARCH" = "i386" ]; then
- SLKCFLAGS="-O3 -march=i386 -mcpu=i686"
-elif [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O3 -march=i486 -mtune=i686"
-elif [ "$ARCH" = "s390" ]; then
- SLKCFLAGS="-O3"
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O3"
- LIBDIR="/usr/lib64"
-fi
-
-cd $TMP
-rm -rf Python-$VERSION
-tar xjvf $SRC_DIR/Python-$VERSION.tar.bz2 || exit $ERROR_TAR
-cd Python-$VERSION
-chown -R root:root .
-find . -type d -exec chmod 755 {} \;
-find . -type f -perm 775 -exec chmod 755 {} \;
-find . -type f -perm 664 -exec chmod 644 {} \;
-find . -type d -name CVS -exec rm -r {} \;
-
-if [ "$ARCH" == "x86_64" ]; then
- zcat $CWD/Python-2.3.3-dirs.patch.gz | patch -p0 --verbose || exit $ERROR_PATCH # thanks suse
-fi
-
-if [ -f "$CWD/$PACKAGE-$VERSION.diff" ]; then
- patch -p1 < $CWD/$PACKAGE-$VERSION.diff || exit $ERROR_PATCH
-fi
-
-OPT="$SLKCFLAGS" \
-./configure \
- --prefix=/usr \
- --libdir=$LIBDIR \
- --with-ncurses \
- --with-threads \
- --enable-ipv6 \
- --enable-shared || exit $ERROR_CONF
-make -j3 || exit $ERROR_MAKE
-make install DESTDIR=$PKG || exit $ERROR_INSTALL
-
-# Install some python-demo files:
-mkdir -p $PKG/usr/doc/python-$VERSION
-cp -a Demo $PKG/usr/doc/python-$VERSION
-
-# We'll install the python-tools under site-packages:
-mkdir -p $SITEPK
-( cd Tools ; cp -a * $SITEPK )
-mkdir -p $PKG/usr/doc/python-$VERSION
-mv $SITEPK/README $PKG/usr/doc/python-$VERSION/README.python-tools
-( cd $PKG/usr/doc/python-$VERSION
- ln -sf $TOOLSDIR Tools
-)
-# Make a few useful symlinks:
-mkdir -p $PKG/usr/bin
-( cd $PKG/usr/bin
- ln -sf /usr/lib/python2.4/site-packages/modulator/modulator.py modulator
- ln -sf /usr/lib/python2.4/site-packages/pynche/pynche pynche
- ln -sf /usr/lib/python2.4/site-packages/i18n/msgfmt.py .
- ln -sf /usr/lib/python2.4/site-packages/i18n/pygettext.py .
-)
-
-# Install docs:
-mkdir -p $PKG/usr/doc/python-$VERSION
-cp -a README $PKG/usr/doc/python-$VERSION
-cp -a Misc $PKG/usr/doc/python-$VERSION
-( cd $PKG/usr/doc/python-$VERSION ; mkdir html )
-( cd $PKG/usr/doc/python-$VERSION/html
- tar xjvf $SRC_DIR/html-$VERSION.tar.bz2
- chown -R root:root .
-)
-( cd $PKG/usr/bin
- rm -f python
- ln -sf python2.4 python
-)
-( cd $PKG
- find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
- find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
-)
-gzip -9 $PKG/usr/man/man1/*.?
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-makepkg -l y -c n $REPOS/$PACKAGE-$VERSION-$ARCH-$BUILD.tgz || exit $ERROR_MKPKG
-
-if [ "$CLEANUP" == "yes" ]; then
- rm -rf $TMP
-fi
-
diff --git a/patches/python/slack-desc b/patches/python/slack-desc
deleted file mode 100644
index 569c3c5b..00000000
--- a/patches/python/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
-
- |-----handy-ruler------------------------------------------------------|
-python: python (object-oriented interpreted programming language)
-python:
-python: Python is an interpreted, interactive, object-oriented programming
-python: language that combines remarkable power with very clear syntax.
-python: Python's basic power can be extended with your own modules written in
-python: C or C++. Python is also adaptable as an extension language for
-python: existing applications.
-python:
-python:
-python:
-python: