aboutsummaryrefslogtreecommitdiff
path: root/patches/python/Python-2.4.4.diff
diff options
context:
space:
mode:
Diffstat (limited to 'patches/python/Python-2.4.4.diff')
-rw-r--r--patches/python/Python-2.4.4.diff351
1 files changed, 0 insertions, 351 deletions
diff --git a/patches/python/Python-2.4.4.diff b/patches/python/Python-2.4.4.diff
deleted file mode 100644
index 09b3d804..00000000
--- a/patches/python/Python-2.4.4.diff
+++ /dev/null
@@ -1,351 +0,0 @@
-diff -Naur Python-2.4.4/Include/pythonrun.h Python-2.4.4.orig/Include/pythonrun.h
---- Python-2.4.4/Include/pythonrun.h 2006-11-02 20:40:07.000000000 -0200
-+++ Python-2.4.4.orig/Include/pythonrun.h 2004-10-07 00:58:07.000000000 -0300
-@@ -93,8 +93,6 @@
- /* In their own files */
- PyAPI_FUNC(const char *) Py_GetVersion(void);
- PyAPI_FUNC(const char *) Py_GetPlatform(void);
--PyAPI_FUNC(const char *) Py_GetArch(void);
--PyAPI_FUNC(const char *) Py_GetLib(void);
- PyAPI_FUNC(const char *) Py_GetCopyright(void);
- PyAPI_FUNC(const char *) Py_GetCompiler(void);
- PyAPI_FUNC(const char *) Py_GetBuildInfo(void);
-diff -Naur Python-2.4.4/Lib/distutils/command/install.py Python-2.4.4.orig/Lib/distutils/command/install.py
---- Python-2.4.4/Lib/distutils/command/install.py 2006-11-02 20:41:22.000000000 -0200
-+++ Python-2.4.4.orig/Lib/distutils/command/install.py 2005-01-20 17:15:39.000000000 -0200
-@@ -38,15 +38,15 @@
-
- INSTALL_SCHEMES = {
- 'unix_prefix': {
-- 'purelib': '$base/'+libname+'/python$py_version_short/site-packages',
-- 'platlib': '$platbase/'+libname+'/python$py_version_short/site-packages',
-+ 'purelib': '$base/lib/python$py_version_short/site-packages',
-+ 'platlib': '$platbase/lib/python$py_version_short/site-packages',
- 'headers': '$base/include/python$py_version_short/$dist_name',
- 'scripts': '$base/bin',
- 'data' : '$base',
- },
- 'unix_home': {
-- 'purelib': '$base/'+libname+'/python',
-- 'platlib': '$base/'+libname+'/python',
-+ 'purelib': '$base/lib/python',
-+ 'platlib': '$base/lib/python',
- 'headers': '$base/include/python/$dist_name',
- 'scripts': '$base/bin',
- 'data' : '$base',
-diff -Naur Python-2.4.4/Lib/distutils/sysconfig.py Python-2.4.4.orig/Lib/distutils/sysconfig.py
---- Python-2.4.4/Lib/distutils/sysconfig.py 2006-11-02 20:42:57.000000000 -0200
-+++ Python-2.4.4.orig/Lib/distutils/sysconfig.py 2006-10-08 14:41:25.000000000 -0300
-@@ -100,8 +100,7 @@
-
- if os.name == "posix":
- libpython = os.path.join(prefix,
-- sys.lib, "python" + get_python_version())
--
-+ "lib", "python" + get_python_version())
- if standard_lib:
- return libpython
- else:
-diff -Naur Python-2.4.4/Lib/distutils/tests/test_install.py Python-2.4.4.orig/Lib/distutils/tests/test_install.py
---- Python-2.4.4/Lib/distutils/tests/test_install.py 2006-11-02 20:44:16.000000000 -0200
-+++ Python-2.4.4.orig/Lib/distutils/tests/test_install.py 2004-06-25 20:02:59.000000000 -0300
-@@ -1,7 +1,6 @@
- """Tests for distutils.command.install."""
-
- import os
--import sys
- import unittest
-
- from distutils.command.install import install
-@@ -24,7 +23,7 @@
- dist.script_name = os.path.join(builddir, "setup.py")
- dist.command_obj["build"] = support.DummyCommand(
- build_base=builddir,
-- build_lib=os.path.join(builddir, sys.lib),
-+ build_lib=os.path.join(builddir, "lib"),
- )
-
- cmd = install(dist)
-@@ -39,7 +38,7 @@
- expected = os.path.normpath(expected)
- self.assertEqual(got, expected)
-
-- libdir = os.path.join(destination, sys.lib, "python")
-+ libdir = os.path.join(destination, "lib", "python")
- check_path(cmd.install_lib, libdir)
- check_path(cmd.install_platlib, libdir)
- check_path(cmd.install_purelib, libdir)
-diff -Naur Python-2.4.4/Lib/pydoc.py Python-2.4.4.orig/Lib/pydoc.py
---- Python-2.4.4/Lib/pydoc.py 2006-11-02 20:45:20.000000000 -0200
-+++ Python-2.4.4.orig/Lib/pydoc.py 2006-03-27 09:50:42.000000000 -0300
-@@ -326,7 +326,7 @@
-
- docloc = os.environ.get("PYTHONDOCS",
- "http://www.python.org/doc/current/lib")
-- basedir = os.path.join(sys.exec_prefix, sys.lib,
-+ basedir = os.path.join(sys.exec_prefix, "lib",
- "python"+sys.version[0:3])
- if (isinstance(object, type(os)) and
- (object.__name__ in ('errno', 'exceptions', 'gc', 'imp',
-diff -Naur Python-2.4.4/Lib/site.py Python-2.4.4.orig/Lib/site.py
---- Python-2.4.4/Lib/site.py 2006-11-02 20:46:06.000000000 -0200
-+++ Python-2.4.4.orig/Lib/site.py 2004-07-19 23:28:28.000000000 -0300
-@@ -179,12 +179,12 @@
- sitedirs = [os.path.join(prefix, "Lib", "site-packages")]
- elif os.sep == '/':
- sitedirs = [os.path.join(prefix,
-- sys.lib,
-+ "lib",
- "python" + sys.version[:3],
- "site-packages"),
-- os.path.join(prefix, sys.lib, "site-python")]
-+ os.path.join(prefix, "lib", "site-python")]
- else:
-- sitedirs = [prefix, os.path.join(prefix, sys.lib, "site-packages")]
-+ sitedirs = [prefix, os.path.join(prefix, "lib", "site-packages")]
- if sys.platform == 'darwin':
- # for framework builds *only* we add the standard Apple
- # locations. Currently only per-user, but /Library and
-diff -Naur Python-2.4.4/Lib/test/test_dl.py Python-2.4.4.orig/Lib/test/test_dl.py
---- Python-2.4.4/Lib/test/test_dl.py 2006-11-02 20:46:49.000000000 -0200
-+++ Python-2.4.4.orig/Lib/test/test_dl.py 2002-07-23 16:04:11.000000000 -0300
-@@ -4,12 +4,11 @@
- """
-
- import dl
--import sys
- from test.test_support import verbose,TestSkipped
-
- sharedlibs = [
-- ('/usr/' + sys.lib + '/libc.so', 'getpid'),
-- ('/' + sys.lib + '/libc.so.6', 'getpid'),
-+ ('/usr/lib/libc.so', 'getpid'),
-+ ('/lib/libc.so.6', 'getpid'),
- ('/usr/bin/cygwin1.dll', 'getpid'),
- ]
-
-diff -Naur Python-2.4.4/Lib/trace.py Python-2.4.4.orig/Lib/trace.py
---- Python-2.4.4/Lib/trace.py 2006-11-02 20:47:15.000000000 -0200
-+++ Python-2.4.4.orig/Lib/trace.py 2005-11-30 05:36:01.000000000 -0200
-@@ -732,10 +732,10 @@
- # should I also call expanduser? (after all, could use $HOME)
-
- s = s.replace("$prefix",
-- os.path.join(sys.prefix, sys.lib,
-+ os.path.join(sys.prefix, "lib",
- "python" + sys.version[:3]))
- s = s.replace("$exec_prefix",
-- os.path.join(sys.exec_prefix, sys.lib,
-+ os.path.join(sys.exec_prefix, "lib",
- "python" + sys.version[:3]))
- s = os.path.normpath(s)
- ignore_dirs.append(s)
-diff -Naur Python-2.4.4/Makefile.pre.in Python-2.4.4.orig/Makefile.pre.in
---- Python-2.4.4/Makefile.pre.in 2006-11-02 20:49:57.000000000 -0200
-+++ Python-2.4.4.orig/Makefile.pre.in 2006-10-08 14:41:25.000000000 -0300
-@@ -70,8 +70,6 @@
-
- # Machine-dependent subdirectories
- MACHDEP= @MACHDEP@
--LIB= @LIB@
--ARCH= @ARCH@
-
- # Install prefix for architecture-independent files
- prefix= @prefix@
-@@ -450,7 +448,6 @@
- -DEXEC_PREFIX='"$(exec_prefix)"' \
- -DVERSION='"$(VERSION)"' \
- -DVPATH='"$(VPATH)"' \
-- -DARCH='"$(ARCH)"' -DLIB='"$(LIB)"' \
- -o $@ $(srcdir)/Modules/getpath.c
-
- Modules/ccpython.o: $(srcdir)/Modules/ccpython.cc
-@@ -474,7 +471,7 @@
- Python/compile.o Python/symtable.o: $(GRAMMAR_H)
-
- Python/getplatform.o: $(srcdir)/Python/getplatform.c
-- $(CC) -c $(PY_CFLAGS) -DPLATFORM='"$(MACHDEP)"' -DARCH='"$(ARCH)"' -DLIB='"$(LIB)"' -o $@ $(srcdir)/Python/getplatform.c
-+ $(CC) -c $(PY_CFLAGS) -DPLATFORM='"$(MACHDEP)"' -o $@ $(srcdir)/Python/getplatform.c
-
- Python/importdl.o: $(srcdir)/Python/importdl.c
- $(CC) -c $(PY_CFLAGS) -I$(DLINCLDIR) -o $@ $(srcdir)/Python/importdl.c
-diff -Naur Python-2.4.4/Modules/getpath.c Python-2.4.4.orig/Modules/getpath.c
---- Python-2.4.4/Modules/getpath.c 2006-11-02 20:52:10.000000000 -0200
-+++ Python-2.4.4.orig/Modules/getpath.c 2006-02-20 14:37:39.000000000 -0300
-@@ -111,11 +111,9 @@
- #define EXEC_PREFIX PREFIX
- #endif
-
--#define LIB_PYTHON LIB "/python" VERSION
--
- #ifndef PYTHONPATH
--#define PYTHONPATH PREFIX "/" LIB_PYTHON ":" \
-- EXEC_PREFIX "/" LIB_PYTHON "/lib-dynload"
-+#define PYTHONPATH PREFIX "/lib/python" VERSION ":" \
-+ EXEC_PREFIX "/lib/python" VERSION "/lib-dynload"
- #endif
-
- #ifndef LANDMARK
-@@ -126,8 +124,7 @@
- static char exec_prefix[MAXPATHLEN+1];
- static char progpath[MAXPATHLEN+1];
- static char *module_search_path = NULL;
--static char lib_python[] = LIB_PYTHON;
--
-+static char lib_python[] = "lib/python" VERSION;
-
- static void
- reduce(char *dir)
-diff -Naur Python-2.4.4/Python/getplatform.c Python-2.4.4.orig/Python/getplatform.c
---- Python-2.4.4/Python/getplatform.c 2006-11-02 20:52:42.000000000 -0200
-+++ Python-2.4.4.orig/Python/getplatform.c 2000-09-01 20:29:29.000000000 -0300
-@@ -10,24 +10,3 @@
- {
- return PLATFORM;
- }
--
--#ifndef ARCH
--#define ARCH "unknown"
--#endif
--
--const char *
--Py_GetArch(void)
--{
-- return ARCH;
--}
--
--#ifndef LIB
--#define LIB "lib"
--#endif
--
--const char *
--Py_GetLib(void)
--{
-- return LIB;
--}
--
-diff -Naur Python-2.4.4/Python/sysmodule.c Python-2.4.4.orig/Python/sysmodule.c
---- Python-2.4.4/Python/sysmodule.c 2006-11-02 21:03:29.000000000 -0200
-+++ Python-2.4.4.orig/Python/sysmodule.c 2006-10-05 15:08:58.000000000 -0300
-@@ -1004,12 +1004,6 @@
- PyDict_SetItemString(sysdict, "hexversion",
- v = PyInt_FromLong(PY_VERSION_HEX));
- Py_XDECREF(v);
-- PyDict_SetItemString(sysdict, "arch",
-- v = PyString_FromString(Py_GetArch()));
-- Py_XDECREF(v);
-- PyDict_SetItemString(sysdict, "lib",
-- v = PyString_FromString(Py_GetLib()));
-- Py_XDECREF(v);
- /*
- * These release level checks are mutually exclusive and cover
- * the field, so don't get too fancy with the pre-processor!
-diff -Naur Python-2.4.4/configure.in Python-2.4.4.orig/configure.in
---- Python-2.4.4/configure.in 2006-11-02 21:04:51.000000000 -0200
-+++ Python-2.4.4.orig/configure.in 2006-10-17 14:03:36.000000000 -0200
-@@ -494,41 +494,6 @@
- ;;
- esac
-
--AC_SUBST(ARCH)
--AC_MSG_CHECKING(ARCH)
--ARCH=`uname -m`
--case $ARCH in
--i?86) ARCH=i386;;
--esac
--AC_MSG_RESULT($ARCH)
--
--AC_SUBST(LIB)
--AC_MSG_CHECKING(LIB)
--case $ac_sys_system in
--Linux*)
-- # Test if the compiler is 64bit
-- echo 'int i;' > conftest.$ac_ext
-- python_cv_cc_64bit_output=no
-- if AC_TRY_EVAL(ac_compile); then
-- case `/usr/bin/file conftest.$ac_objext` in
-- *"ELF 64"*)
-- python_cv_cc_64bit_output=yes
-- ;;
-- esac
-- fi
-- rm -rf conftest*
-- ;;
--esac
--
--case $ARCH:$python_cv_cc_64bit_output in
--ppc64:yes | powerpc64:yes | s390x:yes | sparc64:yes | x86_64:yes)
-- LIB="lib64"
-- ;;
--*:*)
-- LIB="lib"
-- ;;
--esac
--AC_MSG_RESULT($LIB)
-
- AC_SUBST(LIBRARY)
- AC_MSG_CHECKING(LIBRARY)
-diff -Naur Python-2.4.4/setup.py Python-2.4.4.orig/setup.py
---- Python-2.4.4/setup.py 2006-11-02 21:08:06.000000000 -0200
-+++ Python-2.4.4.orig/setup.py 2006-10-08 14:41:25.000000000 -0300
-@@ -240,7 +240,7 @@
-
- def detect_modules(self):
- # Ensure that /usr/local is always used
-- add_dir_to_list(self.compiler.library_dirs, '/usr/local/' + sys.lib)
-+ add_dir_to_list(self.compiler.library_dirs, '/usr/local/lib')
- add_dir_to_list(self.compiler.include_dirs, '/usr/local/include')
-
- # Add paths to popular package managers on OS X/darwin
-@@ -267,7 +267,8 @@
- # if a file is found in one of those directories, it can
- # be assumed that no additional -I,-L directives are needed.
- lib_dirs = self.compiler.library_dirs + [
-- '/' + sys.lib, '/usr/' + sys.lib,
-+ '/lib64', '/usr/lib64',
-+ '/lib', '/usr/lib',
- ]
- inc_dirs = self.compiler.include_dirs + ['/usr/include']
- exts = []
-@@ -449,7 +450,7 @@
- elif self.compiler.find_library_file(lib_dirs, 'curses'):
- readline_libs.append('curses')
- elif self.compiler.find_library_file(lib_dirs +
-- ['/usr/' + sys.lib + '/termcap'],
-+ ['/usr/lib/termcap'],
- 'termcap'):
- readline_libs.append('termcap')
-
-@@ -464,7 +465,7 @@
- readline_extra_link_args = ()
-
- exts.append( Extension('readline', ['readline.c'],
-- library_dirs=['/usr/' + sys.lib + '/termcap'],
-+ library_dirs=['/usr/lib/termcap'],
- extra_link_args=readline_extra_link_args,
- libraries=readline_libs) )
- if platform not in ['mac']:
-@@ -1065,18 +1066,18 @@
- # Check for various platform-specific directories
- if platform == 'sunos5':
- include_dirs.append('/usr/openwin/include')
-- added_lib_dirs.append('/usr/openwin/' + sys.lib)
-+ added_lib_dirs.append('/usr/openwin/lib')
- elif os.path.exists('/usr/X11R6/include'):
- include_dirs.append('/usr/X11R6/include')
-- added_lib_dirs.append('/usr/X11R6/' + sys.lib)
-+ added_lib_dirs.append('/usr/X11R6/lib64')
-+ added_lib_dirs.append('/usr/X11R6/lib')
- elif os.path.exists('/usr/X11R5/include'):
- include_dirs.append('/usr/X11R5/include')
-- added_lib_dirs.append('/usr/X11R5/' + sys.lib)
-+ added_lib_dirs.append('/usr/X11R5/lib')
- else:
- # Assume default location for X11
- include_dirs.append('/usr/X11/include')
-- added_lib_dirs.append('/usr/X11/' + sys.lib)
--
-+ added_lib_dirs.append('/usr/X11/lib')
-
- # If Cygwin, then verify that X is installed before proceeding
- if platform == 'cygwin':