aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMicah Anderson <micah@riseup.net>2008-06-24 18:02:23 +0000
committerMicah Anderson <micah@riseup.net>2008-06-24 18:02:23 +0000
commitca12e5617b1c7a600324e2c6437444627720c62c (patch)
tree21692e13ec99f79839a7dbf8c92571100d583b23 /configure.in
parentfd6796ad99b90371594c3068e6d8bbbdb2b1d1d5 (diff)
downloadbackupninja-ca12e5617b1c7a600324e2c6437444627720c62c.tar.gz
backupninja-ca12e5617b1c7a600324e2c6437444627720c62c.tar.bz2
made mktemp a requirement for building backupninja, added autotools variables to substitute the proper binary location and removed bad fall-back when mktemp was not there
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 0d603ff..43a6513 100644
--- a/configure.in
+++ b/configure.in
@@ -36,6 +36,11 @@ if test x$MD5SUM = "xno"; then
AC_MSG_ERROR([md5sum is required])
fi
+AC_PATH_PROGS(MKTEMP, mktemp, "no")
+if test x$MKTEMPT = "xno"; then
+ AC_MSG_ERROR([mktemp is required])
+fi
+
AC_CHECK_PROG(ac_cv_have_rpm, rpm, "yes", "no")
if test "x$ac_cv_have_rpm" = "xyes"; then
rpm --define '_topdir /tmp' > /dev/null 2>&1