aboutsummaryrefslogtreecommitdiff
path: root/patches/libpng/libpng.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'patches/libpng/libpng.SlackBuild')
-rwxr-xr-xpatches/libpng/libpng.SlackBuild164
1 files changed, 0 insertions, 164 deletions
diff --git a/patches/libpng/libpng.SlackBuild b/patches/libpng/libpng.SlackBuild
deleted file mode 100755
index a218cb32..00000000
--- a/patches/libpng/libpng.SlackBuild
+++ /dev/null
@@ -1,164 +0,0 @@
-#!/bin/bash
-#
-# slackbuild script for libpng
-# by rhatto at riseup.net
-#
-# some code grabbed from slackware 11.0 and slamd64-11.0 scripts, found at
-# ftp://ftp.slackware.com/pub/slackware/slackware-11.0/source/l/libpng/ and
-# http://slamd64.he.net/slamd64-11.0/source/l/libpng/libpng.SlackBuild
-#
-
-if [ -s "slack-required" ]; then
- echo Recomended and required packages for building libpng are:
- cat slack-required | sed -e 's/^/\t/'
- if [ "$INTERACT" != "no" ]; then
- echo If you dont have those installed, press Ctrl-C. Otherwise, hit ENTER.
- read crap
-# else
-# echo Sleeping 3 seconds...
-# sleep 3
- fi
-fi
-
-CWD="`pwd`"
-
-if [ -f ~/.slackbuildrc ]; then
- source ~/.slackbuildrc
-elif [ -f /etc/slackbuildrc ]; then
- source /etc/slackbuildrc
-fi
-
-# default settings
-PACKAGE="libpng"
-ARCH=${ARCH:=i486}
-VERSION=${VERSION:=1.2.29}
-BUILD=${BUILD:=1rha}
-SRC_DIR=${SRC:=$CWD}
-TMP=${TMP:=/tmp}
-REPOS=${REPOS:=$TMP}
-
-if [ "$ARCH" == "x86_64" ]; then
- export LDFLAGS="-L/lib64 -L/usr/lib64"
- LIBDIR=/usr/lib64
-else
- LIBDIR=/usr/lib
-fi
-
-# ------- error codes for createpkg --------------
-ERROR_WGET=31; ERROR_MAKE=32; ERROR_INSTALL=33
-ERROR_MD5=34; ERROR_CONF=35; ERROR_HELP=36
-ERROR_TAR=37; ERROR_MKPKG=38; ERROR_GPG=39
-ERROR_PATCH=40
-
-RTOOL="wget"
-PACKAGE_EXT="gz"
-SRC="$PACKAGE-$VERSION.tar.$PACKAGE_EXT"
-URL="http://ufpr.dl.sourceforge.net/sourceforge/libpng/$SRC"
-
-SRC_DIR="$SRC_DIR/$PACKAGE"
-mkdir -p $SRC_DIR
-
-if [ "$RTOOL" == "wget" ] && [ ! -f "$SRC_DIR/$SRC" ]; then
- wget "$URL" -O "$SRC_DIR/$SRC" || exit $ERROR_WGET
-fi
-
-TMP="$TMP/$PACKAGE"
-rm -rf $TMP
-mkdir -p $TMP
-cd $TMP
-
-tar xvf $SRC_DIR/$SRC || exit $ERROR_TAR
-cd $PACKAGE-$VERSION
-
-if [ -f "$CWD/$PACKAGE-$VERSION.diff" ]; then
- patch -p1 < $CWD/$PACKAGE-$VERSION.diff || exit $ERROR_PATCH
-fi
-
-chown -R root:root .
-find . -perm 664 -exec chmod 644 {} \;
-find . -perm 600 -exec chmod 644 {} \;
-find . -perm 444 -exec chmod 644 {} \;
-find . -perm 400 -exec chmod 644 {} \;
-find . -perm 440 -exec chmod 644 {} \;
-find . -perm 777 -exec chmod 755 {} \;
-find . -perm 775 -exec chmod 755 {} \;
-find . -perm 511 -exec chmod 755 {} \;
-find . -perm 711 -exec chmod 755 {} \;
-find . -perm 555 -exec chmod 755 {} \;
-
-if [ "$ARCH" == "x86_64" ]; then
-
- # Do *NOT* move this... put here in Slamd64 so that libdir
- # can be overriden and so that we don't have inline assembly problems
- # - if you change this, rebuilding libpng will break, and
- # you'll have to rebuild everything that links to it (e.g. KDE).
- zcat $CWD/libpng.libs.diff.gz | patch -p1 --verbose || exit $ERROR_PATCH
- ln -sf scripts/makefile.linux ./Makefile
-
- ./configure --prefix=/usr --libdir=$LIBDIR || exit $ERROR_CONF
-
-else
-
- ./configure --prefix=/usr --libdir=$LIBDIR || exit $ERROR_CONF
- zcat $CWD/libpng.libs.diff.gz | patch -p1 --verbose || exit $ERROR_PATCH
- ln -sf scripts/makefile.linux ./Makefile
-
-fi
-
-make || exit $ERROR_MAKE
-make DESTDIR=$TMP/package-$PACKAGE install || exit $ERROR_INSTALL
-
-CWD="`pwd`"
-
-cd $TMP/package-$PACKAGE
-
-# This symlink is needed to keep old applications running:
-( cd usr/lib
- if [ ! -e libpng.so.0 -a -e libpng.so.3 ]; then
- ln -sf libpng.so.3 libpng.so.0
- fi
-)
-
-find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
-find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
-
-gzip -9 usr/man/man?/*
-
-mkdir install
-cat << EOF > install/slack-desc
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
-
- |-----handy-ruler------------------------------------------------------|
-libpng: libpng (Portable Network Graphics library)
-libpng:
-libpng: PNG (Portable Network Graphics) is an extensible file format for the
-libpng: lossless, portable, well-compressed storage of raster images. PNG
-libpng: provides a patent-free replacement for GIF and can also replace many
-libpng: common uses of TIFF. Indexed-color, grayscale, and truecolor images
-libpng: are supported, plus an optional alpha channel. Sample depths range
-libpng: from 1 to 16 bits.
-libpng:
-libpng:
-libpng:
-EOF
-
-# docs
-mkdir -p usr/doc/$PACKAGE-$VERSION
-
-DOCS="ANNOUNCE CHANGES INSTALL KNOWNBUG LICENSE README TODO Y2KINFO libpng.txt example.c"
-
-for file in $DOCS; do
- cp $CWD/$file* usr/doc/$PACKAGE-$VERSION/
-done
-
-makepkg -c y -l y $REPOS/$PACKAGE-$VERSION-$ARCH-$BUILD.tgz || exit $ERROR_MKPKG
-
-if [ "$CLEANUP" == "yes" ]; then
- rm -rf $TMP
-fi
-