aboutsummaryrefslogtreecommitdiff
path: root/media/sound/hydrogen/hydrogen-0.9.3.diff
diff options
context:
space:
mode:
Diffstat (limited to 'media/sound/hydrogen/hydrogen-0.9.3.diff')
-rw-r--r--media/sound/hydrogen/hydrogen-0.9.3.diff1088
1 files changed, 602 insertions, 486 deletions
diff --git a/media/sound/hydrogen/hydrogen-0.9.3.diff b/media/sound/hydrogen/hydrogen-0.9.3.diff
index d47db8d9..1f0dc30a 100644
--- a/media/sound/hydrogen/hydrogen-0.9.3.diff
+++ b/media/sound/hydrogen/hydrogen-0.9.3.diff
@@ -1,83 +1,599 @@
---- hydrogen-0.9.3/src/lib/xml/tinyxml.h~ 2006-03-15 15:43:13.000000000 +0000
-+++ hydrogen-0.9.3/src/lib/xml/tinyxml.h 2006-03-15 15:43:33.000000000 +0000
-@@ -823,9 +823,9 @@
- #endif
-
- /// Construct.
-- TiXmlDeclaration::TiXmlDeclaration( const char * _version,
-- const char * _encoding,
-- const char * _standalone );
-+ TiXmlDeclaration( const char * _version,
-+ const char * _encoding,
-+ const char * _standalone );
+diff -Naur hydrogen-0.9.3.orig/Makefile.in hydrogen-0.9.3/Makefile.in
+--- hydrogen-0.9.3.orig/Makefile.in 2005-11-10 16:00:08.000000000 -0200
++++ hydrogen-0.9.3/Makefile.in 2008-07-24 19:43:46.000000000 -0300
+@@ -225,7 +225,7 @@
+ mkdir -p $(DESTDIR)$(prefix)/share/hydrogen/data/
+ cp -R data $(DESTDIR)$(prefix)/share/hydrogen
+ mkdir -p $(DESTDIR)$(prefix)/share/hydrogen/data/
+- @install -vD hydrogen.desktop $(DESTDIR)$(prefix)/share/applications/hydrogen.desktop
++ @install -vD -m 644 hydrogen.desktop $(DESTDIR)$(prefix)/share/applications/hydrogen.desktop
+ cd plugins;make install;cd ..
+
+
+diff -Naur hydrogen-0.9.3.orig/configure.in hydrogen-0.9.3/configure.in
+--- hydrogen-0.9.3.orig/configure.in 2006-01-18 20:02:37.000000000 -0200
++++ hydrogen-0.9.3/configure.in 2008-07-24 19:43:40.000000000 -0300
+@@ -367,6 +367,8 @@
+ echo "--- Checking for PortAudio -------------------------------------"
- virtual ~TiXmlDeclaration() {}
+ portaudio_support=false
++AC_ARG_ENABLE(portaudio, [ --disable-portaudio Compile without portaudio support], [want_portaudio=$enableval])
++if test "x$want_portaudio" != "xno"; then
+ AC_MSG_CHECKING([whether PORTAUDIOPATH environment variable is set])
+ if test "x$PORTAUDIOPATH" = "x"; then
+ AC_MSG_RESULT(PORTAUDIOPATH is not set. No PortAudio support.)
+@@ -389,6 +391,7 @@
+ echo "-----------------------------------------------------------------"
+ echo ""
-
---- hydrogen-0.9.3/src/tools/HydrogenPlayer.cpp~ 2007-04-01 21:01:06.000000000 +0000
-+++ hydrogen-0.9.3/src/tools/HydrogenPlayer.cpp 2007-04-01 21:01:28.000000000 +0000
-@@ -25,6 +25,7 @@
++fi
- #include <qapplication.h>
-+#include <cstdlib>
- #include <iostream>
- #include <stdio.h>
- #include <string>
---- hydrogen-0.9.3/src/gui/DrumkitManager.cpp~ 2007-04-01 21:03:50.000000000 +0000
-+++ hydrogen-0.9.3/src/gui/DrumkitManager.cpp 2007-04-01 21:03:58.000000000 +0000
-@@ -22,6 +22,7 @@
- *
- */
- #include <qcursor.h>
-+#include <cstdlib>
-
- #include "config.h"
- #include "Skin.h"
---- hydrogen-0.9.3/src/gui/HydrogenApp.cpp~ 2007-04-01 21:04:29.000000000 +0000
-+++ hydrogen-0.9.3/src/gui/HydrogenApp.cpp 2007-04-01 21:04:37.000000000 +0000
-@@ -46,6 +46,7 @@
- #include "LadspaFXProperties.h"
- #include "SongEditor/SongEditorPanel.h"
-
-+#include <cstdlib>
- #include <qdockwindow.h>
- #include <qsplitter.h>
- #include <qhbox.h>
---- hydrogen-0.9.3/src/gui/main.cpp~ 2007-04-01 21:05:56.000000000 +0000
-+++ hydrogen-0.9.3/src/gui/main.cpp 2007-04-01 21:06:04.000000000 +0000
-@@ -42,6 +42,7 @@
- #include "lib/DataPath.h"
- #include "lib/Exception.h"
-
-+#include <cstdlib>
- #include <iostream>
- using namespace std;
-
---- hydrogen-0.9.3/src/lib/FLACFile.cpp
-+++ hydrogen-0.9.3/src/lib/FLACFile.cpp
-@@ -39,6 +39,8 @@
- #undef LEGACY_FLAC
- #endif
-+#include <cstring>
+diff -Naur hydrogen-0.9.3.orig/configure.in~ hydrogen-0.9.3/configure.in~
+--- hydrogen-0.9.3.orig/configure.in~ 1969-12-31 21:00:00.000000000 -0300
++++ hydrogen-0.9.3/configure.in~ 2006-01-18 20:02:37.000000000 -0200
+@@ -0,0 +1,557 @@
++d added Qt .dylib search for OS X systems (2004/12/17 Jonathan Dempsey)
+
-
- /// Reads a FLAC file...not optimized yet
- class FLACFile_real : public FLAC::Decoder::File, public Object
---- hydrogen-0.9.3/src/lib/drivers/OssDriver.cpp
-+++ hydrogen-0.9.3/src/lib/drivers/OssDriver.cpp
-@@ -31,6 +31,8 @@
-
- #include <pthread.h>
-
-+#include <cstring>
+
- audioProcessCallback ossDriver_audioProcessCallback;
- bool ossDriver_running;
- pthread_t ossDriverThread;
---- hydrogen-0.9.3/src/lib/FLACFile.cpp.old 2007-02-11 20:12:34.000000000 +0100
-+++ hydrogen-0.9.3/src/lib/FLACFile.cpp 2007-02-11 20:18:25.000000000 +0100
++dnl Process this file with autoconf to produce a configure script.
++AC_INIT(README)
++#AC_PREREQ(2.58)
++
++extra_version=""
++hydrogenVersion="0.9.3$extra_version"
++
++echo "
++
++-----------------------------------------------------------------
++Starting Hydrogen $hydrogenVersion configuration...
++-----------------------------------------------------------------
++
++"
++#ac_qmake_lflags="-static"
++#AC_SUBST(ac_qmake_lflags)
++
++
++# static build
++#ac_libraries=-static
++
++
++AC_DEFINE_UNQUOTED(VERSION, "${hydrogenVersion}", [Version])
++
++
++AC_CONFIG_HEADER(config.h)
++
++dnl Set default installation prefix.
++AC_PREFIX_DEFAULT(/usr/local)
++ac_prefix=$prefix
++if test "x$ac_prefix" = "xNONE"; then
++ ac_prefix=$ac_default_prefix
++fi
++AC_SUBST(ac_prefix)
++AC_DEFINE_UNQUOTED(CONFIG_PREFIX, ["$ac_prefix"], [Default installation prefix.])
++
++
++AC_ARG_ENABLE(profile, [ --enable-profile enable profile info (default=no)], [useProfile="yes"], [useProfile="no"])
++if test "x$useProfile" = "xyes"; then
++ ac_qmake_cflags="-pg"
++ ac_qmake_cxxflags="-pg"
++ ac_qmake_lflags="-pg"
++ AC_SUBST(ac_qmake_cflags)
++ AC_SUBST(ac_qmake_cxxflags)
++ AC_SUBST(ac_qmake_lflags)
++fi
++
++dnl Enable debugging argument option.
++AC_ARG_ENABLE(debug, [ --enable-debug enable debugging (default=no)], [ac_debug="debug"], [ac_debug="release"])
++AC_SUBST(ac_debug)
++if test "x$ac_debug" = "xdebug"; then
++ AC_DEFINE(CONFIG_DEBUG, 1, [Define if debugging is enabled.])
++ features_list="${features_list} (Debug)"
++ echo " * Debug mode enabled."
++# CXXFLAGS="${CXXFLAGS} -g -O3"
++#else
++# CXXFLAGS="${CXXFLAGS} -O3"
++fi
++
++ladspa_enabled=yes
++AC_ARG_ENABLE(ladspa, [ --disable-ladspa disable LADSPA support (default=no)], [ladspa_enabled=$enableval])
++
++if test "x$ladspa_enabled" = "xyes"; then
++ AC_DEFINE(LADSPA_SUPPORT, 1, [Define if LADSPA support is enabled.])
++else
++ echo " * LADSPA support disabled."
++fi
++
++
++dnl Checks for programs.
++AC_PROG_CC
++AC_PROG_CPP
++AC_PROG_CXX
++AC_PROG_CXXCPP
++AC_PROG_GCC_TRADITIONAL
++
++dnl Checks for languages.
++AC_LANG_C
++AC_LANG_CPLUSPLUS
++
++
++
++########################
++#
++# QT
++#
++#####################
++echo ""
++echo "--- Checking for QT Libs ----------------------------------------"
++
++#dnl Check for QTDIR environment variable.
++AC_MSG_CHECKING([whether QTDIR environment variable is set])
++if test "x$QTDIR" = "x"; then
++ # is not set
++ AC_MSG_RESULT([no])
++ AC_MSG_WARN([QTDIR must be properly set.])
++
++ echo " * Searching for Qt library"
++ ac_qtlib=""
++ for X in /usr/share/qt /usr/share/qt3 /usr/lib/qt3 /usr/lib/qt-3.1; do
++ if test "x$ac_qtlib" = "x"; then
++ if test -f $X/lib/libqt-mt.so -o -f $X/lib/libqt-mt.a -o -f $X/lib/libqt-mt.dylib; then
++ ac_qtlib=$X
++ QTDIR=$X
++ echo " |-> searching QT in $X *** Found ***"
++ else
++ echo " |-> searching QT in $X *** Not found ***"
++ fi
++ fi
++ done
++else
++ AC_MSG_RESULT([$QTDIR])
++ echo " * Searching for Qt library"
++ ac_qtlib=""
++ if test "x$ac_qtlib" = "x"; then
++ if test -f $QTDIR/lib/libqt-mt.so -o -f $QTDIR/lib/libqt-mt.a -o -f $QTDIR/lib/libqt-mt.dylib; then
++ ac_qtlib=$QTDIR
++ echo " |-> searching QT in $QTDIR *** Found ***"
++ else
++ echo " |-> searching QT in $QTDIR *** Not found ***"
++ fi
++ fi
++fi
++
++#dnl Checks for Qt library.
++#AC_CACHE_CHECK([for Qt library],
++# ac_qtlib, [
++# for X in qt-mt qt; do
++# if test "x$ac_qtlib" = "x"; then
++# if test -f $QTDIR/lib/lib$X.so -o -f $QTDIR/lib/lib$X.a; then
++# ac_qtlib=$X
++# fi
++# fi
++# done
++#])
++
++if test "x$ac_qtlib" = "x"; then
++ AC_MSG_WARN([Qt library not found. Maybe QTDIR isn't properly set.])
++fi
++AC_SUBST(ac_qtlib)
++
++
++#dnl Check for Qt multi-thread support.
++#if test "x$ac_qtlib" = "xqt-mt"; then
++# ac_thread="thread"
++#fi
++#AC_SUBST(ac_thread)
++#
++CFLAGS="$CFLAGS -I$QTDIR/include"
++CPPFLAGS="$CPPFLAGS -I$QTDIR/include"
++LIBS="-L$QTDIR/lib -L/usr/X11R6/lib"
++
++#AC_CACHE_CHECK([for Qt library version >= 3.1.1],
++# ac_qtlib_version, [
++# AC_TRY_LINK([#include "qglobal.h"], [
++#if QT_VERSION < 0x030101
++#error Qt library 3.1.1 or greater required.
++#endif
++# ],
++# ac_qtlib_version="yes", [
++# echo "no; Qt 3.1.1 or greater is required"
++# exit
++# ])
++#])
++
++dnl A common error message:
++ac_qtdir_errmsg="not found in current PATH. Maybe QT development environment isn't available (qt3-devel)."
++
++# Check for Qt qmake utility.
++#AC_PATH_PROG(ac_qmake, qmake, [no], $QTDIR/bin:${PATH})
++AC_PATH_PROG(ac_qmake, qmake, [no], $QTDIR/bin)
++if test "x$ac_qmake" = "xno"; then
++ AC_MSG_ERROR([qmake $ac_qtdir_errmsg])
++fi
++AC_SUBST(ac_qmake)
++
++# Check for Qt moc utility.
++#AC_PATH_PROG(ac_moc, moc, [no], $QTDIR/bin:${PATH})
++AC_PATH_PROG(ac_moc, moc, [no], $QTDIR/bin)
++if test "x$ac_moc" = "xno"; then
++ AC_MSG_ERROR([moc $ac_qtdir_errmsg])
++fi
++AC_SUBST(ac_moc)
++
++# Check for Qt uic utility.
++#AC_PATH_PROG(ac_uic, uic, [no], $QTDIR/bin:${PATH})
++AC_PATH_PROG(ac_uic, uic, [no], $QTDIR/bin)
++if test "x$ac_uic" = "xno"; then
++ AC_MSG_ERROR([uic $ac_qtdir_errmsg])
++fi
++AC_SUBST(ac_uic)
++
++
++
++echo ""
++echo "-----------------------------------------------------------------"
++echo "Checking for libraries.."
++echo "-----------------------------------------------------------------"
++
++
++
++dnl Checks for libraries.
++AC_CHECK_LIB(m, main)
++AC_CHECK_LIB(X11, main)
++AC_CHECK_LIB(Xext, main)
++AC_CHECK_LIB($ac_qtlib, main)
++
++dnl Checks for header files.
++AC_HEADER_STDC
++AC_HEADER_SYS_WAIT
++AC_CHECK_HEADERS(fcntl.h sys/ioctl.h unistd.h poll.h)
++
++dnl Checks for library functions.
++AC_CHECK_FUNCS(system)
++
++
++
++#################################
++#
++# libSndFile
++#
++#################################
++echo ""
++echo "--- Checking for libsndfile -------------------------------------"
++sndfile_found=false
++AC_CHECK_LIB([sndfile], sf_open, sndfile_found=yes)
++#PKG_CHECK_MODULES(LIBSNDFILE, sndfile, sndfile_found=true, sndfile_found=false)
++if test "$sndfile_found" = "false"; then
++ AC_MSG_ERROR("sndfile library not found. Website: http://www.mega-nerd.com/libsndfile/")
++else
++ ac_libraries="${ac_libraries} $( pkg-config --libs sndfile )"
++fi
++echo "-----------------------------------------------------------------"
++echo ""
++
++
++
++
++######################
++#
++# FLAC
++#
++########################
++echo ""
++echo "--- Checking for FLAC++ Libs ------------------------------------"
++flac_support=yes
++AC_ARG_ENABLE(flac_support, [ --disable-flac-support Compile without FLAC support], [flac_support=$enableval])
++
++if test "$flac_support" != "no"; then
++
++ flac_found=no
++ #AC_CHECK_HEADERS(FLAC/file_decoder.h)
++ #AC_CHECK_LIB(FLAC, FLAC__file_decoder_new, flac_found=yes)
++
++ AC_CHECK_HEADERS(FLAC++/all.h, flac_found=yes)
++ #AC_CHECK_LIB(FLAC++, FLAC::Decoder::File, flac_found=yes)
++
++ if test "$flac_found" = "no"; then
++ AC_MSG_ERROR("FLAC++ library not found. FLAC website: http://flac.sourceforge.net")
++ else
++ AC_DEFINE(FLAC_SUPPORT, 1, [Define to enable FLAC support])
++ ac_libraries="${ac_libraries} -lFLAC++ -lFLAC"
++ features_list="${features_list} (FLAC)"
++ fi
++else
++ AC_MSG_WARN("FLAC++ library disabled. WARNING: Many drumkits will not work without FLAC support!!")
++fi
++
++echo "-----------------------------------------------------------------"
++echo ""
++
++
++
++
++##############################
++#
++# JACK SUPPORT
++#
++################################
++echo ""
++echo "--- Checking for JACK -------------------------------------------"
++jack_support=yes
++AC_ARG_ENABLE(jack-support, [ --disable-jack-support Compile without JACK support], [jack_support=$enableval])
++
++JACK_SUPPORT=0
++
++if test "$jack_support" != "no"; then
++ AC_CHECK_LIB(jack, main, [ac_jack_lib="yes"], [ac_jack_lib="no"])
++ if test "x$ac_jack_lib" = "xno"; then
++ AC_MSG_WARN([ *** Could not find the JACK library, disabling JACK driver])
++ else
++ JACK_SUPPORT=1
++ AC_DEFINE(JACK_SUPPORT, 1, [Define to enable JACK driver])
++ features_list="${features_list} (Jack)"
++ ac_libraries="${ac_libraries} -ljack"
++ fi
++else
++ echo "JACK support disabled"
++fi
++echo "-----------------------------------------------------------------"
++echo ""
++
++##########################
++#
++# ALSA
++#
++##########################
++echo ""
++echo "--- Checking for ALSA Libs --------------------------------------"
++
++use_alsa=yes
++
++AC_ARG_ENABLE(alsa, [ --disable-alsa Compile without ALSA support], [use_alsa=$enableval])
++if test "$use_alsa" = "yes"; then
++ alsa_found=no
++ AC_CHECK_HEADERS(alsa/asoundlib.h)
++dnl if test "x${ac_cv_header_alsa_asoundlib_h}" = xyes ; then
++dnl fi
++
++ AC_CHECK_LIB(asound, snd_seq_open, alsa_found=yes)
++ if test "$alsa_found" = "no" ; then
++ AC_MSG_WARN([ *** Could not find the ALSA library, disabling ALSA support])
++ else
++ AC_DEFINE( ALSA_SUPPORT, 1, [Define to use ALSA Audio support])
++ features_list="${features_list} (Alsa)"
++ ac_libraries="${ac_libraries} -lasound"
++ fi
++else
++ echo "ALSA support disabled."
++fi
++
++echo "-----------------------------------------------------------------"
++echo ""
++
++
++##########################
++#
++# OSS SUPPORT
++#
++##########################
++echo ""
++echo "--- Checking for OSS --------------------------------------------"
++oss_support=yes
++
++AC_ARG_ENABLE(oss-support, [ --disable-oss-support Compile without OSS support], [oss_support=$enableval])
++if test "$oss_support" = "yes"; then
++ AC_DEFINE(OSS_SUPPORT, 1, [Define to enable OSS driver])
++ features_list="${features_list} (OSS)"
++else
++ echo "OSS support disabled."
++fi
++
++echo "-----------------------------------------------------------------"
++echo ""
++
++
++
++#################################
++#
++# PortAudio
++#
++#################################
++echo ""
++echo "--- Checking for PortAudio -------------------------------------"
++
++portaudio_support=false
++AC_MSG_CHECKING([whether PORTAUDIOPATH environment variable is set])
++if test "x$PORTAUDIOPATH" = "x"; then
++ AC_MSG_RESULT(PORTAUDIOPATH is not set. No PortAudio support.)
++else
++ AC_MSG_RESULT("[$PORTAUDIOPATH]")
++ if test -f $PORTAUDIOPATH/pa_unix_oss/libportaudio.so; then
++ echo " |-> searching PortAudio in $PORTAUDIOPATH *** Found ***"
++ ac_libraries="${ac_libraries} -L${PORTAUDIOPATH}/pa_unix_oss -lportaudio"
++ features_list="${features_list} (PortAudio)"
++ AC_DEFINE(PORTAUDIO_SUPPORT, 1, [Define to enable PortAudio driver])
++
++ ac_qmake_cxxflags="$ac_qmake_cxxflags -I$PORTAUDIOPATH/pa_common"
++ AC_SUBST(ac_qmake_cxxflags)
++ portaudio_support=true
++ else
++ echo " |-> searching PortAudio in $PORTAUDIOPATH *** Not found ***"
++ fi
++
++fi
++echo "-----------------------------------------------------------------"
++echo ""
++
++
++
++
++#################################
++#
++# PortMidi
++#
++#################################
++echo ""
++echo "--- Checking for PortMidi -------------------------------------"
++portmidi_support=false
++AC_MSG_CHECKING([whether PORTMIDIPATH environment variable is set])
++if test "x$PORTMIDIPATH" = "x"; then
++ AC_MSG_RESULT(PORTMIDIPATH is not set. No PortMidi support.)
++else
++ AC_MSG_RESULT("[$PORTMIDIPATH]")
++ if test -f $PORTMIDIPATH/pm_linux/libportmidi.a; then
++ echo " |-> searching PortMidi in $PORTMIDIPATH *** Found ***"
++ ac_libraries="${ac_libraries} ${PORTMIDIPATH}/pm_linux/libportmidi.a ${PORTMIDIPATH}/porttime/libporttime.a"
++ features_list="${features_list} (PortMidi)"
++ AC_DEFINE(PORTMIDI_SUPPORT, 1, [Define to enable PortMidi driver])
++
++ ac_qmake_cxxflags="$ac_qmake_cxxflags -I$PORTMIDIPATH/pm_common -I$PORTMIDIPATH/porttime"
++ AC_SUBST(ac_qmake_cxxflags)
++ portmidi_support=true
++ else
++ echo " |-> searching PortMidi in $PORTMIDIPATH *** Not found ***"
++ fi
++
++fi
++
++echo "-----------------------------------------------------------------"
++echo ""
++
++
++
++
++##################################
++#
++# LRDF
++#
++###################################
++echo ""
++echo "--- Checking for LRDF -------------------------------------------"
++LRDF_SUPPORT=0
++lrdf_check=yes
++AC_ARG_ENABLE(lrdf-support, [ --disable-lrdf-support Compile without LRDF support], [lrdf_check=$enableval])
++if test "$lrdf_check" = "yes"; then
++ lrdf_found=no
++ AC_CHECK_HEADERS(lrdf.h, lrdf_found=yes)
++# AC_CHECK_LIB(lrdf, lrdf_init, lrdf_found=yes)
++ if test "$lrdf_found" = "no" ; then
++ AC_MSG_WARN([ *** Could not find the LRDF library])
++ else
++ LRDF_SUPPORT=1
++ AC_DEFINE(LRDF_SUPPORT, 1, [Define to enable LRDF support])
++ ac_libraries="${ac_libraries} -llrdf -lraptor -lxml2"
++ features_list="${features_list} (LRDF)"
++ fi
++fi
++echo "-----------------------------------------------------------------"
++echo ""
++
++
++
++##################################
++#
++# define the DATA path
++#
++###################################
++AC_DEFINE_UNQUOTED(DATA_PATH, "${ac_prefix}/share/hydrogen/data", [Data dir])
++AC_DEFINE_UNQUOTED(COMPILED_FEATURES, "${features_list}", [Compiled features])
++
++
++
++
++AC_SUBST(ac_libraries)
++
++
++AC_OUTPUT(
++Makefile
++hydrogen.pro
++hydrogenPlayer.pro
++hydrogenBenchmark.pro
++hydrogen2Midi.pro
++hydrogenCUI.pro
++hydrogen.desktop
++plugins/Makefile
++plugins/wasp/Makefile
++)
++
++
++echo "
++
++-----------------------------------------------------------------
++ Hydrogen ${hydrogenVersion} configuration:
++-----------------------------------------------------------------
++
++ Source code location: ${srcdir}
++ Prefix ${ac_prefix}
++ Data path ${ac_prefix}/share/hydrogen
++ LDFLAGS ${ac_libraries}
++"
++if test "x$ac_debug" = "xdebug"; then
++ echo " Debug messages: yes"
++else
++ echo " Debug messages: no"
++fi
++
++if test "${flac_found}" = "yes"; then
++ echo " FLAC: yes"
++else
++ echo " FLAC: no"
++fi
++
++if test "${LRDF_SUPPORT}" = "1"; then
++ echo " LRDF: yes"
++else
++ echo " LRDF: no"
++fi
++
++echo ""
++
++if test "${JACK_SUPPORT}" = "1"; then
++ echo " Jack: yes"
++else
++ echo " Jack: no"
++fi
++
++if test "${alsa_found}" = "yes"; then
++ echo " ALSA : yes"
++else
++ echo " ALSA : no"
++fi
++
++if test "${oss_support}" = "yes"; then
++ echo " OSS: yes"
++else
++ echo " OSS: no"
++fi
++
++
++if test "${portaudio_support}" = "true"; then
++ echo " PortAudio yes"
++else
++ echo " PortAudio no"
++fi
++
++if test "${portmidi_support}" = "true"; then
++ echo " PortMidi: yes"
++else
++ echo " PortMidi: no"
++fi
++
++
++echo "
++ Features list = ${features_list}
++
++-----------------------------------------------------------------
++Now type make to build Hydrogen.
++-----------------------------------------------------------------
++
++If you're not a member of hydrogen-dev mailing list yet, please join.
++Please see http://www.hydrogen-music.org for details.
++
++"
+diff -Naur hydrogen-0.9.3.orig/src/lib/FLACFile.cpp hydrogen-0.9.3/src/lib/FLACFile.cpp
+--- hydrogen-0.9.3.orig/src/lib/FLACFile.cpp 2005-11-08 07:31:22.000000000 -0200
++++ hydrogen-0.9.3/src/lib/FLACFile.cpp 2008-07-24 19:43:59.000000000 -0300
@@ -33,6 +33,13 @@
//#include "FLAC/file_decoder.h"
#include <FLAC++/all.h>
@@ -120,416 +636,16 @@
+#endif
}
---- a/hydrogen-0.9.3/data/demo_songs/TR808kit-demo.h2song 2005-10-18 00:32:04.000000000 +0200
-+++ b/hydrogen-0.9.3/data/demo_songs/TR808kit-demo.h2song 2007-06-05 15:33:19.000000000 +0200
-@@ -1,5 +1,5 @@
- <song>
-- <version>0.9.2-cvs</version>
-+ <version>0.9.3</version>
- <bpm>125</bpm>
- <volume>0.71</volume>
- <metronomeVolume>0.5</metronomeVolume>
-@@ -7,10 +7,14 @@
- <author>ArtemioLabs</author>
- <notes>Demo patterns for the TR-808 Emulation Kit.</notes>
- <loopEnabled>true</loopEnabled>
-- <mode>song</mode>
-+ <mode>pattern</mode>
- <humanize_time>0</humanize_time>
- <humanize_velocity>0</humanize_velocity>
- <swing_factor>0</swing_factor>
-+ <delayFXEnabled>false</delayFXEnabled>
-+ <delayFXWetLevel>1</delayFXWetLevel>
-+ <delayFXFeedback>0.4</delayFXFeedback>
-+ <delayFXTime>48</delayFXTime>
- <instrumentList>
- <instrument>
- <id>0</id>
-@@ -18,8 +22,10 @@
- <name>Kick Long</name>
- <volume>1</volume>
- <isMuted>false</isMuted>
-+ <isLocked>false</isLocked>
- <pan_L>1</pan_L>
- <pan_R>1</pan_R>
-+ <gain>1</gain>
- <FX1Level>0</FX1Level>
- <FX2Level>0</FX2Level>
- <FX3Level>0</FX3Level>
-@@ -44,8 +50,10 @@
- <name>Kick Short</name>
- <volume>1</volume>
- <isMuted>false</isMuted>
-+ <isLocked>false</isLocked>
- <pan_L>1</pan_L>
- <pan_R>1</pan_R>
-+ <gain>1</gain>
- <FX1Level>0</FX1Level>
- <FX2Level>0</FX2Level>
- <FX3Level>0</FX3Level>
-@@ -70,8 +78,10 @@
- <name>Snare 1</name>
- <volume>1</volume>
- <isMuted>false</isMuted>
-+ <isLocked>false</isLocked>
- <pan_L>1</pan_L>
- <pan_R>1</pan_R>
-+ <gain>1</gain>
- <FX1Level>0</FX1Level>
- <FX2Level>0</FX2Level>
- <FX3Level>0</FX3Level>
-@@ -96,8 +106,10 @@
- <name>Snare 2</name>
- <volume>1</volume>
- <isMuted>false</isMuted>
-+ <isLocked>false</isLocked>
- <pan_L>1</pan_L>
- <pan_R>1</pan_R>
-+ <gain>1</gain>
- <FX1Level>0</FX1Level>
- <FX2Level>0</FX2Level>
- <FX3Level>0</FX3Level>
-@@ -122,8 +134,10 @@
- <name>Clap</name>
- <volume>1</volume>
- <isMuted>false</isMuted>
-+ <isLocked>false</isLocked>
- <pan_L>1</pan_L>
- <pan_R>1</pan_R>
-+ <gain>1</gain>
- <FX1Level>0</FX1Level>
- <FX2Level>0</FX2Level>
- <FX3Level>0</FX3Level>
-@@ -148,8 +162,10 @@
- <name>Tom Low</name>
- <volume>0.77</volume>
- <isMuted>false</isMuted>
-+ <isLocked>false</isLocked>
- <pan_L>1</pan_L>
- <pan_R>0.52</pan_R>
-+ <gain>1</gain>
- <FX1Level>0</FX1Level>
- <FX2Level>0</FX2Level>
- <FX3Level>0</FX3Level>
-@@ -174,8 +190,10 @@
- <name>Tom Mid</name>
- <volume>0.79</volume>
- <isMuted>false</isMuted>
-+ <isLocked>false</isLocked>
- <pan_L>1</pan_L>
- <pan_R>1</pan_R>
-+ <gain>1</gain>
- <FX1Level>0</FX1Level>
- <FX2Level>0</FX2Level>
- <FX3Level>0</FX3Level>
-@@ -200,8 +218,10 @@
- <name>Tom Hi</name>
- <volume>0.79</volume>
- <isMuted>false</isMuted>
-+ <isLocked>false</isLocked>
- <pan_L>0.48</pan_L>
- <pan_R>1</pan_R>
-+ <gain>1</gain>
- <FX1Level>0</FX1Level>
- <FX2Level>0</FX2Level>
- <FX3Level>0</FX3Level>
-@@ -226,8 +246,10 @@
- <name>Closed Hat</name>
- <volume>1</volume>
- <isMuted>false</isMuted>
-+ <isLocked>false</isLocked>
- <pan_L>1</pan_L>
- <pan_R>1</pan_R>
-+ <gain>1</gain>
- <FX1Level>0</FX1Level>
- <FX2Level>0</FX2Level>
- <FX3Level>0</FX3Level>
-@@ -252,8 +274,10 @@
- <name>Pedal Hat</name>
- <volume>1</volume>
- <isMuted>false</isMuted>
-+ <isLocked>false</isLocked>
- <pan_L>1</pan_L>
- <pan_R>1</pan_R>
-+ <gain>1</gain>
- <FX1Level>0</FX1Level>
- <FX2Level>0</FX2Level>
- <FX3Level>0</FX3Level>
-@@ -278,8 +302,10 @@
- <name>Open Hat</name>
- <volume>1</volume>
- <isMuted>false</isMuted>
-+ <isLocked>false</isLocked>
- <pan_L>1</pan_L>
- <pan_R>1</pan_R>
-+ <gain>1</gain>
- <FX1Level>0</FX1Level>
- <FX2Level>0</FX2Level>
- <FX3Level>0</FX3Level>
-@@ -304,8 +330,10 @@
- <name>Cymbal</name>
- <volume>0.82</volume>
- <isMuted>false</isMuted>
-+ <isLocked>false</isLocked>
- <pan_L>1</pan_L>
- <pan_R>1</pan_R>
-+ <gain>1</gain>
- <FX1Level>0</FX1Level>
- <FX2Level>0</FX2Level>
- <FX3Level>0</FX3Level>
-@@ -330,8 +358,10 @@
- <name>Shaker</name>
- <volume>0.84</volume>
- <isMuted>false</isMuted>
-+ <isLocked>false</isLocked>
- <pan_L>1</pan_L>
- <pan_R>1</pan_R>
-+ <gain>1</gain>
- <FX1Level>0</FX1Level>
- <FX2Level>0</FX2Level>
- <FX3Level>0</FX3Level>
-@@ -356,8 +386,10 @@
- <name>Conga</name>
- <volume>0.88</volume>
- <isMuted>false</isMuted>
-+ <isLocked>false</isLocked>
- <pan_L>0.9</pan_L>
- <pan_R>1</pan_R>
-+ <gain>1</gain>
- <FX1Level>0</FX1Level>
- <FX2Level>0</FX2Level>
- <FX3Level>0</FX3Level>
-@@ -382,8 +414,10 @@
- <name>Clave</name>
- <volume>0.84</volume>
- <isMuted>false</isMuted>
-+ <isLocked>false</isLocked>
- <pan_L>0.96</pan_L>
- <pan_R>1</pan_R>
-+ <gain>1</gain>
- <FX1Level>0</FX1Level>
- <FX2Level>0</FX2Level>
- <FX3Level>0</FX3Level>
-@@ -408,8 +442,10 @@
- <name>Cowbell</name>
- <volume>0.85</volume>
- <isMuted>false</isMuted>
-+ <isLocked>false</isLocked>
- <pan_L>0.96</pan_L>
- <pan_R>1</pan_R>
-+ <gain>1</gain>
- <FX1Level>0</FX1Level>
- <FX2Level>0</FX2Level>
- <FX3Level>0</FX3Level>
-@@ -434,8 +470,10 @@
- <name>17</name>
- <volume>0.8</volume>
- <isMuted>true</isMuted>
-+ <isLocked>false</isLocked>
- <pan_L>1</pan_L>
- <pan_R>1</pan_R>
-+ <gain>1</gain>
- <FX1Level>0</FX1Level>
- <FX2Level>0</FX2Level>
- <FX3Level>0</FX3Level>
-@@ -453,8 +491,10 @@
- <name>18</name>
- <volume>0.8</volume>
- <isMuted>true</isMuted>
-+ <isLocked>false</isLocked>
- <pan_L>1</pan_L>
- <pan_R>1</pan_R>
-+ <gain>1</gain>
- <FX1Level>0</FX1Level>
- <FX2Level>0</FX2Level>
- <FX3Level>0</FX3Level>
-@@ -472,8 +512,10 @@
- <name>19</name>
- <volume>0.8</volume>
- <isMuted>true</isMuted>
-+ <isLocked>false</isLocked>
- <pan_L>1</pan_L>
- <pan_R>1</pan_R>
-+ <gain>1</gain>
- <FX1Level>0</FX1Level>
- <FX2Level>0</FX2Level>
- <FX3Level>0</FX3Level>
-@@ -491,8 +533,10 @@
- <name>20</name>
- <volume>0.8</volume>
- <isMuted>true</isMuted>
-+ <isLocked>false</isLocked>
- <pan_L>1</pan_L>
- <pan_R>1</pan_R>
-+ <gain>1</gain>
- <FX1Level>0</FX1Level>
- <FX2Level>0</FX2Level>
- <FX3Level>0</FX3Level>
-@@ -510,8 +554,10 @@
- <name>21</name>
- <volume>0.8</volume>
- <isMuted>true</isMuted>
-+ <isLocked>false</isLocked>
- <pan_L>1</pan_L>
- <pan_R>1</pan_R>
-+ <gain>1</gain>
- <FX1Level>0</FX1Level>
- <FX2Level>0</FX2Level>
- <FX3Level>0</FX3Level>
-@@ -529,8 +575,10 @@
- <name>22</name>
- <volume>0.8</volume>
- <isMuted>true</isMuted>
-+ <isLocked>false</isLocked>
- <pan_L>1</pan_L>
- <pan_R>1</pan_R>
-+ <gain>1</gain>
- <FX1Level>0</FX1Level>
- <FX2Level>0</FX2Level>
- <FX3Level>0</FX3Level>
-@@ -548,8 +596,10 @@
- <name>23</name>
- <volume>0.8</volume>
- <isMuted>true</isMuted>
-+ <isLocked>false</isLocked>
- <pan_L>1</pan_L>
- <pan_R>1</pan_R>
-+ <gain>1</gain>
- <FX1Level>0</FX1Level>
- <FX2Level>0</FX2Level>
- <FX3Level>0</FX3Level>
-@@ -567,8 +617,10 @@
- <name>24</name>
- <volume>0.8</volume>
- <isMuted>true</isMuted>
-+ <isLocked>false</isLocked>
- <pan_L>1</pan_L>
- <pan_R>1</pan_R>
-+ <gain>1</gain>
- <FX1Level>0</FX1Level>
- <FX2Level>0</FX2Level>
- <FX3Level>0</FX3Level>
-@@ -586,8 +638,10 @@
- <name>25</name>
- <volume>0.8</volume>
- <isMuted>true</isMuted>
-+ <isLocked>false</isLocked>
- <pan_L>1</pan_L>
- <pan_R>1</pan_R>
-+ <gain>1</gain>
- <FX1Level>0</FX1Level>
- <FX2Level>0</FX2Level>
- <FX3Level>0</FX3Level>
-@@ -605,8 +659,10 @@
- <name>26</name>
- <volume>0.8</volume>
- <isMuted>true</isMuted>
-+ <isLocked>false</isLocked>
- <pan_L>1</pan_L>
- <pan_R>1</pan_R>
-+ <gain>1</gain>
- <FX1Level>0</FX1Level>
- <FX2Level>0</FX2Level>
- <FX3Level>0</FX3Level>
-@@ -624,8 +680,10 @@
- <name>27</name>
- <volume>0.8</volume>
- <isMuted>true</isMuted>
-+ <isLocked>false</isLocked>
- <pan_L>1</pan_L>
- <pan_R>1</pan_R>
-+ <gain>1</gain>
- <FX1Level>0</FX1Level>
- <FX2Level>0</FX2Level>
- <FX3Level>0</FX3Level>
-@@ -643,8 +701,10 @@
- <name>28</name>
- <volume>0.8</volume>
- <isMuted>true</isMuted>
-+ <isLocked>false</isLocked>
- <pan_L>1</pan_L>
- <pan_R>1</pan_R>
-+ <gain>1</gain>
- <FX1Level>0</FX1Level>
- <FX2Level>0</FX2Level>
- <FX3Level>0</FX3Level>
-@@ -662,8 +722,10 @@
- <name>29</name>
- <volume>0.8</volume>
- <isMuted>true</isMuted>
-+ <isLocked>false</isLocked>
- <pan_L>1</pan_L>
- <pan_R>1</pan_R>
-+ <gain>1</gain>
- <FX1Level>0</FX1Level>
- <FX2Level>0</FX2Level>
- <FX3Level>0</FX3Level>
-@@ -681,8 +743,10 @@
- <name>30</name>
- <volume>0.8</volume>
- <isMuted>true</isMuted>
-+ <isLocked>false</isLocked>
- <pan_L>1</pan_L>
- <pan_R>1</pan_R>
-+ <gain>1</gain>
- <FX1Level>0</FX1Level>
- <FX2Level>0</FX2Level>
- <FX3Level>0</FX3Level>
-@@ -700,8 +764,10 @@
- <name>31</name>
- <volume>0.8</volume>
- <isMuted>true</isMuted>
-+ <isLocked>false</isLocked>
- <pan_L>1</pan_L>
- <pan_R>1</pan_R>
-+ <gain>1</gain>
- <FX1Level>0</FX1Level>
- <FX2Level>0</FX2Level>
- <FX3Level>0</FX3Level>
-@@ -719,8 +785,10 @@
- <name>32</name>
- <volume>0.8</volume>
- <isMuted>true</isMuted>
-+ <isLocked>false</isLocked>
- <pan_L>1</pan_L>
- <pan_R>1</pan_R>
-+ <gain>1</gain>
- <FX1Level>0</FX1Level>
- <FX2Level>0</FX2Level>
- <FX3Level>0</FX3Level>
-@@ -1602,15 +1670,6 @@
- <length>-1</length>
- <instrument>9</instrument>
- </note>
-- <note>
-- <position>168</position>
-- <velocity>0.8</velocity>
-- <pan_L>1</pan_L>
-- <pan_R>1</pan_R>
-- <pitch>0</pitch>
-- <length>-1</length>
-- <instrument>9</instrument>
-- </note>
- </noteList>
- </sequence>
- <sequence>
-@@ -1792,7 +1851,17 @@
- <noteList />
- </sequence>
- <sequence>
-- <noteList />
-+ <noteList>
-+ <note>
-+ <position>156</position>
-+ <velocity>0.8</velocity>
-+ <pan_L>1</pan_L>
-+ <pan_R>1</pan_R>
-+ <pitch>0</pitch>
-+ <length>-1</length>
-+ <instrument>26</instrument>
-+ </note>
-+ </noteList>
- </sequence>
- <sequence>
- <noteList />
-
+
+diff -Naur hydrogen-0.9.3.orig/src/lib/xml/tinyxml.h hydrogen-0.9.3/src/lib/xml/tinyxml.h
+--- hydrogen-0.9.3.orig/src/lib/xml/tinyxml.h 2005-10-17 20:32:04.000000000 -0200
++++ hydrogen-0.9.3/src/lib/xml/tinyxml.h 2008-07-24 19:44:04.000000000 -0300
+@@ -823,7 +823,7 @@
+ #endif
+
+ /// Construct.
+- TiXmlDeclaration::TiXmlDeclaration( const char * _version,
++ TiXmlDeclaration( const char * _version,
+ const char * _encoding,
+ const char * _standalone );
+