aboutsummaryrefslogtreecommitdiff
path: root/dev/util
diff options
context:
space:
mode:
Diffstat (limited to 'dev/util')
-rwxr-xr-xdev/util/eclipse/eclipse.SlackBuild2
-rw-r--r--dev/util/gazpacho/gazpacho.SlackBuild145
-rw-r--r--dev/util/gazpacho/slack-required7
-rw-r--r--dev/util/glade/glade.SlackBuild25
-rw-r--r--dev/util/glade/slack-required7
-rwxr-xr-xdev/util/scons/scons.SlackBuild17
6 files changed, 178 insertions, 25 deletions
diff --git a/dev/util/eclipse/eclipse.SlackBuild b/dev/util/eclipse/eclipse.SlackBuild
index 1c3da421..cc16d62e 100755
--- a/dev/util/eclipse/eclipse.SlackBuild
+++ b/dev/util/eclipse/eclipse.SlackBuild
@@ -33,7 +33,7 @@ CWD="$(pwd)"
SRC_NAME="eclipse"
PKG_NAME="eclipse"
ARCH=${ARCH:=i386}
-SRC_VERSION=${VERSION:=R-3.3.2-200802211800}
+SRC_VERSION=${VERSION:=R-3.4-200806172000}
PKG_VERSION="$(echo "$SRC_VERSION" | cut -d "-" -f 2)"
BUILD=${BUILD:=1ls}
SRC_DIR=${SRC_DIR:=$CWD}/$PKG_NAME
diff --git a/dev/util/gazpacho/gazpacho.SlackBuild b/dev/util/gazpacho/gazpacho.SlackBuild
new file mode 100644
index 00000000..06548446
--- /dev/null
+++ b/dev/util/gazpacho/gazpacho.SlackBuild
@@ -0,0 +1,145 @@
+#!/bin/bash
+#
+# gazpacho.SlackBuild is free software; you can redistribute
+# it and/or modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2 of the License,
+# or any later version.
+#
+# gazpacho.SlackBuild is distributed in the hope that it will
+# be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General
+# Public License for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA
+#
+# slackbuild for gazpacho, by Rudson R. Alves
+# requires: python gtk+ pygtk kiwi
+# tested: gazpacho-0.7.2
+#
+
+# Look for slackbuildrc
+if [ -f ~/.slackbuildrc ]; then
+ source ~/.slackbuildrc
+elif [ -f /etc/slackbuildrc ]; then
+ source /etc/slackbuildrc
+fi
+
+# Set variables
+CWD="$(pwd)"
+SRC_NAME="gazpacho"
+PKG_NAME="gazpacho"
+ARCH=${ARCH:=i486}
+SRC_VERSION=${VERSION:=0.7.2}
+PKG_VERSION="$(echo "$SRC_VERSION" | tr '[[:blank:]-]' '_')"
+BUILD=${BUILD:=1srv}
+SRC_DIR=${SRC_DIR:=$CWD}/$PKG_NAME
+TMP=${TMP:=/tmp}
+PKG=${PKG:=$TMP/package-$PKG_NAME}
+REPOS=${REPOS:=$TMP}
+PREFIX=${PREFIX:=/usr}
+PKG_WORK="$TMP/$SRC_NAME"
+CONF_OPTIONS=${CONF_OPTIONS:=""}
+NUMJOBS=${NUMJOBS:="-j4"}
+
+# Set system libraries' path and optmization flags based on $ARCH
+LIBDIR="$PREFIX/lib"
+
+if [ "$ARCH" = "i386" ]; then
+ SLKCFLAGS="-O2 -march=i386 -mcpu=i686"
+elif [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mcpu=i686"
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686"
+elif [ "$ARCH" = "s390" ]; then
+ SLKCFLAGS="-O2"
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIR="$PREFIX/lib64"
+ LDFLAGS="-L/lib64 -L/usr/lib64"
+fi
+
+# Set error codes (used by createpkg)
+ERROR_WGET=31; ERROR_MAKE=32; ERROR_INSTALL=33
+ERROR_MD5=34; ERROR_CONF=35; ERROR_HELP=36
+ERROR_TAR=37; ERROR_MKPKG=38; ERROR_GPG=39
+ERROR_PATCH=40; ERROR_VCS=41; ERROR_MKDIR=42
+
+# Clean up any leftovers of previous builds
+rm -rf "$PKG_WORK" 2> /dev/null
+rm -rf "$PKG" 2> /dev/null
+
+# Create directories if necessary
+mkdir -p "$SRC_DIR" || exit $ERROR_MKDIR
+mkdir -p "$PKG" || exit $ERROR_MKDIR
+mkdir -p "$REPOS" || exit $ERROR_MKDIR
+mkdir -p "$PKG_WORK" || exit $ERROR_MKDIR
+
+# Dowload source if necessary
+SRC="$SRC_NAME-$VERSION.tar.gz"
+URL="http://ftp.gnome.org/pub/GNOME/sources/gazpacho/0.7/$SRC"
+
+if [ ! -s "$SRC_DIR/$SRC" ] || ! gunzip -t "$SRC_DIR/$SRC" 2> /dev/null; then
+ wget "$URL" -O "$SRC_DIR/$SRC" || exit $ERROR_WGET
+fi
+
+# Untar
+cd "$PKG_WORK"
+tar --no-same-owner --no-same-permissions -xvf "$SRC_DIR/$SRC" || exit $ERROR_TAR
+PKG_SRC="$PWD/`ls -l | awk '/^d/ { print $NF }'`"
+cd "$PKG_SRC"
+
+# Install
+sed -i 's/lib/lib64/g' bin/gazpacho
+python setup.py install --prefix=/usr --root=$PKG || exit $ERROR_INSTALL
+
+# Strip binaries
+( cd "$PKG"
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null
+)
+
+# Install documentation
+DOCS="AUTHORS CONTRIBUTORS COPYING ChangeLog INSTALL MANIFEST.in NEWS PKG-INFO README"
+mkdir -p "$PKG/usr/doc/$PKG_NAME-$PKG_VERSION" || exit $ERROR_MKDIR
+for doc in $DOCS; do
+ if [ -f "$doc" ]; then
+ cp -a $doc "$PKG/usr/doc/$PKG_NAME-$PKG_VERSION"
+ fi
+done
+
+# Add package description (slack-desc)
+mkdir -p "$PKG/install" || exit $ERROR_MKDIR
+cat << EODESC > "$PKG/install/slack-desc"
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler-----------------------------------------------------|
+gazpacho: gazpacho by Slack.Sarava
+gazpacho:
+gazpacho: Gazpacho is a fresh new GUI builder for the GTK+ toolkit designed to
+gazpacho: be ultra easy to use
+gazpacho:
+gazpacho: It is strongly inspired by the Glade project but it is written from
+gazpacho: scratch using the Python language. As a result there are few lines
+gazpacho: of code to read, understand and to maintain!
+gazpacho:
+gazpacho:
+gazpacho:
+EODESC
+
+# Build the package
+cd "$PKG"
+makepkg -l y -c n "$REPOS/$PKG_NAME-$PKG_VERSION-$ARCH-$BUILD.tgz" || exit $ERROR_MKPKG
+
+# Delete source and build directories if requested
+if [ "$CLEANUP" == "yes" ]; then
+ rm -rf "$PKG_WORK" "$PKG"
+fi
diff --git a/dev/util/gazpacho/slack-required b/dev/util/gazpacho/slack-required
new file mode 100644
index 00000000..00f38a65
--- /dev/null
+++ b/dev/util/gazpacho/slack-required
@@ -0,0 +1,7 @@
+# Dependency list to gazpacho
+#
+# dependency [condition] [version]]
+python
+gtk+
+pygtk
+kiwi
diff --git a/dev/util/glade/glade.SlackBuild b/dev/util/glade/glade.SlackBuild
index c2356b95..f598dc9f 100644
--- a/dev/util/glade/glade.SlackBuild
+++ b/dev/util/glade/glade.SlackBuild
@@ -10,13 +10,13 @@
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General
# Public License for more details.
#
-# You should have received a copy of the GNU General Public License along with
-# this program; if not, write to the Free Software Foundation, Inc., 59 Temple
-# Place - Suite 330, Boston, MA 02111-1307, USA
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA
#
# slackbuild for glade, by Rudson R. Alves
-# requires: scrollkeeper gtk+2 libxml2
-# tested: glade-2.12.2
+# requires: gtk+2 libxml2
+# tested: glade-3.1.5
#
# Look for slackbuildrc
@@ -28,10 +28,10 @@ fi
# Set variables
CWD="$(pwd)"
-SRC_NAME="glade"
+SRC_NAME="glade3"
PKG_NAME="glade"
ARCH=${ARCH:=i486}
-SRC_VERSION=${VERSION:=2.12.2}
+SRC_VERSION=${VERSION:=3.4.5}
PKG_VERSION="$(echo "$SRC_VERSION" | tr '[[:blank:]-]' '_')"
BUILD=${BUILD:=1rra}
SRC_DIR=${SRC_DIR:=$CWD}/$PKG_NAME
@@ -55,8 +55,9 @@ elif [ "$ARCH" = "i686" ]; then
elif [ "$ARCH" = "s390" ]; then
SLKCFLAGS="-O2"
elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2"
+ SLKCFLAGS="-O2 -fPIC"
LIBDIR="$PREFIX/lib64"
+ LDFLAGS="-L/lib64 -L/usr/lib64"
fi
# Set error codes (used by createpkg)
@@ -77,7 +78,7 @@ mkdir -p "$PKG_WORK" || exit $ERROR_MKDIR
# Dowload source if necessary
SRC="$SRC_NAME-$VERSION.tar.bz2"
-URL="http://ftp.acc.umu.se/pub/gnome/sources/glade/${VERSION:0:4}/$SRC"
+URL="http://ftp.gnome.org/pub/GNOME/sources/glade3/3.4/$SRC"
if [ ! -s "$SRC_DIR/$SRC" ] || ! bunzip2 -t "$SRC_DIR/$SRC" 2> /dev/null; then
wget "$URL" -O "$SRC_DIR/$SRC" || exit $ERROR_WGET
@@ -86,7 +87,7 @@ fi
# Untar
cd "$PKG_WORK"
tar --no-same-owner --no-same-permissions -xvf "$SRC_DIR/$SRC" || exit $ERROR_TAR
-PKG_SRC="$PWD/`ls -l | awk '/^d/ { print $8 }'`"
+PKG_SRC="$PWD/`ls -l | awk '/^d/ { print $NF }'`"
cd "$PKG_SRC"
# Configure
@@ -122,9 +123,9 @@ done
mkdir -p "$PKG/install" || exit $ERROR_MKDIR
cat << EODESC > "$PKG/install/slack-desc"
# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
+# The "handy ruler" below makes it easier to edit a package description. Line
# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
+# on the right side marks the last column you can put a character in. You must
# make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':'.
diff --git a/dev/util/glade/slack-required b/dev/util/glade/slack-required
index e0d8bb46..2c9cbddc 100644
--- a/dev/util/glade/slack-required
+++ b/dev/util/glade/slack-required
@@ -1,6 +1,5 @@
-# Dependency list to glade
+# Dependency list to glade3
#
# dependency [condition] [version]]
-scrollkeeper
-gtk+2
-libxml2
+gtk+2 >= 2.10.0
+libxml2 >= 2.4.1
diff --git a/dev/util/scons/scons.SlackBuild b/dev/util/scons/scons.SlackBuild
index 18e3a2ce..5adbaa6f 100755
--- a/dev/util/scons/scons.SlackBuild
+++ b/dev/util/scons/scons.SlackBuild
@@ -10,13 +10,13 @@
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General
# Public License for more details.
#
-# You should have received a copy of the GNU General Public License along with
-# this program; if not, write to the Free Software Foundation, Inc., 59 Temple
-# Place - Suite 330, Boston, MA 02111-1307, USA
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA
#
# slackbuild for scons, by Silvio Rhatto
# requires:
-# tested: scons-0.98.2
+# tested: scons-0.98.5
#
# Look for slackbuildrc
@@ -31,7 +31,7 @@ CWD="$(pwd)"
SRC_NAME="scons"
PKG_NAME="scons"
ARCH=${ARCH:=i486}
-SRC_VERSION=${VERSION:=0.98.2}
+SRC_VERSION=${VERSION:=0.98.5}
PKG_VERSION="$(echo "$SRC_VERSION" | tr '[[:blank:]-]' '_')"
BUILD=${BUILD:=1rha}
SRC_DIR=${SRC_DIR:=$CWD}/$PKG_NAME
@@ -57,6 +57,7 @@ elif [ "$ARCH" = "s390" ]; then
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIR="$PREFIX/lib64"
+ LDFLAGS="-L/lib64 -L/usr/lib64"
fi
# Set error codes (used by createpkg)
@@ -86,7 +87,7 @@ fi
# Untar
cd "$PKG_WORK"
tar --no-same-owner --no-same-permissions -xvf "$SRC_DIR/$SRC" || exit $ERROR_TAR
-PKG_SRC="$PWD/`ls -l | awk '/^d/ { print $8 }'`"
+PKG_SRC="$PWD/`ls -l | awk '/^d/ { print $NF }'`"
cd "$PKG_SRC"
# Build and install package
@@ -113,9 +114,9 @@ done
mkdir -p "$PKG/install" || exit $ERROR_MKDIR
cat << EODESC > "$PKG/install/slack-desc"
# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
+# The "handy ruler" below makes it easier to edit a package description. Line
# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
+# on the right side marks the last column you can put a character in. You must
# make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':'.