aboutsummaryrefslogtreecommitdiff
path: root/dev/python/wxpython/wxPython.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev/python/wxpython/wxPython.SlackBuild')
-rwxr-xr-xdev/python/wxpython/wxPython.SlackBuild28
1 files changed, 17 insertions, 11 deletions
diff --git a/dev/python/wxpython/wxPython.SlackBuild b/dev/python/wxpython/wxPython.SlackBuild
index fce3a047..04f598d6 100755
--- a/dev/python/wxpython/wxPython.SlackBuild
+++ b/dev/python/wxpython/wxPython.SlackBuild
@@ -10,12 +10,12 @@
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General
# Public License for more details.
#
-# You should have received a copy of the GNU General Public License along with
-# this program; if not, write to the Free Software Foundation, Inc., 59 Temple
-# Place - Suite 330, Boston, MA 02111-1307, USA
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA
#
# slackbuild for wxPython, by Silvio Rhatto
-# requires: python wxWidgets
+# requires: python wxWidgets
# tested: wxPython-2.8.7.1
#
@@ -55,8 +55,9 @@ elif [ "$ARCH" = "i686" ]; then
elif [ "$ARCH" = "s390" ]; then
SLKCFLAGS="-O2"
elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2"
+ SLKCFLAGS="-O2 -fPIC"
LIBDIR="$PREFIX/lib64"
+ LDFLAGS="-L/lib64 -L/usr/lib64"
fi
# Set error codes (used by createpkg)
@@ -83,7 +84,6 @@ if [ ! -s "$SRC_DIR/$SRC" ] || ! bunzip2 -t "$SRC_DIR/$SRC" 2> /dev/null; then
wget "$URL" -O "$SRC_DIR/$SRC" || exit $ERROR_WGET
fi
-
# Untar
cd "$PKG_WORK"
tar xvf "$SRC_DIR/$SRC" || exit $ERROR_TAR
@@ -91,7 +91,7 @@ PKG_SRC=`ls -l | awk '/^d/ { print $8 }'`
cd "$PKG_SRC/$PKG_NAME"
# Build and install package
-python setup.py build install --root=$PKG
+python setup.py build install --root=$PKG || exit $ERROR_INSTALL
# Strip binaries
( cd "$PKG"
@@ -102,7 +102,7 @@ python setup.py build install --root=$PKG
)
# Install documentation
-DOCS="NEWS TODO README AUTHORS INSTALL ChangeLog MAINTAINERS COPYING readme.*"
+DOCS="NEWS TODO README AUTHORS INSTALL ChangeLog MAINTAINERS COPYING LICENSE SIGNATURE readme.*"
mkdir -p "$PKG/usr/doc/$PKG_NAME-$PKG_VERSION" || exit $ERROR_MKDIR
for doc in $DOCS; do
if [ -f "$doc" ]; then
@@ -114,9 +114,9 @@ done
mkdir -p "$PKG/install" || exit $ERROR_MKDIR
cat << EODESC > "$PKG/install/slack-desc"
# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
+# The "handy ruler" below makes it easier to edit a package description. Line
# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
+# on the right side marks the last column you can put a character in. You must
# make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':'.
@@ -134,11 +134,17 @@ wxPython:
wxPython:
EODESC
+# Copy slack-required
+mkdir -p "$PKG/install" || exit $ERROR_MKDIR
+if [ -f "$CWD/slack-required" ]; then
+ cp $CWD/slack-required $PKG/install
+fi
+
# Build the package
cd "$PKG"
makepkg -l y -c n "$REPOS/$PKG_NAME-$PKG_VERSION-$ARCH-$BUILD.tgz" || exit $ERROR_MKPKG
# Delete source and build directories if requested
-if [ "$CLEANUP" == "yes" ]; then
+if [ "$CLEANUP" == "yes" ] || [ "$1" = "--cleanup" ]; then
rm -rf "$PKG_WORK" "$PKG"
fi