aboutsummaryrefslogtreecommitdiff
path: root/dev/python/twisted
diff options
context:
space:
mode:
Diffstat (limited to 'dev/python/twisted')
-rw-r--r--dev/python/twisted/Twisted.SlackBuild (renamed from dev/python/twisted/twisted.SlackBuild)23
1 files changed, 13 insertions, 10 deletions
diff --git a/dev/python/twisted/twisted.SlackBuild b/dev/python/twisted/Twisted.SlackBuild
index b8b686d3..7f2e4560 100644
--- a/dev/python/twisted/twisted.SlackBuild
+++ b/dev/python/twisted/Twisted.SlackBuild
@@ -1,11 +1,11 @@
#!/bin/bash
#
-# twisted.SlackBuild is free software; you can redistribute
+# Twisted.SlackBuild is free software; you can redistribute
# it and/or modify it under the terms of the GNU General Public License as
# published by the Free Software Foundation; either version 2 of the License,
# or any later version.
#
-# twisted.SlackBuild is distributed in the hope that it will
+# Twisted.SlackBuild is distributed in the hope that it will
# be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General
# Public License for more details.
@@ -14,9 +14,9 @@
# this program; if not, write to the Free Software Foundation, Inc., 59 Temple
# Place - Suite 330, Boston, MA 02111-1307, USA
#
-# slackbuild for twisted, by Rudson R. Alves
-# requires: glibc-solibs python
-# tested: twisted-2.5.0
+# slackbuild for Twisted, by Rudson R. Alves
+# requires: glibc-solibs python
+# tested: Twisted-2.5.0
#
# Look for slackbuildrc
@@ -29,7 +29,7 @@ fi
# Set variables
CWD="$(pwd)"
SRC_NAME="Twisted"
-PKG_NAME="twisted"
+PKG_NAME="Twisted"
ARCH=${ARCH:=i486}
SRC_VERSION=${VERSION:=2.5.0}
PKG_VERSION="$(echo "$SRC_VERSION" | tr '[[:blank:]-]' '_')"
@@ -66,7 +66,7 @@ ERROR_TAR=37; ERROR_MKPKG=38; ERROR_GPG=39
ERROR_PATCH=40; ERROR_VCS=41; ERROR_MKDIR=42
# Clean up any leftovers of previous builds
-rm -rf "$PKG_SRC" 2> /dev/null
+rm -rf "$PKG_WORK" 2> /dev/null
rm -rf "$PKG" 2> /dev/null
# Create directories if necessary
@@ -83,7 +83,6 @@ if [ ! -s "$SRC_DIR/$SRC" ] || ! bunzip2 -t "$SRC_DIR/$SRC" 2> /dev/null; then
wget "$URL" -O "$SRC_DIR/$SRC" || exit $ERROR_WGET
fi
-
# Untar
cd "$PKG_WORK"
tar --no-same-owner --no-same-permissions -xvf "$SRC_DIR/$SRC" || exit $ERROR_TAR
@@ -104,7 +103,11 @@ python setup.py build install --root=$PKG
# Install documentation
DOCS="NEWS TODO README AUTHORS INSTALL ChangeLog MAINTAINERS COPYING readme.*"
mkdir -p "$PKG/usr/doc/$PKG_NAME-$PKG_VERSION" || exit $ERROR_MKDIR
-cp -a $DOCS "$PKG/usr/doc/$PKG_NAME-$PKG_VERSION"
+for doc in $DOCS; do
+ if [ -f "$doc" ]; then
+ cp -a $doc "$PKG/usr/doc/$PKG_NAME-$PKG_VERSION"
+ fi
+done
# Add package description (slack-desc)
mkdir -p "$PKG/install" || exit $ERROR_MKDIR
@@ -136,5 +139,5 @@ makepkg -l y -c n "$REPOS/$PKG_NAME-$PKG_VERSION-$ARCH-$BUILD.tgz" || exit $ERRO
# Delete source and build directories if requested
if [ "$CLEANUP" == "yes" ]; then
- rm -rf "$PKG_SRC" "$PKG"
+ rm -rf "$PKG_WORK" "$PKG"
fi