aboutsummaryrefslogtreecommitdiff
path: root/dev/python/mod_python/mod_python.build
diff options
context:
space:
mode:
Diffstat (limited to 'dev/python/mod_python/mod_python.build')
-rwxr-xr-xdev/python/mod_python/mod_python.build145
1 files changed, 0 insertions, 145 deletions
diff --git a/dev/python/mod_python/mod_python.build b/dev/python/mod_python/mod_python.build
deleted file mode 100755
index af432724..00000000
--- a/dev/python/mod_python/mod_python.build
+++ /dev/null
@@ -1,145 +0,0 @@
-#!/bin/bash
-#
-# mod_python.build is free software; you can redistribute it and/or modify it under the
-# terms of the GNU General Public License as published by the Free Software
-# Foundation; either version 2 of the License, or any later version.
-#
-# mod_python.build is distributed in the hope that it will be useful, but WITHOUT ANY
-# WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR
-# A PARTICULAR PURPOSE. See the GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License along with
-# this program; if not, write to the Free Software Foundation, Inc., 59 Temple
-# Place - Suite 330, Boston, MA 02111-1307, USA
-#
-# build script for mod_python
-# by rhatto at riseup.net
-# build it with slacktrack, example:
-#
-# slacktrack -jefkzp "mod_python-2.7.11-x86_64-1rha.tgz" "./mod_python.build"
-#
-
-CWD="`pwd`"
-
-if [ -f "/etc/slackbuildrc" ]; then
- source /etc/slackbuildrc
-fi
-
-if [ -f "~/.slackbuildrc" ]; then
- source ~/.slackbuildrc
-fi
-
-# default settings
-PACKAGE="mod_python"
-VERSION=${VERSION:=2.7.11}
-ARCH="${ARCH:=x86_64}"
-BUILD=${BUILD:=6rha}
-SRC_DIR=${SRC:=$CWD}
-TMP=${TMP:=/tmp}
-
-# ------- error codes for createpkg --------------
-ERROR_WGET=31; ERROR_MAKE=32; ERROR_INSTALL=33
-ERROR_MD5=34; ERROR_CONF=35; ERROR_HELP=36
-ERROR_TAR=37; ERROR_MKPKG=38; ERROR_GPG=39
-ERROR_PATCH=40
-
-if [ "$ARCH" == "x86_64" ]; then
- export CFLAGS="-fPIC"
- export LDFLAGS="-L/lib64 -L/usr/lib64 -fPIC"
- LIBDIR=/usr/lib64
-else
- LIBDIR=/usr/lib
-fi
-
-RTOOL="wget"
-PACKAGE_EXT="tgz"
-SRC="$PACKAGE-$VERSION.$PACKAGE_EXT"
-URL="http://ftp.unicamp.br/pub/apache/httpd/modpython/$SRC"
-
-SRC_DIR="$SRC_DIR/$PACKAGE"
-
-if [ ! -d "$SRC_DIR" ]; then
- mkdir -p $SRC_DIR
-fi
-
-if [ "$RTOOL" == "wget" ] && [ ! -f "$SRC_DIR/$SRC" ]; then
- wget "$URL" -O "$SRC_DIR/$SRC" || exit $ERROR_WGET
-fi
-
-TMP="$TMP/$PACKAGE"
-
-if [ ! -d "$TMP" ]; then
- mkdir -p $TMP
-fi
-
-cd $TMP
-
-tar xvf $SRC_DIR/$SRC || exit $ERROR_TAR
-cd $PACKAGE-$VERSION
-
-if [ -f "$CWD/$PACKAGE-$VERSION.diff" ]; then
- patch -p1 < $CWD/$PACKAGE-$VERSION.diff || exit $ERROR_PATCH
-fi
-
-if [ -f "$CWD/$PACKAGE-$VERSION-$ARCH.diff" ]; then
- patch -p1 < $CWD/$PACKAGE-$VERSION-$ARCH.diff || exit $ERROR_PATCH
-fi
-
-./configure || exit $ERROR_CONF
-
-# coxa, favor corrigir!
-if [ "$ARCH" == "x86_64" ]; then
- sed -e 's/^OPT=$/OPT=-fPIC -DEAPI/' src/Makefile > src/Makefile.new
- sed -e 's/^PY_STD_LIB=\/usr\/lib/PY_STD_LIB=\/usr\/lib64/' src/Makefile.new > src/Makefile
- # mv src/Makefile.new src/Makefile
- mv lib lib64
-else
- sed -e 's/^OPT=$/OPT=-DEAPI/' src/Makefile > src/Makefile.new
- mv src/Makefile.new src/Makefile
-fi
-
-make || exit $ERROR_MAKE
-make install || exit $ERROR_INSTALL
-
-# strip
-strip --strip-unneeded /usr/libexec/apache/mod_python.so
-
-CWD="`pwd`"
-
-mkdir /install
-
-cat << EOF > /install/slack-desc
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
-
- |-----handy-ruler-----------------------------------------------------|
-mod_python: mod_python (Apache/Python Integration)
-mod_python:
-mod_python: Mod_python is an Apache module that embeds the Python interpreter
-mod_python: within the server. With mod_python you can write web-based
-mod_python: applications in Python that will run many times faster than
-mod_python: traditional CGI and will have access to advanced features such as
-mod_python: ability to retain database connections and other data between hits
-mod_python: and access to Apache internals
-mod_python:
-mod_python:
-mod_python:
-EOF
-
-# docs
-mkdir -p /usr/doc/$PACKAGE-$VERSION
-
-for file in COPYRIGHT CREDITS NEWS README; do
- cp $CWD/$file* /usr/doc/$PACKAGE-$VERSION/
-done
-
-# install script
-echo '( echo Now dont forget to edit your main config and add )' > /install/doinst.sh
-echo '( echo LoadModule python_module /usr/libexec/apache/mod_python.so )' >> /install/doinst.sh
-echo '( echo If your configuration uses ClearModuleList, then also add )' >> /install/doinst.sh
-echo '( echo AddModule mod_python.c )' >> /install/doinst.sh
-