aboutsummaryrefslogtreecommitdiff
path: root/dev/python/kiwi/kiwi.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev/python/kiwi/kiwi.SlackBuild')
-rw-r--r--dev/python/kiwi/kiwi.SlackBuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/dev/python/kiwi/kiwi.SlackBuild b/dev/python/kiwi/kiwi.SlackBuild
index 75c2f739..3605f875 100644
--- a/dev/python/kiwi/kiwi.SlackBuild
+++ b/dev/python/kiwi/kiwi.SlackBuild
@@ -94,7 +94,7 @@ cd "$PKG_SRC"
# Adjust docdir
sed -i "s,share/doc/${PKG_NAME},doc/${PKG_NAME}-${PKG_VERSION},g" setup.py
-python setup.py install --root=$PKG
+python setup.py install --root=$PKG || exit $ERROR_INSTALL
# Install documentation
DOCS="AUTHORS COPYING ChangeLog MANIFEST.in NEWS PKG-INFO README"
@@ -129,11 +129,17 @@ kiwi:
kiwi:
EODESC
+# Copy slack-required
+mkdir -p "$PKG/install" || exit $ERROR_MKDIR
+if [ -f "$CWD/slack-required" ]; then
+ cp $CWD/slack-required $PKG/install
+fi
+
# Build the package
cd "$PKG"
makepkg -l y -c n "$REPOS/$PKG_NAME-$PKG_VERSION-$ARCH-$BUILD.tgz" || exit $ERROR_MKPKG
# Delete source and build directories if requested
-if [ "$CLEANUP" == "yes" ]; then
+if [ "$CLEANUP" == "yes" ] || [ "$1" = "--cleanup" ]; then
rm -rf "$PKG_WORK" "$PKG"
fi