aboutsummaryrefslogtreecommitdiff
path: root/dev/python/genshi/Genshi.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev/python/genshi/Genshi.SlackBuild')
-rwxr-xr-xdev/python/genshi/Genshi.SlackBuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/dev/python/genshi/Genshi.SlackBuild b/dev/python/genshi/Genshi.SlackBuild
index c6b8fbb2..9516ad86 100755
--- a/dev/python/genshi/Genshi.SlackBuild
+++ b/dev/python/genshi/Genshi.SlackBuild
@@ -91,7 +91,7 @@ PKG_SRC="$PWD/`ls -l | awk '/^d/ { print $NF }'`"
cd "$PKG_SRC"
# Build and install package
-python setup.py build install --root=$PKG
+python setup.py build install --root=$PKG || exit $ERROR_INSTALL
# Strip binaries
( cd "$PKG"
@@ -134,11 +134,17 @@ Genshi:
Genshi:
EODESC
+# Copy slack-required
+mkdir -p "$PKG/install" || exit $ERROR_MKDIR
+if [ -f "$CWD/slack-required" ]; then
+ cp $CWD/slack-required $PKG/install
+fi
+
# Build the package
cd "$PKG"
makepkg -l y -c n "$REPOS/$PKG_NAME-$PKG_VERSION-$ARCH-$BUILD.tgz" || exit $ERROR_MKPKG
# Delete source and build directories if requested
-if [ "$CLEANUP" == "yes" ]; then
+if [ "$CLEANUP" == "yes" ] || [ "$1" = "--cleanup" ]; then
rm -rf "$PKG_WORK" "$PKG"
fi