aboutsummaryrefslogtreecommitdiff
path: root/apps/admin/denyhosts
diff options
context:
space:
mode:
Diffstat (limited to 'apps/admin/denyhosts')
-rwxr-xr-xapps/admin/denyhosts/denyhosts.SlackBuild30
-rwxr-xr-xapps/admin/denyhosts/denyhosts.build97
2 files changed, 0 insertions, 127 deletions
diff --git a/apps/admin/denyhosts/denyhosts.SlackBuild b/apps/admin/denyhosts/denyhosts.SlackBuild
deleted file mode 100755
index 42184a02..00000000
--- a/apps/admin/denyhosts/denyhosts.SlackBuild
+++ /dev/null
@@ -1,30 +0,0 @@
-#!/bin/bash
-#
-# SlackBuild script to call denyhosts.build with correct settings
-#
-
-CWD="`pwd`"
-
-if [ -f ~/.slackbuildrc ]; then
- source ~/.slackbuildrc
-elif [ -f /etc/slackbuildrc ]; then
- source /etc/slackbuildrc
-fi
-
-# default settings
-PACKAGE="denyhosts"
-VERSION=${VERSION:=2.5}
-ARCH=${ARCH:=i486}
-BUILD=${BUILD:=1rha}
-SRC_DIR=${SRC:=$CWD}
-TMP=${TMP:=/tmp}
-REPOS=${REPOS:=$TMP}
-
-rm -rf $TMP/$PACKAGE
-mkdir -p $SRC_DIR/$PACKAGE $TMP/$PACKAGE
-
-slacktrack -b $REPOS -x $TMP,$SRC_DIR,/dev -jefkzp "$PACKAGE-$VERSION-$ARCH-$BUILD.tgz" "./$PACKAGE.build"
-
-if [ "$CLEANUP" == "yes" ]; then
- rm -rf $TMP/$PACKAGE
-fi
diff --git a/apps/admin/denyhosts/denyhosts.build b/apps/admin/denyhosts/denyhosts.build
deleted file mode 100755
index dada1ff2..00000000
--- a/apps/admin/denyhosts/denyhosts.build
+++ /dev/null
@@ -1,97 +0,0 @@
-#!/bin/bash
-#
-# build script for denyhosts
-# by rhatto at riseup.net
-# build it with slacktrack, example:
-#
-# slacktrack -jefkzp "denyhosts-0.5-noarch-1rha.tgz" "./denyhosts.build"
-#
-
-CWD="`pwd`"
-
-if [ -f "/etc/slackbuildrc" ]; then
- source /etc/slackbuildrc
-fi
-
-if [ -f "~/.slackbuildrc" ]; then
- source ~/.slackbuildrc
-fi
-
-# default settings
-PACKAGE="denyhosts"
-VERSION=${VERSION:=2.5}
-ARCH=${ARCH:=i486}
-BUILD=${BUILD:=1rha}
-SRC_DIR=${SRC:=$CWD}
-TMP=${TMP:=/tmp}
-
-RTOOL="wget"
-PACKAGE_EXT="gz"
-SRC="DenyHosts-$VERSION.tar.$PACKAGE_EXT"
-URL="http://easynews.dl.sourceforge.net/sourceforge/$PACKAGE/$SRC"
-
-SRC_DIR="$SRC_DIR/$PACKAGE"
-
-if [ ! -d "$SRC_DIR" ]; then
- mkdir -p $SRC_DIR
-fi
-
-if [ "$PACKAGE_EXT" == "bz2" ]; then
- tarflag="j"
-else
- tarflag="z"
-fi
-
-if [ "$RTOOL" == "wget" ] && [ ! -f "$SRC_DIR/$SRC" ]; then
- wget "$URL" -O "$SRC_DIR/$SRC"
-fi
-
-TMP="$TMP/$PACKAGE"
-
-if [ ! -d "$TMP" ]; then
- mkdir -p $TMP
-fi
-
-cd $TMP
-
-tar xvf$tarflag $SRC_DIR/$SRC
-cd DenyHosts-$VERSION
-
-python setup.py install
-
-CWD="`pwd`"
-
-mkdir /install
-
-cat << EOF > /install/slack-desc
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
-
- |-----handy-ruler-----------------------------------------------------|
-denyhosts: denyhosts
-denyhosts:
-denyhosts: DenyHosts is a script intended to help Linux system administrators
-denyhosts: thwart ssh server attacks. DenyHosts scans an ssh server log,
-denyhosts: updates /etc/hosts.deny after a configurable number of failed
-denyhosts: attempts from a rogue host is determined, and alerts the
-denyhosts: administrator of any suspicious logins.
-denyhosts:
-denyhosts:
-denyhosts:
-denyhosts:
-EOF
-
-# docs
-mkdir -p /usr/doc/$PACKAGE-$VERSION
-
-for file in CHANGELOG.txt LICENSE.txt README.txt; do
- cp $CWD/$file* /usr/doc/$PACKAGE-$VERSION/
-done
-
-if [ "$CLEANUP" == "yes" ]; then
- rm -rf $TMP
-fi