aboutsummaryrefslogtreecommitdiff
path: root/app/backup/rdiff-backup/rdiff-backup.build
diff options
context:
space:
mode:
Diffstat (limited to 'app/backup/rdiff-backup/rdiff-backup.build')
-rwxr-xr-xapp/backup/rdiff-backup/rdiff-backup.build22
1 files changed, 11 insertions, 11 deletions
diff --git a/app/backup/rdiff-backup/rdiff-backup.build b/app/backup/rdiff-backup/rdiff-backup.build
index 9afd64e8..93276ec4 100755
--- a/app/backup/rdiff-backup/rdiff-backup.build
+++ b/app/backup/rdiff-backup/rdiff-backup.build
@@ -4,7 +4,7 @@
# by rhatto at riseup.net by rhatto | gpl
# build it with slacktrack, example:
#
-# ARCH=x86_64 slacktrack -jefkzp "rdiff-backup-1.0.4-x86_64-1rha.tgz" "./rdiff-backup.build"
+# ARCH=x86_64 slacktrack -jefkzp "rdiff-backup-1.0.5-x86_64-1rha.tgz" "./rdiff-backup.build"
#
CWD="`pwd`"
@@ -32,11 +32,17 @@ fi
# default settings
PACKAGE="rdiff-backup"
TMP=${TMP:=/tmp}
-VERSION=${VERSION:=1.0.4}
+VERSION=${VERSION:=1.0.5}
ARCH=${ARCH:=i386}
BUILD=${BUILD:=1rha}
SRC_DIR=${SRC:=$CWD}
+# ------- error codes for createpkg --------------
+ERROR_WGET=31; ERROR_MAKE=32; ERROR_INSTALL=33
+ERROR_MD5=34; ERROR_CONF=35; ERROR_HELP=36
+ERROR_TAR=37; ERROR_MKPKG=38; ERROR_GPG=39
+ERROR_PATCH=40
+
if [ "$ARCH" == "x86_64" ]; then
LIBDIR=/usr/lib64
else
@@ -55,13 +61,7 @@ if [ ! -d "$SRC_DIR" ]; then
fi
if [ "$RTOOL" == "wget" ] && [ ! -f "$SRC_DIR/$SRC" ]; then
- wget "$URL" -O "$SRC_DIR/$SRC"
-fi
-
-if [ "$PACKAGE_EXT" == "bz2" ]; then
- tarflag="j"
-else
- tarflag="z"
+ wget "$URL" -O "$SRC_DIR/$SRC" || exit $ERROR_WGET
fi
TMP="$TMP/$PACKAGE"
@@ -70,13 +70,13 @@ if [ ! -d "$TMP" ]; then
mkdir -p $TMP
fi
-tar xvf$tarflag $SRC_DIR/$SRC
+tar xvf $SRC_DIR/$SRC || exit $ERROR_TAR
cd $PACKAGE-$VERSION
# config and install!
mkdir -p /install
-python setup.py install --prefix=/usr/
+python setup.py install --prefix=/usr/ || exit $ERROR_INSTALL
# make the package