aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorrhatto <rhatto@370017ae-e619-0410-ac65-c121f96126d4>2007-07-24 03:19:18 +0000
committerrhatto <rhatto@370017ae-e619-0410-ac65-c121f96126d4>2007-07-24 03:19:18 +0000
commit794f23668c0f667fcefbc7eabee1312b0a412255 (patch)
treece58691e6a8349a706fa9624301a0cf046fd6a05 /www
parent2287f8ab6c99dc16ec20f7513232b8b2d5bb41b9 (diff)
downloadslackbuilds-794f23668c0f667fcefbc7eabee1312b0a412255.tar.gz
slackbuilds-794f23668c0f667fcefbc7eabee1312b0a412255.tar.bz2
added trac
git-svn-id: svn+slack://slack.fluxo.info/var/svn/slackbuilds@1296 370017ae-e619-0410-ac65-c121f96126d4
Diffstat (limited to 'www')
-rw-r--r--www/apps/trac/slack-required2
-rwxr-xr-xwww/apps/trac/trac.SlackBuild42
-rwxr-xr-xwww/apps/trac/trac.build114
3 files changed, 158 insertions, 0 deletions
diff --git a/www/apps/trac/slack-required b/www/apps/trac/slack-required
new file mode 100644
index 00000000..0036071e
--- /dev/null
+++ b/www/apps/trac/slack-required
@@ -0,0 +1,2 @@
+pysqlite
+swig
diff --git a/www/apps/trac/trac.SlackBuild b/www/apps/trac/trac.SlackBuild
new file mode 100755
index 00000000..d97b26db
--- /dev/null
+++ b/www/apps/trac/trac.SlackBuild
@@ -0,0 +1,42 @@
+#!/bin/bash
+#
+# trac.SlackBuild is free software; you can redistribute it and/or modify it under the
+# terms of the GNU General Public License as published by the Free Software
+# Foundation; either version 2 of the License, or any later version.
+#
+# trac.SlackBuild is distributed in the hope that it will be useful, but WITHOUT ANY
+# WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR
+# A PARTICULAR PURPOSE. See the GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License along with
+# this program; if not, write to the Free Software Foundation, Inc., 59 Temple
+# Place - Suite 330, Boston, MA 02111-1307, USA
+#
+# SlackBuild script to call trac.build with correct settings
+#
+
+CWD="`pwd`"
+
+if [ -f ~/.slackbuildrc ]; then
+ source ~/.slackbuildrc
+elif [ -f /etc/slackbuildrc ]; then
+ source /etc/slackbuildrc
+fi
+
+# default settings
+PACKAGE="trac"
+VERSION=${VERSION:=0.10.4}
+ARCH=${ARCH:=i486}
+BUILD=${BUILD:=1rha}
+SRC_DIR=${SRC:=$CWD}
+TMP=${TMP:=/tmp}
+REPOS=${REPOS:=$TMP}
+
+rm -rf $TMP/$PACKAGE
+mkdir -p $SRC_DIR/$PACKAGE $TMP/$PACKAGE $REPOS
+
+slacktrack -b $REPOS -x $TMP,$SRC_DIR,/dev -jefkzp "$PACKAGE-$VERSION-$ARCH-$BUILD.tgz" "./$PACKAGE.build"
+
+if [ "$CLEANUP" == "yes" ]; then
+ rm -rf $TMP/$PACKAGE
+fi
diff --git a/www/apps/trac/trac.build b/www/apps/trac/trac.build
new file mode 100755
index 00000000..8c4a5440
--- /dev/null
+++ b/www/apps/trac/trac.build
@@ -0,0 +1,114 @@
+#!/bin/bash
+#
+# trac.build is free software; you can redistribute it and/or modify it under the
+# terms of the GNU General Public License as published by the Free Software
+# Foundation; either version 2 of the License, or any later version.
+#
+# trac.build is distributed in the hope that it will be useful, but WITHOUT ANY
+# WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR
+# A PARTICULAR PURPOSE. See the GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License along with
+# this program; if not, write to the Free Software Foundation, Inc., 59 Temple
+# Place - Suite 330, Boston, MA 02111-1307, USA
+#
+# build script for trac
+# by rhatto at riseup.net
+# build it with slacktrack, example:
+#
+# slacktrack -jefkzp "trac-0.10.4-i486-1rha.tgz" "./trac.build"
+#
+
+CWD="`pwd`"
+
+if [ -f "/etc/slackbuildrc" ]; then
+ source /etc/slackbuildrc
+fi
+
+if [ -f "~/.slackbuildrc" ]; then
+ source ~/.slackbuildrc
+fi
+
+# default settings
+PACKAGE="trac"
+VERSION=${VERSION:=0.10.4}
+ARCH=${ARCH:=i486}
+BUILD=${BUILD:=1rha}
+SRC_DIR=${SRC:=$CWD}
+TMP=${TMP:=/tmp}
+
+RTOOL="wget"
+PACKAGE_EXT="gz"
+SRC="$PACKAGE-$VERSION.tar.$PACKAGE_EXT"
+URL="http://ftp.edgewall.com/pub/trac/$SRC"
+
+if [ "$ARCH" == "x86_64" ]; then
+ LIBDIR=/usr/lib64
+else
+ LIBDIR=/usr/lib
+fi
+
+# ------- error codes for createpkg --------------
+ERROR_WGET=31; ERROR_MAKE=32; ERROR_INSTALL=33
+ERROR_MD5=34; ERROR_CONF=35; ERROR_HELP=36
+ERROR_TAR=37; ERROR_MKPKG=38; ERROR_GPG=39
+ERROR_PATCH=40
+
+SRC_DIR="$SRC_DIR/$PACKAGE"
+
+if [ ! -d "$SRC_DIR" ]; then
+ mkdir -p $SRC_DIR
+fi
+
+if [ "$RTOOL" == "wget" ] && [ ! -f "$SRC_DIR/$SRC" ]; then
+ wget "$URL" -O "$SRC_DIR/$SRC" || exit $ERROR_WGET
+fi
+
+TMP="$TMP/$PACKAGE"
+
+if [ ! -d "$TMP" ]; then
+ mkdir -p $TMP
+fi
+
+cd $TMP
+
+tar xvf $SRC_DIR/$SRC
+cd $PACKAGE-$VERSION
+
+python setup.py install || exit $ERROR_INSTALL
+
+CWD="`pwd`"
+
+mkdir /install
+
+cat << EOF > /install/slack-desc
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler-----------------------------------------------------|
+trac: trac
+trac:
+trac: Trac is an enhanced wiki and issue tracking system for software
+trac: development projects. Trac uses a minimalistic approach to
+trac: web-based software project management.
+trac:
+trac:
+trac:
+trac:
+trac:
+trac:
+EOF
+
+# docs
+mkdir -p /usr/doc/$PACKAGE-$VERSION
+
+DOCS="AUTHORS COPYING ChangeLog README README.tracd RELEASE THANKS UPGRADE"
+
+for file in $DOCS; do
+ cp $CWD/$file* /usr/doc/$PACKAGE-$VERSION/
+done
+