aboutsummaryrefslogtreecommitdiff
path: root/scons
diff options
context:
space:
mode:
authorrhatto <rhatto@370017ae-e619-0410-ac65-c121f96126d4>2006-09-29 19:29:14 +0000
committerrhatto <rhatto@370017ae-e619-0410-ac65-c121f96126d4>2006-09-29 19:29:14 +0000
commitd7f102c7e3f3c4e3cca9222a5245e1d5c8d7a755 (patch)
tree4cc084b0efbafdab68c2a2b531c1258497fbf931 /scons
parent18b851185f3d214e4ceba5a2d543dbce23cb9bde (diff)
downloadslackbuilds-d7f102c7e3f3c4e3cca9222a5245e1d5c8d7a755.tar.gz
slackbuilds-d7f102c7e3f3c4e3cca9222a5245e1d5c8d7a755.tar.bz2
added scons
git-svn-id: svn+slack://slack.fluxo.info/var/svn/slackbuilds@292 370017ae-e619-0410-ac65-c121f96126d4
Diffstat (limited to 'scons')
-rwxr-xr-xscons/scons.SlackBuild116
-rw-r--r--scons/slack-required1
2 files changed, 117 insertions, 0 deletions
diff --git a/scons/scons.SlackBuild b/scons/scons.SlackBuild
new file mode 100755
index 00000000..cfe11074
--- /dev/null
+++ b/scons/scons.SlackBuild
@@ -0,0 +1,116 @@
+#!/bin/bash
+#
+# slackbuild script for scons
+# by rhatto at riseup.net
+#
+
+if [ -s "slack-required" ]; then
+ echo Recomended and required packages for building scons are:
+ cat slack-required | sed -e 's/^/\t/'
+ if [ "$INTERACT" != "no" ]; then
+ echo If you dont have those installed, press Ctrl-C. Otherwise, hit ENTER.
+ read crap
+ else
+ echo Sleeping 3 seconds...
+ sleep 3
+ fi
+fi
+
+CWD="`pwd`"
+
+if [ -f "/etc/slackbuildrc" ]; then
+ source /etc/slackbuildrc
+fi
+
+if [ -f "~/.slackbuildrc" ]; then
+ source ~/.slackbuildrc
+fi
+
+# default settings
+PACKAGE="scons"
+ARCH=${ARCH:=i486}
+VERSION=${VERSION:=0.96.1}
+BUILD=${BUILD:=1rha}
+SRC_DIR=${SRC:=$CWD}
+TMP=${TMP:=/tmp}
+REPOS=${REPOS:=$TMP}
+
+if [ "$ARCH" == "x86_64" ]; then
+ export LDFLAGS="-L/lib64 -L/usr/lib64"
+ LIBDIR=/usr/lib64
+else
+ LIBDIR=/usr/lib
+fi
+
+RTOOL="wget"
+PACKAGE_EXT="gz"
+SRC="$PACKAGE-$VERSION.tar.$PACKAGE_EXT"
+URL="http://easynews.dl.sourceforge.net/sourceforge/scons/$SRC"
+
+SRC_DIR="$SRC_DIR/$PACKAGE"
+mkdir -p $SRC_DIR
+
+if [ "$PACKAGE_EXT" == "bz2" ]; then
+ tarflag="j"
+else
+ tarflag="z"
+fi
+
+if [ "$RTOOL" == "wget" ] && [ ! -f "$SRC_DIR/$SRC" ]; then
+ wget "$URL" -O "$SRC_DIR/$SRC"
+fi
+
+TMP="$TMP/$PACKAGE"
+rm -rf $TMP
+mkdir -p $TMP
+cd $TMP
+
+tar xvf$tarflag $SRC_DIR/$SRC
+cd $PACKAGE-$VERSION
+
+if [ -f "$CWD/$PACKAGE-$VERSION.diff" ]; then
+ patch -p1 < $CWD/$PACKAGE-$VERSION.diff
+fi
+
+python setup.py install --prefix=$TMP/package-$PACKAGE
+
+CWD="`pwd`"
+
+cd $TMP/package-$PACKAGE
+
+mkdir install
+cat << EOF > install/slack-desc
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler-----------------------------------------------------|
+scons: scons (A software construction tool)
+scons:
+scons: SCons is a software construction tool (build tool substitute for
+scons: Make) implemented in Python. It features a modular build engine that
+scons: can be embedded in other software. SCons configuration files are
+scons: Python scripts that call the build engine API. It can scan files to
+scons: detect dependencies automatically and maintain a global view of all
+scons: dependencies in a build tree, and uses MD5 signatures to detect
+scons: changed file contents reliably. Timestamps can be used if you prefer.
+scons: SCons also supports parallel builds and is easily extensible
+scons: through user-defined builder and scanner objects.
+EOF
+
+# docs
+mkdir -p usr/doc/$PACKAGE-$VERSION
+
+for file in CHANGES.txt LICENSE.txt MANIFEST README.txt RELEASE.txt; do
+ cp $CWD/$file* usr/doc/$PACKAGE-$VERSION/
+done
+
+makepkg -c y -l y $REPOS/$PACKAGE-$VERSION-$ARCH-$BUILD.tgz
+
+if [ "$CLEANUP" == "yes" ]; then
+ rm -rf $TMP
+fi
+
diff --git a/scons/slack-required b/scons/slack-required
new file mode 100644
index 00000000..fdc793e7
--- /dev/null
+++ b/scons/slack-required
@@ -0,0 +1 @@
+python