aboutsummaryrefslogtreecommitdiff
path: root/scons/scons.build
diff options
context:
space:
mode:
authorrhatto <rhatto@370017ae-e619-0410-ac65-c121f96126d4>2006-10-20 14:07:57 +0000
committerrhatto <rhatto@370017ae-e619-0410-ac65-c121f96126d4>2006-10-20 14:07:57 +0000
commit2bb254f3cbb07ff7b64407c1034595f2c5b995e3 (patch)
treed62ad377d5f6bf530ee137f1dc09f1c432f6cdcf /scons/scons.build
parentb48f55e8c45dc69fee0737548158af92676c9bff (diff)
downloadslackbuilds-2bb254f3cbb07ff7b64407c1034595f2c5b995e3.tar.gz
slackbuilds-2bb254f3cbb07ff7b64407c1034595f2c5b995e3.tar.bz2
scons: changing to .build
git-svn-id: svn+slack://slack.fluxo.info/var/svn/slackbuilds@473 370017ae-e619-0410-ac65-c121f96126d4
Diffstat (limited to 'scons/scons.build')
-rwxr-xr-xscons/scons.build122
1 files changed, 122 insertions, 0 deletions
diff --git a/scons/scons.build b/scons/scons.build
new file mode 100755
index 00000000..c9cb18d7
--- /dev/null
+++ b/scons/scons.build
@@ -0,0 +1,122 @@
+#!/bin/bash
+#
+# slackbuild script for scons
+# by rhatto at riseup.net
+#
+
+if [ -s "slack-required" ]; then
+ echo Recomended and required packages for building scons are:
+ cat slack-required | sed -e 's/^/\t/'
+ if [ "$INTERACT" != "no" ]; then
+ echo If you dont have those installed, press Ctrl-C. Otherwise, hit ENTER.
+ read crap
+ else
+ echo Sleeping 3 seconds...
+ sleep 3
+ fi
+fi
+
+CWD="`pwd`"
+
+if [ -f "/etc/slackbuildrc" ]; then
+ source /etc/slackbuildrc
+fi
+
+if [ -f "~/.slackbuildrc" ]; then
+ source ~/.slackbuildrc
+fi
+
+# default settings
+PACKAGE="scons"
+ARCH=${ARCH:=i486}
+VERSION=${VERSION:=0.96.1}
+BUILD=${BUILD:=1rha}
+SRC_DIR=${SRC:=$CWD}
+TMP=${TMP:=/tmp}
+REPOS=${REPOS:=$TMP}
+
+# ------- error codes for createpkg --------------
+ERROR_WGET=31; ERROR_MAKE=32; ERROR_INSTALL=33
+ERROR_MD5=34; ERROR_CONF=35; ERROR_HELP=36
+ERROR_TAR=37; ERROR_MKPKG=38; ERROR_GPG=39
+ERROR_PATCH=40
+
+if [ "$ARCH" == "x86_64" ]; then
+ export LDFLAGS="-L/lib64 -L/usr/lib64"
+ LIBDIR=/usr/lib64
+else
+ LIBDIR=/usr/lib
+fi
+
+RTOOL="wget"
+PACKAGE_EXT="gz"
+SRC="$PACKAGE-$VERSION.tar.$PACKAGE_EXT"
+URL="http://easynews.dl.sourceforge.net/sourceforge/scons/$SRC"
+
+SRC_DIR="$SRC_DIR/$PACKAGE"
+mkdir -p $SRC_DIR
+
+if [ "$PACKAGE_EXT" == "bz2" ]; then
+ tarflag="j"
+else
+ tarflag="z"
+fi
+
+if [ "$RTOOL" == "wget" ] && [ ! -f "$SRC_DIR/$SRC" ]; then
+ wget "$URL" -O "$SRC_DIR/$SRC" || exit $ERROR_WGET
+fi
+
+TMP="$TMP/$PACKAGE"
+rm -rf $TMP
+mkdir -p $TMP
+cd $TMP
+
+tar xvf$tarflag $SRC_DIR/$SRC
+cd $PACKAGE-$VERSION
+
+if [ -f "$CWD/$PACKAGE-$VERSION.diff" ]; then
+ patch -p1 < $CWD/$PACKAGE-$VERSION.diff || exit $ERROR_PATCH
+fi
+
+python setup.py install --prefix=$TMP/package-$PACKAGE --standard-lib || exit $ERROR_INSTALL
+
+CWD="`pwd`"
+
+cd $TMP/package-$PACKAGE
+
+mkdir install
+cat << EOF > install/slack-desc
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler-----------------------------------------------------|
+scons: scons (A software construction tool)
+scons:
+scons: SCons is a software construction tool (build tool substitute for
+scons: Make) implemented in Python. It features a modular build engine that
+scons: can be embedded in other software. SCons configuration files are
+scons: Python scripts that call the build engine API. It can scan files to
+scons: detect dependencies automatically and maintain a global view of all
+scons: dependencies in a build tree, and uses MD5 signatures to detect
+scons: changed file contents reliably. Timestamps can be used if you prefer.
+scons: SCons also supports parallel builds and is easily extensible
+scons: through user-defined builder and scanner objects.
+EOF
+
+# docs
+mkdir -p usr/doc/$PACKAGE-$VERSION
+
+for file in CHANGES.txt LICENSE.txt MANIFEST README.txt RELEASE.txt; do
+ cp $CWD/$file* usr/doc/$PACKAGE-$VERSION/
+done
+
+makepkg -c y -l y $REPOS/$PACKAGE-$VERSION-$ARCH-$BUILD.tgz || exit $ERROR_MKPKG
+
+if [ "$CLEANUP" == "yes" ]; then
+ rm -rf $TMP
+fi
+