aboutsummaryrefslogtreecommitdiff
path: root/rdiff-backup
diff options
context:
space:
mode:
authorrhatto <rhatto@370017ae-e619-0410-ac65-c121f96126d4>2006-07-31 20:45:44 +0000
committerrhatto <rhatto@370017ae-e619-0410-ac65-c121f96126d4>2006-07-31 20:45:44 +0000
commit3ae891bbbaa3f96365f4c9fbe49e5cee26183fbc (patch)
tree59f0163f13e99eefb959385243c564c5662bc5c2 /rdiff-backup
downloadslackbuilds-3ae891bbbaa3f96365f4c9fbe49e5cee26183fbc.tar.gz
slackbuilds-3ae891bbbaa3f96365f4c9fbe49e5cee26183fbc.tar.bz2
initial import
git-svn-id: svn+slack://slack.fluxo.info/var/svn/slackbuilds@1 370017ae-e619-0410-ac65-c121f96126d4
Diffstat (limited to 'rdiff-backup')
-rwxr-xr-xrdiff-backup/rdiff-backup.build82
1 files changed, 82 insertions, 0 deletions
diff --git a/rdiff-backup/rdiff-backup.build b/rdiff-backup/rdiff-backup.build
new file mode 100755
index 00000000..c2364e56
--- /dev/null
+++ b/rdiff-backup/rdiff-backup.build
@@ -0,0 +1,82 @@
+#!/bin/bash
+#
+# build script for rdiff-backup by rhatto | gpl
+# build it with slacktrack, example:
+#
+# ARCH=x86_64 slacktrack -jefkzp "rdiff-backup-1.0.4-x86_64-1rha.tgz" "./rdiff-backup.build"
+#
+
+CWD="`pwd`"
+
+if [ -f "/etc/slackbuildrc" ]; then
+ source /etc/slackbuildrc
+fi
+
+if [ -f "~/.slackbuildrc" ]; then
+ source ~/.slackbuildrc
+fi
+
+# default settings
+PACKAGE="rdiff-backup"
+TMP=${TMP:=/tmp}
+VERSION=${VERSION:=1.0.4}
+ARCH=${ARCH:=i386}
+BUILD=${BUILD:=1rha}
+SRC_DIR=${SRC:=$CWD}
+
+if [ "$ARCH" == "x86_64" ]; then
+ LIBDIR=/usr/lib64
+else
+ LIBDIR=/usr/lib
+fi
+
+RTOOL="wget"
+PACKAGE_EXT="gz"
+SRC="$PACKAGE-$VERSION.tar.$PACKAGE_EXT"
+URL="http://savannah.nongnu.org/download/rdiff-backup/$SRC"
+
+if [ "$RTOOL" == "wget" ] && [ ! -f "$SRC_DIR/$SRC" ]; then
+ wget "$URL" -O "$SRC_DIR/$SRC"
+fi
+
+if [ "$PACKAGE_EXT" == "bz2" ]; then
+ tarflag="j"
+else
+ tarflag="z"
+fi
+
+rm -rf $TMP/package-$PACKAGE
+mkdir $TMP/package-$PACKAGE
+cd $TMP/package-$PACKAGE
+tar xvf$tarflag $SRC_DIR/$SRC
+cd $PACKAGE-$VERSION
+
+# config and install!
+mkdir -p /install
+
+python setup.py install --prefix=/usr/
+
+# make the package
+
+cat << EOF > /install/slack-desc
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler-----------------------------------------------------|
+rdiff-backup: rdiff-backup (remote incremental backup tool)
+rdiff-backup:
+rdiff-backup: rdiff-backup backs up one directory to another. The target directory
+rdiff-backup: ends up a copy of the source directory, but extra reverse diffs are
+rdiff-backup: stored in a special directory so you can still recover files lost
+rdiff-backup: some time ago. The idea is to combine the best features of a mirror
+rdiff-backup: and an incremental backup. rdiff-backup can also operate in a
+rdiff-backup: bandwidth- efficient manner over a pipe, like rsync. Thus you can
+rdiff-backup: use rdiff-backup and ssh to securely back up to a remote location,
+rdiff-backup: and only the differences will be transmitted. It can also handle
+rdiff-backup: symlinks, device files, permissions, ownership, etc.
+EOF
+