aboutsummaryrefslogtreecommitdiff
path: root/patches
diff options
context:
space:
mode:
authorrhatto <rhatto@370017ae-e619-0410-ac65-c121f96126d4>2007-03-17 21:32:05 +0000
committerrhatto <rhatto@370017ae-e619-0410-ac65-c121f96126d4>2007-03-17 21:32:05 +0000
commit3c0af75e4e26e1fb22b73f51d49bd417dac956be (patch)
tree777c6244501921b3dedd7c8bf5e76a3ee78e3e81 /patches
parent62e19d6591ffd768addd5574cb76bf1a7bf9d015 (diff)
downloadslackbuilds-3c0af75e4e26e1fb22b73f51d49bd417dac956be.tar.gz
slackbuilds-3c0af75e4e26e1fb22b73f51d49bd417dac956be.tar.bz2
libpng: fix for x86_64
git-svn-id: svn+slack://slack.fluxo.info/var/svn/slackbuilds@1121 370017ae-e619-0410-ac65-c121f96126d4
Diffstat (limited to 'patches')
-rwxr-xr-xpatches/libpng/libpng.SlackBuild21
1 files changed, 16 insertions, 5 deletions
diff --git a/patches/libpng/libpng.SlackBuild b/patches/libpng/libpng.SlackBuild
index 63457984..ecc4a926 100755
--- a/patches/libpng/libpng.SlackBuild
+++ b/patches/libpng/libpng.SlackBuild
@@ -3,8 +3,9 @@
# slackbuild script for libpng
# by rhatto at riseup.net
#
-# some code grabbed from slackware 11.0 script, at
-# ftp://ftp.slackware.com/pub/slackware/slackware-11.0/source/l/libpng/
+# some code grabbed from slackware 11.0 and slamd64-11.0 scripts, found at
+# ftp://ftp.slackware.com/pub/slackware/slackware-11.0/source/l/libpng/ and
+# http://slamd64.he.net/slamd64-11.0/source/l/libpng/libpng.SlackBuild
#
if [ -s "slack-required" ]; then
@@ -85,10 +86,20 @@ find . -perm 511 -exec chmod 755 {} \;
find . -perm 711 -exec chmod 755 {} \;
find . -perm 555 -exec chmod 755 {} \;
-zcat $CWD/libpng.libs.diff.gz | patch -p1 --verbose || exit $ERROR_PATCH
-ln -sf scripts/makefile.linux ./Makefile
+if [ "$ARCH" == "x86_64" ]; then
+ # Do *NOT* move this... put here in Slamd64 so that libdir
+ # can be overriden and so that we don't have inline assembly problems
+ # - if you change this, rebuilding libpng will break, and
+ # you'll have to rebuild everything that links to it (e.g. KDE).
+ zcat $CWD/libpng.libs.diff.gz | patch -p1 --verbose || exit $ERROR_PATCH
+ ln -sf scripts/makefile.linux ./Makefile
+ ./configure --prefix=/usr --libdir=$LIBDIR || exit $ERROR_CONF
+else
+ ./configure --prefix=/usr --libdir=$LIBDIR || exit $ERROR_CONF
+ zcat $CWD/libpng.libs.diff.gz | patch -p1 --verbose || exit $ERROR_PATCH
+ ln -sf scripts/makefile.linux ./Makefile
+fi
-./configure --prefix=/usr --libdir=$LIBDIR || exit $ERROR_CONF
make || exit $ERROR_MAKE
make DESTDIR=$TMP/package-$PACKAGE install || exit $ERROR_INSTALL