aboutsummaryrefslogtreecommitdiff
path: root/others
diff options
context:
space:
mode:
authorrudson <rudson@370017ae-e619-0410-ac65-c121f96126d4>2006-11-15 22:45:18 +0000
committerrudson <rudson@370017ae-e619-0410-ac65-c121f96126d4>2006-11-15 22:45:18 +0000
commit7e673fa0af3bc487acfb41d9cb551b2fa146b9f7 (patch)
tree391a4b028b7d8d5007792f9f1c1f63f7a771eb69 /others
parent5edac4f98ec983dca5724a95bdc6fac061bb18ba (diff)
downloadslackbuilds-7e673fa0af3bc487acfb41d9cb551b2fa146b9f7.tar.gz
slackbuilds-7e673fa0af3bc487acfb41d9cb551b2fa146b9f7.tar.bz2
movendo...
git-svn-id: svn+slack://slack.fluxo.info/var/svn/slackbuilds@672 370017ae-e619-0410-ac65-c121f96126d4
Diffstat (limited to 'others')
-rwxr-xr-xothers/envy24control/envy24control.SlackBuild121
-rw-r--r--others/feast/feast-03b.diff23
-rwxr-xr-xothers/feast/feast.SlackBuild134
-rw-r--r--others/feast/slack-required2
4 files changed, 280 insertions, 0 deletions
diff --git a/others/envy24control/envy24control.SlackBuild b/others/envy24control/envy24control.SlackBuild
new file mode 100755
index 00000000..4ba7faa6
--- /dev/null
+++ b/others/envy24control/envy24control.SlackBuild
@@ -0,0 +1,121 @@
+#!/bin/bash
+#
+# slackbuild script for envy24control
+# by rhatto at riseup.net
+#
+
+if [ -s "slack-required" ]; then
+ echo Recomended and required packages for building envy24control are:
+ cat slack-required | sed -e 's/^/\t/'
+ if [ "$INTERACT" != "no" ]; then
+ echo If you dont have those installed, press Ctrl-C. Otherwise, hit ENTER.
+ read crap
+# else
+# echo Sleeping 3 seconds...
+# sleep 3
+ fi
+fi
+
+CWD="`pwd`"
+
+if [ -f ~/.slackbuildrc ]; then
+ source ~/.slackbuildrc
+elif [ -f /etc/slackbuildrc ]; then
+ source /etc/slackbuildrc
+fi
+
+# default settings
+PACKAGE="envy24control"
+ARCH=${ARCH:=i486}
+VERSION=${VERSION:=1.0.13}
+BUILD=${BUILD:=1rha}
+SRC_DIR=${SRC:=$CWD}
+TMP=${TMP:=/tmp}
+REPOS=${REPOS:=$TMP}
+
+if [ "$ARCH" == "x86_64" ]; then
+ export LDFLAGS="-L/lib64 -L/usr/lib64"
+ LIBDIR=/usr/lib64
+else
+ LIBDIR=/usr/lib
+fi
+
+# ------- error codes for createpkg --------------
+ERROR_WGET=31; ERROR_MAKE=32; ERROR_INSTALL=33
+ERROR_MD5=34; ERROR_CONF=35; ERROR_HELP=36
+ERROR_TAR=37; ERROR_MKPKG=38; ERROR_GPG=39
+ERROR_PATCH=40
+
+RTOOL="wget"
+PACKAGE_EXT="bz2"
+SRC="alsa-tools-$VERSION.tar.$PACKAGE_EXT"
+URL="ftp://ftp.alsa-project.org/pub/tools/$SRC"
+
+SRC_DIR="$SRC_DIR/alsa-tools"
+mkdir -p $SRC_DIR
+
+if [ "$RTOOL" == "wget" ] && [ ! -f "$SRC_DIR/$SRC" ]; then
+ wget "$URL" -O "$SRC_DIR/$SRC" || exit $ERROR_WGET
+fi
+
+TMP="$TMP/$PACKAGE"
+rm -rf $TMP
+mkdir -p $TMP
+cd $TMP
+
+tar xvf $SRC_DIR/$SRC || exit $ERROR_TAR
+cd alsa-tools-$VERSION/$PACKAGE
+
+if [ -f "$CWD/$PACKAGE-$VERSION.diff" ]; then
+ patch -p1 < $CWD/$PACKAGE-$VERSION.diff || exit $ERROR_PATCH
+fi
+
+./configure --prefix=/usr --sysconfdir=/etc --libdir=$LIBDIR || exit $ERROR_CONF
+make || exit $ERROR_MAKE
+make DESTDIR=$TMP/package-$PACKAGE install || exit $ERROR_INSTALL
+
+CWD="`pwd`"
+
+cd $TMP/package-$PACKAGE
+
+find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+
+mkdir install
+cat << EOF > install/slack-desc
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler-----------------------------------------------------|
+envy24control: envy24control (Control tool for Envy24 (ice1712) based soundcards)
+envy24control:
+envy24control: Envy24control is a graphical utility for controlling cards based on
+envy24control: the envy24 or ice1712 chipset, e.g., the Midiman Delta series and
+envy24control: the Terratec EWS and EWX series. It is supplied as part of the
+envy24control: alsa-tools package. The utility allows control of the digital mixer,
+envy24control: channel gains and other hardware settings, as well as displaying a
+envy24control: level meter for each input and output channel.
+envy24control:
+envy24control:
+envy24control:
+EOF
+
+# docs
+mkdir -p usr/doc/$PACKAGE-$VERSION
+
+DOCS="AUTHORS COPYING README"
+
+for file in $DOCS; do
+ cp $CWD/$file* usr/doc/$PACKAGE-$VERSION/
+done
+
+makepkg -c y -l y $REPOS/$PACKAGE-$VERSION-$ARCH-$BUILD.tgz || exit $ERROR_MKPKG
+
+if [ "$CLEANUP" == "yes" ]; then
+ rm -rf $TMP
+fi
+
diff --git a/others/feast/feast-03b.diff b/others/feast/feast-03b.diff
new file mode 100644
index 00000000..baec8896
--- /dev/null
+++ b/others/feast/feast-03b.diff
@@ -0,0 +1,23 @@
+diff -Naur feast_03b.orig/Makefile feast_03b/Makefile
+--- feast_03b.orig/Makefile 2005-11-10 08:19:08.000000000 -0200
++++ feast_03b/Makefile 2006-10-19 18:43:57.000000000 -0200
+@@ -10,8 +10,8 @@
+ #
+ # To compile just type "make" and away you go.
+ #
+-SILC_LIB = /usr/local/silc/lib
+-SILC_INCLUDES = /usr/local/silc/include
++SILC_LIB = /usr/lib
++SILC_INCLUDES = /usr/include
+
+ CFLAGS = $(INCLUDES) $(SILC_COMMON_LIBS) $(LDFLAGS)
+ SOURCES = src/feast.c src/feast_irc.c src/feast_silc.c src/irc_parser.c src/feast_config.c
+@@ -22,7 +22,7 @@
+ rm -f feast
+
+ feast: $(SOURCES)
+- gcc -o feast $(SOURCES) -g -O2 -Wall -finline-functions -D_REENTRANT -I./ -I$(SILC_INCLUDES) -lcrypt -ldl -lpthread -L$(SILC_LIB) -lsilc -lsilcclient -lsilc
++ gcc -o feast $(SOURCES) -g -O2 -Wall -finline-functions -D_REENTRANT -I./ -I$(SILC_INCLUDES) -lcrypt -ldl -lpthread -L$(SILC_LIB) -lsilc -lsilcclient -lsilc -liconv
+
+ debug: clean $(SOURCES)
+ gcc -o feast $(SOURCES) -g -O2 -Wall -DDEBUG -finline-functions -D_REENTRANT -I./ -I$(SILC_INCLUDES) -lcrypt -ldl -lpthread -L$(SILC_LIB) -lsilc -lsilcclient -lsilc
diff --git a/others/feast/feast.SlackBuild b/others/feast/feast.SlackBuild
new file mode 100755
index 00000000..cd96dc31
--- /dev/null
+++ b/others/feast/feast.SlackBuild
@@ -0,0 +1,134 @@
+#!/bin/bash
+#
+# slackbuild script for feast
+# by rhatto at riseup.net
+#
+
+if [ -s "slack-required" ]; then
+ echo Recomended and required packages for building feast are:
+ cat slack-required | sed -e 's/^/\t/'
+ if [ "$INTERACT" != "no" ]; then
+ echo If you dont have those installed, press Ctrl-C. Otherwise, hit ENTER.
+ read crap
+# else
+# echo Sleeping 3 seconds...
+# sleep 3
+ fi
+fi
+
+CWD="`pwd`"
+
+if [ -f ~/.slackbuildrc ]; then
+ source ~/.slackbuildrc
+elif [ -f /etc/slackbuildrc ]; then
+ source /etc/slackbuildrc
+fi
+
+# default settings
+PACKAGE="feast"
+ARCH=${ARCH:=i486}
+VERSION=${VERSION:=03b}
+BUILD=${BUILD:=1rha}
+SRC_DIR=${SRC:=$CWD}
+TMP=${TMP:=/tmp}
+REPOS=${REPOS:=$TMP}
+
+if [ "$ARCH" == "x86_64" ]; then
+ export LDFLAGS="-L/lib64 -L/usr/lib64"
+ LIBDIR=/usr/lib64
+else
+ LIBDIR=/usr/lib
+fi
+
+# ------- error codes for createpkg --------------
+ERROR_WGET=31; ERROR_MAKE=32; ERROR_INSTALL=33
+ERROR_MD5=34; ERROR_CONF=35; ERROR_HELP=36
+ERROR_TAR=37; ERROR_MKPKG=38; ERROR_GPG=39
+ERROR_PATCH=40
+
+RTOOL="wget"
+PACKAGE_EXT="tgz"
+SRC="$PACKAGE"_"$VERSION.$PACKAGE_EXT"
+URL="http://www.hick.org/~raffi/download/$SRC"
+
+SRC_DIR="$SRC_DIR/$PACKAGE"
+mkdir -p $SRC_DIR
+
+if [ "$RTOOL" == "wget" ] && [ ! -f "$SRC_DIR/$SRC" ]; then
+ wget "$URL" -O "$SRC_DIR/$SRC" || exit $ERROR_WGET
+fi
+
+TMP="$TMP/$PACKAGE"
+rm -rf $TMP
+mkdir -p $TMP
+cd $TMP
+
+tar xvf $SRC_DIR/$SRC || exit $ERROR_TAR
+cd "$PACKAGE"_"$VERSION"
+
+if [ -f "$CWD/$PACKAGE-$VERSION.diff" ]; then
+ patch -p1 < $CWD/$PACKAGE-$VERSION.diff || exit $ERROR_PATCH
+fi
+
+if [ "$ARC" == "x86_64" ]; then
+ sed -e 's/\/usr\/lib/\/usr\/lib64/' Makefile > Makefile.tmp
+ mv Makefile.tmp Makefile
+fi
+
+make || exit $ERROR_MAKE
+
+CWD="`pwd`"
+
+mkdir -p $TMP/package-$PACKAGE
+cd $TMP/package-$PACKAGE
+
+mkdir -p usr/bin
+cp $CWD/feast usr/bin
+
+mkdir -p etc/feast
+cp $CWD/feast.conf etc/feast.conf.new
+
+find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+
+mkdir install
+cat << EOF > install/slack-desc
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler-----------------------------------------------------|
+feast: feast (silc to irc translator)
+feast:
+feast: SILC stands for Secure Internet Live Conferencing.
+feast: Far East Trader (feast) is meant to open up the world of SILC to
+feast: IRC users who are to lazy to download a SILC client.
+feast:
+feast:
+feast:
+feast:
+feast:
+feast:
+EOF
+
+# docs
+mkdir -p usr/doc/$PACKAGE-$VERSION
+
+DOCS="license.txt readme.txt"
+
+for file in $DOCS; do
+ cp $CWD/$file* usr/doc/$PACKAGE-$VERSION/
+done
+
+# install script
+echo '( if [ ! -f "etc/feast.conf" ]; then mv etc/feast.conf.new etc/feast.conf; fi )' > install/doinst.sh
+
+makepkg -c y -l y $REPOS/$PACKAGE-$VERSION-$ARCH-$BUILD.tgz || exit $ERROR_MKPKG
+
+if [ "$CLEANUP" == "yes" ]; then
+ rm -rf $TMP
+fi
+
diff --git a/others/feast/slack-required b/others/feast/slack-required
new file mode 100644
index 00000000..a22b636a
--- /dev/null
+++ b/others/feast/slack-required
@@ -0,0 +1,2 @@
+libiconv
+silc-toolkit