aboutsummaryrefslogtreecommitdiff
path: root/others
diff options
context:
space:
mode:
authorrafael2k <rafael2k@370017ae-e619-0410-ac65-c121f96126d4>2007-02-26 19:50:14 +0000
committerrafael2k <rafael2k@370017ae-e619-0410-ac65-c121f96126d4>2007-02-26 19:50:14 +0000
commit29dbda7d6ee5e74b1b17692a69c11820b24aed84 (patch)
tree2147ab56ecfffc7b0407ba7f8153a718dc3681fb /others
parent0b57714c533ac2a33065e85bfbfef6733861092c (diff)
downloadslackbuilds-29dbda7d6ee5e74b1b17692a69c11820b24aed84.tar.gz
slackbuilds-29dbda7d6ee5e74b1b17692a69c11820b24aed84.tar.bz2
more location fixes
git-svn-id: svn+slack://slack.fluxo.info/var/svn/slackbuilds@1062 370017ae-e619-0410-ac65-c121f96126d4
Diffstat (limited to 'others')
-rwxr-xr-xothers/downtube/downtube.SlackBuild30
-rwxr-xr-xothers/downtube/downtube.build97
-rw-r--r--others/feast/feast-03b.diff23
-rwxr-xr-xothers/feast/feast.SlackBuild134
-rw-r--r--others/feast/slack-required2
-rwxr-xr-xothers/torsmo/torsmo.SlackBuild124
6 files changed, 0 insertions, 410 deletions
diff --git a/others/downtube/downtube.SlackBuild b/others/downtube/downtube.SlackBuild
deleted file mode 100755
index bd9eb96f..00000000
--- a/others/downtube/downtube.SlackBuild
+++ /dev/null
@@ -1,30 +0,0 @@
-#!/bin/bash
-#
-# SlackBuild script to call downtube.build with correct settings
-#
-
-CWD="`pwd`"
-
-if [ -f ~/.slackbuildrc ]; then
- source ~/.slackbuildrc
-elif [ -f /etc/slackbuildrc ]; then
- source /etc/slackbuildrc
-fi
-
-# default settings
-PACKAGE="downtube"
-VERSION=${VERSION:=1.2}
-ARCH="noarch"
-BUILD=${BUILD:=1rha}
-SRC_DIR=${SRC:=$CWD}
-TMP=${TMP:=/tmp}
-REPOS=${REPOS:=$TMP}
-
-rm -rf $TMP/$PACKAGE
-mkdir -p $SRC_DIR/$PACKAGE $TMP/$PACKAGE
-
-slacktrack -b $REPOS -x $TMP,$SRC_DIR,/dev -jefkzp "$PACKAGE-$VERSION-$ARCH-$BUILD.tgz" "./$PACKAGE.build"
-
-if [ "$CLEANUP" == "yes" ]; then
- rm -rf $TMP/$PACKAGE
-fi
diff --git a/others/downtube/downtube.build b/others/downtube/downtube.build
deleted file mode 100755
index 0d537552..00000000
--- a/others/downtube/downtube.build
+++ /dev/null
@@ -1,97 +0,0 @@
-#!/bin/bash
-#
-# build script for downtube
-# by rhatto at riseup.net
-# build it with slacktrack, example:
-#
-# slacktrack -jefkzp "downtube-1.2-noarch-1rha.tgz" "./downtube.build"
-#
-
-CWD="`pwd`"
-
-if [ -f "/etc/slackbuildrc" ]; then
- source /etc/slackbuildrc
-fi
-
-if [ -f "~/.slackbuildrc" ]; then
- source ~/.slackbuildrc
-fi
-
-# default settings
-PACKAGE="downtube"
-VERSION=${VERSION:=1.2}
-ARCH="noarch"
-BUILD=${BUILD:=1rha}
-SRC_DIR=${SRC:=$CWD}
-TMP=${TMP:=/tmp}
-
-RTOOL="wget"
-PACKAGE_EXT="gz"
-SRC="$PACKAGE-$VERSION.tar.$PACKAGE_EXT"
-URL="http://codigolivre.org.br/frs/download.php/5174/$SRC"
-
-SRC_DIR="$SRC_DIR/$PACKAGE"
-
-if [ ! -d "$SRC_DIR" ]; then
- mkdir -p $SRC_DIR
-fi
-
-if [ "$PACKAGE_EXT" == "bz2" ]; then
- tarflag="j"
-else
- tarflag="z"
-fi
-
-if [ "$RTOOL" == "wget" ] && [ ! -f "$SRC_DIR/$SRC" ]; then
- wget "$URL" -O "$SRC_DIR/$SRC"
-fi
-
-TMP="$TMP/$PACKAGE"
-
-if [ ! -d "$TMP" ]; then
- mkdir -p $TMP
-fi
-
-cd $TMP
-
-tar xvf$tarflag $SRC_DIR/$SRC
-cd $PACKAGE-$VERSION
-
-python setup.py install
-
-CWD="`pwd`"
-
-mkdir /install
-
-cat << EOF > /install/slack-desc
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
-
- |-----handy-ruler-----------------------------------------------------|
-downtube: downtube: youtube.com video downloader and converter.
-downtube:
-downtube:
-downtube:
-downtube:
-downtube:
-downtube:
-downtube:
-downtube:
-downtube:
-downtube:
-EOF
-
-# docs
-mkdir -p /usr/doc/$PACKAGE-$VERSION
-
-for file in AUTHORS COPYING ChangeLog FAQ INSTALL README TODO; do
- cp $CWD/$file* /usr/doc/$PACKAGE-$VERSION/
-done
-
-if [ "$CLEANUP" == "yes" ]; then
- rm -rf $TMP
-fi
diff --git a/others/feast/feast-03b.diff b/others/feast/feast-03b.diff
deleted file mode 100644
index baec8896..00000000
--- a/others/feast/feast-03b.diff
+++ /dev/null
@@ -1,23 +0,0 @@
-diff -Naur feast_03b.orig/Makefile feast_03b/Makefile
---- feast_03b.orig/Makefile 2005-11-10 08:19:08.000000000 -0200
-+++ feast_03b/Makefile 2006-10-19 18:43:57.000000000 -0200
-@@ -10,8 +10,8 @@
- #
- # To compile just type "make" and away you go.
- #
--SILC_LIB = /usr/local/silc/lib
--SILC_INCLUDES = /usr/local/silc/include
-+SILC_LIB = /usr/lib
-+SILC_INCLUDES = /usr/include
-
- CFLAGS = $(INCLUDES) $(SILC_COMMON_LIBS) $(LDFLAGS)
- SOURCES = src/feast.c src/feast_irc.c src/feast_silc.c src/irc_parser.c src/feast_config.c
-@@ -22,7 +22,7 @@
- rm -f feast
-
- feast: $(SOURCES)
-- gcc -o feast $(SOURCES) -g -O2 -Wall -finline-functions -D_REENTRANT -I./ -I$(SILC_INCLUDES) -lcrypt -ldl -lpthread -L$(SILC_LIB) -lsilc -lsilcclient -lsilc
-+ gcc -o feast $(SOURCES) -g -O2 -Wall -finline-functions -D_REENTRANT -I./ -I$(SILC_INCLUDES) -lcrypt -ldl -lpthread -L$(SILC_LIB) -lsilc -lsilcclient -lsilc -liconv
-
- debug: clean $(SOURCES)
- gcc -o feast $(SOURCES) -g -O2 -Wall -DDEBUG -finline-functions -D_REENTRANT -I./ -I$(SILC_INCLUDES) -lcrypt -ldl -lpthread -L$(SILC_LIB) -lsilc -lsilcclient -lsilc
diff --git a/others/feast/feast.SlackBuild b/others/feast/feast.SlackBuild
deleted file mode 100755
index cd96dc31..00000000
--- a/others/feast/feast.SlackBuild
+++ /dev/null
@@ -1,134 +0,0 @@
-#!/bin/bash
-#
-# slackbuild script for feast
-# by rhatto at riseup.net
-#
-
-if [ -s "slack-required" ]; then
- echo Recomended and required packages for building feast are:
- cat slack-required | sed -e 's/^/\t/'
- if [ "$INTERACT" != "no" ]; then
- echo If you dont have those installed, press Ctrl-C. Otherwise, hit ENTER.
- read crap
-# else
-# echo Sleeping 3 seconds...
-# sleep 3
- fi
-fi
-
-CWD="`pwd`"
-
-if [ -f ~/.slackbuildrc ]; then
- source ~/.slackbuildrc
-elif [ -f /etc/slackbuildrc ]; then
- source /etc/slackbuildrc
-fi
-
-# default settings
-PACKAGE="feast"
-ARCH=${ARCH:=i486}
-VERSION=${VERSION:=03b}
-BUILD=${BUILD:=1rha}
-SRC_DIR=${SRC:=$CWD}
-TMP=${TMP:=/tmp}
-REPOS=${REPOS:=$TMP}
-
-if [ "$ARCH" == "x86_64" ]; then
- export LDFLAGS="-L/lib64 -L/usr/lib64"
- LIBDIR=/usr/lib64
-else
- LIBDIR=/usr/lib
-fi
-
-# ------- error codes for createpkg --------------
-ERROR_WGET=31; ERROR_MAKE=32; ERROR_INSTALL=33
-ERROR_MD5=34; ERROR_CONF=35; ERROR_HELP=36
-ERROR_TAR=37; ERROR_MKPKG=38; ERROR_GPG=39
-ERROR_PATCH=40
-
-RTOOL="wget"
-PACKAGE_EXT="tgz"
-SRC="$PACKAGE"_"$VERSION.$PACKAGE_EXT"
-URL="http://www.hick.org/~raffi/download/$SRC"
-
-SRC_DIR="$SRC_DIR/$PACKAGE"
-mkdir -p $SRC_DIR
-
-if [ "$RTOOL" == "wget" ] && [ ! -f "$SRC_DIR/$SRC" ]; then
- wget "$URL" -O "$SRC_DIR/$SRC" || exit $ERROR_WGET
-fi
-
-TMP="$TMP/$PACKAGE"
-rm -rf $TMP
-mkdir -p $TMP
-cd $TMP
-
-tar xvf $SRC_DIR/$SRC || exit $ERROR_TAR
-cd "$PACKAGE"_"$VERSION"
-
-if [ -f "$CWD/$PACKAGE-$VERSION.diff" ]; then
- patch -p1 < $CWD/$PACKAGE-$VERSION.diff || exit $ERROR_PATCH
-fi
-
-if [ "$ARC" == "x86_64" ]; then
- sed -e 's/\/usr\/lib/\/usr\/lib64/' Makefile > Makefile.tmp
- mv Makefile.tmp Makefile
-fi
-
-make || exit $ERROR_MAKE
-
-CWD="`pwd`"
-
-mkdir -p $TMP/package-$PACKAGE
-cd $TMP/package-$PACKAGE
-
-mkdir -p usr/bin
-cp $CWD/feast usr/bin
-
-mkdir -p etc/feast
-cp $CWD/feast.conf etc/feast.conf.new
-
-find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
-find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
-
-mkdir install
-cat << EOF > install/slack-desc
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
-
- |-----handy-ruler-----------------------------------------------------|
-feast: feast (silc to irc translator)
-feast:
-feast: SILC stands for Secure Internet Live Conferencing.
-feast: Far East Trader (feast) is meant to open up the world of SILC to
-feast: IRC users who are to lazy to download a SILC client.
-feast:
-feast:
-feast:
-feast:
-feast:
-feast:
-EOF
-
-# docs
-mkdir -p usr/doc/$PACKAGE-$VERSION
-
-DOCS="license.txt readme.txt"
-
-for file in $DOCS; do
- cp $CWD/$file* usr/doc/$PACKAGE-$VERSION/
-done
-
-# install script
-echo '( if [ ! -f "etc/feast.conf" ]; then mv etc/feast.conf.new etc/feast.conf; fi )' > install/doinst.sh
-
-makepkg -c y -l y $REPOS/$PACKAGE-$VERSION-$ARCH-$BUILD.tgz || exit $ERROR_MKPKG
-
-if [ "$CLEANUP" == "yes" ]; then
- rm -rf $TMP
-fi
-
diff --git a/others/feast/slack-required b/others/feast/slack-required
deleted file mode 100644
index a22b636a..00000000
--- a/others/feast/slack-required
+++ /dev/null
@@ -1,2 +0,0 @@
-libiconv
-silc-toolkit
diff --git a/others/torsmo/torsmo.SlackBuild b/others/torsmo/torsmo.SlackBuild
deleted file mode 100755
index ecbd92b3..00000000
--- a/others/torsmo/torsmo.SlackBuild
+++ /dev/null
@@ -1,124 +0,0 @@
-#!/bin/bash
-#
-# slackbuild script for torsmo
-# by rhatto at riseup.net
-#
-
-if [ -s "slack-required" ]; then
- echo Recomended and required packages for building torsmo are:
- cat slack-required | sed -e 's/^/\t/'
- if [ "$INTERACT" != "no" ]; then
- echo If you dont have those installed, press Ctrl-C. Otherwise, hit ENTER.
- read crap
-# else
-# echo Sleeping 3 seconds...
-# sleep 3
- fi
-fi
-
-CWD="`pwd`"
-
-if [ -f ~/.slackbuildrc ]; then
- source ~/.slackbuildrc
-elif [ -f /etc/slackbuildrc ]; then
- source /etc/slackbuildrc
-fi
-
-# default settings
-PACKAGE="torsmo"
-ARCH=${ARCH:=i486}
-VERSION=${VERSION:=0.18}
-BUILD=${BUILD:=1rha}
-SRC_DIR=${SRC:=$CWD}
-TMP=${TMP:=/tmp}
-REPOS=${REPOS:=$TMP}
-
-export CFLAGS="-I/usr/X11R6/include"
-
-if [ "$ARCH" == "x86_64" ]; then
- export LDFLAGS="-L/lib64 -L/usr/lib64"
- export CFLAGS="-L/usr/X11R6/lib64 -lX11 -lXext"
- LIBDIR=/usr/lib64
-else
- LIBDIR=/usr/lib
-fi
-
-# ------- error codes for createpkg --------------
-ERROR_WGET=31; ERROR_MAKE=32; ERROR_INSTALL=33
-ERROR_MD5=34; ERROR_CONF=35; ERROR_HELP=36
-ERROR_TAR=37; ERROR_MKPKG=38; ERROR_GPG=39
-ERROR_PATCH=40
-
-RTOOL="wget"
-PACKAGE_EXT="gz"
-SRC="$PACKAGE-$VERSION.tar.$PACKAGE_EXT"
-URL="http://easynews.dl.sourceforge.net/sourceforge/$PACKAGE/$SRC"
-
-SRC_DIR="$SRC_DIR/$PACKAGE"
-mkdir -p $SRC_DIR
-
-if [ "$RTOOL" == "wget" ] && [ ! -f "$SRC_DIR/$SRC" ]; then
- wget "$URL" -O "$SRC_DIR/$SRC" || exit $ERROR_WGET
-fi
-
-TMP="$TMP/$PACKAGE"
-rm -rf $TMP
-mkdir -p $TMP
-cd $TMP
-
-tar xvf $SRC_DIR/$SRC || exit $ERROR_TAR
-cd $PACKAGE-$VERSION
-
-if [ -f "$CWD/$PACKAGE-$VERSION.diff" ]; then
- patch -p1 < $CWD/$PACKAGE-$VERSION.diff || exit $ERROR_PATCH
-fi
-
-./configure --prefix=/usr --sysconfdir=/etc --libdir=$LIBDIR || exit $ERROR_CONF
-make || exit $ERROR_MAKE
-make DESTDIR=$TMP/package-$PACKAGE install || exit $ERROR_INSTALL
-
-CWD="`pwd`"
-
-cd $TMP/package-$PACKAGE
-
-find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
-find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
-
-mkdir install
-cat << EOF > install/slack-desc
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
-
- |-----handy-ruler-----------------------------------------------------|
-torsmo: torsmo (Tyopoyta ORvelo System MOnitor)
-torsmo:
-torsmo: Torsmo is a system monitor that sits in the corner of your desktop.
-torsmo: Torsmo can show various information about your system and its
-torsmo: peripherals. Torsmo is very light and customizable, and it
-torsmo: renders text on the root window.
-torsmo:
-torsmo:
-torsmo:
-torsmo:
-torsmo:
-EOF
-
-# docs
-mkdir -p usr/doc/$PACKAGE-$VERSION
-
-DOCS="AUTHORS COPYING ChangeLog INSTALL NEWS README"
-
-for file in $DOCS; do
- cp $CWD/$file* usr/doc/$PACKAGE-$VERSION/
-done
-
-makepkg -c y -l y $REPOS/$PACKAGE-$VERSION-$ARCH-$BUILD.tgz || exit $ERROR_MKPKG
-
-if [ "$CLEANUP" == "yes" ]; then
- rm -rf $TMP
-fi
-