aboutsummaryrefslogtreecommitdiff
path: root/nicotine
diff options
context:
space:
mode:
authorrhatto <rhatto@370017ae-e619-0410-ac65-c121f96126d4>2006-09-07 17:07:47 +0000
committerrhatto <rhatto@370017ae-e619-0410-ac65-c121f96126d4>2006-09-07 17:07:47 +0000
commitf55a5ffee055a85dcfa8aca3c2a8139fc8642c21 (patch)
tree6ccd0acee57ad4b2109cc36d2fb94aba601582aa /nicotine
parent0e2667a6e8a2d8078ae3dfb7091e7be5a0cd12cd (diff)
downloadslackbuilds-f55a5ffee055a85dcfa8aca3c2a8139fc8642c21.tar.gz
slackbuilds-f55a5ffee055a85dcfa8aca3c2a8139fc8642c21.tar.bz2
nicotine update: now two flavors: vanilla and nicotine+
git-svn-id: svn+slack://slack.fluxo.info/var/svn/slackbuilds@157 370017ae-e619-0410-ac65-c121f96126d4
Diffstat (limited to 'nicotine')
-rwxr-xr-xnicotine/nicotine+.SlackBuild32
-rwxr-xr-xnicotine/nicotine+.build96
-rwxr-xr-xnicotine/nicotine.build16
3 files changed, 135 insertions, 9 deletions
diff --git a/nicotine/nicotine+.SlackBuild b/nicotine/nicotine+.SlackBuild
new file mode 100755
index 00000000..d715b791
--- /dev/null
+++ b/nicotine/nicotine+.SlackBuild
@@ -0,0 +1,32 @@
+#!/bin/bash
+#
+# SlackBuild script to call nicotine+.build with correct settings
+#
+
+CWD="`pwd`"
+
+if [ -f "/etc/slackbuildrc" ]; then
+ source /etc/slackbuildrc
+fi
+
+if [ -f "~/.slackbuildrc" ]; then
+ source ~/.slackbuildrc
+fi
+
+# default settings
+PACKAGE="nicotine+"
+VERSION=${VERSION:=1.2.4.1}
+ARCH="noarch"
+BUILD=${BUILD:=1rha}
+SRC_DIR=${SRC:=$CWD}
+TMP=${TMP:=/tmp}
+REPOS=${REPOS:=$TMP}
+
+rm -rf $TMP/$PACKAGE
+mkdir -p $SRC_DIR/$PACKAGE $TMP/$PACKAGE $REPOS
+
+slacktrack -b $REPOS -x $TMP,$SRC_DIR,/dev -jefkzp "$PACKAGE-$VERSION-$ARCH-$BUILD.tgz" "./$PACKAGE.build"
+
+if [ "$CLEANUP" == "yes" ]; then
+ rm -rf $TMP/$PACKAGE
+fi
diff --git a/nicotine/nicotine+.build b/nicotine/nicotine+.build
new file mode 100755
index 00000000..96cf2977
--- /dev/null
+++ b/nicotine/nicotine+.build
@@ -0,0 +1,96 @@
+#!/bin/bash
+#
+# build script for nicotine+
+# by rhatto at riseup.net
+# build it with slacktrack, example:
+#
+# slacktrack -jefkzp "nicotine+-1.2.4.1-noarch-1rha.tgz" "./nicotine+.build"
+#
+
+CWD="`pwd`"
+
+if [ -f "/etc/slackbuildrc" ]; then
+ source /etc/slackbuildrc
+fi
+
+if [ -f "~/.slackbuildrc" ]; then
+ source ~/.slackbuildrc
+fi
+
+# default settings
+PACKAGE="nicotine"
+VERSION=${VERSION:=1.2.4.1}
+ARCH="noarch"
+BUILD=${BUILD:=1rha}
+SRC_DIR=${SRC:=$CWD}
+TMP=${TMP:=/tmp}
+
+RTOOL="wget"
+PACKAGE_EXT="bz2"
+SRC="$PACKAGE-$VERSION.tar.$PACKAGE_EXT"
+URL="http://easynews.dl.sourceforge.net/sourceforge/nicotine-plus/$SRC"
+
+SRC_DIR="$SRC_DIR/$PACKAGE"
+
+if [ ! -d "$SRC_DIR" ]; then
+ mkdir -p $SRC_DIR
+fi
+
+if [ "$PACKAGE_EXT" == "bz2" ]; then
+ tarflag="j"
+else
+ tarflag="z"
+fi
+
+if [ "$RTOOL" == "wget" ] && [ ! -f "$SRC_DIR/$SRC" ]; then
+ wget "$URL" -O "$SRC_DIR/$SRC"
+fi
+
+TMP="$TMP/$PACKAGE"
+
+if [ ! -d "$TMP" ]; then
+ mkdir -p $TMP
+fi
+
+cd $TMP
+
+tar xvf$tarflag $SRC_DIR/$SRC
+cd $PACKAGE-$VERSION
+
+python setup.py install --prefix=/usr
+
+CWD="`pwd`"
+
+mkdir /install
+
+cat << EOF > /install/slack-desc
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler-----------------------------------------------------|
+nicotine+: nicotine+ (soulseek client clone)
+nicotine+:
+nicotine+: Nicotine is a SoulSeek client written in Python, based on the
+nicotine+: PySoulSeek project by Alexander Kanavin. It features, among other
+nicotine+: things, a completely rewritten graphical user interface which uses
+nicotine+: the PyGTK-2 toolkit and a less strict user request policy.
+nicotine+:
+nicotine+: This version is the forked one distributed at
+nicotine+: http://nicotine-plus.sourceforge.net
+nicotine+:
+nicotine+:
+EOF
+
+# docs
+mkdir -p /usr/doc/$PACKAGE-$VERSION
+
+for file in COPYING MANIFEST; do
+ cp $CWD/$file* /usr/doc/$PACKAGE-$VERSION/
+done
+
+cp -R $CWD/docs/* /usr/doc/$PACKAGE-$VERSION/
+
diff --git a/nicotine/nicotine.build b/nicotine/nicotine.build
index e42c7180..74320861 100755
--- a/nicotine/nicotine.build
+++ b/nicotine/nicotine.build
@@ -19,7 +19,7 @@ fi
# default settings
PACKAGE="nicotine"
-VERSION=${VERSION:=1.2.4.1}
+VERSION=${VERSION:=1.0.8}
ARCH="noarch"
BUILD=${BUILD:=1rha}
SRC_DIR=${SRC:=$CWD}
@@ -27,8 +27,8 @@ TMP=${TMP:=/tmp}
RTOOL="wget"
PACKAGE_EXT="bz2"
-SRC="$PACKAGE+-$VERSION.tar.$PACKAGE_EXT"
-URL="http://easynews.dl.sourceforge.net/sourceforge/nicotine-plus/$SRC"
+SRC="$PACKAGE-$VERSION.tar.$PACKAGE_EXT"
+URL="http://nicotine.thegraveyard.org/$SRC"
SRC_DIR="$SRC_DIR/$PACKAGE"
@@ -55,7 +55,7 @@ fi
cd $TMP
tar xvf$tarflag $SRC_DIR/$SRC
-cd $PACKAGE+-$VERSION
+cd $PACKAGE-$VERSION
python setup.py install --prefix=/usr
@@ -79,8 +79,8 @@ nicotine: PySoulSeek project by Alexander Kanavin. It features, among other
nicotine: things, a completely rewritten graphical user interface which uses
nicotine: the PyGTK-2 toolkit and a less strict user request policy.
nicotine:
-nicotine: This version is the forked one distributed at
-nicotine: http://nicotine-plus.sourceforge.net
+nicotine:
+nicotine:
nicotine:
nicotine:
EOF
@@ -88,9 +88,7 @@ EOF
# docs
mkdir -p /usr/doc/$PACKAGE-$VERSION
-for file in COPYING MANIFEST; do
+for file in CHANGELOG COPYING INSTALL KNOWN_BUGS MAINTAINERS MANIFEST PKG-INFO README README.import-winconfig TODO TRANSLATORS; do
cp $CWD/$file* /usr/doc/$PACKAGE-$VERSION/
done
-cp -R $CWD/docs/* /usr/doc/$PACKAGE-$VERSION/
-