aboutsummaryrefslogtreecommitdiff
path: root/nicotine/nicotine.build
diff options
context:
space:
mode:
authorrudson <rudson@370017ae-e619-0410-ac65-c121f96126d4>2006-11-15 23:40:22 +0000
committerrudson <rudson@370017ae-e619-0410-ac65-c121f96126d4>2006-11-15 23:40:22 +0000
commitf6499eb8393ebb1de5ccefe4356053035b090acb (patch)
treeaeb4f93c59c39737a549fd5405881d4040c0db32 /nicotine/nicotine.build
parent4c047569a7fb213df74643e7e92d8b82be8f25c8 (diff)
downloadslackbuilds-f6499eb8393ebb1de5ccefe4356053035b090acb.tar.gz
slackbuilds-f6499eb8393ebb1de5ccefe4356053035b090acb.tar.bz2
movendo libs...
git-svn-id: svn+slack://slack.fluxo.info/var/svn/slackbuilds@685 370017ae-e619-0410-ac65-c121f96126d4
Diffstat (limited to 'nicotine/nicotine.build')
-rwxr-xr-xnicotine/nicotine.build94
1 files changed, 0 insertions, 94 deletions
diff --git a/nicotine/nicotine.build b/nicotine/nicotine.build
deleted file mode 100755
index 149062fd..00000000
--- a/nicotine/nicotine.build
+++ /dev/null
@@ -1,94 +0,0 @@
-#!/bin/bash
-#
-# build script for nicotine
-# by rhatto at riseup.net
-# build it with slacktrack, example:
-#
-# slacktrack -jefkzp "nicotine-1.2.4.1-noarch-1rha.tgz" "./nicotine.build"
-#
-
-CWD="`pwd`"
-
-if [ -f "/etc/slackbuildrc" ]; then
- source /etc/slackbuildrc
-fi
-
-if [ -f "~/.slackbuildrc" ]; then
- source ~/.slackbuildrc
-fi
-
-# default settings
-PACKAGE="nicotine"
-VERSION=${VERSION:=1.0.8}
-ARCH=${ARCH:=i486}
-BUILD=${BUILD:=1rha}
-SRC_DIR=${SRC:=$CWD}
-TMP=${TMP:=/tmp}
-
-RTOOL="wget"
-PACKAGE_EXT="bz2"
-SRC="$PACKAGE-$VERSION.tar.$PACKAGE_EXT"
-URL="http://nicotine.thegraveyard.org/$SRC"
-
-SRC_DIR="$SRC_DIR/$PACKAGE"
-
-if [ ! -d "$SRC_DIR" ]; then
- mkdir -p $SRC_DIR
-fi
-
-if [ "$PACKAGE_EXT" == "bz2" ]; then
- tarflag="j"
-else
- tarflag="z"
-fi
-
-if [ "$RTOOL" == "wget" ] && [ ! -f "$SRC_DIR/$SRC" ]; then
- wget "$URL" -O "$SRC_DIR/$SRC"
-fi
-
-TMP="$TMP/$PACKAGE"
-
-if [ ! -d "$TMP" ]; then
- mkdir -p $TMP
-fi
-
-cd $TMP
-
-tar xvf$tarflag $SRC_DIR/$SRC
-cd $PACKAGE-$VERSION
-
-python setup.py install --prefix=/usr
-
-CWD="`pwd`"
-
-mkdir /install
-
-cat << EOF > /install/slack-desc
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
-
- |-----handy-ruler-----------------------------------------------------|
-nicotine: nicotine (soulseek client clone)
-nicotine:
-nicotine: Nicotine is a SoulSeek client written in Python, based on the
-nicotine: PySoulSeek project by Alexander Kanavin. It features, among other
-nicotine: things, a completely rewritten graphical user interface which uses
-nicotine: the PyGTK-2 toolkit and a less strict user request policy.
-nicotine:
-nicotine:
-nicotine:
-nicotine:
-nicotine:
-EOF
-
-# docs
-mkdir -p /usr/doc/$PACKAGE-$VERSION
-
-for file in CHANGELOG COPYING INSTALL KNOWN_BUGS MAINTAINERS MANIFEST PKG-INFO README README.import-winconfig TODO TRANSLATORS; do
- cp $CWD/$file* /usr/doc/$PACKAGE-$VERSION/
-done
-