aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorrudson <rudson@370017ae-e619-0410-ac65-c121f96126d4>2006-11-15 23:40:22 +0000
committerrudson <rudson@370017ae-e619-0410-ac65-c121f96126d4>2006-11-15 23:40:22 +0000
commitf6499eb8393ebb1de5ccefe4356053035b090acb (patch)
treeaeb4f93c59c39737a549fd5405881d4040c0db32 /net
parent4c047569a7fb213df74643e7e92d8b82be8f25c8 (diff)
downloadslackbuilds-f6499eb8393ebb1de5ccefe4356053035b090acb.tar.gz
slackbuilds-f6499eb8393ebb1de5ccefe4356053035b090acb.tar.bz2
movendo libs...
git-svn-id: svn+slack://slack.fluxo.info/var/svn/slackbuilds@685 370017ae-e619-0410-ac65-c121f96126d4
Diffstat (limited to 'net')
-rwxr-xr-xnet/im/bitlbee/bitlbee.SlackBuild (renamed from net/chat/bitlbee/bitlbee.SlackBuild)0
-rw-r--r--net/im/bitlbee/slack-required (renamed from net/chat/bitlbee/slack-required)0
-rwxr-xr-xnet/im/ekiga/ekiga.SlackBuild (renamed from net/chat/ekiga/ekiga.SlackBuild)0
-rw-r--r--net/im/ekiga/slack-required (renamed from net/chat/ekiga/slack-required)0
-rwxr-xr-xnet/im/lirc/lirc.SlackBuild (renamed from net/chat/lirc/lirc.SlackBuild)0
-rwxr-xr-xnet/libs/opal/opal.SlackBuild111
-rw-r--r--net/libs/opal/slack-required1
-rwxr-xr-xnet/nds/openldap/openldap-client.SlackBuild123
-rwxr-xr-xnet/nds/openldap/openldap.SlackBuild135
-rwxr-xr-xnet/p2p/nicotine/nicotine+.SlackBuild30
-rwxr-xr-xnet/p2p/nicotine/nicotine+.build96
-rwxr-xr-xnet/p2p/nicotine/nicotine.SlackBuild42
-rwxr-xr-xnet/p2p/nicotine/nicotine.build94
-rw-r--r--net/p2p/nicotine/slack-required1
-rwxr-xr-xnet/www/nspluginwrapper/nspluginwrapper.SlackBuild121
15 files changed, 754 insertions, 0 deletions
diff --git a/net/chat/bitlbee/bitlbee.SlackBuild b/net/im/bitlbee/bitlbee.SlackBuild
index 47713be6..47713be6 100755
--- a/net/chat/bitlbee/bitlbee.SlackBuild
+++ b/net/im/bitlbee/bitlbee.SlackBuild
diff --git a/net/chat/bitlbee/slack-required b/net/im/bitlbee/slack-required
index 196e8fce..196e8fce 100644
--- a/net/chat/bitlbee/slack-required
+++ b/net/im/bitlbee/slack-required
diff --git a/net/chat/ekiga/ekiga.SlackBuild b/net/im/ekiga/ekiga.SlackBuild
index 0c43d9c6..0c43d9c6 100755
--- a/net/chat/ekiga/ekiga.SlackBuild
+++ b/net/im/ekiga/ekiga.SlackBuild
diff --git a/net/chat/ekiga/slack-required b/net/im/ekiga/slack-required
index df2d09b1..df2d09b1 100644
--- a/net/chat/ekiga/slack-required
+++ b/net/im/ekiga/slack-required
diff --git a/net/chat/lirc/lirc.SlackBuild b/net/im/lirc/lirc.SlackBuild
index 13268723..13268723 100755
--- a/net/chat/lirc/lirc.SlackBuild
+++ b/net/im/lirc/lirc.SlackBuild
diff --git a/net/libs/opal/opal.SlackBuild b/net/libs/opal/opal.SlackBuild
new file mode 100755
index 00000000..c9c495c3
--- /dev/null
+++ b/net/libs/opal/opal.SlackBuild
@@ -0,0 +1,111 @@
+#!/bin/bash
+#
+# slackbuild script for opal
+# by rafael at riseup.net
+#
+
+if [ -s "slack-required" ]; then
+ echo Recomended and required packages for building pwlib are:
+ cat slack-required | sed -e 's/^/\t/'
+ if [ "$INTERACT" != "no" ]; then
+ echo If you dont have those installed, press Ctrl-C. Otherwise, hit ENTER.
+ read crap
+# else
+# echo Sleeping 3 seconds...
+# sleep 3
+ fi
+fi
+
+CWD="`pwd`"
+
+if [ -f ~/.slackbuildrc ]; then
+ source ~/.slackbuildrc
+elif [ -f /etc/slackbuildrc ]; then
+ source /etc/slackbuildrc
+fi
+
+# default settings
+PACKAGE="opal"
+ARCH=${ARCH:=i486}
+VERSION=${VERSION:=2.2.3}
+BUILD=${BUILD:=1rd}
+SRC_DIR=${SRC:=$CWD}
+TMP=${TMP:=/tmp}
+REPOS=${REPOS:=$TMP}
+
+if [ "$ARCH" == "x86_64" ]; then
+ LIBDIR=/usr/lib64
+else
+ LIBDIR=/usr/lib
+fi
+
+RTOOL="wget"
+PACKAGE_EXT="gz"
+SRC="$PACKAGE-$VERSION.tar.$PACKAGE_EXT"
+URL="http://www.ekiga.org/admin/downloads/latest/sources/sources/$SRC"
+
+SRC_DIR="$SRC_DIR/$PACKAGE"
+mkdir -p $SRC_DIR
+
+if [ "$PACKAGE_EXT" == "bz2" ]; then
+ tarflag="j"
+else
+ tarflag="z"
+fi
+
+if [ "$RTOOL" == "wget" ] && [ ! -f "$SRC_DIR/$SRC" ]; then
+ wget "$URL" -O "$SRC_DIR/$SRC"
+fi
+
+TMP="$TMP/$PACKAGE"
+rm -rf $TMP
+mkdir -p $TMP
+cd $TMP
+
+tar xvf$tarflag $SRC_DIR/$SRC
+cd $PACKAGE-$VERSION
+
+if [ -f "$CWD/$PACKAGE-$VERSION.diff" ]; then
+ patch -p1 < $CWD/$PACKAGE-$VERSION.diff
+fi
+
+./configure --prefix=/usr --sysconfdir=/etc --libdir=$LIBDIR --with-docdir=/usr/doc/$PACKAGE-$VERSION
+make || exit 32
+make DESTDIR=$TMP/package-$PACKAGE install
+
+CWD="`pwd`"
+
+cd $TMP/package-$PACKAGE
+
+find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+
+mkdir install
+cat << EOF > install/slack-desc
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler-----------------------------------------------------|
+opal: opal (Opal is a library for VoIP protocols)
+opal:
+opal:
+opal:
+opal:
+opal:
+opal:
+opal:
+opal:
+opal:
+opal:
+EOF
+
+makepkg -c y -l y $REPOS/$PACKAGE-$VERSION-$ARCH-$BUILD.tgz
+
+if [ "$CLEANUP" == "yes" ]; then
+ rm -rf $TMP
+fi
+
diff --git a/net/libs/opal/slack-required b/net/libs/opal/slack-required
new file mode 100644
index 00000000..de907ed8
--- /dev/null
+++ b/net/libs/opal/slack-required
@@ -0,0 +1 @@
+pwlib
diff --git a/net/nds/openldap/openldap-client.SlackBuild b/net/nds/openldap/openldap-client.SlackBuild
new file mode 100755
index 00000000..b2e49184
--- /dev/null
+++ b/net/nds/openldap/openldap-client.SlackBuild
@@ -0,0 +1,123 @@
+#!/bin/bash
+#
+# slackbuild script for openldap-client
+#
+
+CWD="`pwd`"
+
+if [ -f ~/.slackbuildrc ]; then
+ source ~/.slackbuildrc
+elif [ -f /etc/slackbuildrc ]; then
+ source /etc/slackbuildrc
+fi
+
+# default settings
+PACKAGE="openldap-client"
+ARCH=${ARCH:=i486}
+VERSION=${VERSION:=2.3.24}
+BUILD=${BUILD:=2rha}
+SRC_DIR=${SRC:=$CWD}
+TMP=${TMP:=/tmp}
+REPOS=${REPOS:=$TMP}
+
+if [ "$ARCH" == "x86_64" ]; then
+ LIBDIR=/usr/lib64
+else
+ LIBDIR=/usr/lib
+fi
+
+RTOOL="wget"
+PACKAGE_EXT="tgz"
+SRC="$PACKAGE-$VERSION.tar.$PACKAGE_EXT"
+KEY="http://www.courier-mta.org/KEYS.bin"
+SRC="openldap-$VERSION.$PACKAGE_EXT"
+#URL="ftp://ftp.openldap.org/pub/OpenLDAP/openldap-release/$SRC"
+URL="http://public.planetmirror.com/pub/openldap/openldap-release/$SRC"
+
+if [ "$PACKAGE_EXT" == "bz2" ]; then
+ tarflag="j"
+else
+ tarflag="z"
+fi
+
+SRC_DIR="$SRC_DIR/openldap"
+mkdir -p $SRC_DIR
+
+if [ "$RTOOL" == "wget" ] && [ ! -f "$SRC_DIR/$SRC" ]; then
+ wget "$URL" -O "$SRC_DIR/$SRC"
+fi
+
+if [ "$ARCH" == "x86_64" ]; then
+ LIBDIR="/usr/lib64"
+else
+ LIBDIR="/usr/lib"
+fi
+
+TMP="$TMP/$PACKAGE"
+rm -rf $TMP
+mkdir -p $TMP
+cd $TMP
+
+tar xvf$tarflag $SRC_DIR/$SRC
+mv openldap-$VERSION $PACKAGE-$VERSION
+cd $PACKAGE-$VERSION
+
+./configure --prefix=/usr --sysconfdir=/etc --libdir=$LIBDIR --without-kerberos \
+ --without-cyrus-sasl --without-tls --without-threads --disable-slapd --disable-slurpd
+
+make depend
+make || exit 32
+make DESTDIR=$TMP/package-$PACKAGE install
+
+CWD="`pwd`"
+
+cd $TMP/package-$PACKAGE
+
+find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+
+mkdir install
+cat << EOF > install/slack-desc
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler-----------------------------------------------------|
+openldap-client: openldap-client (LDAP application client)
+openldap-client:
+openldap-client: The OpenLDAP Project is a collaborative effort to provide a robust,
+openldap-client: commercial-grade, fully featured, open source LDAP software suite.
+openldap-client: The project is managed by a worldwide community of volunteers that
+openldap-client: use the Internet to communicate, plan, and develop OpenLDAP Software
+openldap-client: and its related documentation. OpenLDAP Software provides a complete
+openldap-client: LDAP implementation including server, clients, C SDK, and associated
+openldap-client: tools.
+openldap-client:
+openldap-client:
+EOF
+
+# configs
+if [ -f "etc/openldap/ldap.conf" ]; then
+ mv etc/openldap/ldap.conf etc/openldap/ldap.conf.new
+fi
+
+if [ -f "etc/openldap/slapd.conf" ]; then
+ mv etc/openldap/slapd.conf etc/openldap/slapd.conf.new
+fi
+
+# docs
+mkdir -p usr/doc/$PACKAGE-$VERSION
+
+for file in ANNOUNCEMENT CHANGES COPYRIGHT INSTALL LICENSE README; do
+ cp $CWD/$file* usr/doc/$PACKAGE-$VERSION/
+done
+
+makepkg -c y -l y $REPOS/$PACKAGE-$VERSION-$ARCH-$BUILD.tgz
+
+if [ "$CLEANUP" == "yes" ]; then
+ rm -rf $TMP
+fi
+
diff --git a/net/nds/openldap/openldap.SlackBuild b/net/nds/openldap/openldap.SlackBuild
new file mode 100755
index 00000000..1cb6ee6c
--- /dev/null
+++ b/net/nds/openldap/openldap.SlackBuild
@@ -0,0 +1,135 @@
+#!/bin/bash
+#
+# slackbuild script for openldap
+# by rhatto at riseup.net
+#
+
+CWD="`pwd`"
+
+if [ -f ~/.slackbuildrc ]; then
+ source ~/.slackbuildrc
+elif [ -f /etc/slackbuildrc ]; then
+ source /etc/slackbuildrc
+fi
+
+# default settings
+PACKAGE="openldap"
+ARCH=${ARCH:=i486}
+VERSION=${VERSION:=2.3.24}
+BUILD=${BUILD:=1rha}
+SRC_DIR=${SRC:=$CWD}
+TMP=${TMP:=/tmp}
+REPOS=${REPOS:=$TMP}
+
+if [ "$ARCH" == "x86_64" ]; then
+ LIBDIR=/usr/lib64
+else
+ LIBDIR=/usr/lib
+fi
+
+RTOOL="wget"
+PACKAGE_EXT="tgz"
+SRC="$PACKAGE-$VERSION.tar.$PACKAGE_EXT"
+KEY="http://www.courier-mta.org/KEYS.bin"
+SRC="$PACKAGE-$VERSION.$PACKAGE_EXT"
+#URL="ftp://ftp.openldap.org/pub/OpenLDAP/openldap-release/$SRC"
+URL="http://public.planetmirror.com/pub/openldap/openldap-release/$SRC"
+
+if [ "$PACKAGE_EXT" == "bz2" ]; then
+ tarflag="j"
+else
+ tarflag="z"
+fi
+
+SRC_DIR="$SRC_DIR/$PACKAGE"
+mkdir -p $SRC_DIR
+
+if [ "$RTOOL" == "wget" ] && [ ! -f "$SRC_DIR/$SRC" ]; then
+ wget "$URL" -O "$SRC_DIR/$SRC"
+fi
+
+if [ "$ARCH" == "x86_64" ]; then
+ LIBDIR="/usr/lib64"
+else
+ LIBDIR="/usr/lib"
+fi
+
+TMP="$TMP/$PACKAGE"
+rm -rf $TMP
+mkdir -p $TMP
+cd $TMP
+
+tar xvf$tarflag $SRC_DIR/$SRC
+cd $PACKAGE-$VERSION
+
+# otherwise will not work
+DBINC="`ls -l /usr/include/db.h | awk '{ print $10 }'`"
+if [ ! -f "$DBINC" ]; then
+ cp /usr/include/db.h db.h.save
+fi
+
+ln -sf /usr/include/db4/db.h /usr/include/db.h
+
+./configure --prefix=/usr --sysconfdir=/etc --libdir=$LIBDIR
+make depend
+make || exit 32
+make DESTDIR=$TMP/package-$PACKAGE install
+
+# fix your system
+if [ ! -f "$DBINC" ]; then
+ cp db.h.save /usr/include/db.h
+else
+ ln -sf $DBINC /usr/include/db.h
+fi
+
+CWD="`pwd`"
+
+cd $TMP/package-$PACKAGE
+
+find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+
+mkdir install
+cat << EOF > install/slack-desc
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler-----------------------------------------------------|
+openldap: openldap (LDAP suite of applications and development tools)
+openldap:
+openldap: The OpenLDAP Project is a collaborative effort to provide a robust,
+openldap: commercial-grade, fully featured, open source LDAP software suite.
+openldap: The project is managed by a worldwide community of volunteers that
+openldap: use the Internet to communicate, plan, and develop OpenLDAP Software
+openldap: and its related documentation. OpenLDAP Software provides a complete
+openldap: LDAP implementation including server, clients, C SDK, and associated
+openldap: tools.
+openldap:
+openldap:
+EOF
+
+# configs
+mv etc/openldap/ldap.conf etc/openldap/ldap.conf.new
+mv etc/openldap/slapd.conf etc/openldap/slapd.conf.new
+
+# docs
+mkdir -p usr/doc/$PACKAGE-$VERSION
+
+for file in ANNOUNCEMENT CHANGES COPYRIGHT INSTALL LICENSE README; do
+ cp $CWD/$file* usr/doc/$PACKAGE-$VERSION/
+done
+
+# install script
+echo '( if [ ! -f "etc/openldap/ldap.conf" ]; then mv etc/openldap/ldap.conf.new etc/openldap/ldap.conf; fi )' > install/doinst.sh
+echo '( if [ ! -f "etc/openldap/slapd.conf" ]; then mv etc/openldap/slapd.conf.new etc/openldap/slapd.conf; fi )' >> install/doinst.sh
+
+makepkg -c y -l y $REPOS/$PACKAGE-$VERSION-$ARCH-$BUILD.tgz
+
+if [ "$CLEANUP" == "yes" ]; then
+ rm -rf $TMP
+fi
+
diff --git a/net/p2p/nicotine/nicotine+.SlackBuild b/net/p2p/nicotine/nicotine+.SlackBuild
new file mode 100755
index 00000000..0da0eac9
--- /dev/null
+++ b/net/p2p/nicotine/nicotine+.SlackBuild
@@ -0,0 +1,30 @@
+#!/bin/bash
+#
+# SlackBuild script to call nicotine+.build with correct settings
+#
+
+CWD="`pwd`"
+
+if [ -f ~/.slackbuildrc ]; then
+ source ~/.slackbuildrc
+elif [ -f /etc/slackbuildrc ]; then
+ source /etc/slackbuildrc
+fi
+
+# default settings
+PACKAGE="nicotine+"
+VERSION=${VERSION:=1.2.4.1}
+ARCH="noarch"
+BUILD=${BUILD:=1rha}
+SRC_DIR=${SRC:=$CWD}
+TMP=${TMP:=/tmp}
+REPOS=${REPOS:=$TMP}
+
+rm -rf $TMP/$PACKAGE
+mkdir -p $SRC_DIR/$PACKAGE $TMP/$PACKAGE $REPOS
+
+slacktrack -b $REPOS -x $TMP,$SRC_DIR,/dev -jefkzp "$PACKAGE-$VERSION-$ARCH-$BUILD.tgz" "./$PACKAGE.build"
+
+if [ "$CLEANUP" == "yes" ]; then
+ rm -rf $TMP/$PACKAGE
+fi
diff --git a/net/p2p/nicotine/nicotine+.build b/net/p2p/nicotine/nicotine+.build
new file mode 100755
index 00000000..12a6c58a
--- /dev/null
+++ b/net/p2p/nicotine/nicotine+.build
@@ -0,0 +1,96 @@
+#!/bin/bash
+#
+# build script for nicotine+
+# by rhatto at riseup.net
+# build it with slacktrack, example:
+#
+# slacktrack -jefkzp "nicotine+-1.2.4.1-noarch-1rha.tgz" "./nicotine+.build"
+#
+
+CWD="`pwd`"
+
+if [ -f "/etc/slackbuildrc" ]; then
+ source /etc/slackbuildrc
+fi
+
+if [ -f "~/.slackbuildrc" ]; then
+ source ~/.slackbuildrc
+fi
+
+# default settings
+PACKAGE="nicotine+"
+VERSION=${VERSION:=1.2.4.1}
+ARCH="noarch"
+BUILD=${BUILD:=1rha}
+SRC_DIR=${SRC:=$CWD}
+TMP=${TMP:=/tmp}
+
+RTOOL="wget"
+PACKAGE_EXT="bz2"
+SRC="$PACKAGE-$VERSION.tar.$PACKAGE_EXT"
+URL="http://easynews.dl.sourceforge.net/sourceforge/nicotine-plus/$SRC"
+
+SRC_DIR="$SRC_DIR/$PACKAGE"
+
+if [ ! -d "$SRC_DIR" ]; then
+ mkdir -p $SRC_DIR
+fi
+
+if [ "$PACKAGE_EXT" == "bz2" ]; then
+ tarflag="j"
+else
+ tarflag="z"
+fi
+
+if [ "$RTOOL" == "wget" ] && [ ! -f "$SRC_DIR/$SRC" ]; then
+ wget "$URL" -O "$SRC_DIR/$SRC"
+fi
+
+TMP="$TMP/$PACKAGE"
+
+if [ ! -d "$TMP" ]; then
+ mkdir -p $TMP
+fi
+
+cd $TMP
+
+tar xvf$tarflag $SRC_DIR/$SRC
+cd $PACKAGE-$VERSION
+
+python setup.py install --prefix=/usr
+
+CWD="`pwd`"
+
+mkdir /install
+
+cat << EOF > /install/slack-desc
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler-----------------------------------------------------|
+nicotine+: nicotine+ (soulseek client clone)
+nicotine+:
+nicotine+: Nicotine is a SoulSeek client written in Python, based on the
+nicotine+: PySoulSeek project by Alexander Kanavin. It features, among other
+nicotine+: things, a completely rewritten graphical user interface which uses
+nicotine+: the PyGTK-2 toolkit and a less strict user request policy.
+nicotine+:
+nicotine+: This version is the forked one distributed at
+nicotine+: http://nicotine-plus.sourceforge.net
+nicotine+:
+nicotine+:
+EOF
+
+# docs
+mkdir -p /usr/doc/$PACKAGE-$VERSION
+
+for file in COPYING MANIFEST; do
+ cp $CWD/$file* /usr/doc/$PACKAGE-$VERSION/
+done
+
+cp -R $CWD/docs/* /usr/doc/$PACKAGE-$VERSION/
+
diff --git a/net/p2p/nicotine/nicotine.SlackBuild b/net/p2p/nicotine/nicotine.SlackBuild
new file mode 100755
index 00000000..aa1250d2
--- /dev/null
+++ b/net/p2p/nicotine/nicotine.SlackBuild
@@ -0,0 +1,42 @@
+#!/bin/bash
+#
+# SlackBuild script to call nicotine.build with correct settings
+#
+
+if [ -s "slack-required" ]; then
+ echo Recomended and required packages for building nicotine are:
+ cat slack-required | sed -e 's/^/\t/'
+ if [ "$INTERACT" != "no" ]; then
+ echo If you dont have those installed, press Ctrl-C. Otherwise, hit ENTER.
+ read crap
+# else
+# echo Sleeping 3 seconds...
+# sleep 3
+ fi
+fi
+
+CWD="`pwd`"
+
+if [ -f ~/.slackbuildrc ]; then
+ source ~/.slackbuildrc
+elif [ -f /etc/slackbuildrc ]; then
+ source /etc/slackbuildrc
+fi
+
+# default settings
+PACKAGE="nicotine"
+VERSION=${VERSION:=1.0.8}
+ARCH=${ARCH:=i486}
+BUILD=${BUILD:=1rha}
+SRC_DIR=${SRC:=$CWD}
+TMP=${TMP:=/tmp}
+REPOS=${REPOS:=$TMP}
+
+rm -rf $TMP/$PACKAGE
+mkdir -p $SRC_DIR/$PACKAGE $TMP/$PACKAGE $REPOS
+
+slacktrack -b $REPOS -x $TMP,$SRC_DIR,/dev -jefkzp "$PACKAGE-$VERSION-$ARCH-$BUILD.tgz" "./$PACKAGE.build"
+
+if [ "$CLEANUP" == "yes" ]; then
+ rm -rf $TMP/$PACKAGE
+fi
diff --git a/net/p2p/nicotine/nicotine.build b/net/p2p/nicotine/nicotine.build
new file mode 100755
index 00000000..149062fd
--- /dev/null
+++ b/net/p2p/nicotine/nicotine.build
@@ -0,0 +1,94 @@
+#!/bin/bash
+#
+# build script for nicotine
+# by rhatto at riseup.net
+# build it with slacktrack, example:
+#
+# slacktrack -jefkzp "nicotine-1.2.4.1-noarch-1rha.tgz" "./nicotine.build"
+#
+
+CWD="`pwd`"
+
+if [ -f "/etc/slackbuildrc" ]; then
+ source /etc/slackbuildrc
+fi
+
+if [ -f "~/.slackbuildrc" ]; then
+ source ~/.slackbuildrc
+fi
+
+# default settings
+PACKAGE="nicotine"
+VERSION=${VERSION:=1.0.8}
+ARCH=${ARCH:=i486}
+BUILD=${BUILD:=1rha}
+SRC_DIR=${SRC:=$CWD}
+TMP=${TMP:=/tmp}
+
+RTOOL="wget"
+PACKAGE_EXT="bz2"
+SRC="$PACKAGE-$VERSION.tar.$PACKAGE_EXT"
+URL="http://nicotine.thegraveyard.org/$SRC"
+
+SRC_DIR="$SRC_DIR/$PACKAGE"
+
+if [ ! -d "$SRC_DIR" ]; then
+ mkdir -p $SRC_DIR
+fi
+
+if [ "$PACKAGE_EXT" == "bz2" ]; then
+ tarflag="j"
+else
+ tarflag="z"
+fi
+
+if [ "$RTOOL" == "wget" ] && [ ! -f "$SRC_DIR/$SRC" ]; then
+ wget "$URL" -O "$SRC_DIR/$SRC"
+fi
+
+TMP="$TMP/$PACKAGE"
+
+if [ ! -d "$TMP" ]; then
+ mkdir -p $TMP
+fi
+
+cd $TMP
+
+tar xvf$tarflag $SRC_DIR/$SRC
+cd $PACKAGE-$VERSION
+
+python setup.py install --prefix=/usr
+
+CWD="`pwd`"
+
+mkdir /install
+
+cat << EOF > /install/slack-desc
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler-----------------------------------------------------|
+nicotine: nicotine (soulseek client clone)
+nicotine:
+nicotine: Nicotine is a SoulSeek client written in Python, based on the
+nicotine: PySoulSeek project by Alexander Kanavin. It features, among other
+nicotine: things, a completely rewritten graphical user interface which uses
+nicotine: the PyGTK-2 toolkit and a less strict user request policy.
+nicotine:
+nicotine:
+nicotine:
+nicotine:
+nicotine:
+EOF
+
+# docs
+mkdir -p /usr/doc/$PACKAGE-$VERSION
+
+for file in CHANGELOG COPYING INSTALL KNOWN_BUGS MAINTAINERS MANIFEST PKG-INFO README README.import-winconfig TODO TRANSLATORS; do
+ cp $CWD/$file* /usr/doc/$PACKAGE-$VERSION/
+done
+
diff --git a/net/p2p/nicotine/slack-required b/net/p2p/nicotine/slack-required
new file mode 100644
index 00000000..d01ef22f
--- /dev/null
+++ b/net/p2p/nicotine/slack-required
@@ -0,0 +1 @@
+pygtk
diff --git a/net/www/nspluginwrapper/nspluginwrapper.SlackBuild b/net/www/nspluginwrapper/nspluginwrapper.SlackBuild
new file mode 100755
index 00000000..59102127
--- /dev/null
+++ b/net/www/nspluginwrapper/nspluginwrapper.SlackBuild
@@ -0,0 +1,121 @@
+#!/bin/bash
+#
+# slackbuild script for nspluginwrapper
+# by rhatto at riseup.net
+#
+
+if [ -s "slack-required" ]; then
+ echo Recomended and required packages for building nspluginwrapper are:
+ cat slack-required | sed -e 's/^/\t/'
+ if [ "$INTERACT" != "no" ]; then
+ echo If you dont have those installed, press Ctrl-C. Otherwise, hit ENTER.
+ read crap
+# else
+# echo Sleeping 3 seconds...
+# sleep 3
+ fi
+fi
+
+CWD="`pwd`"
+
+if [ -f ~/.slackbuildrc ]; then
+ source ~/.slackbuildrc
+elif [ -f /etc/slackbuildrc ]; then
+ source /etc/slackbuildrc
+fi
+
+# default settings
+PACKAGE="nspluginwrapper"
+ARCH=${ARCH:=i486}
+VERSION=${VERSION:=0.9.90.1}
+BUILD=${BUILD:=1rha}
+SRC_DIR=${SRC:=$CWD}
+TMP=${TMP:=/tmp}
+REPOS=${REPOS:=$TMP}
+
+if [ "$ARCH" == "x86_64" ]; then
+ export LDFLAGS="-L/lib64 -L/usr/lib64"
+ LIBDIR=/usr/lib64
+else
+ LIBDIR=/usr/lib
+fi
+
+# ------- error codes for createpkg --------------
+ERROR_WGET=31; ERROR_MAKE=32; ERROR_INSTALL=33
+ERROR_MD5=34; ERROR_CONF=35; ERROR_HELP=36
+ERROR_TAR=37; ERROR_MKPKG=38; ERROR_GPG=39
+ERROR_PATCH=40
+
+RTOOL="wget"
+PACKAGE_EXT="bz2"
+SRC="$PACKAGE-$VERSION.tar.$PACKAGE_EXT"
+URL="http://www.gibix.net/projects/nspluginwrapper/files/$SRC"
+
+SRC_DIR="$SRC_DIR/$PACKAGE"
+mkdir -p $SRC_DIR
+
+if [ "$RTOOL" == "wget" ] && [ ! -f "$SRC_DIR/$SRC" ]; then
+ wget "$URL" -O "$SRC_DIR/$SRC" || exit $ERROR_WGET
+fi
+
+TMP="$TMP/$PACKAGE"
+rm -rf $TMP
+mkdir -p $TMP
+cd $TMP
+
+tar xvf $SRC_DIR/$SRC || exit $ERROR_TAR
+cd $PACKAGE-$VERSION
+
+if [ -f "$CWD/$PACKAGE-$VERSION.diff" ]; then
+ patch -p1 < $CWD/$PACKAGE-$VERSION.diff || exit $ERROR_PATCH
+fi
+
+./configure --prefix=/usr --with-lib=$LIBDIR || exit $ERROR_CONF
+make || exit $ERROR_MAKE
+make DESTDIR=$TMP/package-$PACKAGE install || exit $ERROR_INSTALL
+
+CWD="`pwd`"
+
+cd $TMP/package-$PACKAGE
+
+find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+
+mkdir install
+cat << EOF > install/slack-desc
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler-----------------------------------------------------|
+nspluginwrapper: nspluginwrapper
+nspluginwrapper:
+nspluginwrapper: nspluginwrapper is an Open Source compatibility plugin for Netscape
+nspluginwrapper: 4 (NPAPI) plugins. That is, it enables you to use plugins on
+nspluginwrapper: platforms they were not built for. For example, you can use the
+nspluginwrapper: Adobe Flash plugin with x86-64 compiled Mozilla browsers.
+nspluginwrapper:
+nspluginwrapper:
+nspluginwrapper:
+nspluginwrapper:
+nspluginwrapper:
+EOF
+
+# docs
+mkdir -p usr/doc/$PACKAGE-$VERSION
+
+DOCS="COPYING NEWS README TODO"
+
+for file in $DOCS; do
+ cp $CWD/$file* usr/doc/$PACKAGE-$VERSION/
+done
+
+makepkg -c y -l y $REPOS/$PACKAGE-$VERSION-$ARCH-$BUILD.tgz || exit $ERROR_MKPKG
+
+if [ "$CLEANUP" == "yes" ]; then
+ rm -rf $TMP
+fi
+