aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorrhatto <rhatto@370017ae-e619-0410-ac65-c121f96126d4>2009-03-03 00:11:18 +0000
committerrhatto <rhatto@370017ae-e619-0410-ac65-c121f96126d4>2009-03-03 00:11:18 +0000
commit9eeb7aa29c3696501ea471252538ed0cff492ff3 (patch)
treecb9d3ff9b238ec7ae10bee066e5f7cca7db11b4c /net
parente005cb997e20f02356bd1658c1c3a0cbd8fe296e (diff)
downloadslackbuilds-9eeb7aa29c3696501ea471252538ed0cff492ff3.tar.gz
slackbuilds-9eeb7aa29c3696501ea471252538ed0cff492ff3.tar.bz2
nicotine+: removing wrong SlackBuild
git-svn-id: svn+slack://slack.fluxo.info/var/svn/slackbuilds@2114 370017ae-e619-0410-ac65-c121f96126d4
Diffstat (limited to 'net')
-rw-r--r--net/p2p/nicotine+/nicotine%2B.SlackBuild212
1 files changed, 0 insertions, 212 deletions
diff --git a/net/p2p/nicotine+/nicotine%2B.SlackBuild b/net/p2p/nicotine+/nicotine%2B.SlackBuild
deleted file mode 100644
index 67ba11e0..00000000
--- a/net/p2p/nicotine+/nicotine%2B.SlackBuild
+++ /dev/null
@@ -1,212 +0,0 @@
-#!/bin/bash
-#
-# nicotine%2B.SlackBuild is free software; you can redistribute
-# it and/or modify it under the terms of the GNU General Public License as
-# published by the Free Software Foundation; either version 2 of the License,
-# or any later version.
-#
-# nicotine%2B.SlackBuild is distributed in the hope that it will
-# be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General
-# Public License for more details.
-#
-# You should have received a copy of the GNU General Public License along
-# with this program; if not, write to the Free Software Foundation, Inc.,
-# 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA
-#
-# slackbuild for nicotine%2B, by Silvio Rhatto
-# requires:
-# tested: nicotine%2B-1.2.10
-# model: generic.mkSlackBuild $Rev: 784 $
-#
-
-# Look for slackbuildrc
-if [ -f ~/.slackbuildrc ]; then
- source ~/.slackbuildrc
-elif [ -f /etc/slackbuildrc ]; then
- source /etc/slackbuildrc
-fi
-
-# Set variables
-CWD="$(pwd)"
-SRC_NAME="nicotine%2B"
-PKG_NAME="nicotine%2B"
-ARCH=${ARCH:=i486}
-SRC_VERSION=${VERSION:=1.2.10}
-PKG_VERSION="$(echo "$SRC_VERSION" | tr '[[:blank:]-]' '_')"
-BUILD=${BUILD:=1rha}
-SRC_DIR=${SRC_DIR:=$CWD}/$PKG_NAME
-TMP=${TMP:=/tmp}
-PKG=${PKG:=$TMP/package-$PKG_NAME}
-REPOS=${REPOS:=$TMP}
-PREFIX=${PREFIX:=/usr}
-PKG_WORK="$TMP/$SRC_NAME"
-CONF_OPTIONS=${CONF_OPTIONS:=""}
-NUMJOBS=${NUMJOBS:=""}
-
-# Set system libraries' path and optmization flags based on $ARCH
-LIBDIR="$PREFIX/lib"
-
-if [ "$ARCH" = "i386" ]; then
- SLKCFLAGS="-O2 -march=i386 -mtune=i686"
-elif [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686"
-elif [ "$ARCH" = "s390" ]; then
- SLKCFLAGS="-O2"
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIR="$PREFIX/lib64"
- LDFLAGS="-L/lib64 -L/usr/lib64"
-fi
-
-# Set error codes (used by createpkg)
-ERROR_WGET=31; ERROR_MAKE=32; ERROR_INSTALL=33
-ERROR_MD5=34; ERROR_CONF=35; ERROR_HELP=36
-ERROR_TAR=37; ERROR_MKPKG=38; ERROR_GPG=39
-ERROR_PATCH=40; ERROR_VCS=41; ERROR_MKDIR=42
-ERROR_MANIFEST=43;
-
-# Clean up any leftovers of previous builds
-rm -rf "$PKG_WORK" 2> /dev/null
-rm -rf "$PKG" 2> /dev/null
-
-# Create directories if necessary
-mkdir -p "$SRC_DIR" || exit $ERROR_MKDIR
-mkdir -p "$PKG" || exit $ERROR_MKDIR
-mkdir -p "$REPOS" || exit $ERROR_MKDIR
-mkdir -p "$PKG_WORK" || exit $ERROR_MKDIR
-
-# Dowload source if necessary
-SRC="$SRC_NAME-$VERSION.tar.bz2"
-URL="http://www.nicotine-plus.org/files/$SRC"
-
-if [ ! -s "$SRC_DIR/$SRC" ] || ! bunzip2 -t "$SRC_DIR/$SRC" 2> /dev/null; then
- wget "$URL" -O "$SRC_DIR/$SRC" || exit $ERROR_WGET
-fi
-
-# Check Manifest file
-if [ -e "$CWD/Manifest" ]; then
-
- # Manifest signature checking
- if grep -q -- "-----BEGIN PGP SIGNED MESSAGE-----" $CWD/Manifest; then
- echo "Checking Manifest signature..."
- gpg --verify $CWD/Manifest
- if [ "$?" != "0" ]; then
- exit $ERROR_MANIFEST
- fi
- fi
-
- MANIFEST_LINES="`grep -E -v "^(MKBUILD|SLACKBUILD)" $CWD/Manifest | wc -l`"
-
- for ((MANIFEST_COUNT=1; MANIFEST_COUNT <= $MANIFEST_LINES; MANIFEST_COUNT++)); do
-
- MANIFEST_LINE="`grep -E -v "^(MKBUILD|SLACKBUILD)" $CWD/Manifest | head -n $MANIFEST_COUNT | tail -n 1`"
- MANIFEST_FILE="`echo $MANIFEST_LINE | awk '{ print $2 }'`"
- MANIFEST_FILE_TYPE="`echo $MANIFEST_LINE | awk '{ print $1 }'`"
-
- if [ -e "$SRC_DIR/$MANIFEST_FILE" ]; then
- MANIFEST_FILE="$SRC_DIR/$MANIFEST_FILE"
- else
- MANIFEST_FILE="`find $CWD -name $MANIFEST_FILE`"
- fi
-
- if [ ! -e "$MANIFEST_FILE" ] || [ -d "$MANIFEST_FILE" ]; then
- continue
- fi
-
- echo "Checking Manifest for $MANIFEST_FILE_TYPE $MANIFEST_FILE integrity..."
-
- SIZE_SRC="`wc -c $MANIFEST_FILE | awk '{ print $1 }'`"
- SIZE_MANIFEST="`echo $MANIFEST_LINE | awk '{ print $3 }'`"
-
- # Check source code size
- if [ "$SIZE_SRC" != "$SIZE_MANIFEST" ]; then
- echo "SIZE Manifest: $SIZE_MANIFEST; SIZE $SRC: $SIZE_SRC"
- exit $ERROR_MANIFEST
- else
- echo "Size match."
- fi
-
- # Check source code integrity
- for ALGO in md5 rmd160 sha1 sha256 sha512; do
- if [ $ALGO = "rmd160" ]; then
- ALGO_SRC="`openssl rmd160 $MANIFEST_FILE | awk '{ print $2 }'`"
- else
- ALGO_SRC="`"$ALGO"sum $MANIFEST_FILE | awk '{ print $1 }'`"
- fi
- ALGO="`echo $ALGO | tr '[:lower:]' '[:upper:]'`"
- ALGO_MANIFEST=$(echo $MANIFEST_LINE | sed "s/.* $ALGO //" | awk '{ print $1 }')
- if [ "$ALGO_SRC" != "$ALGO_MANIFEST" ]; then
- echo "$ALGO Manifest: $ALGO_MANIFEST; $ALGO $SRC: $ALGO_SRC"
- exit $ERROR_MANIFEST
- else
- echo "$ALGO match."
- fi
- done
-
- done
-
-else
- exit $ERROR_MANIFEST
-fi
-
-# Untar
-cd "$PKG_WORK"
-tar --no-same-owner --no-same-permissions -xvf "$SRC_DIR/$SRC" || exit $ERROR_TAR
-PKG_SRC="$PWD/`ls -l | awk '/^d/ { print $NF }'`"
-cd "$PKG_SRC"
-
-# Build and install package
-python setup.py build install --root=$PKG
-
-# Strip binaries
-( cd "$PKG"
- find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
- xargs strip --strip-unneeded 2> /dev/null
- find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
- xargs strip --strip-unneeded 2> /dev/null
-)
-
-# Install documentation
-DOCS="COPYING MANIFEST"
-mkdir -p "$PKG/usr/doc/$PKG_NAME-$PKG_VERSION" || exit $ERROR_MKDIR
-for doc in $DOCS; do
- if [ -f "$doc" ]; then
- cp -a $doc "$PKG/usr/doc/$PKG_NAME-$PKG_VERSION"
- fi
-done
-
-# Add package description (slack-desc)
-mkdir -p "$PKG/install" || exit $ERROR_MKDIR
-cat << EODESC > "$PKG/install/slack-desc"
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
-
- % |-----handy-ruler--------------------------------------------------|
-nicotine+: nicotine+ (soulseek client clone)
-nicotine+:
-nicotine+: Nicotine is a SoulSeek client written in Python, based on the
-nicotine+: PySoulSeek project by Alexander Kanavin. It features, among other
-nicotine+: things, a completely rewritten graphical user interface which uses
-nicotine+: the PyGTK-2 toolkit and a less strict user request policy.
-nicotine+:
-nicotine+: This version is the forked one distributed at
-nicotine+: http://nicotine-plus.sourceforge.net
-nicotine+:
-nicotine+:
-EODESC
-
-# Build the package
-cd "$PKG"
-makepkg -l y -c n "$REPOS/$PKG_NAME-$PKG_VERSION-$ARCH-$BUILD.tgz" || exit $ERROR_MKPKG
-
-# Delete source and build directories if requested
-if [ "$CLEANUP" == "yes" ] || [ "$1" = "--cleanup" ]; then
- rm -rf "$PKG_WORK" "$PKG"
-fi