aboutsummaryrefslogtreecommitdiff
path: root/net/www
diff options
context:
space:
mode:
authorrafael2k <rafael2k@370017ae-e619-0410-ac65-c121f96126d4>2007-02-26 19:50:14 +0000
committerrafael2k <rafael2k@370017ae-e619-0410-ac65-c121f96126d4>2007-02-26 19:50:14 +0000
commit29dbda7d6ee5e74b1b17692a69c11820b24aed84 (patch)
tree2147ab56ecfffc7b0407ba7f8153a718dc3681fb /net/www
parent0b57714c533ac2a33065e85bfbfef6733861092c (diff)
downloadslackbuilds-29dbda7d6ee5e74b1b17692a69c11820b24aed84.tar.gz
slackbuilds-29dbda7d6ee5e74b1b17692a69c11820b24aed84.tar.bz2
more location fixes
git-svn-id: svn+slack://slack.fluxo.info/var/svn/slackbuilds@1062 370017ae-e619-0410-ac65-c121f96126d4
Diffstat (limited to 'net/www')
-rwxr-xr-xnet/www/downtube/downtube.SlackBuild30
-rwxr-xr-xnet/www/downtube/downtube.build97
2 files changed, 127 insertions, 0 deletions
diff --git a/net/www/downtube/downtube.SlackBuild b/net/www/downtube/downtube.SlackBuild
new file mode 100755
index 00000000..bd9eb96f
--- /dev/null
+++ b/net/www/downtube/downtube.SlackBuild
@@ -0,0 +1,30 @@
+#!/bin/bash
+#
+# SlackBuild script to call downtube.build with correct settings
+#
+
+CWD="`pwd`"
+
+if [ -f ~/.slackbuildrc ]; then
+ source ~/.slackbuildrc
+elif [ -f /etc/slackbuildrc ]; then
+ source /etc/slackbuildrc
+fi
+
+# default settings
+PACKAGE="downtube"
+VERSION=${VERSION:=1.2}
+ARCH="noarch"
+BUILD=${BUILD:=1rha}
+SRC_DIR=${SRC:=$CWD}
+TMP=${TMP:=/tmp}
+REPOS=${REPOS:=$TMP}
+
+rm -rf $TMP/$PACKAGE
+mkdir -p $SRC_DIR/$PACKAGE $TMP/$PACKAGE
+
+slacktrack -b $REPOS -x $TMP,$SRC_DIR,/dev -jefkzp "$PACKAGE-$VERSION-$ARCH-$BUILD.tgz" "./$PACKAGE.build"
+
+if [ "$CLEANUP" == "yes" ]; then
+ rm -rf $TMP/$PACKAGE
+fi
diff --git a/net/www/downtube/downtube.build b/net/www/downtube/downtube.build
new file mode 100755
index 00000000..0d537552
--- /dev/null
+++ b/net/www/downtube/downtube.build
@@ -0,0 +1,97 @@
+#!/bin/bash
+#
+# build script for downtube
+# by rhatto at riseup.net
+# build it with slacktrack, example:
+#
+# slacktrack -jefkzp "downtube-1.2-noarch-1rha.tgz" "./downtube.build"
+#
+
+CWD="`pwd`"
+
+if [ -f "/etc/slackbuildrc" ]; then
+ source /etc/slackbuildrc
+fi
+
+if [ -f "~/.slackbuildrc" ]; then
+ source ~/.slackbuildrc
+fi
+
+# default settings
+PACKAGE="downtube"
+VERSION=${VERSION:=1.2}
+ARCH="noarch"
+BUILD=${BUILD:=1rha}
+SRC_DIR=${SRC:=$CWD}
+TMP=${TMP:=/tmp}
+
+RTOOL="wget"
+PACKAGE_EXT="gz"
+SRC="$PACKAGE-$VERSION.tar.$PACKAGE_EXT"
+URL="http://codigolivre.org.br/frs/download.php/5174/$SRC"
+
+SRC_DIR="$SRC_DIR/$PACKAGE"
+
+if [ ! -d "$SRC_DIR" ]; then
+ mkdir -p $SRC_DIR
+fi
+
+if [ "$PACKAGE_EXT" == "bz2" ]; then
+ tarflag="j"
+else
+ tarflag="z"
+fi
+
+if [ "$RTOOL" == "wget" ] && [ ! -f "$SRC_DIR/$SRC" ]; then
+ wget "$URL" -O "$SRC_DIR/$SRC"
+fi
+
+TMP="$TMP/$PACKAGE"
+
+if [ ! -d "$TMP" ]; then
+ mkdir -p $TMP
+fi
+
+cd $TMP
+
+tar xvf$tarflag $SRC_DIR/$SRC
+cd $PACKAGE-$VERSION
+
+python setup.py install
+
+CWD="`pwd`"
+
+mkdir /install
+
+cat << EOF > /install/slack-desc
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler-----------------------------------------------------|
+downtube: downtube: youtube.com video downloader and converter.
+downtube:
+downtube:
+downtube:
+downtube:
+downtube:
+downtube:
+downtube:
+downtube:
+downtube:
+downtube:
+EOF
+
+# docs
+mkdir -p /usr/doc/$PACKAGE-$VERSION
+
+for file in AUTHORS COPYING ChangeLog FAQ INSTALL README TODO; do
+ cp $CWD/$file* /usr/doc/$PACKAGE-$VERSION/
+done
+
+if [ "$CLEANUP" == "yes" ]; then
+ rm -rf $TMP
+fi