aboutsummaryrefslogtreecommitdiff
path: root/net/im
diff options
context:
space:
mode:
authorrafael2k <rafael2k@370017ae-e619-0410-ac65-c121f96126d4>2008-03-28 23:19:51 +0000
committerrafael2k <rafael2k@370017ae-e619-0410-ac65-c121f96126d4>2008-03-28 23:19:51 +0000
commit41a944e803acf119ec188a2b4bc3af74d18d39a5 (patch)
tree44cc93f3441329fd064e7baa45c1193e96602f78 /net/im
parent0ef4cd7bd84b6edad90348fc42b6d296109a850a (diff)
downloadslackbuilds-41a944e803acf119ec188a2b4bc3af74d18d39a5.tar.gz
slackbuilds-41a944e803acf119ec188a2b4bc3af74d18d39a5.tar.bz2
ekiga fixes
git-svn-id: svn+slack://slack.fluxo.info/var/svn/slackbuilds@1685 370017ae-e619-0410-ac65-c121f96126d4
Diffstat (limited to 'net/im')
-rw-r--r--net/im/ekiga/ekiga-2.0.12.diff53
-rwxr-xr-xnet/im/ekiga/ekiga.SlackBuild12
-rw-r--r--net/im/ekiga/slack-required2
3 files changed, 48 insertions, 19 deletions
diff --git a/net/im/ekiga/ekiga-2.0.12.diff b/net/im/ekiga/ekiga-2.0.12.diff
index 25c9468a..e38a8297 100644
--- a/net/im/ekiga/ekiga-2.0.12.diff
+++ b/net/im/ekiga/ekiga-2.0.12.diff
@@ -1,16 +1,41 @@
---- configure.in.orig 2008-03-25 16:19:32.000000000 -0300
-+++ configure.in 2008-03-25 16:07:12.000000000 -0300
-@@ -58,10 +58,10 @@
- fi
+#! /bin/sh /usr/share/dpatch/dpatch-run
+## gnome-free-gdu.dpatch by Kilian Krause <kilian@debian.org>
+##
+## All lines beginning with `## DP:' are a description of the patch.
+## DP: backport from trunk to make gnome-autogen.sh happy
+
+@DPATCH@
+diff -urNad ekiga-2.0.11~/configure.in ekiga-2.0.11/configure.in
+--- ekiga-2.0.11~/configure.in 2007-09-18 09:38:25.000000000 +0000
++++ ekiga-2.0.11/configure.in 2007-10-06 18:11:37.000000000 +0000
+@@ -219,6 +219,30 @@
+ libname="lib"
+ ;;
+ esac
++dnl ###############################
++dnl Gnome-Doc-Utils
++dnl ###############################
++GDU="disabled"
++if test "x${gm_platform}" != "xmingw" ; then
++ AC_ARG_ENABLE(gdu, [ --disable-gdu Disable GNOME-Doc-Utils support],,enable_gdu=yes)
++
++ if test "x$enable_gdu" = "xyes"; then
++GNOME_DOC_INIT
++ AC_PATH_PROG(SK_CONFIG,scrollkeeper-config,no)
++ if test "x$SK_CONFIG" = "xno"; then
++ AC_MSG_ERROR(Couldn't find scrollkeeper-config. Please install the scrollkeeper package: http://scrollkeeper.sourceforge.net)
++ fi
++ GDU="enabled"
++ else
++ ENABLE_SK_TRUE="#"
++ ENABLE_SK_FALSE=""
++ fi
++else
++ ENABLE_SK_TRUE="#"
++ ENABLE_SK_FALSE=""
++fi
++
++AM_CONDITIONAL(HAVE_GNOME_DOC_UTILS, test "x${enable_gdu}" = "xyes")
- if test ${enable_gnome} = yes && test ${enable_doc} = yes; then
--GNOME_DOC_INIT
-+ GNOME_DOC_INIT
- else
--ENABLE_SK_TRUE="#"
--ENABLE_SK_FALSE=""
-+ dnl Do not care if GDU is not found
-+ GNOME_DOC_INIT(,,[:])
- fi
- AM_CONDITIONAL(DISABLE_DOC, test ${enable_doc} = no)
+ dnl ###########################################################################
diff --git a/net/im/ekiga/ekiga.SlackBuild b/net/im/ekiga/ekiga.SlackBuild
index 491e9020..60d272af 100755
--- a/net/im/ekiga/ekiga.SlackBuild
+++ b/net/im/ekiga/ekiga.SlackBuild
@@ -41,7 +41,7 @@ fi
# default settings
PACKAGE="ekiga"
ARCH=${ARCH:=i486}
-VERSION=${VERSION:=2.0.11}
+VERSION=${VERSION:=2.0.12}
BUILD=${BUILD:=1rd}
SRC_DIR=${SRC:=$CWD}
TMP=${TMP:=/tmp}
@@ -81,14 +81,18 @@ tar xvf$tarflag $SRC_DIR/$SRC
cd $PACKAGE-$VERSION
if [ -f "$CWD/$PACKAGE-$VERSION.diff" ]; then
- patch -p0 < $CWD/$PACKAGE-$VERSION.diff
+ patch -p1 < $CWD/$PACKAGE-$VERSION.diff
fi
# lets regenerate configure, as its broken in 2.0.12 ...
-# aclocal
-# autoconf
+aclocal
+autoconf
./configure --prefix=/usr --enable-dbus --disable-gnome --sysconfdir=/etc --libdir=$LIBDIR
+
+# one more hack for 2.0.12 ....
+cp /usr/bin/intltool-merge .
+
make || exit 32
make DESTDIR=$TMP/package-$PACKAGE install
diff --git a/net/im/ekiga/slack-required b/net/im/ekiga/slack-required
index cd011d0f..895ce243 100644
--- a/net/im/ekiga/slack-required
+++ b/net/im/ekiga/slack-required
@@ -4,4 +4,4 @@ opal
avahi
gnome-doc-utils
intltool
-gconf
+GConf