aboutsummaryrefslogtreecommitdiff
path: root/mod_python
diff options
context:
space:
mode:
authorrhatto <rhatto@370017ae-e619-0410-ac65-c121f96126d4>2006-11-03 01:04:08 +0000
committerrhatto <rhatto@370017ae-e619-0410-ac65-c121f96126d4>2006-11-03 01:04:08 +0000
commitc7e9c63ce107141622ae37195f9c825ed617c038 (patch)
tree5c7d71a43d23f828306400de96533e35bb745283 /mod_python
parent0c62b5301d55c407ea241725fef8f20ef2d975b6 (diff)
downloadslackbuilds-c7e9c63ce107141622ae37195f9c825ed617c038.tar.gz
slackbuilds-c7e9c63ce107141622ae37195f9c825ed617c038.tar.bz2
mod_python: added patch for x86_64
git-svn-id: svn+slack://slack.fluxo.info/var/svn/slackbuilds@578 370017ae-e619-0410-ac65-c121f96126d4
Diffstat (limited to 'mod_python')
-rw-r--r--mod_python/mod_python-2.7.11-x86_64.diff32
-rwxr-xr-xmod_python/mod_python.build22
2 files changed, 50 insertions, 4 deletions
diff --git a/mod_python/mod_python-2.7.11-x86_64.diff b/mod_python/mod_python-2.7.11-x86_64.diff
new file mode 100644
index 00000000..840070a1
--- /dev/null
+++ b/mod_python/mod_python-2.7.11-x86_64.diff
@@ -0,0 +1,32 @@
+diff -Naur mod_python-2.7.11.orig/Makefile.in mod_python-2.7.11/Makefile.in
+--- mod_python-2.7.11.orig/Makefile.in 2000-12-06 01:05:37.000000000 -0200
++++ mod_python-2.7.11/Makefile.in 2006-11-02 22:56:24.000000000 -0200
+@@ -115,7 +115,7 @@
+
+ install_py_lib:
+ $(INSTALL) -d $(PY_STD_LIB)/site-packages/mod_python
+- @for f in `ls lib/python/mod_python/*.py`; \
++ @for f in `ls lib64/python/mod_python/*.py`; \
+ do \
+ $(INSTALL) $$f $(PY_STD_LIB)/site-packages/mod_python; \
+ done
+diff -Naur mod_python-2.7.11.orig/configure mod_python-2.7.11/configure
+--- mod_python-2.7.11.orig/configure 2001-06-11 16:16:25.000000000 -0300
++++ mod_python-2.7.11/configure 2006-11-02 22:56:38.000000000 -0200
+@@ -1348,14 +1348,14 @@
+
+ # this is where the Python libraries will get installed
+
+-PY_STD_LIB=${PyEXEC_INSTALLDIR}/lib/python${PyVERSION}
++PY_STD_LIB=${PyEXEC_INSTALLDIR}/lib64/python${PyVERSION}
+
+ # set python std library variable
+ echo $ac_n "checking what libraries Python was linked with""... $ac_c" 1>&6
+ echo "configure:1356: checking what libraries Python was linked with" >&5
+
+ if test -z "$PYTHON_SRC"; then
+- PyLIBP=${PyEXEC_INSTALLDIR}/lib/python${PyVERSION}
++ PyLIBP=${PyEXEC_INSTALLDIR}/lib64/python${PyVERSION}
+ PyLIBPL=${PyLIBP}/config
+ PyPYTHONLIBS=${PyLIBPL}/libpython${PyVERSION}.a
+ PyLIBS=`grep "^LIB[SMC]=" ${PyLIBPL}/Makefile | cut -f2 -d= | tr '\011\012\015' ' '`
diff --git a/mod_python/mod_python.build b/mod_python/mod_python.build
index d2d5f09f..cd23abf2 100755
--- a/mod_python/mod_python.build
+++ b/mod_python/mod_python.build
@@ -21,10 +21,16 @@ fi
PACKAGE="mod_python"
VERSION=${VERSION:=2.7.11}
ARCH="${ARCH:=x86_64}"
-BUILD=${BUILD:=1rha}
+BUILD=${BUILD:=2rha}
SRC_DIR=${SRC:=$CWD}
TMP=${TMP:=/tmp}
+# ------- error codes for createpkg --------------
+ERROR_WGET=31; ERROR_MAKE=32; ERROR_INSTALL=33
+ERROR_MD5=34; ERROR_CONF=35; ERROR_HELP=36
+ERROR_TAR=37; ERROR_MKPKG=38; ERROR_GPG=39
+ERROR_PATCH=40
+
if [ "$ARCH" == "x86_64" ]; then
export CFLAGS="-fPIC"
export LDFLAGS="-L/lib64 -L/usr/lib64 -fPIC"
@@ -51,7 +57,7 @@ else
fi
if [ "$RTOOL" == "wget" ] && [ ! -f "$SRC_DIR/$SRC" ]; then
- wget "$URL" -O "$SRC_DIR/$SRC"
+ wget "$URL" -O "$SRC_DIR/$SRC" || exit $ERROR_WGET
fi
TMP="$TMP/$PACKAGE"
@@ -65,6 +71,14 @@ cd $TMP
tar xvf$tarflag $SRC_DIR/$SRC
cd $PACKAGE-$VERSION
+if [ -f "$CWD/$PACKAGE-$VERSION.diff" ]; then
+ patch -p1 < $CWD/$PACKAGE-$VERSION.diff || exit $ERROR_PATCH
+fi
+
+if [ -f "$CWD/$PACKAGE-$VERSION-$ARCH.diff" ]; then
+ patch -p1 < $CWD/$PACKAGE-$VERSION-$ARCH.diff || exit $ERROR_PATCH
+fi
+
./configure
# coxa, favor corrigir!
@@ -73,8 +87,8 @@ if [ "$ARCH" == "x86_64" ]; then
mv src/Makefile.new src/Makefile
fi
-make || exit 32
-make install
+make || exit $ERROR_MAKE
+make install || exit $ERROR_INSTALL
CWD="`pwd`"