aboutsummaryrefslogtreecommitdiff
path: root/mod_python
diff options
context:
space:
mode:
authorrudson <rudson@370017ae-e619-0410-ac65-c121f96126d4>2006-11-15 23:32:09 +0000
committerrudson <rudson@370017ae-e619-0410-ac65-c121f96126d4>2006-11-15 23:32:09 +0000
commit36dfae9b5a58be5a5ad46c4741c0565eebc352d5 (patch)
treebf4ebd0c129509b386cc671458b3b5e1bfc20d2a /mod_python
parentd0e473b0107d9f3939ddba7f49965c2fb9079a3d (diff)
downloadslackbuilds-36dfae9b5a58be5a5ad46c4741c0565eebc352d5.tar.gz
slackbuilds-36dfae9b5a58be5a5ad46c4741c0565eebc352d5.tar.bz2
movendo...
git-svn-id: svn+slack://slack.fluxo.info/var/svn/slackbuilds@683 370017ae-e619-0410-ac65-c121f96126d4
Diffstat (limited to 'mod_python')
-rw-r--r--mod_python/mod_python-2.7.11-x86_64.diff32
-rwxr-xr-xmod_python/mod_python.SlackBuild30
-rwxr-xr-xmod_python/mod_python.build134
3 files changed, 0 insertions, 196 deletions
diff --git a/mod_python/mod_python-2.7.11-x86_64.diff b/mod_python/mod_python-2.7.11-x86_64.diff
deleted file mode 100644
index 840070a1..00000000
--- a/mod_python/mod_python-2.7.11-x86_64.diff
+++ /dev/null
@@ -1,32 +0,0 @@
-diff -Naur mod_python-2.7.11.orig/Makefile.in mod_python-2.7.11/Makefile.in
---- mod_python-2.7.11.orig/Makefile.in 2000-12-06 01:05:37.000000000 -0200
-+++ mod_python-2.7.11/Makefile.in 2006-11-02 22:56:24.000000000 -0200
-@@ -115,7 +115,7 @@
-
- install_py_lib:
- $(INSTALL) -d $(PY_STD_LIB)/site-packages/mod_python
-- @for f in `ls lib/python/mod_python/*.py`; \
-+ @for f in `ls lib64/python/mod_python/*.py`; \
- do \
- $(INSTALL) $$f $(PY_STD_LIB)/site-packages/mod_python; \
- done
-diff -Naur mod_python-2.7.11.orig/configure mod_python-2.7.11/configure
---- mod_python-2.7.11.orig/configure 2001-06-11 16:16:25.000000000 -0300
-+++ mod_python-2.7.11/configure 2006-11-02 22:56:38.000000000 -0200
-@@ -1348,14 +1348,14 @@
-
- # this is where the Python libraries will get installed
-
--PY_STD_LIB=${PyEXEC_INSTALLDIR}/lib/python${PyVERSION}
-+PY_STD_LIB=${PyEXEC_INSTALLDIR}/lib64/python${PyVERSION}
-
- # set python std library variable
- echo $ac_n "checking what libraries Python was linked with""... $ac_c" 1>&6
- echo "configure:1356: checking what libraries Python was linked with" >&5
-
- if test -z "$PYTHON_SRC"; then
-- PyLIBP=${PyEXEC_INSTALLDIR}/lib/python${PyVERSION}
-+ PyLIBP=${PyEXEC_INSTALLDIR}/lib64/python${PyVERSION}
- PyLIBPL=${PyLIBP}/config
- PyPYTHONLIBS=${PyLIBPL}/libpython${PyVERSION}.a
- PyLIBS=`grep "^LIB[SMC]=" ${PyLIBPL}/Makefile | cut -f2 -d= | tr '\011\012\015' ' '`
diff --git a/mod_python/mod_python.SlackBuild b/mod_python/mod_python.SlackBuild
deleted file mode 100755
index ea99a2b6..00000000
--- a/mod_python/mod_python.SlackBuild
+++ /dev/null
@@ -1,30 +0,0 @@
-#!/bin/bash
-#
-# SlackBuild script to call mod_python.build with correct settings
-#
-
-CWD="`pwd`"
-
-if [ -f ~/.slackbuildrc ]; then
- source ~/.slackbuildrc
-elif [ -f /etc/slackbuildrc ]; then
- source /etc/slackbuildrc
-fi
-
-# default settings
-PACKAGE="mod_python"
-VERSION=${VERSION:=2.7.11}
-ARCH="${ARCH:=x86_64}"
-BUILD=${BUILD:=2rha}
-SRC_DIR=${SRC:=$CWD}
-TMP=${TMP:=/tmp}
-REPOS=${REPOS:=$TMP}
-
-rm -rf $TMP/$PACKAGE
-mkdir -p $SRC_DIR/$PACKAGE $TMP/$PACKAGE
-
-slacktrack -b $REPOS -x $TMP,$SRC_DIR,/dev -jefkzp "$PACKAGE-$VERSION-$ARCH-$BUILD.tgz" "./$PACKAGE.build"
-
-if [ "$CLEANUP" == "yes" ]; then
- rm -rf $TMP/$PACKAGE
-fi
diff --git a/mod_python/mod_python.build b/mod_python/mod_python.build
deleted file mode 100755
index 0f290e44..00000000
--- a/mod_python/mod_python.build
+++ /dev/null
@@ -1,134 +0,0 @@
-#!/bin/bash
-#
-# build script for mod_python
-# by rhatto at riseup.net
-# build it with slacktrack, example:
-#
-# slacktrack -jefkzp "mod_python-2.7.11-x86_64-1rha.tgz" "./mod_python.build"
-#
-
-CWD="`pwd`"
-
-if [ -f "/etc/slackbuildrc" ]; then
- source /etc/slackbuildrc
-fi
-
-if [ -f "~/.slackbuildrc" ]; then
- source ~/.slackbuildrc
-fi
-
-# default settings
-PACKAGE="mod_python"
-VERSION=${VERSION:=2.7.11}
-ARCH="${ARCH:=x86_64}"
-BUILD=${BUILD:=2rha}
-SRC_DIR=${SRC:=$CWD}
-TMP=${TMP:=/tmp}
-
-# ------- error codes for createpkg --------------
-ERROR_WGET=31; ERROR_MAKE=32; ERROR_INSTALL=33
-ERROR_MD5=34; ERROR_CONF=35; ERROR_HELP=36
-ERROR_TAR=37; ERROR_MKPKG=38; ERROR_GPG=39
-ERROR_PATCH=40
-
-if [ "$ARCH" == "x86_64" ]; then
- export CFLAGS="-fPIC"
- export LDFLAGS="-L/lib64 -L/usr/lib64 -fPIC"
- LIBDIR=/usr/lib64
-else
- LIBDIR=/usr/lib
-fi
-
-RTOOL="wget"
-PACKAGE_EXT="tgz"
-SRC="$PACKAGE-$VERSION.$PACKAGE_EXT"
-URL="http://ftp.unicamp.br/pub/apache/httpd/modpython/$SRC"
-
-SRC_DIR="$SRC_DIR/$PACKAGE"
-
-if [ ! -d "$SRC_DIR" ]; then
- mkdir -p $SRC_DIR
-fi
-
-if [ "$PACKAGE_EXT" == "bz2" ]; then
- tarflag="j"
-else
- tarflag="z"
-fi
-
-if [ "$RTOOL" == "wget" ] && [ ! -f "$SRC_DIR/$SRC" ]; then
- wget "$URL" -O "$SRC_DIR/$SRC" || exit $ERROR_WGET
-fi
-
-TMP="$TMP/$PACKAGE"
-
-if [ ! -d "$TMP" ]; then
- mkdir -p $TMP
-fi
-
-cd $TMP
-
-tar xvf$tarflag $SRC_DIR/$SRC
-cd $PACKAGE-$VERSION
-
-if [ -f "$CWD/$PACKAGE-$VERSION.diff" ]; then
- patch -p1 < $CWD/$PACKAGE-$VERSION.diff || exit $ERROR_PATCH
-fi
-
-if [ -f "$CWD/$PACKAGE-$VERSION-$ARCH.diff" ]; then
- patch -p1 < $CWD/$PACKAGE-$VERSION-$ARCH.diff || exit $ERROR_PATCH
-fi
-
-./configure
-
-# coxa, favor corrigir!
-if [ "$ARCH" == "x86_64" ]; then
- sed -e 's/^OPT=$/OPT="-fPIC -DEAPI"/' src/Makefile > src/Makefile.new
- mv src/Makefile.new src/Makefile
-else
- sed -e 's/^OPT=$/OPT=-DEAPI/' src/Makefile > src/Makefile.new
- mv src/Makefile.new src/Makefile
-fi
-
-make || exit $ERROR_MAKE
-make install || exit $ERROR_INSTALL
-
-CWD="`pwd`"
-
-mkdir /install
-
-cat << EOF > /install/slack-desc
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
-
- |-----handy-ruler-----------------------------------------------------|
-mod_python: mod_python (Apache/Python Integration)
-mod_python:
-mod_python: Mod_python is an Apache module that embeds the Python interpreter
-mod_python: within the server. With mod_python you can write web-based
-mod_python: applications in Python that will run many times faster than
-mod_python: traditional CGI and will have access to advanced features such as
-mod_python: ability to retain database connections and other data between hits
-mod_python: and access to Apache internals
-mod_python:
-mod_python:
-mod_python:
-EOF
-
-# docs
-mkdir -p /usr/doc/$PACKAGE-$VERSION
-
-for file in COPYRIGHT CREDITS NEWS README; do
- cp $CWD/$file* /usr/doc/$PACKAGE-$VERSION/
-done
-
-# install script
-echo '( echo Now dont forget to edit your main config and add )' > /install/doinst.sh
-echo '( echo LoadModule python_module /usr/libexec/apache/mod_python.so )' >> /install/doinst.sh
-echo '( echo If your configuration uses ClearModuleList, then also add )' >> /install/doinst.sh
-echo '( echo AddModule mod_python.c )' >> /install/doinst.sh
-