aboutsummaryrefslogtreecommitdiff
path: root/gnash
diff options
context:
space:
mode:
authorrhatto <rhatto@370017ae-e619-0410-ac65-c121f96126d4>2006-09-02 14:59:37 +0000
committerrhatto <rhatto@370017ae-e619-0410-ac65-c121f96126d4>2006-09-02 14:59:37 +0000
commit3dcaee2196a32b37c17730062a1121d08f905459 (patch)
tree009359f95c115d4a83ab50d492e42d5245e062b9 /gnash
parent4f7e5ca8a4f8468c6f2d1eeca5723a75b458b144 (diff)
downloadslackbuilds-3dcaee2196a32b37c17730062a1121d08f905459.tar.gz
slackbuilds-3dcaee2196a32b37c17730062a1121d08f905459.tar.bz2
gnash update
git-svn-id: svn+slack://slack.fluxo.info/var/svn/slackbuilds@145 370017ae-e619-0410-ac65-c121f96126d4
Diffstat (limited to 'gnash')
-rwxr-xr-xgnash/gnash.SlackBuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/gnash/gnash.SlackBuild b/gnash/gnash.SlackBuild
index 511564ed..547bcd64 100755
--- a/gnash/gnash.SlackBuild
+++ b/gnash/gnash.SlackBuild
@@ -25,8 +25,8 @@ REPOS=${REPOS:=$TMP}
if [ "$ARCH" == "x86_64" ]; then
export CFLAGS=-fPIC
export LDFLAGS="-L/lib64 -L/usr/lib64 -fPIC"
- export X_LDFLAGS="-L/usr/lib64"
- export X_LIBS="-L/usr/lib64"
+ # export X_LDFLAGS="-L/usr/lib64"
+ # export X_LIBS="-L/usr/lib64"
LIBDIR=/usr/lib64
else
LIBDIR=/usr/lib
@@ -63,6 +63,14 @@ if [ -f "$CWD/$PACKAGE-$VERSION.diff" ]; then
fi
./configure --prefix=/usr --sysconfdir=/etc --libdir=$LIBDIR
+
+# coxa, favor corrigir!
+if [ "$ARCH" == "x86_64" ]; then
+ sed -e "s/^X_LDFLAGS = -L\/usr\/lib/X_LDFLAGS = -L\/usr\/lib64/" \
+ -e "s/^X_LIBS = -L\/usr\/lib/X_LIBS = -L\/usr\/lib64/" plugin/Makefile > plugin/Makefile.new
+ mv plugin/Makefile.new plugin/Makefile
+fi
+
make
make DESTDIR=$TMP/package-$PACKAGE install