aboutsummaryrefslogtreecommitdiff
path: root/duplicity
diff options
context:
space:
mode:
authorrudson <rudson@370017ae-e619-0410-ac65-c121f96126d4>2006-11-15 22:34:08 +0000
committerrudson <rudson@370017ae-e619-0410-ac65-c121f96126d4>2006-11-15 22:34:08 +0000
commit5edac4f98ec983dca5724a95bdc6fac061bb18ba (patch)
treeb0ac2b06eb8a5890542a6973fc901292dc676e18 /duplicity
parentd0e7ca1fa33783f8d3b62046fd5aad04e35e9845 (diff)
downloadslackbuilds-5edac4f98ec983dca5724a95bdc6fac061bb18ba.tar.gz
slackbuilds-5edac4f98ec983dca5724a95bdc6fac061bb18ba.tar.bz2
movendo...
git-svn-id: svn+slack://slack.fluxo.info/var/svn/slackbuilds@671 370017ae-e619-0410-ac65-c121f96126d4
Diffstat (limited to 'duplicity')
-rwxr-xr-xduplicity/duplicity.SlackBuild30
-rwxr-xr-xduplicity/duplicity.build109
2 files changed, 0 insertions, 139 deletions
diff --git a/duplicity/duplicity.SlackBuild b/duplicity/duplicity.SlackBuild
deleted file mode 100755
index dcd17147..00000000
--- a/duplicity/duplicity.SlackBuild
+++ /dev/null
@@ -1,30 +0,0 @@
-#!/bin/bash
-#
-# SlackBuild script to call duplicity.build with correct settings
-#
-
-CWD="`pwd`"
-
-if [ -f ~/.slackbuildrc ]; then
- source ~/.slackbuildrc
-elif [ -f /etc/slackbuildrc ]; then
- source /etc/slackbuildrc
-fi
-
-# default settings
-PACKAGE="duplicity"
-VERSION=${VERSION:=0.4.2}
-ARCH=${ARCH:=i386}
-BUILD=${BUILD:=1rha}
-SRC_DIR=${SRC:=$CWD}
-TMP=${TMP:=/tmp}
-REPOS=${REPOS:=$TMP}
-
-rm -rf $TMP/$PACKAGE
-mkdir -p $SRC_DIR/$PACKAGE $TMP/$PACKAGE $REPOS
-
-slacktrack -b $REPOS -x $TMP,$SRC_DIR,/dev -jefkzp "$PACKAGE-$VERSION-$ARCH-$BUILD.tgz" "./$PACKAGE.build"
-
-if [ "$CLEANUP" == "yes" ]; then
- rm -rf $TMP/$PACKAGE
-fi
diff --git a/duplicity/duplicity.build b/duplicity/duplicity.build
deleted file mode 100755
index 4e67958a..00000000
--- a/duplicity/duplicity.build
+++ /dev/null
@@ -1,109 +0,0 @@
-#!/bin/bash
-#
-# build script for duplicity
-# by rhatto at riseup.net by rhatto | gpl
-# build it with slacktrack, example:
-#
-# ARCH=x86_64 slacktrack -jefkzp "duplicity-0.4.2-x86_64-1rha.tgz" "./duplicity.build"
-#
-
-cat << EOCAT
-You'll need to have following package installed:
-
- librsync
-
-EOCAT
-
-if [ "$INTERACT" != "no" ]; then
- echo "Hit ENTER do continue, Crtl-C to abort"
- read crap
-else
- echo sleeping 3 seconds...
- sleep 3
-fi
-
-CWD="`pwd`"
-
-if [ -f "/etc/slackbuildrc" ]; then
- source /etc/slackbuildrc
-fi
-
-if [ -f "~/.slackbuildrc" ]; then
- source ~/.slackbuildrc
-fi
-
-# default settings
-PACKAGE="duplicity"
-TMP=${TMP:=/tmp}
-VERSION=${VERSION:=0.4.2}
-ARCH=${ARCH:=i386}
-BUILD=${BUILD:=1rha}
-SRC_DIR=${SRC:=$CWD}
-
-if [ "$ARCH" == "x86_64" ]; then
- LIBDIR=/usr/lib64
-else
- LIBDIR=/usr/lib
-fi
-
-RTOOL="wget"
-PACKAGE_EXT="gz"
-SRC="$PACKAGE-$VERSION.tar.$PACKAGE_EXT"
-URL="http://savannah.nongnu.org/download/duplicity/$SRC"
-
-SRC_DIR="$SRC_DIR/$PACKAGE"
-
-if [ ! -d "$SRC_DIR" ]; then
- mkdir -p $SRC_DIR
-fi
-
-if [ "$RTOOL" == "wget" ] && [ ! -f "$SRC_DIR/$SRC" ]; then
- wget "$URL" -O "$SRC_DIR/$SRC"
-fi
-
-if [ "$PACKAGE_EXT" == "bz2" ]; then
- tarflag="j"
-else
- tarflag="z"
-fi
-
-TMP="$TMP/$PACKAGE"
-
-if [ ! -d "$TMP" ]; then
- mkdir -p $TMP
-fi
-
-cd $TMP
-
-tar xvf$tarflag $SRC_DIR/$SRC
-cd $PACKAGE-$VERSION
-
-# config and install!
-mkdir -p /install
-
-python setup.py install --prefix=/usr/
-
-# make the package
-
-cat << EOF > /install/slack-desc
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
-
- |-----handy-ruler-----------------------------------------------------|
-duplicity: duplicity (encrypted bandwidth-efficient backup)
-duplicity:
-duplicity: duplicity is an incremental backup tool that backs up files and
-duplicity: directories by building tar-format volumes and uploading them to a
-duplicity: file server. By default, these volumes will be GPG encrypted, although
-duplicity: simple gzipping is also supported. It supports local, FTP, and ssh/scp
-duplicity: back-ends. Because it uses librsync, archives only record the parts
-duplicity: of files that have changed since the last backup. It supports deleted
-duplicity: files, full Unix permissions, directories, symbolic links, and fifos,
-duplicity: but currently not hard links.
-duplicity:
-EOF
-