aboutsummaryrefslogtreecommitdiff
path: root/dev/util
diff options
context:
space:
mode:
authorrhatto <rhatto@370017ae-e619-0410-ac65-c121f96126d4>2007-05-16 19:30:53 +0000
committerrhatto <rhatto@370017ae-e619-0410-ac65-c121f96126d4>2007-05-16 19:30:53 +0000
commita800339c9110292fdc6a431f6f3cbb3bb3a54938 (patch)
treec555d13df3e686f06ed5e4e202f0dcde5cb68a9b /dev/util
parent7cd715862eb2ec2c5e396ebd692aea9d171f90a6 (diff)
downloadslackbuilds-a800339c9110292fdc6a431f6f3cbb3bb3a54938.tar.gz
slackbuilds-a800339c9110292fdc6a431f6f3cbb3bb3a54938.tar.bz2
added bzr
git-svn-id: svn+slack://slack.fluxo.info/var/svn/slackbuilds@1229 370017ae-e619-0410-ac65-c121f96126d4
Diffstat (limited to 'dev/util')
-rwxr-xr-xdev/util/bzr/bzr.SlackBuild42
-rwxr-xr-xdev/util/bzr/bzr.build102
2 files changed, 144 insertions, 0 deletions
diff --git a/dev/util/bzr/bzr.SlackBuild b/dev/util/bzr/bzr.SlackBuild
new file mode 100755
index 00000000..9d84a046
--- /dev/null
+++ b/dev/util/bzr/bzr.SlackBuild
@@ -0,0 +1,42 @@
+#!/bin/bash
+#
+# bzr.SlackBuild is free software; you can redistribute it and/or modify it under the
+# terms of the GNU General Public License as published by the Free Software
+# Foundation; either version 2 of the License, or any later version.
+#
+# bzr.SlackBuild is distributed in the hope that it will be useful, but WITHOUT ANY
+# WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR
+# A PARTICULAR PURPOSE. See the GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License along with
+# this program; if not, write to the Free Software Foundation, Inc., 59 Temple
+# Place - Suite 330, Boston, MA 02111-1307, USA
+#
+# SlackBuild script to call bzr.build with correct settings
+#
+
+CWD="`pwd`"
+
+if [ -f ~/.slackbuildrc ]; then
+ source ~/.slackbuildrc
+elif [ -f /etc/slackbuildrc ]; then
+ source /etc/slackbuildrc
+fi
+
+# default settings
+PACKAGE="bzr"
+VERSION=${VERSION:=0.16}
+ARCH=${ARCH:=i486}
+BUILD=${BUILD:=1rha}
+SRC_DIR=${SRC:=$CWD}
+TMP=${TMP:=/tmp}
+REPOS=${REPOS:=$TMP}
+
+rm -rf $TMP/$PACKAGE
+mkdir -p $SRC_DIR/$PACKAGE $TMP/$PACKAGE $REPOS
+
+slacktrack -b $REPOS -x $TMP,$SRC_DIR,/dev -jefkzp "$PACKAGE-$VERSION-$ARCH-$BUILD.tgz" "./$PACKAGE.build"
+
+if [ "$CLEANUP" == "yes" ]; then
+ rm -rf $TMP/$PACKAGE
+fi
diff --git a/dev/util/bzr/bzr.build b/dev/util/bzr/bzr.build
new file mode 100755
index 00000000..cb748e4f
--- /dev/null
+++ b/dev/util/bzr/bzr.build
@@ -0,0 +1,102 @@
+#!/bin/bash
+#
+# bzr.build is free software; you can redistribute it and/or modify it under the
+# terms of the GNU General Public License as published by the Free Software
+# Foundation; either version 2 of the License, or any later version.
+#
+# bzr.build is distributed in the hope that it will be useful, but WITHOUT ANY
+# WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR
+# A PARTICULAR PURPOSE. See the GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License along with
+# this program; if not, write to the Free Software Foundation, Inc., 59 Temple
+# Place - Suite 330, Boston, MA 02111-1307, USA
+#
+# build script for bzr
+# by rhatto at riseup.net
+# build it with slacktrack, example:
+#
+# slacktrack -jefkzp "bzr-0.16-x86_64-1rha.tgz" "./bzr.build"
+#
+
+CWD="`pwd`"
+
+if [ -f "/etc/slackbuildrc" ]; then
+ source /etc/slackbuildrc
+fi
+
+if [ -f "~/.slackbuildrc" ]; then
+ source ~/.slackbuildrc
+fi
+
+# default settings
+PACKAGE="bzr"
+VERSION=${VERSION:=0.16}
+ARCH=${ARCH:=i486}
+BUILD=${BUILD:=1rha}
+SRC_DIR=${SRC:=$CWD}
+TMP=${TMP:=/tmp}
+
+RTOOL="wget"
+PACKAGE_EXT="gz"
+SRC="$PACKAGE-$VERSION.tar.$PACKAGE_EXT"
+URL="http://bazaar-vcs.org/releases/src/$SRC"
+
+SRC_DIR="$SRC_DIR/$PACKAGE"
+
+if [ ! -d "$SRC_DIR" ]; then
+ mkdir -p $SRC_DIR
+fi
+
+if [ "$RTOOL" == "wget" ] && [ ! -f "$SRC_DIR/$SRC" ]; then
+ wget "$URL" -O "$SRC_DIR/$SRC"
+fi
+
+TMP="$TMP/$PACKAGE"
+
+if [ ! -d "$TMP" ]; then
+ mkdir -p $TMP
+fi
+
+cd $TMP
+
+tar xvf $SRC_DIR/$SRC
+cd $PACKAGE-$VERSION
+
+python setup.py install
+
+CWD="`pwd`"
+
+mkdir /install
+
+cat << EOF > /install/slack-desc
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler-----------------------------------------------------|
+bzr: bzr
+bzr:
+bzr: Bazaar is a distributed version control system available under the
+bzr: GPL that aids open source development and reduces barriers to
+bzr: participation.
+bzr:
+bzr:
+bzr:
+bzr:
+bzr:
+bzr:
+EOF
+
+# docs
+mkdir -p /usr/doc/$PACKAGE-$VERSION
+
+for file in BRANCH.TODO COPYING.txt HACKING INSTALL NEWS README TODO; do
+ cp $CWD/$file* /usr/doc/$PACKAGE-$VERSION/
+done
+
+cp -R $CWD/doc/* /usr/doc/$PACKAGE-$VERSION/
+