aboutsummaryrefslogtreecommitdiff
path: root/dev/util
diff options
context:
space:
mode:
authorrudson <rudson@370017ae-e619-0410-ac65-c121f96126d4>2006-11-15 23:51:43 +0000
committerrudson <rudson@370017ae-e619-0410-ac65-c121f96126d4>2006-11-15 23:51:43 +0000
commit65d91a2968762e5a75b14364bf35a01d79431b4e (patch)
treed3284a396909d19817ef9552f47eb0f46aafba93 /dev/util
parent6b58cd82155f6f588fcdfd808f493cde8a849962 (diff)
downloadslackbuilds-65d91a2968762e5a75b14364bf35a01d79431b4e.tar.gz
slackbuilds-65d91a2968762e5a75b14364bf35a01d79431b4e.tar.bz2
movendo libs...
git-svn-id: svn+slack://slack.fluxo.info/var/svn/slackbuilds@688 370017ae-e619-0410-ac65-c121f96126d4
Diffstat (limited to 'dev/util')
-rwxr-xr-xdev/util/scons/scons.SlackBuild42
-rwxr-xr-xdev/util/scons/scons.build103
2 files changed, 145 insertions, 0 deletions
diff --git a/dev/util/scons/scons.SlackBuild b/dev/util/scons/scons.SlackBuild
new file mode 100755
index 00000000..0e6c8c69
--- /dev/null
+++ b/dev/util/scons/scons.SlackBuild
@@ -0,0 +1,42 @@
+#!/bin/bash
+#
+# SlackBuild script to call scons.build with correct settings
+#
+
+if [ -s "slack-required" ]; then
+ echo Recomended and required packages for building scons are:
+ cat scons.slack-required | sed -e 's/^/\t/'
+ if [ "$INTERACT" != "no" ]; then
+ echo If you dont have those installed, press Ctrl-C. Otherwise, hit ENTER.
+ read crap
+# else
+# echo Sleeping 3 seconds...
+# sleep 3
+ fi
+fi
+
+CWD="`pwd`"
+
+if [ -f ~/.slackbuildrc ]; then
+ source ~/.slackbuildrc
+elif [ -f /etc/slackbuildrc ]; then
+ source /etc/slackbuildrc
+fi
+
+# default settings
+PACKAGE="scons"
+VERSION=${VERSION:=0.96.1}
+ARCH="${ARCH:=i486}"
+BUILD=${BUILD:=1rha}
+SRC_DIR=${SRC:=$CWD}
+TMP=${TMP:=/tmp}
+REPOS=${REPOS:=$TMP}
+
+rm -rf $TMP/$PACKAGE
+mkdir -p $SRC_DIR/$PACKAGE $TMP/$PACKAGE
+
+slacktrack -b $REPOS -x $TMP,$SRC_DIR,/dev -jefkzp "$PACKAGE-$VERSION-$ARCH-$BUILD.tgz" "./$PACKAGE.build"
+
+if [ "$CLEANUP" == "yes" ]; then
+ rm -rf $TMP/$PACKAGE
+fi
diff --git a/dev/util/scons/scons.build b/dev/util/scons/scons.build
new file mode 100755
index 00000000..2b636fe4
--- /dev/null
+++ b/dev/util/scons/scons.build
@@ -0,0 +1,103 @@
+#!/bin/bash
+#
+# slackbuild script for scons
+# by rhatto at riseup.net
+#
+
+CWD="`pwd`"
+
+if [ -f "/etc/slackbuildrc" ]; then
+ source /etc/slackbuildrc
+fi
+
+if [ -f "~/.slackbuildrc" ]; then
+ source ~/.slackbuildrc
+fi
+
+# default settings
+PACKAGE="scons"
+ARCH=${ARCH:=i486}
+VERSION=${VERSION:=0.96.1}
+BUILD=${BUILD:=1rha}
+SRC_DIR=${SRC:=$CWD}
+TMP=${TMP:=/tmp}
+REPOS=${REPOS:=$TMP}
+
+# ------- error codes for createpkg --------------
+ERROR_WGET=31; ERROR_MAKE=32; ERROR_INSTALL=33
+ERROR_MD5=34; ERROR_CONF=35; ERROR_HELP=36
+ERROR_TAR=37; ERROR_MKPKG=38; ERROR_GPG=39
+ERROR_PATCH=40
+
+if [ "$ARCH" == "x86_64" ]; then
+ export LDFLAGS="-L/lib64 -L/usr/lib64"
+ LIBDIR=/usr/lib64
+else
+ LIBDIR=/usr/lib
+fi
+
+RTOOL="wget"
+PACKAGE_EXT="gz"
+SRC="$PACKAGE-$VERSION.tar.$PACKAGE_EXT"
+URL="http://easynews.dl.sourceforge.net/sourceforge/scons/$SRC"
+
+SRC_DIR="$SRC_DIR/$PACKAGE"
+if [ ! -d "$SRC_DIR" ]; then
+ mkdir -p $SRC_DIR
+fi
+
+if [ "$RTOOL" == "wget" ] && [ ! -f "$SRC_DIR/$SRC" ]; then
+ wget "$URL" -O "$SRC_DIR/$SRC" || exit $ERROR_WGET
+fi
+
+TMP="$TMP/$PACKAGE"
+if [ ! -d "$TMP" ]; then
+ mkdir -p $TMP
+fi
+cd $TMP
+
+tar xvf $SRC_DIR/$SRC || exit $ERROR_TAR
+cd $PACKAGE-$VERSION
+
+if [ -f "$CWD/$PACKAGE-$VERSION.diff" ]; then
+ patch -p1 < $CWD/$PACKAGE-$VERSION.diff || exit $ERROR_PATCH
+fi
+
+python setup.py install --standard-lib || exit $ERROR_INSTALL
+
+CWD="`pwd`"
+
+mkdir /install
+cat << EOF > /install/slack-desc
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler-----------------------------------------------------|
+scons: scons (A software construction tool)
+scons:
+scons: SCons is a software construction tool (build tool substitute for
+scons: Make) implemented in Python. It features a modular build engine that
+scons: can be embedded in other software. SCons configuration files are
+scons: Python scripts that call the build engine API. It can scan files to
+scons: detect dependencies automatically and maintain a global view of all
+scons: dependencies in a build tree, and uses MD5 signatures to detect
+scons: changed file contents reliably. Timestamps can be used if you prefer.
+scons: SCons also supports parallel builds and is easily extensible
+scons: through user-defined builder and scanner objects.
+EOF
+
+# docs
+mkdir -p /usr/doc/$PACKAGE-$VERSION
+
+for file in CHANGES.txt LICENSE.txt MANIFEST README.txt RELEASE.txt; do
+ cp $CWD/$file* /usr/doc/$PACKAGE-$VERSION/
+done
+
+if [ "$CLEANUP" == "yes" ]; then
+ rm -rf $TMP
+fi
+