aboutsummaryrefslogtreecommitdiff
path: root/dev/python
diff options
context:
space:
mode:
authorrhatto <rhatto@370017ae-e619-0410-ac65-c121f96126d4>2007-07-25 21:08:46 +0000
committerrhatto <rhatto@370017ae-e619-0410-ac65-c121f96126d4>2007-07-25 21:08:46 +0000
commitc8c45473b4e4dc1f7f9deac9f1ff79b8f9ae544f (patch)
tree7b0429be9aa194c252d74709a5f12968a9afb31c /dev/python
parent54d1cb46bec8fb74e000e3a0550a913c0cdc0ac3 (diff)
downloadslackbuilds-c8c45473b4e4dc1f7f9deac9f1ff79b8f9ae544f.tar.gz
slackbuilds-c8c45473b4e4dc1f7f9deac9f1ff79b8f9ae544f.tar.bz2
added setuptools
git-svn-id: svn+slack://slack.fluxo.info/var/svn/slackbuilds@1300 370017ae-e619-0410-ac65-c121f96126d4
Diffstat (limited to 'dev/python')
-rwxr-xr-xdev/python/pysqlite/pysqlite.build2
-rwxr-xr-xdev/python/setuptools/setuptools.SlackBuild42
-rwxr-xr-xdev/python/setuptools/setuptools.build104
3 files changed, 147 insertions, 1 deletions
diff --git a/dev/python/pysqlite/pysqlite.build b/dev/python/pysqlite/pysqlite.build
index 840feead..43985e82 100755
--- a/dev/python/pysqlite/pysqlite.build
+++ b/dev/python/pysqlite/pysqlite.build
@@ -16,7 +16,7 @@
# by rhatto at riseup.net
# build it with slacktrack, example:
#
-# slacktrack -jefkzp "pysqlite-0.10.4-i486-1rha.tgz" "./pysqlite.build"
+# slacktrack -jefkzp "pysqlite-2.3.5-i486-1rha.tgz" "./pysqlite.build"
#
CWD="`pwd`"
diff --git a/dev/python/setuptools/setuptools.SlackBuild b/dev/python/setuptools/setuptools.SlackBuild
new file mode 100755
index 00000000..be973be9
--- /dev/null
+++ b/dev/python/setuptools/setuptools.SlackBuild
@@ -0,0 +1,42 @@
+#!/bin/bash
+#
+# setuptools.SlackBuild is free software; you can redistribute it and/or modify it under the
+# terms of the GNU General Public License as published by the Free Software
+# Foundation; either version 2 of the License, or any later version.
+#
+# setuptools.SlackBuild is distributed in the hope that it will be useful, but WITHOUT ANY
+# WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR
+# A PARTICULAR PURPOSE. See the GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License along with
+# this program; if not, write to the Free Software Foundation, Inc., 59 Temple
+# Place - Suite 330, Boston, MA 02111-1307, USA
+#
+# SlackBuild script to call setuptools.build with correct settings
+#
+
+CWD="`pwd`"
+
+if [ -f ~/.slackbuildrc ]; then
+ source ~/.slackbuildrc
+elif [ -f /etc/slackbuildrc ]; then
+ source /etc/slackbuildrc
+fi
+
+# default settings
+PACKAGE="setuptools"
+VERSION=${VERSION:=0.6c6}
+ARCH=${ARCH:=i486}
+BUILD=${BUILD:=1rha}
+SRC_DIR=${SRC:=$CWD}
+TMP=${TMP:=/tmp}
+REPOS=${REPOS:=$TMP}
+
+rm -rf $TMP/$PACKAGE
+mkdir -p $SRC_DIR/$PACKAGE $TMP/$PACKAGE $REPOS
+
+slacktrack -b $REPOS -x $TMP,$SRC_DIR,/dev -jefkzp "$PACKAGE-$VERSION-$ARCH-$BUILD.tgz" "./$PACKAGE.build"
+
+if [ "$CLEANUP" == "yes" ]; then
+ rm -rf $TMP/$PACKAGE
+fi
diff --git a/dev/python/setuptools/setuptools.build b/dev/python/setuptools/setuptools.build
new file mode 100755
index 00000000..2cde1156
--- /dev/null
+++ b/dev/python/setuptools/setuptools.build
@@ -0,0 +1,104 @@
+#!/bin/bash
+#
+# setuptools.build is free software; you can redistribute it and/or modify it under the
+# terms of the GNU General Public License as published by the Free Software
+# Foundation; either version 2 of the License, or any later version.
+#
+# setuptools.build is distributed in the hope that it will be useful, but WITHOUT ANY
+# WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR
+# A PARTICULAR PURPOSE. See the GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License along with
+# this program; if not, write to the Free Software Foundation, Inc., 59 Temple
+# Place - Suite 330, Boston, MA 02111-1307, USA
+#
+# build script for setuptools
+# by rhatto at riseup.net
+# build it with slacktrack, example:
+#
+# slacktrack -jefkzp "setuptools-0.6c6-i486-1rha.tgz" "./setuptools.build"
+#
+
+CWD="`pwd`"
+
+if [ -f "/etc/slackbuildrc" ]; then
+ source /etc/slackbuildrc
+fi
+
+if [ -f "~/.slackbuildrc" ]; then
+ source ~/.slackbuildrc
+fi
+
+# default settings
+PACKAGE="setuptools"
+VERSION=${VERSION:=0.6c6}
+ARCH=${ARCH:=i486}
+BUILD=${BUILD:=1rha}
+SRC_DIR=${SRC:=$CWD}
+TMP=${TMP:=/tmp}
+
+RTOOL="wget"
+PACKAGE_EXT="gz"
+SRC="$PACKAGE-$VERSION.tar.$PACKAGE_EXT"
+URL="http://peak.telecommunity.com/dist/ez_setup.py"
+
+if [ "$ARCH" == "x86_64" ]; then
+ LIBDIR=/usr/lib64
+else
+ LIBDIR=/usr/lib
+fi
+
+# ------- error codes for createpkg --------------
+ERROR_WGET=31; ERROR_MAKE=32; ERROR_INSTALL=33
+ERROR_MD5=34; ERROR_CONF=35; ERROR_HELP=36
+ERROR_TAR=37; ERROR_MKPKG=38; ERROR_GPG=39
+ERROR_PATCH=40
+
+SRC_DIR="$SRC_DIR/$PACKAGE"
+
+if [ ! -d "$SRC_DIR" ]; then
+ mkdir -p $SRC_DIR
+fi
+
+if [ "$RTOOL" == "wget" ]; then
+ wget "$URL" -O "$SRC_DIR/$SRC" || exit $ERROR_WGET
+fi
+
+TMP="$TMP/$PACKAGE"
+
+if [ ! -d "$TMP" ]; then
+ mkdir -p $TMP
+fi
+
+cd $TMP
+
+cd $PACKAGE-$VERSION
+mv $SRC_DIR/ez_setup.py .
+python ez_setup.py install || exit $ERROR_INSTALL
+
+CWD="`pwd`"
+
+mkdir /install
+
+cat << EOF > /install/slack-desc
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler-----------------------------------------------------|
+setuptools: setuptools
+setuptools:
+setuptools: setuptools is a collection of enhancements to the Python distutils.
+setuptools:
+setuptools:
+setuptools:
+setuptools:
+setuptools:
+setuptools:
+setuptools:
+setuptools:
+EOF
+