aboutsummaryrefslogtreecommitdiff
path: root/dev/python
diff options
context:
space:
mode:
authorrudson <rudson@370017ae-e619-0410-ac65-c121f96126d4>2006-11-15 23:46:37 +0000
committerrudson <rudson@370017ae-e619-0410-ac65-c121f96126d4>2006-11-15 23:46:37 +0000
commit6b58cd82155f6f588fcdfd808f493cde8a849962 (patch)
treeefb5f7d30008d1eb56526808338866043eab3eee /dev/python
parenteab5be76d432faaa9885b6d9b626403d4e246c00 (diff)
downloadslackbuilds-6b58cd82155f6f588fcdfd808f493cde8a849962.tar.gz
slackbuilds-6b58cd82155f6f588fcdfd808f493cde8a849962.tar.bz2
movendo libs...
git-svn-id: svn+slack://slack.fluxo.info/var/svn/slackbuilds@687 370017ae-e619-0410-ac65-c121f96126d4
Diffstat (limited to 'dev/python')
-rwxr-xr-xdev/python/pygtk/pygtk.SlackBuild132
-rwxr-xr-xdev/python/pyrex/Pyrex.SlackBuild42
-rwxr-xr-xdev/python/pyrex/Pyrex.build105
3 files changed, 279 insertions, 0 deletions
diff --git a/dev/python/pygtk/pygtk.SlackBuild b/dev/python/pygtk/pygtk.SlackBuild
new file mode 100755
index 00000000..1f602a4b
--- /dev/null
+++ b/dev/python/pygtk/pygtk.SlackBuild
@@ -0,0 +1,132 @@
+#!/bin/bash
+#
+# slackbuild script for pygtk
+# by rhatto at riseup.net
+#
+
+if [ -s "slack-required" ]; then
+ echo Recomended and required packages for building pygtk are:
+ cat slack-required | sed -e 's/^/\t/'
+ if [ "$INTERACT" != "no" ]; then
+ echo If you dont have those installed, press Ctrl-C. Otherwise, hit ENTER.
+ read crap
+# else
+# echo Sleeping 3 seconds...
+# sleep 3
+ fi
+fi
+
+CWD="`pwd`"
+
+if [ -f ~/.slackbuildrc ]; then
+ source ~/.slackbuildrc
+elif [ -f /etc/slackbuildrc ]; then
+ source /etc/slackbuildrc
+fi
+
+# default settings
+PACKAGE="pygtk"
+ARCH=${ARCH:=i486}
+VERSION=${VERSION:=2.8.5}
+BUILD=${BUILD:=1rha}
+SRC_DIR=${SRC:=$CWD}
+TMP=${TMP:=/tmp}
+REPOS=${REPOS:=$TMP}
+
+if [ "$ARCH" == "x86_64" ]; then
+ export LDFLAGS="-L/lib64 -L/usr/lib64"
+ LIBDIR=/usr/lib64
+else
+ LIBDIR=/usr/lib
+fi
+
+# ------- error codes for createpkg --------------
+ERROR_WGET=31; ERROR_MAKE=32; ERROR_INSTALL=33
+ERROR_MD5=34; ERROR_CONF=35; ERROR_HELP=36
+ERROR_TAR=37; ERROR_MKPKG=38; ERROR_GPG=39
+ERROR_PATCH=40
+
+RTOOL="wget"
+PACKAGE_EXT="bz2"
+SRC="$PACKAGE-$VERSION.tar.$PACKAGE_EXT"
+URL="http://ftp.gnome.org/pub/GNOME/sources/pygtk/2.8/$SRC"
+MD5="$PACKAGE-$VERSION.md5sum"
+MD5_URL="http://ftp.gnome.org/pub/GNOME/sources/pygtk/2.8/$MD5"
+
+SRC_DIR="$SRC_DIR/$PACKAGE"
+mkdir -p $SRC_DIR
+
+if [ "$RTOOL" == "wget" ]; then
+ if [ ! -f "$SRC_DIR/$SRC" ]; then
+ wget "$URL" -O "$SRC_DIR/$SRC" || exit $ERROR_WGET
+ fi
+ if [ ! -f "$SRC_DIR/$MD5" ]; then
+ wget "$MD5_URL" -O "$SRC_DIR/$MD5" || exit $ERROR_WGET
+ fi
+fi
+
+cd $SRC_DIR
+grep $SRC $MD5 > $SRC.md5
+md5sum $SRC | diff - $SRC.md5 || exit $ERROR_MD5
+
+TMP="$TMP/$PACKAGE"
+rm -rf $TMP
+mkdir -p $TMP
+cd $TMP
+
+tar xvf $SRC_DIR/$SRC || exit $ERROR_TAR
+cd $PACKAGE-$VERSION
+
+if [ -f "$CWD/$PACKAGE-$VERSION.diff" ]; then
+ patch -p1 < $CWD/$PACKAGE-$VERSION.diff || exit $ERROR_PATCH
+fi
+
+./configure --prefix=/usr --sysconfdir=/etc --libdir=$LIBDIR || exit $ERROR_CONF
+make || exit $ERROR_MAKE
+make DESTDIR=$TMP/package-$PACKAGE install || exit $ERROR_INSTALL
+
+CWD="`pwd`"
+
+cd $TMP/package-$PACKAGE
+
+find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+
+mkdir install
+cat << EOF > install/slack-desc
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler-----------------------------------------------------|
+pygtk: pygtk (A set of Python bindings for the GTK widget set)
+pygtk:
+pygtk: PyGTK provides a convenient wrapper for the GTK library for use in
+pygtk: Python programs, and takes care of many of the boring details such
+pygtk: as managing memory and type casting. When combined with PyORBit and
+pygtk: gnome-python, it can be used to write full featured Gnome
+pygtk: applications.
+pygtk:
+pygtk:
+pygtk:
+pygtk:
+EOF
+
+# docs
+mkdir -p usr/doc/$PACKAGE-$VERSION
+
+DOCS="COPYING README"
+
+for file in $DOCS; do
+ cp $CWD/$file* usr/doc/$PACKAGE-$VERSION/
+done
+
+makepkg -c y -l y $REPOS/$PACKAGE-$VERSION-$ARCH-$BUILD.tgz || exit $ERROR_MKPKG
+
+if [ "$CLEANUP" == "yes" ]; then
+ rm -rf $TMP
+fi
+
diff --git a/dev/python/pyrex/Pyrex.SlackBuild b/dev/python/pyrex/Pyrex.SlackBuild
new file mode 100755
index 00000000..ca1c1c5b
--- /dev/null
+++ b/dev/python/pyrex/Pyrex.SlackBuild
@@ -0,0 +1,42 @@
+#!/bin/bash
+#
+# SlackBuild script to call Pyrex.build with correct settings
+#
+
+if [ -s "slack-required" ]; then
+ echo Recomended and required packages for building Pyrex are:
+ cat slack-required | sed -e 's/^/\t/'
+ if [ "$INTERACT" != "no" ]; then
+ echo If you dont have those installed, press Ctrl-C. Otherwise, hit ENTER.
+ read crap
+# else
+# echo Sleeping 3 seconds...
+# sleep 3
+ fi
+fi
+
+CWD="`pwd`"
+
+if [ -f ~/.slackbuildrc ]; then
+ source ~/.slackbuildrc
+elif [ -f /etc/slackbuildrc ]; then
+ source /etc/slackbuildrc
+fi
+
+# default settings
+PACKAGE="Pyrex"
+VERSION=${VERSION:=0.9.4.1}
+ARCH="${ARCH:=i486}"
+BUILD=${BUILD:=1rha}
+SRC_DIR=${SRC:=$CWD}
+TMP=${TMP:=/tmp}
+REPOS=${REPOS:=$TMP}
+
+rm -rf $TMP/$PACKAGE
+mkdir -p $SRC_DIR/$PACKAGE $TMP/$PACKAGE
+
+slacktrack -b $REPOS -x $TMP,$SRC_DIR,/dev -jefkzp "$PACKAGE-$VERSION-$ARCH-$BUILD.tgz" "./$PACKAGE.build"
+
+if [ "$CLEANUP" == "yes" ]; then
+ rm -rf $TMP/$PACKAGE
+fi
diff --git a/dev/python/pyrex/Pyrex.build b/dev/python/pyrex/Pyrex.build
new file mode 100755
index 00000000..d3a48e48
--- /dev/null
+++ b/dev/python/pyrex/Pyrex.build
@@ -0,0 +1,105 @@
+#!/bin/bash
+#
+# slackbuild script for Pyrex
+# by rhatto at riseup.net
+#
+
+CWD="`pwd`"
+
+if [ -f "/etc/slackbuildrc" ]; then
+ source /etc/slackbuildrc
+fi
+
+if [ -f "~/.slackbuildrc" ]; then
+ source ~/.slackbuildrc
+fi
+
+# default settings
+PACKAGE="Pyrex"
+ARCH=${ARCH:=i486}
+VERSION=${VERSION:=0.9.4.1}
+BUILD=${BUILD:=1rha}
+SRC_DIR=${SRC:=$CWD}
+TMP=${TMP:=/tmp}
+REPOS=${REPOS:=$TMP}
+
+# ------- error codes for createpkg --------------
+ERROR_WGET=31; ERROR_MAKE=32; ERROR_INSTALL=33
+ERROR_MD5=34; ERROR_CONF=35; ERROR_HELP=36
+ERROR_TAR=37; ERROR_MKPKG=38; ERROR_GPG=39
+ERROR_PATCH=40
+
+if [ "$ARCH" == "x86_64" ]; then
+ export LDFLAGS="-L/lib64 -L/usr/lib64"
+ LIBDIR=/usr/lib64
+else
+ LIBDIR=/usr/lib
+fi
+
+RTOOL="wget"
+PACKAGE_EXT="gz"
+SRC="$PACKAGE-$VERSION.tar.$PACKAGE_EXT"
+URL="http://www.cosc.canterbury.ac.nz/greg.ewing/python/Pyrex/$SRC"
+
+SRC_DIR="$SRC_DIR/$PACKAGE"
+if [ ! -d "$SRC_DIR" ]; then
+ mkdir -p $SRC_DIR
+fi
+
+if [ "$RTOOL" == "wget" ] && [ ! -f "$SRC_DIR/$SRC" ]; then
+ wget "$URL" -O "$SRC_DIR/$SRC" || exit $ERROR_WGET
+fi
+
+TMP="$TMP/$PACKAGE"
+if [ ! -d "$TMP" ]; then
+ mkdir -p $TMP
+fi
+cd $TMP
+
+tar xvf $SRC_DIR/$SRC || exit $ERROR_TAR
+cd $PACKAGE-$VERSION
+
+if [ -f "$CWD/$PACKAGE-$VERSION.diff" ]; then
+ patch -p1 < $CWD/$PACKAGE-$VERSION.diff || exit $ERROR_PATCH
+fi
+
+python setup.py install || exit $ERROR_INSTALL
+
+CWD="`pwd`"
+
+mkdir /install
+cat << EOF > /install/slack-desc
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler-----------------------------------------------------|
+Pyrex: Pyrex (Language for Writing Python Extension Modules)
+Pyrex:
+Pyrex: Pyrex lets you write code that mixes Python and C data types any
+Pyrex: way you want, and compiles it into a C extension for Python.
+Pyrex:
+Pyrex:
+Pyrex:
+Pyrex:
+Pyrex:
+Pyrex:
+Pyrex:
+EOF
+
+# docs
+mkdir -p /usr/doc/$PACKAGE-$VERSION
+
+DOCS="CHANGES.txt MANIFEST.in README.txt ToDo.txt USAGE.txt"
+
+for file in $DOCS; do
+ cp $CWD/$file* /usr/doc/$PACKAGE-$VERSION/
+done
+
+if [ "$CLEANUP" == "yes" ]; then
+ rm -rf $TMP
+fi
+