aboutsummaryrefslogtreecommitdiff
path: root/dev/python
diff options
context:
space:
mode:
authorrhatto <rhatto@370017ae-e619-0410-ac65-c121f96126d4>2008-11-17 15:16:50 +0000
committerrhatto <rhatto@370017ae-e619-0410-ac65-c121f96126d4>2008-11-17 15:16:50 +0000
commit2b493a4ed28a7450185523f30407bec95be0d8c3 (patch)
treecff362036f48a1701f575174a5e40ad58e1c9f53 /dev/python
parenta0ba0ca0d7e48023f4506b31ae2e4f29c57e8689 (diff)
downloadslackbuilds-2b493a4ed28a7450185523f30407bec95be0d8c3.tar.gz
slackbuilds-2b493a4ed28a7450185523f30407bec95be0d8c3.tar.bz2
twisted: rebuilt from mkbuild
git-svn-id: svn+slack://slack.fluxo.info/var/svn/slackbuilds@1934 370017ae-e619-0410-ac65-c121f96126d4
Diffstat (limited to 'dev/python')
-rw-r--r--dev/python/twisted/Twisted.SlackBuild17
-rw-r--r--dev/python/twisted/slack-required1
2 files changed, 10 insertions, 8 deletions
diff --git a/dev/python/twisted/Twisted.SlackBuild b/dev/python/twisted/Twisted.SlackBuild
index 7f12d87b..5ec31db7 100644
--- a/dev/python/twisted/Twisted.SlackBuild
+++ b/dev/python/twisted/Twisted.SlackBuild
@@ -10,12 +10,12 @@
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General
# Public License for more details.
#
-# You should have received a copy of the GNU General Public License along with
-# this program; if not, write to the Free Software Foundation, Inc., 59 Temple
-# Place - Suite 330, Boston, MA 02111-1307, USA
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA
#
# slackbuild for Twisted, by Rudson R. Alves
-# requires: glibc-solibs python
+# requires: glibc-solibs python zope.interface
# tested: Twisted-2.5.0
#
@@ -57,6 +57,7 @@ elif [ "$ARCH" = "s390" ]; then
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIR="$PREFIX/lib64"
+ LDFLAGS="-L/lib64 -L/usr/lib64"
fi
# Set error codes (used by createpkg)
@@ -86,11 +87,11 @@ fi
# Untar
cd "$PKG_WORK"
tar --no-same-owner --no-same-permissions -xvf "$SRC_DIR/$SRC" || exit $ERROR_TAR
-PKG_SRC="$PWD/`ls -l | awk '/^d/ { print $8 }'`"
+PKG_SRC="$PWD/`ls -l | awk '/^d/ { print $NF }'`"
cd "$PKG_SRC"
# Build and install package
-python setup.py build install --root=$PKG
+python setup.py build install --root=$PKG || exit $ERROR_INSTALL
# Strip binaries
( cd "$PKG"
@@ -113,9 +114,9 @@ done
mkdir -p "$PKG/install" || exit $ERROR_MKDIR
cat << EODESC > "$PKG/install/slack-desc"
# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
+# The "handy ruler" below makes it easier to edit a package description. Line
# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
+# on the right side marks the last column you can put a character in. You must
# make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':'.
diff --git a/dev/python/twisted/slack-required b/dev/python/twisted/slack-required
index 6afd7915..e7d771a3 100644
--- a/dev/python/twisted/slack-required
+++ b/dev/python/twisted/slack-required
@@ -3,3 +3,4 @@
# dependency [condition] [version]]
glibc-solibs
python
+zope.interface