aboutsummaryrefslogtreecommitdiff
path: root/denyhosts/DenyHosts.build
diff options
context:
space:
mode:
authorrhatto <rhatto@370017ae-e619-0410-ac65-c121f96126d4>2006-10-28 17:41:00 +0000
committerrhatto <rhatto@370017ae-e619-0410-ac65-c121f96126d4>2006-10-28 17:41:00 +0000
commit6b3e150296ab3d2eec5ee7440afec2cb0851a777 (patch)
treea57ce0714b6d09895d9bfcea37f6f1353a4b2ca8 /denyhosts/DenyHosts.build
parenta05ae4a1b962a01be3f630e502f12f2e7b88c126 (diff)
downloadslackbuilds-6b3e150296ab3d2eec5ee7440afec2cb0851a777.tar.gz
slackbuilds-6b3e150296ab3d2eec5ee7440afec2cb0851a777.tar.bz2
moving back DenyHosts to denyhosts
git-svn-id: svn+slack://slack.fluxo.info/var/svn/slackbuilds@543 370017ae-e619-0410-ac65-c121f96126d4
Diffstat (limited to 'denyhosts/DenyHosts.build')
-rwxr-xr-xdenyhosts/DenyHosts.build97
1 files changed, 0 insertions, 97 deletions
diff --git a/denyhosts/DenyHosts.build b/denyhosts/DenyHosts.build
deleted file mode 100755
index 1df3b34d..00000000
--- a/denyhosts/DenyHosts.build
+++ /dev/null
@@ -1,97 +0,0 @@
-#!/bin/bash
-#
-# build script for denyhosts
-# by rhatto at riseup.net
-# build it with slacktrack, example:
-#
-# slacktrack -jefkzp "denyhosts-0.5-noarch-1rha.tgz" "./denyhosts.build"
-#
-
-CWD="`pwd`"
-
-if [ -f "/etc/slackbuildrc" ]; then
- source /etc/slackbuildrc
-fi
-
-if [ -f "~/.slackbuildrc" ]; then
- source ~/.slackbuildrc
-fi
-
-# default settings
-PACKAGE="denyhosts"
-VERSION=${VERSION:=2.5}
-ARCH="noarch"
-BUILD=${BUILD:=1rha}
-SRC_DIR=${SRC:=$CWD}
-TMP=${TMP:=/tmp}
-
-RTOOL="wget"
-PACKAGE_EXT="gz"
-SRC="DenyHosts-$VERSION.tar.$PACKAGE_EXT"
-URL="http://easynews.dl.sourceforge.net/sourceforge/$PACKAGE/$SRC"
-
-SRC_DIR="$SRC_DIR/$PACKAGE"
-
-if [ ! -d "$SRC_DIR" ]; then
- mkdir -p $SRC_DIR
-fi
-
-if [ "$PACKAGE_EXT" == "bz2" ]; then
- tarflag="j"
-else
- tarflag="z"
-fi
-
-if [ "$RTOOL" == "wget" ] && [ ! -f "$SRC_DIR/$SRC" ]; then
- wget "$URL" -O "$SRC_DIR/$SRC"
-fi
-
-TMP="$TMP/$PACKAGE"
-
-if [ ! -d "$TMP" ]; then
- mkdir -p $TMP
-fi
-
-cd $TMP
-
-tar xvf$tarflag $SRC_DIR/$SRC
-cd DenyHosts-$VERSION
-
-python setup.py install
-
-CWD="`pwd`"
-
-mkdir /install
-
-cat << EOF > /install/slack-desc
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
-
- |-----handy-ruler-----------------------------------------------------|
-denyhosts: denyhosts
-denyhosts:
-denyhosts: DenyHosts is a script intended to help Linux system administrators
-denyhosts: thwart ssh server attacks. DenyHosts scans an ssh server log,
-denyhosts: updates /etc/hosts.deny after a configurable number of failed
-denyhosts: attempts from a rogue host is determined, and alerts the
-denyhosts: administrator of any suspicious logins.
-denyhosts:
-denyhosts:
-denyhosts:
-denyhosts:
-EOF
-
-# docs
-mkdir -p /usr/doc/$PACKAGE-$VERSION
-
-for file in CHANGELOG.txt LICENSE.txt README.txt; do
- cp $CWD/$file* /usr/doc/$PACKAGE-$VERSION/
-done
-
-if [ "$CLEANUP" == "yes" ]; then
- rm -rf $TMP
-fi