aboutsummaryrefslogtreecommitdiff
path: root/cinelerra
diff options
context:
space:
mode:
authorrafael2k <rafael2k@370017ae-e619-0410-ac65-c121f96126d4>2006-10-26 04:35:12 +0000
committerrafael2k <rafael2k@370017ae-e619-0410-ac65-c121f96126d4>2006-10-26 04:35:12 +0000
commit5246d6574a0667927bbf94d11c5cebb77c3b96f7 (patch)
tree37aff7066157fcff84418158623f4db60746d146 /cinelerra
parentb80435f6541106f3d72a6daa7754a683ecb08a69 (diff)
downloadslackbuilds-5246d6574a0667927bbf94d11c5cebb77c3b96f7.tar.gz
slackbuilds-5246d6574a0667927bbf94d11c5cebb77c3b96f7.tar.bz2
powerpc patch updated
git-svn-id: svn+slack://slack.fluxo.info/var/svn/slackbuilds@529 370017ae-e619-0410-ac65-c121f96126d4
Diffstat (limited to 'cinelerra')
-rw-r--r--cinelerra/cinelerra-powerpc.diff62
1 files changed, 59 insertions, 3 deletions
diff --git a/cinelerra/cinelerra-powerpc.diff b/cinelerra/cinelerra-powerpc.diff
index 20ae8f28..a8953f34 100644
--- a/cinelerra/cinelerra-powerpc.diff
+++ b/cinelerra/cinelerra-powerpc.diff
@@ -1,12 +1,68 @@
+Index: quicktime/ffmpeg/libavcodec/Makefile.am
+===================================================================
+--- quicktime/ffmpeg/libavcodec/Makefile.am (revision 946)
++++ quicktime/ffmpeg/libavcodec/Makefile.am (working copy)
+@@ -1,12 +1,6 @@
+-# i386 mmx specific stuff
+-if USEMMX
+-MM_DIR = i386
+-MM_LIB = i386/libavcodeci386.la
+-MM_FLAGS = -DHAVE_MMX
+-if TARGET_BUILTIN_VECTOR
+-MM_FLAGS += -DHAVE_BUILTIN_VECTOR
+-endif
+-endif
++# ppc specific stuff
++MM_DIR = ppc
++MM_LIB = ppc/libavcodecppc.la
+
+ SUBDIRS = $(MM_DIR)
+
Index: quicktime/ffmpeg/avconfig.h
===================================================================
--- quicktime/ffmpeg/avconfig.h (revision 946)
+++ quicktime/ffmpeg/avconfig.h (working copy)
-@@ -1,7 +1,4 @@
- #define FFMPEG_CONFIGURATION " "
+@@ -1,7 +1,9 @@
+-#define FFMPEG_CONFIGURATION " "
-#define ARCH_X86 1
--#define TUNECPU generic
++/* Automatically generated by configure - do not modify */
++#define FFMPEG_CONFIGURATION " --disable-altivec "
++#define ARCH_POWERPC 1
++#define POWERPC_MODE_32BITS 1
+ #define TUNECPU generic
-#define __CPU__ 586
++#define WORDS_BIGENDIAN 1
#define HAVE_LOCALTIME_R 1
#define HAVE_LRINTF 1
#define HAVE_VHOOK 1
+Index: configure.in
+===================================================================
+--- configure.in (revision 946)
++++ configure.in (working copy)
+@@ -405,7 +405,7 @@
+ quicktime/encore50/Makefile \
+ quicktime/ffmpeg/Makefile \
+ quicktime/ffmpeg/libavcodec/Makefile \
+- quicktime/ffmpeg/libavcodec/i386/Makefile \
++ quicktime/ffmpeg/libavcodec/ppc/Makefile \
+ mpeg2enc/Makefile toolame-02l/Makefile \
+ guicast/Makefile cinelerra/Makefile \
+ cinelerra/data/Makefile \
+--- quicktime/ffmpeg/libavcodec/ppc/Makefile.am.not 1970-01-01 00:00:00.000000000 +0000
++++ quicktime/ffmpeg/libavcodec/ppc/Makefile.am 2006-10-25 23:38:10.000000000 +0000
+@@ -0,0 +1,15 @@
++noinst_LTLIBRARIES = libavcodecppc.la
++
++# special options needed due to scarcity of registers
++AM_CFLAGS = \
++ $(LARGEFILE_CFLAGS) \
++ $(CPU_CFLAGS) \
++ -O3 -prefer-non-pic \
++ -D_GNU_SOURCE -DHAVE_AV_CONFIG_H -I$(srcdir)/../..
++
++libavcodecppc_la_SOURCES = \
++ dsputil_ppc.c mpegvideo_ppc.c
++
++EXTRA_DIST = dsputil_ppc.c \
++ mpegvideo_ppc.c
++