aboutsummaryrefslogtreecommitdiff
path: root/apps/admin
diff options
context:
space:
mode:
authorrudson <rudson@370017ae-e619-0410-ac65-c121f96126d4>2006-11-16 00:59:34 +0000
committerrudson <rudson@370017ae-e619-0410-ac65-c121f96126d4>2006-11-16 00:59:34 +0000
commit7da9a7993ef0ebe40a80e3f357423adfbea4c863 (patch)
tree6ecdb05c5f7c1c679738c991967a97f396afd25b /apps/admin
parent48a388bc51f72e4988dc2e7a72948bcff8522ab9 (diff)
downloadslackbuilds-7da9a7993ef0ebe40a80e3f357423adfbea4c863.tar.gz
slackbuilds-7da9a7993ef0ebe40a80e3f357423adfbea4c863.tar.bz2
movendo libs...
git-svn-id: svn+slack://slack.fluxo.info/var/svn/slackbuilds@714 370017ae-e619-0410-ac65-c121f96126d4
Diffstat (limited to 'apps/admin')
-rwxr-xr-xapps/admin/conky/conky.SlackBuild121
-rwxr-xr-xapps/admin/denyhosts/denyhosts.SlackBuild30
-rwxr-xr-xapps/admin/denyhosts/denyhosts.build97
-rwxr-xr-xapps/admin/hddtemp/hddtemp.SlackBuild202
4 files changed, 0 insertions, 450 deletions
diff --git a/apps/admin/conky/conky.SlackBuild b/apps/admin/conky/conky.SlackBuild
deleted file mode 100755
index de335ade..00000000
--- a/apps/admin/conky/conky.SlackBuild
+++ /dev/null
@@ -1,121 +0,0 @@
-#!/bin/bash
-#
-# slackbuild script for conky
-# by rhatto at riseup.net
-#
-
-if [ -s "slack-required" ]; then
- echo Recomended and required packages for building conky are:
- cat slack-required | sed -e 's/^/\t/'
- if [ "$INTERACT" != "no" ]; then
- echo If you dont have those installed, press Ctrl-C. Otherwise, hit ENTER.
- read crap
-# else
-# echo Sleeping 3 seconds...
-# sleep 3
- fi
-fi
-
-CWD="`pwd`"
-
-if [ -f ~/.slackbuildrc ]; then
- source ~/.slackbuildrc
-elif [ -f /etc/slackbuildrc ]; then
- source /etc/slackbuildrc
-fi
-
-# default settings
-PACKAGE="conky"
-ARCH=${ARCH:=i486}
-VERSION=${VERSION:=1.4.2}
-BUILD=${BUILD:=1rha}
-SRC_DIR=${SRC:=$CWD}
-TMP=${TMP:=/tmp}
-REPOS=${REPOS:=$TMP}
-
-if [ "$ARCH" == "x86_64" ]; then
- export LDFLAGS="-L/lib64 -L/usr/lib64"
- LIBDIR=/usr/lib64
-else
- LIBDIR=/usr/lib
-fi
-
-# ------- error codes for createpkg --------------
-ERROR_WGET=31; ERROR_MAKE=32; ERROR_INSTALL=33
-ERROR_MD5=34; ERROR_CONF=35; ERROR_HELP=36
-ERROR_TAR=37; ERROR_MKPKG=38; ERROR_GPG=39
-ERROR_PATCH=40
-
-RTOOL="wget"
-PACKAGE_EXT="gz"
-SRC="$PACKAGE-$VERSION.tar.$PACKAGE_EXT"
-URL="http://easynews.dl.sourceforge.net/sourceforge/$PACKAGE/$SRC"
-
-SRC_DIR="$SRC_DIR/$PACKAGE"
-mkdir -p $SRC_DIR
-
-if [ "$RTOOL" == "wget" ] && [ ! -f "$SRC_DIR/$SRC" ]; then
- wget "$URL" -O "$SRC_DIR/$SRC" || exit $ERROR_WGET
-fi
-
-TMP="$TMP/$PACKAGE"
-rm -rf $TMP
-mkdir -p $TMP
-cd $TMP
-
-tar xvf $SRC_DIR/$SRC || exit $ERROR_TAR
-cd $PACKAGE-$VERSION
-
-if [ -f "$CWD/$PACKAGE-$VERSION.diff" ]; then
- patch -p1 < $CWD/$PACKAGE-$VERSION.diff || exit $ERROR_PATCH
-fi
-
-./configure --prefix=/usr --sysconfdir=/etc --libdir=$LIBDIR || exit $ERROR_CONF
-make || exit $ERROR_MAKE
-make DESTDIR=$TMP/package-$PACKAGE install || exit $ERROR_INSTALL
-
-CWD="`pwd`"
-
-cd $TMP/package-$PACKAGE
-
-find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
-find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
-
-mkdir install
-cat << EOF > install/slack-desc
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
-
- |-----handy-ruler-----------------------------------------------------|
-conky: conky
-conky:
-conky: Conky is an advanced, highly configurable system monitor for X.
-conky:
-conky:
-conky:
-conky:
-conky:
-conky:
-conky:
-conky:
-EOF
-
-# docs
-mkdir -p usr/doc/$PACKAGE-$VERSION
-
-DOCS="ABOUT-NLS AUTHORS COPYING ChangeLog INSTALL NEWS README TODO"
-
-for file in $DOCS; do
- cp $CWD/$file* usr/doc/$PACKAGE-$VERSION/
-done
-
-makepkg -c y -l y $REPOS/$PACKAGE-$VERSION-$ARCH-$BUILD.tgz || exit $ERROR_MKPKG
-
-if [ "$CLEANUP" == "yes" ]; then
- rm -rf $TMP
-fi
-
diff --git a/apps/admin/denyhosts/denyhosts.SlackBuild b/apps/admin/denyhosts/denyhosts.SlackBuild
deleted file mode 100755
index 42184a02..00000000
--- a/apps/admin/denyhosts/denyhosts.SlackBuild
+++ /dev/null
@@ -1,30 +0,0 @@
-#!/bin/bash
-#
-# SlackBuild script to call denyhosts.build with correct settings
-#
-
-CWD="`pwd`"
-
-if [ -f ~/.slackbuildrc ]; then
- source ~/.slackbuildrc
-elif [ -f /etc/slackbuildrc ]; then
- source /etc/slackbuildrc
-fi
-
-# default settings
-PACKAGE="denyhosts"
-VERSION=${VERSION:=2.5}
-ARCH=${ARCH:=i486}
-BUILD=${BUILD:=1rha}
-SRC_DIR=${SRC:=$CWD}
-TMP=${TMP:=/tmp}
-REPOS=${REPOS:=$TMP}
-
-rm -rf $TMP/$PACKAGE
-mkdir -p $SRC_DIR/$PACKAGE $TMP/$PACKAGE
-
-slacktrack -b $REPOS -x $TMP,$SRC_DIR,/dev -jefkzp "$PACKAGE-$VERSION-$ARCH-$BUILD.tgz" "./$PACKAGE.build"
-
-if [ "$CLEANUP" == "yes" ]; then
- rm -rf $TMP/$PACKAGE
-fi
diff --git a/apps/admin/denyhosts/denyhosts.build b/apps/admin/denyhosts/denyhosts.build
deleted file mode 100755
index dada1ff2..00000000
--- a/apps/admin/denyhosts/denyhosts.build
+++ /dev/null
@@ -1,97 +0,0 @@
-#!/bin/bash
-#
-# build script for denyhosts
-# by rhatto at riseup.net
-# build it with slacktrack, example:
-#
-# slacktrack -jefkzp "denyhosts-0.5-noarch-1rha.tgz" "./denyhosts.build"
-#
-
-CWD="`pwd`"
-
-if [ -f "/etc/slackbuildrc" ]; then
- source /etc/slackbuildrc
-fi
-
-if [ -f "~/.slackbuildrc" ]; then
- source ~/.slackbuildrc
-fi
-
-# default settings
-PACKAGE="denyhosts"
-VERSION=${VERSION:=2.5}
-ARCH=${ARCH:=i486}
-BUILD=${BUILD:=1rha}
-SRC_DIR=${SRC:=$CWD}
-TMP=${TMP:=/tmp}
-
-RTOOL="wget"
-PACKAGE_EXT="gz"
-SRC="DenyHosts-$VERSION.tar.$PACKAGE_EXT"
-URL="http://easynews.dl.sourceforge.net/sourceforge/$PACKAGE/$SRC"
-
-SRC_DIR="$SRC_DIR/$PACKAGE"
-
-if [ ! -d "$SRC_DIR" ]; then
- mkdir -p $SRC_DIR
-fi
-
-if [ "$PACKAGE_EXT" == "bz2" ]; then
- tarflag="j"
-else
- tarflag="z"
-fi
-
-if [ "$RTOOL" == "wget" ] && [ ! -f "$SRC_DIR/$SRC" ]; then
- wget "$URL" -O "$SRC_DIR/$SRC"
-fi
-
-TMP="$TMP/$PACKAGE"
-
-if [ ! -d "$TMP" ]; then
- mkdir -p $TMP
-fi
-
-cd $TMP
-
-tar xvf$tarflag $SRC_DIR/$SRC
-cd DenyHosts-$VERSION
-
-python setup.py install
-
-CWD="`pwd`"
-
-mkdir /install
-
-cat << EOF > /install/slack-desc
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
-
- |-----handy-ruler-----------------------------------------------------|
-denyhosts: denyhosts
-denyhosts:
-denyhosts: DenyHosts is a script intended to help Linux system administrators
-denyhosts: thwart ssh server attacks. DenyHosts scans an ssh server log,
-denyhosts: updates /etc/hosts.deny after a configurable number of failed
-denyhosts: attempts from a rogue host is determined, and alerts the
-denyhosts: administrator of any suspicious logins.
-denyhosts:
-denyhosts:
-denyhosts:
-denyhosts:
-EOF
-
-# docs
-mkdir -p /usr/doc/$PACKAGE-$VERSION
-
-for file in CHANGELOG.txt LICENSE.txt README.txt; do
- cp $CWD/$file* /usr/doc/$PACKAGE-$VERSION/
-done
-
-if [ "$CLEANUP" == "yes" ]; then
- rm -rf $TMP
-fi
diff --git a/apps/admin/hddtemp/hddtemp.SlackBuild b/apps/admin/hddtemp/hddtemp.SlackBuild
deleted file mode 100755
index 4f632bb3..00000000
--- a/apps/admin/hddtemp/hddtemp.SlackBuild
+++ /dev/null
@@ -1,202 +0,0 @@
-#!/bin/bash
-#
-# slackbuild for hddtemp, by Rudson R. Alves
-# requires: none
-# tested: hddtemp-0.3-beta12
-
-CWD=`pwd`
-
-# ---- Inicializa variáveis com o slackbuild ------------
-if [ -e "/root/.slackbuildrc" ]; then
- source /root/.slackbuildrc
-elif [ -e "/etc/slackbuildrc" ]; then
- source /etc/slackbuildrc
-fi
-
-# -------- Variáveis de controle de versão --------------
-# Nome da fonte para a qual o slackbuild foi construído e
-# o seu md5sum
-SRC_ORIG="hddtemp-0.3-beta15.tar.bz2"
-MD5_ORIG="8b829339e1ae9df701684ec239021bb8"
-PACKAGE_ORIG=`echo $SRC_ORIG | sed -r 's/(.*)-(.*)-(.*)\.(.*\..*)/\1/'`
-VERSION_ORIG=`echo $SRC_ORIG | sed -r 's/(.*)-(.*)-(.*)\.(.*\..*)/\2/'`
- REVISION=`echo $SRC_ORIG | sed -r 's/(.*)-(.*)-(.*)\.(.*\..*)/\3/'`
- EXTENSION=`echo $SRC_ORIG | sed -r 's/(.*)-(.*)-(.*)\.(.*\..*)/\4/'`
-
-# ------- Códigos de erro para o createpkg --------------
-ERROR_WGET=31; ERROR_MAKE=32; ERROR_INSTALL=33
-ERROR_MD5=34; ERROR_CONF=35; ERROR_HELP=36
-ERROR_TAR=37; ERROR_MKPKG=38; ERROR_GPG=39
-ERROR_PATCH=40; ERROR_VCS=41
-
-# --------- Inicializa variáveis de entrada -------------
-PACKAGE=$PACKAGE_ORIG
-ARCH=${ARCH:=i468}
-SRC_DIR=${SRC:=$CWD}
-VERSION=${VERSION:=$VERSION_ORIG}
-SRC=$PACKAGE-$VERSION-$REVISION.$EXTENSION
-BUILD=${BUILD:=1rud}
-TMP=${TMP:=/tmp}
-REPOS=${REPOS:=$TMP}
-PREFIX=${PREFIX:=/usr}
-OPTCONF=${OPTCONF:=""}
-MD5=${MD5:=$MD5_ORIG}
-URL=${URL:="http://www.guzu.net/files/$SRC"}
-
-# ---------------- SlackBuild Help ----------------------
-if [ "$1" = "--help" -o "$1" = "help" ]; then
- echo -e "\033[01;32m
-Use: var1=\"value 1\" var2=\"value 2\" ... <package>.SlackBuild
-where:
- ARCH=machine arch (i386, i486, i686, ...)
- VERSION=package version
- BUILD=package build version (default 1rud)
- SRC=source name of package
- SRC_DIR=source directory (default $PWD)
- TMP=temporary directory (default /tmp)
- REPOS=repository directory
- PREFIX=prefix from install package
- OPTCONF=options to pass from ./configure. To configure
- help, use OPTCONF=\"--help\"
- MD5=md5sum from package source
- URL=url from package source
-\033[m"
- exit $ERROR_HELP
-fi
-
-# ---------------- Download fontes ----------------------
-# Fonte a ser compilada, com o path
-SOURCE=$SRC_DIR/$PACKAGE/$SRC
-# Verifica existência do pacote em $SRC em $SRC_DIR
-if [ ! -e $SOURCE ]; then
- echo -e "\n\n\033[01;32m Download $PACKAGE \n\033[m"
- wget "$URL" -P "$SRC_DIR/$PACKAGE"
- # Verifica se o
- if [ $? -ne 0 ]; then
- echo -e "\n\n\033[01;31m No such source file in $URL\n\033[m"
- exit $ERROR_WGET
- fi
-fi
-
-# ------------------ Checa md5sum -----------------------
-if [ "$SRC_ORIG" = "$SRC" -o "$MD5" != "$MD5_ORIG" -a "$MD5" != "no" ]; then
- SUM=`md5sum $SOURCE | awk '{print $1}'`
- if [ "$SUM" != "$MD5" ]; then
- echo -e "\n\n\033[01;31m MD5SUM error: run Slackbuild again \n\033[m"
- echo -e "\033[01;31m Remove $PACKAGE from $SRC_DIR and start Slackbuild again or use MD5=\"no\" \n\033[m"
- exit 0
- fi
- echo -e "\n\n\033[01;32m Md5sum Ok \n\033[m"
-fi
-
-# ----------------- ARCH e LIBDIR -----------------------
-# Libdir, para arch x86_64
-LIBDIR=$PREFIX/lib
-# Seleciona flags para o compilador
-if [ "$ARCH" = "i386" ]; then
- SLKCFLAGS="-O2 -march=i386 -mcpu=i686"
-elif [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mcpu=i686"
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686"
-elif [ "$ARCH" = "s390" ]; then
- SLKCFLAGS="-O2"
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2"
- LIBDIR="$PREFIX/lib64"
-fi
-
-# -------------- Desempacota fontes ---------------------
-# Desempacota fontes em PKG_SRC=$TMP/$PACKAGE-source
-PKG_SRC=$TMP/$PACKAGE-source
-rm -rf $PKG_SRC 2>/dev/null
-mkdir -p $PKG_SRC
-# Desempacota $SOURCE em $TMP/$PACKAGE-source
-tar xvf $SOURCE -C $PKG_SRC
-if [ $? -ne 0 ]; then
- echo -e "\n\n\033[01;31m $SOURCE file error \n\033[m"
- exit $ERROR_TAR
-fi
-# Pega o nome do diretório das fontes independente de sua
-# estrutura (package-version...)
-PKG_DIR="$PKG_SRC/$( ls $PKG_SRC/ )"
-cd $PKG_DIR
-
-# -------------- Configura programa ---------------------
-# Configura programa
-echo -e "\n\n\033[01;32m CFLAGS=\"$SLKCFLAGS\" ./configure --prefix=$PREFIX --libdir=$LIBDIR $OPTCONF \n\033[m"
-CFLAGS="$SLKCFLAGS" ./configure --prefix=$PREFIX --libdir=$LIBDIR $OPTCONF
-if [ $? -ne 0 -o "$OPTCONF" = "--help" ]; then
- echo -e "\n\n\033[01;31m Configure error \n\033[m"
- exit $ERROR_CONF
-fi
-
-# ---------------- Compila programa ---------------------
-echo -e "\n\n\033[01;32m make -j3 \n\033[m"
-make -j3
-if [ $? -ne 0 ]; then
- echo -e "\n\n\033[01;31m Build error \n\033[m"
- exit $ERROR_MAKE
-fi
-
-# ------------- Diretório Temporário --------------------
-# Cria diretório temporário para construção do pacote
-PKG=$TMP/$PACKAGE
-rm -rf $PKG
-mkdir -p $PKG
-
-# --------------- Instala programa ----------------------
-# Instala programa em diretório temporário
-echo -e "\n\n\033[01;32m make install DESTDIR=$PKG \n\033[m"
-make install DESTDIR=$PKG
-if [ $? -ne 0 ]; then
- echo -e "\n\n\033[01;31m Install error \n\033[m"
- exit $ERROR_INSTALL
-fi
-
-# ----------------- Stripa código -----------------------
-cd $PKG
-find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
-find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
-
-# ---------------- Cria slack-desc ----------------------
-mkdir $PKG/install
-cat << EOF > install/slack-desc
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|' on
-# the right side marks the last column you can put a character in. You must make
-# exactly 11 lines for the formatting to be correct. It's also customary to
-# leave one space after the ':'.
-
- |----handy-ruler------------------------------------------------------|
-hddtemp: hddtemp.SlackBuild by Rudson R. Alves
-hddtemp:
-hddtemp: hddtemp is a small utility that gives you the temperature of your
-hddtemp: hard drive by reading S.M.A.R.T. informations (for drives that
-hddtemp: support this feature).
-hddtemp: Note: only recent hard drives have a temperature sensor.
-hddtemp:
-hddtemp: The temperature information seems to be vendor specific (i.e. not
-hddtemp: standardized). So hddtemp comes with a file (hddtemp.db) that contains
-hddtemp: informations about drives that were reported to work with hddtemp.
-EOF
-
-# ----------------- Documentações -----------------------
-# Criar diretório de documentação
-PKG_DOC=$PKG/usr/doc/$PACKAGE-$VERSION
-mkdir -p $PKG_DOC
-cp $PKG_DIR/{ABOUT-NLS,AUTHORS,COPYING,ChangeLog,GPL-2,INSTALL,LICENSE,NEWS,README,TODO} $PKG_DOC
-
-# --------------- Constroi o pacote ---------------------
-echo -e "\n\n\033[01;32m makepkg -c y -l y $REPOS/$PACKAGE-$VERSION-$ARCH-$BUILD.tgz \n\033[m"
-makepkg -c y -l y $REPOS/$PACKAGE-$VERSION-$ARCH-$BUILD.tgz
-if [ $? -ne 0 ]; then
- exit $ERROR_MKPKG
-fi
-
-# ----------- Remove arquivos temporários ---------------
-if [ "$CLEANUP" = "yes" ]; then
- echo -e "\n\n\033[01;32m Remove files... \n\033[m"
- rm -rf $PKG $PKG_SRC
-fi