aboutsummaryrefslogtreecommitdiff
path: root/app/misc
diff options
context:
space:
mode:
authorrhatto <rhatto@370017ae-e619-0410-ac65-c121f96126d4>2008-04-21 18:54:13 +0000
committerrhatto <rhatto@370017ae-e619-0410-ac65-c121f96126d4>2008-04-21 18:54:13 +0000
commit9eeb208413dcc8df96e16557d3410dafadc39322 (patch)
tree0bd5f7e408941979b2989b32c92ef6455070b5cc /app/misc
parent820f314143601ede8e5a81a0efb9003d516f9d02 (diff)
downloadslackbuilds-9eeb208413dcc8df96e16557d3410dafadc39322.tar.gz
slackbuilds-9eeb208413dcc8df96e16557d3410dafadc39322.tar.bz2
wipe: rebuilt from mkbuild
git-svn-id: svn+slack://slack.fluxo.info/var/svn/slackbuilds@1713 370017ae-e619-0410-ac65-c121f96126d4
Diffstat (limited to 'app/misc')
-rw-r--r--app/misc/wipe/wipe-2.2.0.diff26
-rwxr-xr-xapp/misc/wipe/wipe.SlackBuild178
-rwxr-xr-xapp/misc/wipe/wipe.build124
3 files changed, 182 insertions, 146 deletions
diff --git a/app/misc/wipe/wipe-2.2.0.diff b/app/misc/wipe/wipe-2.2.0.diff
new file mode 100644
index 00000000..dfe2f017
--- /dev/null
+++ b/app/misc/wipe/wipe-2.2.0.diff
@@ -0,0 +1,26 @@
+diff -Naur wipe-2.2.0.orig/Makefile.in wipe-2.2.0/Makefile.in
+--- wipe-2.2.0.orig/Makefile.in 2003-08-30 22:18:03.000000000 -0300
++++ wipe-2.2.0/Makefile.in 2008-04-21 15:45:45.000000000 -0300
+@@ -57,15 +57,15 @@
+ @ldd $(BIN_OUT)
+
+ install: $(BIN_OUT)
+- $(INSTALL_BIN) -d $(bindir)
+- $(INSTALL_BIN) -s $(BIN_OUT) $(bindir)
+- $(INSTALL) -d $(mandir)/man1
+- $(INSTALL) -o root -m 0644 wipe.1 $(mandir)/man1/
+- rm -rf $(datadir)/doc/wipe*
+- $(INSTALL) -d $(datadir)/doc/wipe
++ $(INSTALL_BIN) -d $(DESTDIR)/$(bindir)
++ $(INSTALL_BIN) -s $(BIN_OUT) $(DESTDIR)/$(bindir)
++ $(INSTALL) -d $(DESTDIR)/$(mandir)/man1
++ $(INSTALL) -o root -m 0644 wipe.1 $(DESTDIR)/$(mandir)/man1/
++ rm -rf $(DESTDIR)/$(datadir)/doc/wipe*
++ $(INSTALL) -d $(DESTDIR)/$(datadir)/doc/wipe
+
+ for file in $(DOCS); do \
+- $(INSTALL) -o root -m 0644 $$file $(datadir)/doc/wipe/; \
++ $(INSTALL) -o root -m 0644 $$file $(DESTDIR)/$(datadir)/doc/wipe/; \
+ done
+
+ install_home: $(BIN_OUT)
diff --git a/app/misc/wipe/wipe.SlackBuild b/app/misc/wipe/wipe.SlackBuild
index 3e56029a..21def4f3 100755
--- a/app/misc/wipe/wipe.SlackBuild
+++ b/app/misc/wipe/wipe.SlackBuild
@@ -1,48 +1,182 @@
#!/bin/bash
#
-# wipe.SlackBuild is free software; you can redistribute it and/or modify it under the
-# terms of the GNU General Public License as published by the Free Software
-# Foundation; either version 2 of the License, or any later version.
+# wipe.SlackBuild is free software; you can redistribute
+# it and/or modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2 of the License,
+# or any later version.
#
-# wipe.SlackBuild is distributed in the hope that it will be useful, but WITHOUT ANY
-# WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR
-# A PARTICULAR PURPOSE. See the GNU General Public License for more details.
+# wipe.SlackBuild is distributed in the hope that it will
+# be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General
+# Public License for more details.
#
# You should have received a copy of the GNU General Public License along with
# this program; if not, write to the Free Software Foundation, Inc., 59 Temple
# Place - Suite 330, Boston, MA 02111-1307, USA
#
-# SlackBuild script to call wipe.build with correct settings
+# slackbuild for wipe, by Silvio Rhatto
+# requires:
+# tested: wipe-2.2.0
#
-CWD="`pwd`"
-
+# Look for slackbuildrc
if [ -f ~/.slackbuildrc ]; then
source ~/.slackbuildrc
elif [ -f /etc/slackbuildrc ]; then
source /etc/slackbuildrc
fi
-# default settings
-PACKAGE="wipe"
-VERSION=${VERSION:=2.2.0}
-ARCH="${ARCH:=i486}"
+# Set variables
+CWD="$(pwd)"
+SRC_NAME="wipe"
+PKG_NAME="wipe"
+ARCH=${ARCH:=i486}
+SRC_VERSION=${VERSION:=2.2.0}
+PKG_VERSION="$(echo "$SRC_VERSION" | tr '[[:blank:]-]' '_')"
BUILD=${BUILD:=1rha}
-SRC_DIR=${SRC:=$CWD}
+SRC_DIR=${SRC_DIR:=$CWD}/$PKG_NAME
TMP=${TMP:=/tmp}
+PKG=${PKG:=$TMP/package-$PKG_NAME}
REPOS=${REPOS:=$TMP}
+PREFIX=${PREFIX:=/usr}
+PKG_WORK="$TMP/$SRC_NAME"
+CONF_OPTIONS=${CONF_OPTIONS:=""}
+NUMJOBS=${NUMJOBS:=""}
+
+# Set system libraries' path and optmization flags based on $ARCH
+LIBDIR="$PREFIX/lib"
+
+if [ "$ARCH" = "i386" ]; then
+ SLKCFLAGS="-O2 -march=i386 -mcpu=i686"
+elif [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mcpu=i686"
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686"
+elif [ "$ARCH" = "s390" ]; then
+ SLKCFLAGS="-O2"
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIR="$PREFIX/lib64"
+fi
+
+# Set error codes (used by createpkg)
+ERROR_WGET=31; ERROR_MAKE=32; ERROR_INSTALL=33
+ERROR_MD5=34; ERROR_CONF=35; ERROR_HELP=36
+ERROR_TAR=37; ERROR_MKPKG=38; ERROR_GPG=39
+ERROR_PATCH=40; ERROR_VCS=41; ERROR_MKDIR=42
+
+# Clean up any leftovers of previous builds
+rm -rf "$PKG_WORK" 2> /dev/null
+rm -rf "$PKG" 2> /dev/null
+
+# Create directories if necessary
+mkdir -p "$SRC_DIR" || exit $ERROR_MKDIR
+mkdir -p "$PKG" || exit $ERROR_MKDIR
+mkdir -p "$REPOS" || exit $ERROR_MKDIR
+mkdir -p "$PKG_WORK" || exit $ERROR_MKDIR
+
+# Dowload source if necessary
+SRC="$SRC_NAME-$VERSION.tar.bz2"
+URL="http://downloads.sourceforge.net/wipe/$SRC"
+
+if [ ! -s "$SRC_DIR/$SRC" ] || ! bunzip2 -t "$SRC_DIR/$SRC" 2> /dev/null; then
+ wget "$URL" -O "$SRC_DIR/$SRC" || exit $ERROR_WGET
+fi
-rm -rf $TMP/$PACKAGE
-mkdir -p $SRC_DIR/$PACKAGE $TMP/$PACKAGE
+# Untar
+cd "$PKG_WORK"
+tar --no-same-owner --no-same-permissions -xvf "$SRC_DIR/$SRC" || exit $ERROR_TAR
+PKG_SRC="$PWD/`ls -l | awk '/^d/ { print $8 }'`"
+cd "$PKG_SRC"
-export PACKAGE VERSION ARCH BUILD SRC_DIR TMP REPOS
+# Patch source
+patches="
+ $PKG_NAME.diff $PKG_NAME-$PKG_VERSION.diff
+ $PKG_NAME-$PKG_VERSION-$ARCH.diff $PKG_NAME-$ARCH.diff"
+for patch in $patches; do
+ if [ -f "$CWD/$patch" ]; then
+ patch -Np1 < "$CWD/$patch" || exit $ERROR_PATCH
+ elif [ -f "$CWD/patches/$patch" ]; then
+ patch -Np1 < "$CWD/patches/$patch" || exit $ERROR_PATCH
+ fi
+done
-if which simpletrack &> /dev/null; then
- simpletrack $PACKAGE.build
-else
- slacktrack -b $REPOS -x $TMP,$SRC_DIR,/dev -jefkzp "$PACKAGE-$VERSION-$ARCH-$BUILD.tgz" "./$PACKAGE.build"
+if echo [[PATCH URLS]] | grep -q -v "PATCH URLS"; then
+ for patch_url in [[PATCH URLS]]; do
+ patch="`basename $patch_url`"
+ if [ ! -s "$SRC_DIR/$patch" ]; then
+ wget "$patch_url" -O "$SRC_DIR/$patch" || exit $ERROR_WGET
+ fi
+ if [ "`basename $patch .gz`" != "$patch" ]; then
+ gzip -dc $SRC_DIR/$patch | patch -Np1 || exit $ERROR_PATCH
+ elif [ "`basename $patch .bz2`" != "$patch" ]; then
+ bzip2 -dc $SRC_DIR/$patch | patch -Np1 || exit $ERROR_PATCH
+ else
+ patch -Np1 < "$SRC_DIR/$patch" || exit $ERROR_PATCH
+ fi
+ done
fi
+# Configure
+autoheader
+autoconf
+CFLAGS="$SLKCFLAGS" \
+ CXXFLAGS="$SLKCFLAGS" \
+ ./configure \
+ --prefix="$PREFIX" --libdir="$LIBDIR" $CONF_OPTIONS || exit $ERROR_CONF
+
+# Compile
+make $NUMJOBS || exit $ERROR_MAKE
+
+# Install
+make install DESTDIR="$PKG" || exit $ERROR_INSTALL
+
+# Strip binaries
+( cd "$PKG"
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null
+)
+
+# Install documentation
+DOCS="CHANGES INSTALL LICENSE README TESTING TODO"
+mkdir -p "$PKG/usr/doc/$PKG_NAME-$PKG_VERSION" || exit $ERROR_MKDIR
+for doc in $DOCS; do
+ if [ -f "$doc" ]; then
+ cp -a $doc "$PKG/usr/doc/$PKG_NAME-$PKG_VERSION"
+ fi
+done
+
+# Add package description (slack-desc)
+mkdir -p "$PKG/install" || exit $ERROR_MKDIR
+cat << EODESC > "$PKG/install/slack-desc"
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler---------------------------------------------------------|
+wipe: wipe (secure deletion of files from magnetic media)
+wipe:
+wipe: Wipe repeatedly writes special patterns to the file or files to be
+wipe: destroyed, using the fsync() call and/or the O_SYNC bit to force
+wipe: disk access, in order to lessen the chance of data recovery using
+wipe: techniques such as magnetic force microscopy.
+wipe:
+wipe:
+wipe:
+wipe:
+wipe:
+EODESC
+
+# Build the package
+cd "$PKG"
+makepkg -l y -c n "$REPOS/$PKG_NAME-$PKG_VERSION-$ARCH-$BUILD.tgz" || exit $ERROR_MKPKG
+
+# Delete source and build directories if requested
if [ "$CLEANUP" == "yes" ]; then
- rm -rf $TMP/$PACKAGE
+ rm -rf "$PKG_WORK" "$PKG"
fi
diff --git a/app/misc/wipe/wipe.build b/app/misc/wipe/wipe.build
deleted file mode 100755
index 48bcf8a3..00000000
--- a/app/misc/wipe/wipe.build
+++ /dev/null
@@ -1,124 +0,0 @@
-#!/bin/bash
-#
-# wipe.build is free software; you can redistribute it and/or modify it under the
-# terms of the GNU General Public License as published by the Free Software
-# Foundation; either version 2 of the License, or any later version.
-#
-# wipe.build is distributed in the hope that it will be useful, but WITHOUT ANY
-# WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR
-# A PARTICULAR PURPOSE. See the GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License along with
-# this program; if not, write to the Free Software Foundation, Inc., 59 Temple
-# Place - Suite 330, Boston, MA 02111-1307, USA
-#
-# build script for wipe
-# by rhatto at riseup.net
-# build it with slacktrack, example:
-#
-# ARCH=x86_64 slacktrack -jefkzp "wipe-2.2.0-x86_64-1rha.tgz" "./wipe.build"
-#
-
-CWD="`pwd`"
-
-if [ -f "/etc/slackbuildrc" ]; then
- source /etc/slackbuildrc
-fi
-
-if [ -f "~/.slackbuildrc" ]; then
- source ~/.slackbuildrc
-fi
-
-# default settings
-PACKAGE="wipe"
-ARCH=${ARCH:=i486}
-VERSION=${VERSION:=2.2.0}
-BUILD=${BUILD:=1rha}
-SRC_DIR=${SRC:=$CWD}
-TMP=${TMP:=/tmp}
-REPOS=${REPOS:=$TMP}
-
-if [ "$ARCH" == "x86_64" ]; then
- LIBDIR=/usr/lib64
-else
- LIBDIR=/usr/lib
-fi
-
-RTOOL="wget"
-PACKAGE_EXT="bz2"
-SRC="$PACKAGE-$VERSION.tar.$PACKAGE_EXT"
-URL="http://easynews.dl.sourceforge.net/sourceforge/wipe/$SRC"
-
-SRC_DIR="$SRC_DIR/$PACKAGE"
-if [ ! -d "$SRC_DIR" ]; then
- mkdir -p $SRC_DIR
-fi
-
-if [ "$PACKAGE_EXT" == "bz2" ]; then
- tarflag="j"
-else
- tarflag="z"
-fi
-
-if [ "$RTOOL" == "wget" ] && [ ! -f "$SRC_DIR/$SRC" ]; then
- wget "$URL" -O "$SRC_DIR/$SRC"
-fi
-
-TMP="$TMP/$PACKAGE"
-if [ ! -d "$TMP" ]; then
- mkdir -p $TMP
-fi
-cd $TMP
-
-tar xvf$tarflag $SRC_DIR/$SRC
-cd $PACKAGE-$VERSION
-
-if [ -f "$CWD/$PACKAGE-$VERSION.diff" ]; then
- patch -p1 < $CWD/$PACKAGE-$VERSION.diff
-fi
-
-autoheader
-autoconf
-./configure --prefix=/usr --sysconfdir=/etc/$PACKAGE --libdir=$LIBDIR
-make || exit 32
-make install
-
-CWD="`pwd`"
-
-# strip --strip-unneeded /usr/bin/wipe
-
-mkdir /install
-cat << EOF > /install/slack-desc
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
-
- |-----handy-ruler-----------------------------------------------------|
-wipe: wipe (secure deletion of files from magnetic media)
-wipe:
-wipe: Wipe repeatedly writes special patterns to the file or files to be
-wipe: destroyed, using the fsync() call and/or the O_SYNC bit to force
-wipe: disk access, in order to lessen the chance of data recovery using
-wipe: techniques such as magnetic force microscopy.
-wipe:
-wipe:
-wipe:
-wipe:
-wipe:
-EOF
-
-# docs
-mv /usr/doc/$PACKAGE /usr/doc/$PACKAGE-$VERSION
-# mkdir -p /usr/doc/$PACKAGE-$VERSION
-
-# for file in CHANGES INSTALL LICENSE README TESTING TODO; do
-# cp $CWD/$file* /usr/doc/$PACKAGE-$VERSION/
-# done
-
-if [ "$CLEANUP" == "yes" ]; then
- rm -rf $TMP
-fi
-