aboutsummaryrefslogtreecommitdiff
path: root/app/backup/duplicity
diff options
context:
space:
mode:
authorrhatto <rhatto@370017ae-e619-0410-ac65-c121f96126d4>2007-01-16 11:31:18 +0000
committerrhatto <rhatto@370017ae-e619-0410-ac65-c121f96126d4>2007-01-16 11:31:18 +0000
commitac73a3ac4e8f3b2ba0fe9f07baebb2b74e5ef455 (patch)
tree5953f841a92f368b2de66820ac53a6fa08344ada /app/backup/duplicity
parentcd58b62f059af08e84eba3bf996c626050a1af93 (diff)
downloadslackbuilds-ac73a3ac4e8f3b2ba0fe9f07baebb2b74e5ef455.tar.gz
slackbuilds-ac73a3ac4e8f3b2ba0fe9f07baebb2b74e5ef455.tar.bz2
duplicity: update
git-svn-id: svn+slack://slack.fluxo.info/var/svn/slackbuilds@966 370017ae-e619-0410-ac65-c121f96126d4
Diffstat (limited to 'app/backup/duplicity')
-rwxr-xr-xapp/backup/duplicity/duplicity.SlackBuild12
-rwxr-xr-xapp/backup/duplicity/duplicity.build25
2 files changed, 21 insertions, 16 deletions
diff --git a/app/backup/duplicity/duplicity.SlackBuild b/app/backup/duplicity/duplicity.SlackBuild
index dcd17147..b7b6d542 100755
--- a/app/backup/duplicity/duplicity.SlackBuild
+++ b/app/backup/duplicity/duplicity.SlackBuild
@@ -3,6 +3,18 @@
# SlackBuild script to call duplicity.build with correct settings
#
+if [ -s "slack-required" ]; then
+ echo Recomended and required packages for building duplicity are:
+ cat slack-required | sed -e 's/^/\t/'
+ if [ "$INTERACT" != "no" ]; then
+ echo If you dont have those installed, press Ctrl-C. Otherwise, hit ENTER.
+ read crap
+# else
+# echo Sleeping 3 seconds...
+# sleep 3
+ fi
+fi
+
CWD="`pwd`"
if [ -f ~/.slackbuildrc ]; then
diff --git a/app/backup/duplicity/duplicity.build b/app/backup/duplicity/duplicity.build
index 4e67958a..88fc06d0 100755
--- a/app/backup/duplicity/duplicity.build
+++ b/app/backup/duplicity/duplicity.build
@@ -7,13 +7,6 @@
# ARCH=x86_64 slacktrack -jefkzp "duplicity-0.4.2-x86_64-1rha.tgz" "./duplicity.build"
#
-cat << EOCAT
-You'll need to have following package installed:
-
- librsync
-
-EOCAT
-
if [ "$INTERACT" != "no" ]; then
echo "Hit ENTER do continue, Crtl-C to abort"
read crap
@@ -40,6 +33,12 @@ ARCH=${ARCH:=i386}
BUILD=${BUILD:=1rha}
SRC_DIR=${SRC:=$CWD}
+# ------- error codes for createpkg --------------
+ERROR_WGET=31; ERROR_MAKE=32; ERROR_INSTALL=33
+ERROR_MD5=34; ERROR_CONF=35; ERROR_HELP=36
+ERROR_TAR=37; ERROR_MKPKG=38 ERROR_GPP=39
+ERROR_PATCH=40
+
if [ "$ARCH" == "x86_64" ]; then
LIBDIR=/usr/lib64
else
@@ -58,13 +57,7 @@ if [ ! -d "$SRC_DIR" ]; then
fi
if [ "$RTOOL" == "wget" ] && [ ! -f "$SRC_DIR/$SRC" ]; then
- wget "$URL" -O "$SRC_DIR/$SRC"
-fi
-
-if [ "$PACKAGE_EXT" == "bz2" ]; then
- tarflag="j"
-else
- tarflag="z"
+ wget "$URL" -O "$SRC_DIR/$SRC" || exit $ERROR_WGET
fi
TMP="$TMP/$PACKAGE"
@@ -75,13 +68,13 @@ fi
cd $TMP
-tar xvf$tarflag $SRC_DIR/$SRC
+tar xvf $SRC_DIR/$SRC || exit $ERROR_TAR
cd $PACKAGE-$VERSION
# config and install!
mkdir -p /install
-python setup.py install --prefix=/usr/
+python setup.py install --prefix=/usr/ || exit $ERROR_INSTALL
# make the package