aboutsummaryrefslogtreecommitdiff
path: root/app/admin/apg/apg-2.3.0b.diff
diff options
context:
space:
mode:
authorrhatto <rhatto@370017ae-e619-0410-ac65-c121f96126d4>2009-08-11 20:16:17 +0000
committerrhatto <rhatto@370017ae-e619-0410-ac65-c121f96126d4>2009-08-11 20:16:17 +0000
commitbd7d35dab7b6ee5396301661fd2348d145b22272 (patch)
treeb59ede41d3a1516a9773cd6caf79f439fddff139 /app/admin/apg/apg-2.3.0b.diff
parenta9bbacf2a9afd3a7556f162e62f5e8b05fcd93ea (diff)
downloadslackbuilds-bd7d35dab7b6ee5396301661fd2348d145b22272.tar.gz
slackbuilds-bd7d35dab7b6ee5396301661fd2348d145b22272.tar.bz2
apg: enhancing patch to fix gentoo bug #155526
git-svn-id: svn+slack://slack.fluxo.info/var/svn/slackbuilds@2234 370017ae-e619-0410-ac65-c121f96126d4
Diffstat (limited to 'app/admin/apg/apg-2.3.0b.diff')
-rw-r--r--app/admin/apg/apg-2.3.0b.diff35
1 files changed, 34 insertions, 1 deletions
diff --git a/app/admin/apg/apg-2.3.0b.diff b/app/admin/apg/apg-2.3.0b.diff
index ee659c9f..05e85ebe 100644
--- a/app/admin/apg/apg-2.3.0b.diff
+++ b/app/admin/apg/apg-2.3.0b.diff
@@ -1,6 +1,6 @@
diff -Naur apg-2.3.0b.orig/Makefile apg-2.3.0b/Makefile
--- apg-2.3.0b.orig/Makefile 2003-08-07 12:40:39.000000000 -0300
-+++ apg-2.3.0b/Makefile 2009-06-24 00:12:27.000000000 -0300
++++ apg-2.3.0b/Makefile 2009-08-11 17:13:18.000000000 -0300
@@ -1,7 +1,7 @@
##################################################################
# Directories
@@ -45,3 +45,36 @@ diff -Naur apg-2.3.0b.orig/Makefile apg-2.3.0b/Makefile
fi
install-cygwin:
+diff -Naur apg-2.3.0b.orig/apg.c apg-2.3.0b/apg.c
+--- apg-2.3.0b.orig/apg.c 2003-08-07 12:40:39.000000000 -0300
++++ apg-2.3.0b/apg.c 2009-08-11 17:14:03.000000000 -0300
+@@ -100,6 +100,7 @@
+ #else /* CLISERV */
+ #if defined(APG_USE_CRACKLIB)
+ #define APG_PROGRAMM_OPTIONS "M:E:a:r:b:p:n:m:x:vkt"
++#include <crack.h>
+ #else /* CRACKLIB */
+ #define APG_PROGRAMM_OPTIONS "M:E:a:r:b:p:n:m:x:vt"
+ #endif /* CRACKLIB */
+@@ -709,7 +710,7 @@
+ */
+ char * crypt_passstring (const char *p)
+ {
+- char salt[10];
++ char salt[11];
+ gen_rand_pass (salt, 10, 10, S_SL|S_CL|S_NB);
+ return (crypt(p, salt));
+ }
+diff -Naur apg-2.3.0b.orig/restrict.c apg-2.3.0b/restrict.c
+--- apg-2.3.0b.orig/restrict.c 2003-08-07 12:40:39.000000000 -0300
++++ apg-2.3.0b/restrict.c 2009-08-11 17:14:03.000000000 -0300
+@@ -33,6 +33,9 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
++#if defined(APG_USE_CRACKLIB)
++#include <crack.h>
++#endif /* APG_USE_CRACKLIB */
+ #include "restrict.h"
+ extern struct sym smbl[94];
+ /*