aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorrhatto <rhatto@370017ae-e619-0410-ac65-c121f96126d4>2007-05-30 20:14:34 +0000
committerrhatto <rhatto@370017ae-e619-0410-ac65-c121f96126d4>2007-05-30 20:14:34 +0000
commit775cbafd2e88918b0c8ce8b871008a402f6302e6 (patch)
treeb6da2b6563374acb2f0aadc1c266128e349cfbfe
parenta762efe299a28acb2047b62f103de3b03b28a7d6 (diff)
downloadslackbuilds-775cbafd2e88918b0c8ce8b871008a402f6302e6.tar.gz
slackbuilds-775cbafd2e88918b0c8ce8b871008a402f6302e6.tar.bz2
added pysqlite
git-svn-id: svn+slack://slack.fluxo.info/var/svn/slackbuilds@1247 370017ae-e619-0410-ac65-c121f96126d4
-rwxr-xr-xdev/python/pysqlite/pysqlite.SlackBuild42
-rwxr-xr-xdev/python/pysqlite/pysqlite.build114
2 files changed, 156 insertions, 0 deletions
diff --git a/dev/python/pysqlite/pysqlite.SlackBuild b/dev/python/pysqlite/pysqlite.SlackBuild
new file mode 100755
index 00000000..578cbc99
--- /dev/null
+++ b/dev/python/pysqlite/pysqlite.SlackBuild
@@ -0,0 +1,42 @@
+#!/bin/bash
+#
+# pysqlite.SlackBuild is free software; you can redistribute it and/or modify it under the
+# terms of the GNU General Public License as published by the Free Software
+# Foundation; either version 2 of the License, or any later version.
+#
+# pysqlite.SlackBuild is distributed in the hope that it will be useful, but WITHOUT ANY
+# WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR
+# A PARTICULAR PURPOSE. See the GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License along with
+# this program; if not, write to the Free Software Foundation, Inc., 59 Temple
+# Place - Suite 330, Boston, MA 02111-1307, USA
+#
+# SlackBuild script to call pysqlite.build with correct settings
+#
+
+CWD="`pwd`"
+
+if [ -f ~/.slackbuildrc ]; then
+ source ~/.slackbuildrc
+elif [ -f /etc/slackbuildrc ]; then
+ source /etc/slackbuildrc
+fi
+
+# default settings
+PACKAGE="pysqlite"
+VERSION=${VERSION:=2.3.3}
+ARCH=${ARCH:=i486}
+BUILD=${BUILD:=1rha}
+SRC_DIR=${SRC:=$CWD}
+TMP=${TMP:=/tmp}
+REPOS=${REPOS:=$TMP}
+
+rm -rf $TMP/$PACKAGE
+mkdir -p $SRC_DIR/$PACKAGE $TMP/$PACKAGE $REPOS
+
+slacktrack -b $REPOS -x $TMP,$SRC_DIR,/dev -jefkzp "$PACKAGE-$VERSION-$ARCH-$BUILD.tgz" "./$PACKAGE.build"
+
+if [ "$CLEANUP" == "yes" ]; then
+ rm -rf $TMP/$PACKAGE
+fi
diff --git a/dev/python/pysqlite/pysqlite.build b/dev/python/pysqlite/pysqlite.build
new file mode 100755
index 00000000..2b5e1032
--- /dev/null
+++ b/dev/python/pysqlite/pysqlite.build
@@ -0,0 +1,114 @@
+#!/bin/bash
+#
+# pysqlite.build is free software; you can redistribute it and/or modify it under the
+# terms of the GNU General Public License as published by the Free Software
+# Foundation; either version 2 of the License, or any later version.
+#
+# pysqlite.build is distributed in the hope that it will be useful, but WITHOUT ANY
+# WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR
+# A PARTICULAR PURPOSE. See the GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License along with
+# this program; if not, write to the Free Software Foundation, Inc., 59 Temple
+# Place - Suite 330, Boston, MA 02111-1307, USA
+#
+# build script for pysqlite
+# by rhatto at riseup.net
+# build it with slacktrack, example:
+#
+# slacktrack -jefkzp "pysqlite-0.10.4-i486-1rha.tgz" "./pysqlite.build"
+#
+
+CWD="`pwd`"
+
+if [ -f "/etc/slackbuildrc" ]; then
+ source /etc/slackbuildrc
+fi
+
+if [ -f "~/.slackbuildrc" ]; then
+ source ~/.slackbuildrc
+fi
+
+# default settings
+PACKAGE="pysqlite"
+VERSION=${VERSION:=2.3.3}
+ARCH=${ARCH:=i486}
+BUILD=${BUILD:=1rha}
+SRC_DIR=${SRC:=$CWD}
+TMP=${TMP:=/tmp}
+
+RTOOL="wget"
+PACKAGE_EXT="gz"
+SRC="$PACKAGE-$VERSION.tar.$PACKAGE_EXT"
+URL="http://initd.org/pub/software/pysqlite/releases/2.3/$VERSION/$SRC"
+
+if [ "$ARCH" == "x86_64" ]; then
+ LIBDIR=/usr/lib64
+else
+ LIBDIR=/usr/lib
+fi
+
+# ------- error codes for createpkg --------------
+ERROR_WGET=31; ERROR_MAKE=32; ERROR_INSTALL=33
+ERROR_MD5=34; ERROR_CONF=35; ERROR_HELP=36
+ERROR_TAR=37; ERROR_MKPKG=38; ERROR_GPG=39
+ERROR_PATCH=40
+
+SRC_DIR="$SRC_DIR/$PACKAGE"
+
+if [ ! -d "$SRC_DIR" ]; then
+ mkdir -p $SRC_DIR
+fi
+
+if [ "$RTOOL" == "wget" ] && [ ! -f "$SRC_DIR/$SRC" ]; then
+ wget "$URL" -O "$SRC_DIR/$SRC" || exit $ERROR_WGET
+fi
+
+TMP="$TMP/$PACKAGE"
+
+if [ ! -d "$TMP" ]; then
+ mkdir -p $TMP
+fi
+
+cd $TMP
+
+tar xvf $SRC_DIR/$SRC
+cd $PACKAGE-$VERSION
+
+python setup.py install || exit $ERROR_INSTALL
+
+CWD="`pwd`"
+
+mkdir /install
+
+cat << EOF > /install/slack-desc
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler-----------------------------------------------------|
+pysqlite: pysqlite
+pysqlite:
+pysqlite: Python wrapper for the local database Sqlite.
+pysqlite:
+pysqlite:
+pysqlite:
+pysqlite:
+pysqlite:
+pysqlite:
+pysqlite:
+pysqlite:
+EOF
+
+# docs
+mkdir -p /usr/doc/$PACKAGE-$VERSION
+
+DOCS="LICENSE"
+
+for file in $DOCS; do
+ cp $CWD/$file* /usr/doc/$PACKAGE-$VERSION/
+done
+