aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorrhatto <rhatto@370017ae-e619-0410-ac65-c121f96126d4>2006-10-26 15:46:52 +0000
committerrhatto <rhatto@370017ae-e619-0410-ac65-c121f96126d4>2006-10-26 15:46:52 +0000
commit31697a387a81590210670b5553b63d8ae7393a16 (patch)
tree3b7032ace8121fc3990c64d2e7d67fe8030d7528
parent5246d6574a0667927bbf94d11c5cebb77c3b96f7 (diff)
downloadslackbuilds-31697a387a81590210670b5553b63d8ae7393a16.tar.gz
slackbuilds-31697a387a81590210670b5553b63d8ae7393a16.tar.bz2
added pyrex
git-svn-id: svn+slack://slack.fluxo.info/var/svn/slackbuilds@530 370017ae-e619-0410-ac65-c121f96126d4
-rwxr-xr-xpyrex/Pyrex.SlackBuild44
-rwxr-xr-xpyrex/Pyrex.build105
2 files changed, 149 insertions, 0 deletions
diff --git a/pyrex/Pyrex.SlackBuild b/pyrex/Pyrex.SlackBuild
new file mode 100755
index 00000000..983bb506
--- /dev/null
+++ b/pyrex/Pyrex.SlackBuild
@@ -0,0 +1,44 @@
+#!/bin/bash
+#
+# SlackBuild script to call Pyrex.build with correct settings
+#
+
+if [ -s "slack-required" ]; then
+ echo Recomended and required packages for building Pyrex are:
+ cat Pyrex.slack-required | sed -e 's/^/\t/'
+ if [ "$INTERACT" != "no" ]; then
+ echo If you dont have those installed, press Ctrl-C. Otherwise, hit ENTER.
+ read crap
+ else
+ echo Sleeping 3 seconds...
+ sleep 3
+ fi
+fi
+
+CWD="`pwd`"
+
+if [ -f "/etc/slackbuildrc" ]; then
+ source /etc/slackbuildrc
+fi
+
+if [ -f "~/.slackbuildrc" ]; then
+ source ~/.slackbuildrc
+fi
+
+# default settings
+PACKAGE="Pyrex"
+VERSION=${VERSION:=0.9.4.1}
+ARCH="${ARCH:=i486}"
+BUILD=${BUILD:=1rha}
+SRC_DIR=${SRC:=$CWD}
+TMP=${TMP:=/tmp}
+REPOS=${REPOS:=$TMP}
+
+rm -rf $TMP/$PACKAGE
+mkdir -p $SRC_DIR/$PACKAGE $TMP/$PACKAGE
+
+slacktrack -b $REPOS -x $TMP,$SRC_DIR,/dev -jefkzp "$PACKAGE-$VERSION-$ARCH-$BUILD.tgz" "./$PACKAGE.build"
+
+if [ "$CLEANUP" == "yes" ]; then
+ rm -rf $TMP/$PACKAGE
+fi
diff --git a/pyrex/Pyrex.build b/pyrex/Pyrex.build
new file mode 100755
index 00000000..d3a48e48
--- /dev/null
+++ b/pyrex/Pyrex.build
@@ -0,0 +1,105 @@
+#!/bin/bash
+#
+# slackbuild script for Pyrex
+# by rhatto at riseup.net
+#
+
+CWD="`pwd`"
+
+if [ -f "/etc/slackbuildrc" ]; then
+ source /etc/slackbuildrc
+fi
+
+if [ -f "~/.slackbuildrc" ]; then
+ source ~/.slackbuildrc
+fi
+
+# default settings
+PACKAGE="Pyrex"
+ARCH=${ARCH:=i486}
+VERSION=${VERSION:=0.9.4.1}
+BUILD=${BUILD:=1rha}
+SRC_DIR=${SRC:=$CWD}
+TMP=${TMP:=/tmp}
+REPOS=${REPOS:=$TMP}
+
+# ------- error codes for createpkg --------------
+ERROR_WGET=31; ERROR_MAKE=32; ERROR_INSTALL=33
+ERROR_MD5=34; ERROR_CONF=35; ERROR_HELP=36
+ERROR_TAR=37; ERROR_MKPKG=38; ERROR_GPG=39
+ERROR_PATCH=40
+
+if [ "$ARCH" == "x86_64" ]; then
+ export LDFLAGS="-L/lib64 -L/usr/lib64"
+ LIBDIR=/usr/lib64
+else
+ LIBDIR=/usr/lib
+fi
+
+RTOOL="wget"
+PACKAGE_EXT="gz"
+SRC="$PACKAGE-$VERSION.tar.$PACKAGE_EXT"
+URL="http://www.cosc.canterbury.ac.nz/greg.ewing/python/Pyrex/$SRC"
+
+SRC_DIR="$SRC_DIR/$PACKAGE"
+if [ ! -d "$SRC_DIR" ]; then
+ mkdir -p $SRC_DIR
+fi
+
+if [ "$RTOOL" == "wget" ] && [ ! -f "$SRC_DIR/$SRC" ]; then
+ wget "$URL" -O "$SRC_DIR/$SRC" || exit $ERROR_WGET
+fi
+
+TMP="$TMP/$PACKAGE"
+if [ ! -d "$TMP" ]; then
+ mkdir -p $TMP
+fi
+cd $TMP
+
+tar xvf $SRC_DIR/$SRC || exit $ERROR_TAR
+cd $PACKAGE-$VERSION
+
+if [ -f "$CWD/$PACKAGE-$VERSION.diff" ]; then
+ patch -p1 < $CWD/$PACKAGE-$VERSION.diff || exit $ERROR_PATCH
+fi
+
+python setup.py install || exit $ERROR_INSTALL
+
+CWD="`pwd`"
+
+mkdir /install
+cat << EOF > /install/slack-desc
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler-----------------------------------------------------|
+Pyrex: Pyrex (Language for Writing Python Extension Modules)
+Pyrex:
+Pyrex: Pyrex lets you write code that mixes Python and C data types any
+Pyrex: way you want, and compiles it into a C extension for Python.
+Pyrex:
+Pyrex:
+Pyrex:
+Pyrex:
+Pyrex:
+Pyrex:
+Pyrex:
+EOF
+
+# docs
+mkdir -p /usr/doc/$PACKAGE-$VERSION
+
+DOCS="CHANGES.txt MANIFEST.in README.txt ToDo.txt USAGE.txt"
+
+for file in $DOCS; do
+ cp $CWD/$file* /usr/doc/$PACKAGE-$VERSION/
+done
+
+if [ "$CLEANUP" == "yes" ]; then
+ rm -rf $TMP
+fi
+