aboutsummaryrefslogtreecommitdiff
path: root/modules/debian/pbuilderrc.dot.link
diff options
context:
space:
mode:
authorSilvio Rhatto <rhatto@riseup.net>2013-02-04 15:08:39 -0200
committerSilvio Rhatto <rhatto@riseup.net>2013-02-04 15:08:39 -0200
commit28cc7964357a2c0dedfe7715265765a2e0039852 (patch)
tree0b903b684f060285eb633bb5f9e36956727f818a /modules/debian/pbuilderrc.dot.link
parentb3232dc1f91adaa3f93919766ef34b29f046651a (diff)
downloadmetadot-28cc7964357a2c0dedfe7715265765a2e0039852.tar.gz
metadot-28cc7964357a2c0dedfe7715265765a2e0039852.tar.bz2
Adding debian dev module
Diffstat (limited to 'modules/debian/pbuilderrc.dot.link')
-rw-r--r--modules/debian/pbuilderrc.dot.link79
1 files changed, 79 insertions, 0 deletions
diff --git a/modules/debian/pbuilderrc.dot.link b/modules/debian/pbuilderrc.dot.link
new file mode 100644
index 0000000..e5bc540
--- /dev/null
+++ b/modules/debian/pbuilderrc.dot.link
@@ -0,0 +1,79 @@
+# See https://wiki.ubuntu.com/PbuilderHowto#Manually_doing_what_pbuilder-dist_can_do
+# Codenames for Debian suites according to their alias. Update these when
+# needed.
+UNSTABLE_CODENAME="sid"
+TESTING_CODENAME="wheezy"
+STABLE_CODENAME="squeeze"
+STABLE_BACKPORTS_SUITE="$STABLE_CODENAME-backports"
+
+# List of Debian suites.
+DEBIAN_SUITES=($UNSTABLE_CODENAME $TESTING_CODENAME $STABLE_CODENAME
+ "unstable" "testing" "stable")
+
+# List of Ubuntu suites. Update these when needed.
+UBUNTU_SUITES=("natty" "maverick" "lucid" "karmic" "jaunty" "hardy")
+
+# Mirrors to use. Update these to your preferred mirror.
+DEBIAN_MIRROR="ftp.us.debian.org"
+UBUNTU_MIRROR="ftp.ubuntu.com"
+
+# Optionally use the changelog of a package to determine the suite to use if
+# none set.
+if [ -z "${DIST}" ] && [ -r "debian/changelog" ]; then
+ DIST=$(dpkg-parsechangelog | awk '/^Distribution: / {print $2}')
+ DIST="${DIST%%-*}"
+ # Use the unstable suite for certain suite values.
+ if $(echo "experimental UNRELEASED" | grep -q $DIST); then
+ DIST="$UNSTABLE_CODENAME"
+ fi
+fi
+
+# Optionally set a default distribution if none is used. Note that you can set
+# your own default (i.e. ${DIST:="unstable"}).
+: ${DIST:="$(lsb_release --short --codename)"}
+
+# Optionally change Debian release states in $DIST to their names.
+case "$DIST" in
+ unstable)
+ DIST="$UNSTABLE_CODENAME"
+ ;;
+ testing)
+ DIST="$TESTING_CODENAME"
+ ;;
+ stable)
+ DIST="$STABLE_CODENAME"
+ ;;
+esac
+
+# Optionally set the architecture to the host architecture if none set. Note
+# that you can set your own default (i.e. ${ARCH:="i386"}).
+: ${ARCH:="$(dpkg --print-architecture)"}
+
+NAME="$DIST"
+if [ -n "${ARCH}" ]; then
+ NAME="$NAME-$ARCH"
+ DEBOOTSTRAPOPTS=("--arch" "$ARCH" "${DEBOOTSTRAPOPTS[@]}")
+fi
+BASETGZ="/var/cache/pbuilder/$NAME-base.tgz"
+# Optionally, set BASEPATH (and not BASETGZ) if using cowbuilder
+# BASEPATH="/var/cache/pbuilder/$NAME/base.cow/"
+DISTRIBUTION="$DIST"
+BUILDRESULT="/var/cache/pbuilder/$NAME/result/"
+APTCACHE="/var/cache/pbuilder/$NAME/aptcache/"
+BUILDPLACE="/var/cache/pbuilder/build/"
+
+if $(echo ${DEBIAN_SUITES[@]} | grep -q $DIST); then
+ # Debian configuration
+ MIRRORSITE="http://$DEBIAN_MIRROR/debian/"
+ COMPONENTS="main contrib non-free"
+ DEBOOTSTRAPOPTS=("${DEBOOTSTRAPOPTS[@]}" "--keyring=/usr/share/keyrings/debian-archive-keyring.gpg")
+
+elif $(echo ${UBUNTU_SUITES[@]} | grep -q $DIST); then
+ # Ubuntu configuration
+ MIRRORSITE="http://$UBUNTU_MIRROR/ubuntu/"
+ COMPONENTS="main restricted universe multiverse"
+ DEBOOTSTRAPOPTS=("${DEBOOTSTRAPOPTS[@]}" "--keyring=/usr/share/keyrings/ubuntu-archive-keyring.gpg")
+else
+ echo "Unknown distribution: $DIST"
+ exit 1
+fi